]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- fix paths in pkgconfig file and add missing dir to package
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
ca2adc08
JB
2# - contrib subpackage(s)
3# - contrib BRs:
4# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7# opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8# opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9# opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
09d132a9
ER
10# unpackaged (3.4.0)
11#/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12#/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13#/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14#/usr/share/OpenCV/valgrind.supp
15#/usr/share/OpenCV/valgrind_3rdparty.supp
16
ca2adc08 17#
2acd8ac1 18# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 19# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 20# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 21#
0c2d6b7d 22# Conditional build:
a55ba198
JB
23# - general options:
24%bcond_with tbb # Threading Building Blocks support (everywhere)
25%bcond_with sse # use SSE instructions
26%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
27%bcond_with sse3 # use SSE3 instructions
28%bcond_with ssse3 # use SSSE3 instructions
29%bcond_with sse41 # use SSE4.1 instructions
30%bcond_with sse42 # use SSE4.2 instructions
31%bcond_with avx # use AVX instructions
8d5385eb
JB
32%bcond_without opencl # OpenCL support
33%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
34%bcond_with opencl_amdfft # AMD OpenCL FFT routines
35%bcond_without opengl # OpenGL support
4a401ecc 36%bcond_without openmp # OpenMP support (available when not using tbb)
200823d5 37%bcond_without examples # Install examples
b07433c6
JB
38# - bindings
39%bcond_without java # Java binding
a55ba198 40# - highgui options:
b3920a9d 41%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
42%bcond_without gstreamer # GStreamer support in highgui
43%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 44%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 45%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 46%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 47%bcond_without v4l # Video4Linux in highgui
a55ba198 48%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 49%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
50# - other modules
51%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 52
e36ac029 53%ifarch pentium3 pentium4 %{x8664} x32
1c9fe580
JB
54%define with_sse 1
55%endif
e36ac029 56%ifarch pentium4 %{x8664} x32
1c9fe580
JB
57%define with_sse2 1
58%endif
901927d3 59Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 60Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 61Name: opencv
701be548 62Version: 4.5.1
e652d7a7 63Release: 2
901927d3 64Epoch: 1
d5e56e66
JB
65%if %{with unicap} || %{with xine}
66License: GPL (enforced by used libraries), BSD (opencv itself)
67%else
901927d3 68License: BSD
d5e56e66 69%endif
901927d3 70Group: Libraries
200823d5 71Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
701be548 72# Source0-md5: 2205d3169238ec1f184438a96de68513
b287af3c 73Source1: https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
701be548 74# Source1-md5: 19a31bf7271978ab426112dbf5d1b83f
8a121398
JR
75# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76Source10: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77# Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78Source11: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79# Source11-md5: 232c966b13651bd0e46a1497b0852191
80Source12: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81# Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82Source13: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83# Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84Source14: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85# Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86Source15: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87# Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88Source16: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89# Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91Source20: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92# Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93Source21: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94# Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95Source22: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96# Source22-md5: 7cd47228edec52b6d82f46511af325c5
97Source23: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98# Source23-md5: 151805e03568c9f490a5e3a872777b75
454d8108 99# See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
8a121398
JR
100Source30: https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101# Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
701be548
JR
102# See opencv-4.5.1/modules/gapi/CMakeLists.txt
103Source40: https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
104# Source40-md5: b624b995ec9c439cbc2e9e6ee940d3a2
fe201543
JR
105Patch0: %{name}-ximea.patch
106Patch1: python-install.patch
e652d7a7 107Patch2: pkgconfig-paths.patch
200823d5 108URL: http://www.opencv.org/
d5e56e66 109%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 110%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 111BuildRequires: OpenEXR-devel
5df3cf1b 112%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 113%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 114# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 115%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 116%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 117%{?with_java:BuildRequires: ant}
8a121398 118BuildRequires: boost-devel
ef4af528
JB
119%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
120%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 121BuildRequires: cmake >= 2.8
0c2d6b7d 122BuildRequires: doxygen
809ce413 123BuildRequires: eigen3 >= 3
b3920a9d 124%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
4a401ecc 125%{?with_openmp:BuildRequires: gcc-c++ >= 6:4.2}
fb5ded39 126BuildRequires: gflags-devel
74cbdeb2 127BuildRequires: gl2ps-devel
debb38d4 128BuildRequires: glog-devel
0c2d6b7d 129%if %{with gstreamer}
158e0ccc
JB
130BuildRequires: gstreamer-devel >= 1.0
131BuildRequires: gstreamer-plugins-base-devel >= 1.0
0c2d6b7d 132%endif
901927d3 133BuildRequires: jasper-devel
b07433c6 134%{?with_java:BuildRequires: jdk}
158e0ccc 135BuildRequires: libdc1394-devel >= 2
4a401ecc 136%{?with_openmp:BuildRequires: libgomp-devel}
901927d3
AM
137BuildRequires: libjpeg-devel
138BuildRequires: libpng-devel
139BuildRequires: libraw1394-devel
0c2d6b7d 140BuildRequires: libstdc++-devel
901927d3 141BuildRequires: libtiff-devel
148338c5 142BuildRequires: libtool
d5e56e66
JB
143%if %{with unicap}
144BuildRequires: libucil-devel
145BuildRequires: libunicap-devel
146%endif
0c2d6b7d 147BuildRequires: libv4l-devel
4836bff0 148BuildRequires: ogre-devel
af6d2888 149BuildRequires: pkgconfig
701be548 150BuildRequires: protobuf-devel
158e0ccc
JB
151BuildRequires: python >= 2.0
152BuildRequires: python-devel >= 2.0
0c2d6b7d 153BuildRequires: python-numpy-devel
b221500a
JB
154BuildRequires: python3 >= 1:3.2
155BuildRequires: python3-devel >= 1:3.2
156BuildRequires: python3-numpy-devel
901927d3 157BuildRequires: rpm-pythonprov
8d499a62 158BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 159BuildRequires: sed >= 4.0
158e0ccc 160BuildRequires: sphinx-pdg
996927aa 161BuildRequires: swig-python
f8e040cc 162%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
163%if %{with vtk}
164BuildRequires: vtk-devel >= 5.8.0
fba97d16 165BuildRequires: vtk-java >= 5.8.0
701be548 166BuildRequires: vtk-python3-devel >= 5.8.0
ae3d975d 167%endif
901927d3 168%{?with_xine:BuildRequires: xine-lib-devel}
158e0ccc 169BuildRequires: xorg-lib-libX11-devel
452b38e1 170BuildRequires: zlib-devel
4afb606b 171%if %{with qt}
4afb606b
JB
172BuildRequires: QtCore-devel >= 4
173BuildRequires: QtGui-devel >= 4
5df3cf1b 174%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
175BuildRequires: qt4-qmake >= 4
176%else
177BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 178%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 179%endif
da5d1e09 180Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
181BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
182
158e0ccc 183%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
71c2eb73 184%define sover %(echo %{version} | cut -d. -f1-2)
933de752 185
901927d3
AM
186%description
187OpenCV (Open Source Computer Vision) is a library of programming
188functions mainly aimed at real time computer vision.
189
0c2d6b7d
JB
190Example applications of the OpenCV library are:
191- Human-Computer Interaction (HCI)
192- Object Identification, Segmentation and Recognition
193- Face Recognition
194- Gesture Recognition
195- Motion Tracking
196- Ego Motion, Motion Understanding
197- Structure From Motion (SFM)
198- Stereo and Multi-Camera Calibration and Depth Computation
199- Mobile Robotics.
200
201%description -l pl.UTF-8
202OpenCV (Open Source Computer Vision) to biblioteka funkcji
203przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
204
205Przykładowe zastosowania biblioteki OpenCV to
206- interakcje człowiek-komputer (HCI)
207- identyfikacja, segmentacja i rozpoznawanie obiektów
208- rozpoznawanie twarzy
209- rozpoznawanie gestów
210- śledzenie ruchu
211- rozumienie ruchu
212- SFM (Structure From Motion)
213- kalibracja dwu- i wielokamerowa, obliczanie głębi
214- robotyka ruchu.
901927d3 215
933de752
ER
216%package core
217Summary: OpenCV core libraries
da5d1e09 218Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 219Group: Libraries
da5d1e09 220Conflicts: opencv < 2.4.6.2-1
933de752
ER
221
222%description core
223This package contains the OpenCV C/C++ core libraries.
224
da5d1e09
JB
225%description core -l pl.UTF-8
226Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
227
cf32945e
JB
228%package viz
229Summary: OpenCV viz library (VTK support)
230Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
231Group: Libraries
232Requires: %{name} = %{epoch}:%{version}-%{release}
233
234%description viz
235OpenCV viz library (VTK support).
236
237%description viz -l pl.UTF-8
238Biblioteka OpenCV viz (obsługa VTK).
239
901927d3 240%package devel
0c2d6b7d
JB
241Summary: Header files for OpenCV library
242Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
243Group: Development/Libraries
244Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
245%if %{with vtk}
246Requires: %{name}-viz = %{epoch}:%{version}-%{release}
247%endif
0c2d6b7d 248Obsoletes: opencv-static
901927d3
AM
249
250%description devel
0c2d6b7d 251Header files for OpenCV library.
901927d3 252
0c2d6b7d
JB
253%description devel -l pl.UTF-8
254Pliki nagłówkowe biblioteki OpenCV.
901927d3 255
9141b1e2
ER
256%package doc
257Summary: Manual for OpenCV
258Summary(fr.UTF-8): Documentation pour OpenCV
259Summary(it.UTF-8): Documentazione di OpenCV
260Summary(pl.UTF-8): Podręcznik dla OpenCV
261Group: Documentation
262# noarch subpackages only when building with rpm5
9141b1e2 263BuildArch: noarch
9141b1e2
ER
264
265%description doc
266Documentation for OpenCV.
267
268%description doc -l fr.UTF-8
269Documentation pour OpenCV.
270
271%description doc -l it.UTF-8
272Documentazione di OpenCV.
273
274%description doc -l pl.UTF-8
275Dokumentacja do OpenCV.
276
200823d5
ER
277%package examples
278Summary: OpenCV code examples
279Group: Documentation
200823d5 280BuildArch: noarch
200823d5
ER
281
282%description examples
283OpenCV code examples.
284
b07433c6
JB
285%package -n java-opencv
286Summary: OpenCV Java bindings
287Summary(pl.UTF-8): Wiązania Javy do OpenCV
288Group: Libraries/Java
289Requires: %{name} = %{epoch}:%{version}-%{release}
290Requires: jre
291
292%description -n java-opencv
293OpenCV Java bindings.
294
295%description -n java-opencv -l pl.UTF-8
296Wiązania Javy do OpenCV.
297
901927d3 298%package -n python-opencv
b221500a
JB
299Summary: OpenCV Python 2 bindings
300Summary(pl.UTF-8): Wiązania Pythona 2 do OpenCV
0c2d6b7d 301Group: Libraries/Python
cd1f0136 302Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 303Requires: python-libs
901927d3
AM
304
305%description -n python-opencv
b221500a 306OpenCV Python 2 bindings.
901927d3 307
0c2d6b7d 308%description -n python-opencv -l pl.UTF-8
b221500a
JB
309Wiązania Pythona 2 do OpenCV.
310
311%package -n python3-opencv
312Summary: OpenCV Python 3 bindings
313Summary(pl.UTF-8): Wiązania Pythona 3 do OpenCV
314Group: Libraries/Python
315Requires: %{name} = %{epoch}:%{version}-%{release}
316Requires: python3-libs
317
318%description -n python3-opencv
319OpenCV Python 3 bindings.
320
321%description -n python3-opencv -l pl.UTF-8
322Wiązania Pythona 3 do OpenCV.
0c2d6b7d 323
901927d3 324%prep
b287af3c 325%setup -q -a1
54551f29 326
da67222a 327%undos CMakeLists.txt
54551f29 328
8a121398 329%patch0 -p1
08b22f18 330%patch1 -p1
e652d7a7 331%patch2 -p1
148338c5 332
701be548
JR
333cache_file() {
334 f="$1"
335 d="$2"
336 md5="$(md5sum "$f" | awk '{print $1}')"
337 file="$(basename "$f")"
338 mkdir -p ".cache/$d"
339 install "$f" ".cache/$d/$md5-$file"
340}
341for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
342 cache_file $f xfeatures2d/boostdesc
343done
344for f in %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}; do
345 cache_file $f xfeatures2d/vgg
346done
347cache_file %{SOURCE30} data
348cache_file %{SOURCE40} ade
349
901927d3 350%build
701be548 351mkdir -p build
95daeb66 352cd build
ea26b025
ER
353
354# handle cmake & ccache
355# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
356if [[ "%{__cc}" = *ccache* ]]; then
357 cc="%{__cc}"
358 cxx="%{__cxx}"
359 ccache="
360 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
361 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
362 "
363fi
364
0c2d6b7d 365%cmake .. \
ea26b025 366 $ccache \
08b22f18 367 -DENABLE_PRECOMPILED_HEADERS=OFF \
09d132a9 368 -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
b287af3c 369 -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
da5d1e09 370 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
371 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
372 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
373 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
374 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
375 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
376 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 377 -DBUILD_NEW_PYTHON_SUPPORT=ON \
701be548 378 -DOPENCV_GENERATE_PKGCONFIG:BOOL=ON \
200823d5
ER
379%if %{with examples}
380 -DINSTALL_C_EXAMPLES=ON \
381 -DINSTALL_PYTHON_EXAMPLES=ON \
382%endif
b3920a9d 383 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 384 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 385 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
386 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
387 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 388 %{?with_opengl:-DWITH_OPENGL=ON} \
4a401ecc 389 %{?with_openmp:-DWITH_OPENMP=ON} \
1c9fe580 390 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 391 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 392 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 393 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 394 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 395 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 396 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 397 %{?with_ximea:-DWITH_XIMEA=ON} \
33a5389a
JR
398 %{?with_xine:-DWITH_XINE=ON} \
399 -DWITH_IPP=OFF
54551f29 400
8b9f61f7 401%{__make}
901927d3
AM
402
403%install
404rm -rf $RPM_BUILD_ROOT
95daeb66 405%{__make} -C build install \
901927d3
AM
406 DESTDIR=$RPM_BUILD_ROOT
407
200823d5
ER
408%if %{with examples}
409install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
701be548 410mv $RPM_BUILD_ROOT%{_datadir}/opencv4/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
200823d5 411%endif
9141b1e2 412
7545129b 413# disable completeness check incompatible with split packaging
701be548 414%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules.cmake
7545129b 415
8d499a62
JB
416%py_comp $RPM_BUILD_ROOT%{py_sitedir}
417%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
418%py_postclean
419
b07433c6
JB
420%if %{with java}
421# move to proper directories, create symlink
422install -d $RPM_BUILD_ROOT%{_javadir}
701be548
JR
423%{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
424sed -i -e 's#/share/java/opencv4/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
425 $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules-pld.cmake
426%{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
427rmdir $RPM_BUILD_ROOT%{_javadir}/opencv4
b07433c6
JB
428ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
429%endif
430
901927d3
AM
431%clean
432rm -rf $RPM_BUILD_ROOT
433
434%post -p /sbin/ldconfig
435%postun -p /sbin/ldconfig
436
933de752
ER
437%post core -p /sbin/ldconfig
438%postun core -p /sbin/ldconfig
439
485d5dca
JB
440%post viz -p /sbin/ldconfig
441%postun viz -p /sbin/ldconfig
442
b07433c6
JB
443%post -n java-opencv -p /sbin/ldconfig
444%postun -n java-opencv -p /sbin/ldconfig
445
901927d3
AM
446%files
447%defattr(644,root,root,755)
f753ced4 448%attr(755,root,root) %{_bindir}/opencv_annotation
701be548 449#%attr(755,root,root) %{_bindir}/opencv_createsamples
09d132a9 450%attr(755,root,root) %{_bindir}/opencv_interactive-calibration
701be548 451#%attr(755,root,root) %{_bindir}/opencv_traincascade
09d132a9
ER
452%attr(755,root,root) %{_bindir}/opencv_version
453%attr(755,root,root) %{_bindir}/opencv_visualisation
701be548 454%attr(755,root,root) %{_bindir}/setup_vars_opencv4.sh
158e0ccc 455%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
71c2eb73 456%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
158e0ccc 457%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
71c2eb73 458%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
158e0ccc 459%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
71c2eb73 460%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
158e0ccc 461%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
71c2eb73 462%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
158e0ccc 463%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
71c2eb73 464%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
158e0ccc 465%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
71c2eb73 466%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
158e0ccc 467%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
71c2eb73 468%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
b287af3c
JR
469# contrib modules
470%attr(755,root,root) %{_bindir}/opencv_waldboost_detector
471%attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
472%attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
473%attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
474%attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
475%attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
476%attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
477%attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
478%attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
479%attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
480%attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
481%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
482%attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
c9cb1c24
JR
483%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
484%attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
b287af3c
JR
485%attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
486%attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
487%attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
488%attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
09d132a9
ER
489%attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
490%attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
b287af3c
JR
491%attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
492%attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
493%attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
494%attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
c9cb1c24
JR
495%attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
496%attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
09d132a9
ER
497%attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
498%attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
b287af3c
JR
499%attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
500%attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
3752412b
JR
501%attr(755,root,root) %ghost %{_libdir}/libopencv_ovis.so.%{sover}
502%attr(755,root,root) %{_libdir}/libopencv_ovis.so.*.*.*
b287af3c
JR
503%attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
504%attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
09d132a9
ER
505%attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
506%attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
b287af3c
JR
507%attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
508%attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
509%attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
510%attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
511%attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
512%attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
513%attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
514%attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
515%attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
516%attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
517%attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
518%attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
519%attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
520%attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
521%attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
522%attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
523%attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
524%attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
525%attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
526%attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
527%attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
528%attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
529%attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
530%attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
531%attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
532%attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
533%attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
534%attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
701be548
JR
535%attr(755,root,root) %ghost %{_libdir}/libopencv_alphamat.so.%{sover}
536%attr(755,root,root) %{_libdir}/libopencv_alphamat.so.*.*.*
537%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_superres.so.%{sover}
538%attr(755,root,root) %{_libdir}/libopencv_dnn_superres.so.*.*.*
539%attr(755,root,root) %ghost %{_libdir}/libopencv_gapi.so.%{sover}
540%attr(755,root,root) %{_libdir}/libopencv_gapi.so.*.*.*
541%attr(755,root,root) %ghost %{_libdir}/libopencv_intensity_transform.so.%{sover}
542%attr(755,root,root) %{_libdir}/libopencv_intensity_transform.so.*.*.*
543%attr(755,root,root) %ghost %{_libdir}/libopencv_mcc.so.%{sover}
544%attr(755,root,root) %{_libdir}/libopencv_mcc.so.*.*.*
545%attr(755,root,root) %ghost %{_libdir}/libopencv_quality.so.%{sover}
546%attr(755,root,root) %{_libdir}/libopencv_quality.so.*.*.*
547%attr(755,root,root) %ghost %{_libdir}/libopencv_rapid.so.%{sover}
548%attr(755,root,root) %{_libdir}/libopencv_rapid.so.*.*.*
549
550%dir %{_datadir}/opencv4
551%{_datadir}/opencv4/haarcascades
552%{_datadir}/opencv4/lbpcascades
553%{_datadir}/opencv4/quality
901927d3 554
933de752
ER
555%files core
556%defattr(644,root,root,755)
158e0ccc 557%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
71c2eb73 558%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
158e0ccc 559%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
71c2eb73 560%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
158e0ccc 561%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
71c2eb73 562%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
158e0ccc 563%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
71c2eb73 564%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
158e0ccc 565%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
71c2eb73 566%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
158e0ccc 567%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
71c2eb73 568%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
33a5389a 569%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
71c2eb73 570%attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
33a5389a 571%attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
71c2eb73 572%attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
33a5389a 573%attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
71c2eb73 574%attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
cf32945e
JB
575
576%if %{with vtk}
577%files viz
578%defattr(644,root,root,755)
158e0ccc 579%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
71c2eb73 580%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
cf32945e 581%endif
933de752 582
901927d3
AM
583%files devel
584%defattr(644,root,root,755)
cf32945e 585# core
701be548
JR
586%{_libdir}/libopencv_core.so
587%{_libdir}/libopencv_flann.so
588%{_libdir}/libopencv_imgproc.so
589%{_libdir}/libopencv_ml.so
590%{_libdir}/libopencv_photo.so
591%{_libdir}/libopencv_video.so
cf32945e 592# GUI/extensions (base package)
701be548
JR
593%{_libdir}/libopencv_calib3d.so
594%{_libdir}/libopencv_features2d.so
595%{_libdir}/libopencv_highgui.so
596%{_libdir}/libopencv_objdetect.so
597%{_libdir}/libopencv_stitching.so
598%{_libdir}/libopencv_superres.so
599%{_libdir}/libopencv_videostab.so
600%{_libdir}/libopencv_imgcodecs.so
601%{_libdir}/libopencv_shape.so
602%{_libdir}/libopencv_videoio.so
b287af3c 603# contrib
701be548
JR
604%{_libdir}/libopencv_aruco.so
605%{_libdir}/libopencv_bgsegm.so
606%{_libdir}/libopencv_bioinspired.so
607%{_libdir}/libopencv_ccalib.so
608%{_libdir}/libopencv_datasets.so
609%{_libdir}/libopencv_dnn.so
610%{_libdir}/libopencv_dnn_objdetect.so
611%{_libdir}/libopencv_dpm.so
612%{_libdir}/libopencv_face.so
613%{_libdir}/libopencv_freetype.so
614%{_libdir}/libopencv_fuzzy.so
615%{_libdir}/libopencv_hdf.so
616%{_libdir}/libopencv_hfs.so
617%{_libdir}/libopencv_img_hash.so
618%{_libdir}/libopencv_line_descriptor.so
619%{_libdir}/libopencv_optflow.so
620%{_libdir}/libopencv_ovis.so
621%{_libdir}/libopencv_phase_unwrapping.so
622%{_libdir}/libopencv_plot.so
623%{_libdir}/libopencv_reg.so
624%{_libdir}/libopencv_rgbd.so
625%{_libdir}/libopencv_saliency.so
626%{_libdir}/libopencv_sfm.so
627%{_libdir}/libopencv_stereo.so
628%{_libdir}/libopencv_structured_light.so
629%{_libdir}/libopencv_surface_matching.so
630%{_libdir}/libopencv_text.so
631%{_libdir}/libopencv_tracking.so
632%{_libdir}/libopencv_xfeatures2d.so
633%{_libdir}/libopencv_ximgproc.so
634%{_libdir}/libopencv_xobjdetect.so
635%{_libdir}/libopencv_xphoto.so
636%{_libdir}/libopencv_alphamat.so
637%{_libdir}/libopencv_dnn_superres.so
638%{_libdir}/libopencv_gapi.so
639%{_libdir}/libopencv_intensity_transform.so
640%{_libdir}/libopencv_mcc.so
641%{_libdir}/libopencv_quality.so
642%{_libdir}/libopencv_rapid.so
cf32945e
JB
643# viz
644%if %{with vtk}
701be548 645%{_libdir}/libopencv_viz.so
0e077f8d 646%endif
701be548 647%{_includedir}/opencv4
e652d7a7 648%dir %{_libdir}/cmake/opencv4
701be548
JR
649%{_libdir}/cmake/opencv4/OpenCV*.cmake
650%{_pkgconfigdir}/opencv4.pc
901927d3 651
9141b1e2
ER
652%files doc
653%defattr(644,root,root,755)
654# TODO: probably could rebuild them and package via make install
655%doc doc/*
656
200823d5
ER
657%if %{with examples}
658%files examples
659%defattr(644,root,root,755)
660%{_examplesdir}/%{name}-%{version}
661%endif
662
b07433c6
JB
663%if %{with java}
664%files -n java-opencv
665%defattr(644,root,root,755)
835e0cdd
ER
666%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
667%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
668%{_javadir}/opencv.jar
669%endif
670
901927d3
AM
671%files -n python-opencv
672%defattr(644,root,root,755)
fe201543
JR
673%dir %{py_sitedir}/cv2
674%dir %{py_sitedir}/cv2/python-*
675%attr(755,root,root) %{py_sitedir}/cv2/python-*/cv2.so
676%{py_sitedir}/cv2/*.py[co]
b221500a
JB
677
678%files -n python3-opencv
679%defattr(644,root,root,755)
fe201543
JR
680%dir %{py3_sitedir}/cv2
681%dir %{py3_sitedir}/cv2/python-*
682%attr(755,root,root) %{py3_sitedir}/cv2/python-*/cv2.cpython-*.so
683%{py3_sitedir}/cv2/*.py
This page took 0.189473 seconds and 4 git commands to generate.