]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- there is no _mm_pause() on ix86
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
ca2adc08
JB
2# - contrib subpackage(s)
3# - contrib BRs:
4# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7# opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8# opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9# opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
09d132a9
ER
10# unpackaged (3.4.0)
11#/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12#/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13#/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14#/usr/share/OpenCV/valgrind.supp
15#/usr/share/OpenCV/valgrind_3rdparty.supp
16
ca2adc08 17#
2acd8ac1 18# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 19# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 20# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 21#
0c2d6b7d 22# Conditional build:
a55ba198
JB
23# - general options:
24%bcond_with tbb # Threading Building Blocks support (everywhere)
25%bcond_with sse # use SSE instructions
26%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
27%bcond_with sse3 # use SSE3 instructions
28%bcond_with ssse3 # use SSSE3 instructions
29%bcond_with sse41 # use SSE4.1 instructions
30%bcond_with sse42 # use SSE4.2 instructions
31%bcond_with avx # use AVX instructions
8d5385eb
JB
32%bcond_without opencl # OpenCL support
33%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
34%bcond_with opencl_amdfft # AMD OpenCL FFT routines
35%bcond_without opengl # OpenGL support
4a401ecc 36%bcond_without openmp # OpenMP support (available when not using tbb)
200823d5 37%bcond_without examples # Install examples
b07433c6
JB
38# - bindings
39%bcond_without java # Java binding
a55ba198 40# - highgui options:
b3920a9d 41%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
42%bcond_without gstreamer # GStreamer support in highgui
43%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 44%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 45%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 46%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 47%bcond_without v4l # Video4Linux in highgui
a55ba198 48%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 49%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
50# - other modules
51%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 52
e36ac029 53%ifarch pentium3 pentium4 %{x8664} x32
1c9fe580
JB
54%define with_sse 1
55%endif
e36ac029 56%ifarch pentium4 %{x8664} x32
1c9fe580
JB
57%define with_sse2 1
58%endif
901927d3 59Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 60Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 61Name: opencv
01c6bd4e 62Version: 3.4.1
09d132a9 63Release: 0.1
901927d3 64Epoch: 1
d5e56e66
JB
65%if %{with unicap} || %{with xine}
66License: GPL (enforced by used libraries), BSD (opencv itself)
67%else
901927d3 68License: BSD
d5e56e66 69%endif
901927d3 70Group: Libraries
200823d5 71Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
01c6bd4e 72# Source0-md5: a0b7a47899e67b3490ea31edc4f6e8e6
b287af3c 73Source1: https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
01c6bd4e 74# Source1-md5: dd0c63f4185ab8a4829d8154ae382266
8a121398
JR
75# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76Source10: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77# Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78Source11: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79# Source11-md5: 232c966b13651bd0e46a1497b0852191
80Source12: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81# Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82Source13: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83# Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84Source14: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85# Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86Source15: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87# Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88Source16: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89# Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91Source20: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92# Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93Source21: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94# Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95Source22: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96# Source22-md5: 7cd47228edec52b6d82f46511af325c5
97Source23: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98# Source23-md5: 151805e03568c9f490a5e3a872777b75
99Source30: https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
100# Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
101Patch0: ix86-pause.patch
08b22f18 102Patch1: %{name}-ximea.patch
08b22f18 103Patch3: cmake-install-path.patch
200823d5 104URL: http://www.opencv.org/
d5e56e66 105%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 106%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 107BuildRequires: OpenEXR-devel
5df3cf1b 108%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 109%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 110# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 111%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 112%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 113%{?with_java:BuildRequires: ant}
8a121398 114BuildRequires: boost-devel
ef4af528
JB
115%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
116%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 117BuildRequires: cmake >= 2.8
0c2d6b7d 118BuildRequires: doxygen
809ce413 119BuildRequires: eigen3 >= 3
b3920a9d 120%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
4a401ecc 121%{?with_openmp:BuildRequires: gcc-c++ >= 6:4.2}
fb5ded39 122BuildRequires: gflags-devel
74cbdeb2 123BuildRequires: gl2ps-devel
debb38d4 124BuildRequires: glog-devel
0c2d6b7d 125%if %{with gstreamer}
158e0ccc
JB
126BuildRequires: gstreamer-devel >= 1.0
127BuildRequires: gstreamer-plugins-base-devel >= 1.0
0c2d6b7d 128%endif
901927d3 129BuildRequires: jasper-devel
b07433c6 130%{?with_java:BuildRequires: jdk}
158e0ccc 131BuildRequires: libdc1394-devel >= 2
4a401ecc 132%{?with_openmp:BuildRequires: libgomp-devel}
901927d3
AM
133BuildRequires: libjpeg-devel
134BuildRequires: libpng-devel
135BuildRequires: libraw1394-devel
0c2d6b7d 136BuildRequires: libstdc++-devel
901927d3 137BuildRequires: libtiff-devel
148338c5 138BuildRequires: libtool
d5e56e66
JB
139%if %{with unicap}
140BuildRequires: libucil-devel
141BuildRequires: libunicap-devel
142%endif
0c2d6b7d 143BuildRequires: libv4l-devel
af6d2888 144BuildRequires: pkgconfig
158e0ccc
JB
145BuildRequires: python >= 2.0
146BuildRequires: python-devel >= 2.0
0c2d6b7d 147BuildRequires: python-numpy-devel
b221500a
JB
148BuildRequires: python3 >= 1:3.2
149BuildRequires: python3-devel >= 1:3.2
150BuildRequires: python3-numpy-devel
901927d3 151BuildRequires: rpm-pythonprov
8d499a62 152BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 153BuildRequires: sed >= 4.0
158e0ccc 154BuildRequires: sphinx-pdg
996927aa 155BuildRequires: swig-python
f8e040cc 156%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
157%if %{with vtk}
158BuildRequires: vtk-devel >= 5.8.0
fba97d16 159BuildRequires: vtk-java >= 5.8.0
ae3d975d
AM
160BuildRequires: vtk-tcl >= 5.8.0
161%endif
901927d3 162%{?with_xine:BuildRequires: xine-lib-devel}
158e0ccc 163BuildRequires: xorg-lib-libX11-devel
452b38e1 164BuildRequires: zlib-devel
4afb606b 165%if %{with qt}
4afb606b
JB
166BuildRequires: QtCore-devel >= 4
167BuildRequires: QtGui-devel >= 4
5df3cf1b 168%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
169BuildRequires: qt4-qmake >= 4
170%else
171BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 172%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 173%endif
da5d1e09 174Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
175BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
176
158e0ccc 177%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
71c2eb73 178%define sover %(echo %{version} | cut -d. -f1-2)
933de752 179
901927d3
AM
180%description
181OpenCV (Open Source Computer Vision) is a library of programming
182functions mainly aimed at real time computer vision.
183
0c2d6b7d
JB
184Example applications of the OpenCV library are:
185- Human-Computer Interaction (HCI)
186- Object Identification, Segmentation and Recognition
187- Face Recognition
188- Gesture Recognition
189- Motion Tracking
190- Ego Motion, Motion Understanding
191- Structure From Motion (SFM)
192- Stereo and Multi-Camera Calibration and Depth Computation
193- Mobile Robotics.
194
195%description -l pl.UTF-8
196OpenCV (Open Source Computer Vision) to biblioteka funkcji
197przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
198
199Przykładowe zastosowania biblioteki OpenCV to
200- interakcje człowiek-komputer (HCI)
201- identyfikacja, segmentacja i rozpoznawanie obiektów
202- rozpoznawanie twarzy
203- rozpoznawanie gestów
204- śledzenie ruchu
205- rozumienie ruchu
206- SFM (Structure From Motion)
207- kalibracja dwu- i wielokamerowa, obliczanie głębi
208- robotyka ruchu.
901927d3 209
933de752
ER
210%package core
211Summary: OpenCV core libraries
da5d1e09 212Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 213Group: Libraries
da5d1e09 214Conflicts: opencv < 2.4.6.2-1
933de752
ER
215
216%description core
217This package contains the OpenCV C/C++ core libraries.
218
da5d1e09
JB
219%description core -l pl.UTF-8
220Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
221
cf32945e
JB
222%package viz
223Summary: OpenCV viz library (VTK support)
224Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
225Group: Libraries
226Requires: %{name} = %{epoch}:%{version}-%{release}
227
228%description viz
229OpenCV viz library (VTK support).
230
231%description viz -l pl.UTF-8
232Biblioteka OpenCV viz (obsługa VTK).
233
901927d3 234%package devel
0c2d6b7d
JB
235Summary: Header files for OpenCV library
236Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
237Group: Development/Libraries
238Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
239%if %{with vtk}
240Requires: %{name}-viz = %{epoch}:%{version}-%{release}
241%endif
0c2d6b7d 242Obsoletes: opencv-static
901927d3
AM
243
244%description devel
0c2d6b7d 245Header files for OpenCV library.
901927d3 246
0c2d6b7d
JB
247%description devel -l pl.UTF-8
248Pliki nagłówkowe biblioteki OpenCV.
901927d3 249
9141b1e2
ER
250%package doc
251Summary: Manual for OpenCV
252Summary(fr.UTF-8): Documentation pour OpenCV
253Summary(it.UTF-8): Documentazione di OpenCV
254Summary(pl.UTF-8): Podręcznik dla OpenCV
255Group: Documentation
256# noarch subpackages only when building with rpm5
257%if "%{_rpmversion}" >= "5"
258BuildArch: noarch
259%endif
260
261%description doc
262Documentation for OpenCV.
263
264%description doc -l fr.UTF-8
265Documentation pour OpenCV.
266
267%description doc -l it.UTF-8
268Documentazione di OpenCV.
269
270%description doc -l pl.UTF-8
271Dokumentacja do OpenCV.
272
200823d5
ER
273%package examples
274Summary: OpenCV code examples
275Group: Documentation
276%if "%{_rpmversion}" >= "5"
277BuildArch: noarch
278%endif
279
280%description examples
281OpenCV code examples.
282
b07433c6
JB
283%package -n java-opencv
284Summary: OpenCV Java bindings
285Summary(pl.UTF-8): Wiązania Javy do OpenCV
286Group: Libraries/Java
287Requires: %{name} = %{epoch}:%{version}-%{release}
288Requires: jre
289
290%description -n java-opencv
291OpenCV Java bindings.
292
293%description -n java-opencv -l pl.UTF-8
294Wiązania Javy do OpenCV.
295
901927d3 296%package -n python-opencv
b221500a
JB
297Summary: OpenCV Python 2 bindings
298Summary(pl.UTF-8): Wiązania Pythona 2 do OpenCV
0c2d6b7d 299Group: Libraries/Python
cd1f0136 300Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 301Requires: python-libs
901927d3
AM
302
303%description -n python-opencv
b221500a 304OpenCV Python 2 bindings.
901927d3 305
0c2d6b7d 306%description -n python-opencv -l pl.UTF-8
b221500a
JB
307Wiązania Pythona 2 do OpenCV.
308
309%package -n python3-opencv
310Summary: OpenCV Python 3 bindings
311Summary(pl.UTF-8): Wiązania Pythona 3 do OpenCV
312Group: Libraries/Python
313Requires: %{name} = %{epoch}:%{version}-%{release}
314Requires: python3-libs
315
316%description -n python3-opencv
317OpenCV Python 3 bindings.
318
319%description -n python3-opencv -l pl.UTF-8
320Wiązania Pythona 3 do OpenCV.
0c2d6b7d 321
901927d3 322%prep
b287af3c 323%setup -q -a1
54551f29 324
da67222a 325%undos CMakeLists.txt
54551f29 326
8a121398 327%patch0 -p1
08b22f18 328%patch1 -p1
01c6bd4e 329%patch3 -p1
148338c5 330
901927d3 331%build
8a121398 332install -d build/{share/OpenCV/testdata/cv/face,downloads/xfeatures2d}
95daeb66 333cd build
ea26b025 334
8a121398
JR
335install %{SOURCE30} share/OpenCV/testdata/cv/face/
336install %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16} downloads/xfeatures2d/
337install %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} downloads/xfeatures2d/
338
ea26b025
ER
339# handle cmake & ccache
340# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
341if [[ "%{__cc}" = *ccache* ]]; then
342 cc="%{__cc}"
343 cxx="%{__cxx}"
344 ccache="
345 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
346 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
347 "
348fi
349
0c2d6b7d 350%cmake .. \
ea26b025 351 $ccache \
08b22f18 352 -DENABLE_PRECOMPILED_HEADERS=OFF \
09d132a9 353 -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
b287af3c 354 -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
da5d1e09 355 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
356 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
357 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
358 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
359 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
360 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
361 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 362 -DBUILD_NEW_PYTHON_SUPPORT=ON \
200823d5
ER
363%if %{with examples}
364 -DINSTALL_C_EXAMPLES=ON \
365 -DINSTALL_PYTHON_EXAMPLES=ON \
366%endif
b3920a9d 367 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 368 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 369 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
370 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
371 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 372 %{?with_opengl:-DWITH_OPENGL=ON} \
4a401ecc 373 %{?with_openmp:-DWITH_OPENMP=ON} \
1c9fe580 374 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 375 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 376 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 377 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 378 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 379 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 380 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 381 %{?with_ximea:-DWITH_XIMEA=ON} \
33a5389a
JR
382 %{?with_xine:-DWITH_XINE=ON} \
383 -DWITH_IPP=OFF
54551f29 384
8b9f61f7 385%{__make}
901927d3
AM
386
387%install
388rm -rf $RPM_BUILD_ROOT
95daeb66 389%{__make} -C build install \
901927d3
AM
390 DESTDIR=$RPM_BUILD_ROOT
391
200823d5
ER
392%if %{with examples}
393install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
394mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
395%endif
9141b1e2 396
4bd2eae7 397install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
a4737151 398cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
4bd2eae7 399
7545129b
JB
400# disable completeness check incompatible with split packaging
401%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
402
8d499a62
JB
403%py_comp $RPM_BUILD_ROOT%{py_sitedir}
404%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
405%py_postclean
406
b07433c6
JB
407%if %{with java}
408# move to proper directories, create symlink
409install -d $RPM_BUILD_ROOT%{_javadir}
410%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
c3075463
AM
411sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
412 $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
b07433c6
JB
413%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
414rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
415ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
416%endif
417
901927d3
AM
418%clean
419rm -rf $RPM_BUILD_ROOT
420
421%post -p /sbin/ldconfig
422%postun -p /sbin/ldconfig
423
933de752
ER
424%post core -p /sbin/ldconfig
425%postun core -p /sbin/ldconfig
426
485d5dca
JB
427%post viz -p /sbin/ldconfig
428%postun viz -p /sbin/ldconfig
429
b07433c6
JB
430%post -n java-opencv -p /sbin/ldconfig
431%postun -n java-opencv -p /sbin/ldconfig
432
901927d3
AM
433%files
434%defattr(644,root,root,755)
f753ced4 435%attr(755,root,root) %{_bindir}/opencv_annotation
933de752 436%attr(755,root,root) %{_bindir}/opencv_createsamples
09d132a9 437%attr(755,root,root) %{_bindir}/opencv_interactive-calibration
933de752 438%attr(755,root,root) %{_bindir}/opencv_traincascade
09d132a9
ER
439%attr(755,root,root) %{_bindir}/opencv_version
440%attr(755,root,root) %{_bindir}/opencv_visualisation
158e0ccc 441%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
71c2eb73 442%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
158e0ccc 443%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
71c2eb73 444%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
158e0ccc 445%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
71c2eb73 446%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
158e0ccc 447%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
71c2eb73 448%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
158e0ccc 449%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
71c2eb73 450%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
158e0ccc 451%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
71c2eb73 452%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
158e0ccc 453%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
71c2eb73 454%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
b287af3c
JR
455# contrib modules
456%attr(755,root,root) %{_bindir}/opencv_waldboost_detector
457%attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
458%attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
459%attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
460%attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
461%attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
462%attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
463%attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
464%attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
465%attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
466%attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
467%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
468%attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
c9cb1c24
JR
469%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
470%attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
b287af3c
JR
471%attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
472%attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
473%attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
474%attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
09d132a9
ER
475%attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
476%attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
b287af3c
JR
477%attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
478%attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
479%attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
480%attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
c9cb1c24
JR
481%attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
482%attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
09d132a9
ER
483%attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
484%attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
b287af3c
JR
485%attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
486%attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
487%attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
488%attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
09d132a9
ER
489%attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
490%attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
b287af3c
JR
491%attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
492%attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
493%attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
494%attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
495%attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
496%attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
497%attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
498%attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
499%attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
500%attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
501%attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
502%attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
503%attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
504%attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
505%attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
506%attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
507%attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
508%attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
509%attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
510%attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
511%attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
512%attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
513%attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
514%attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
515%attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
516%attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
517%attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
518%attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
09d132a9 519
452b38e1 520%dir %{_datadir}/OpenCV
452b38e1 521%{_datadir}/OpenCV/haarcascades
522%{_datadir}/OpenCV/lbpcascades
901927d3 523
933de752
ER
524%files core
525%defattr(644,root,root,755)
158e0ccc 526%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
71c2eb73 527%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
158e0ccc 528%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
71c2eb73 529%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
158e0ccc 530%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
71c2eb73 531%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
158e0ccc 532%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
71c2eb73 533%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
158e0ccc 534%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
71c2eb73 535%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
158e0ccc 536%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
71c2eb73 537%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
33a5389a 538%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
71c2eb73 539%attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
33a5389a 540%attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
71c2eb73 541%attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
33a5389a 542%attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
71c2eb73 543%attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
cf32945e
JB
544
545%if %{with vtk}
546%files viz
547%defattr(644,root,root,755)
158e0ccc 548%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
71c2eb73 549%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
cf32945e 550%endif
933de752 551
901927d3
AM
552%files devel
553%defattr(644,root,root,755)
cf32945e
JB
554# core
555%attr(755,root,root) %{_libdir}/libopencv_core.so
556%attr(755,root,root) %{_libdir}/libopencv_flann.so
557%attr(755,root,root) %{_libdir}/libopencv_imgproc.so
558%attr(755,root,root) %{_libdir}/libopencv_ml.so
559%attr(755,root,root) %{_libdir}/libopencv_photo.so
560%attr(755,root,root) %{_libdir}/libopencv_video.so
561# GUI/extensions (base package)
562%attr(755,root,root) %{_libdir}/libopencv_calib3d.so
cf32945e 563%attr(755,root,root) %{_libdir}/libopencv_features2d.so
cf32945e 564%attr(755,root,root) %{_libdir}/libopencv_highgui.so
cf32945e 565%attr(755,root,root) %{_libdir}/libopencv_objdetect.so
cf32945e
JB
566%attr(755,root,root) %{_libdir}/libopencv_stitching.so
567%attr(755,root,root) %{_libdir}/libopencv_superres.so
cf32945e 568%attr(755,root,root) %{_libdir}/libopencv_videostab.so
33a5389a
JR
569%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so
570%attr(755,root,root) %{_libdir}/libopencv_shape.so
571%attr(755,root,root) %{_libdir}/libopencv_videoio.so
b287af3c
JR
572# contrib
573%attr(755,root,root) %{_libdir}/libopencv_aruco.so
574%attr(755,root,root) %{_libdir}/libopencv_bgsegm.so
575%attr(755,root,root) %{_libdir}/libopencv_bioinspired.so
576%attr(755,root,root) %{_libdir}/libopencv_ccalib.so
577%attr(755,root,root) %{_libdir}/libopencv_datasets.so
578%attr(755,root,root) %{_libdir}/libopencv_dnn.so
c9cb1c24 579%attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so
b287af3c
JR
580%attr(755,root,root) %{_libdir}/libopencv_dpm.so
581%attr(755,root,root) %{_libdir}/libopencv_face.so
09d132a9 582%attr(755,root,root) %{_libdir}/libopencv_freetype.so
b287af3c
JR
583%attr(755,root,root) %{_libdir}/libopencv_fuzzy.so
584%attr(755,root,root) %{_libdir}/libopencv_hdf.so
c9cb1c24 585%attr(755,root,root) %{_libdir}/libopencv_hfs.so
09d132a9 586%attr(755,root,root) %{_libdir}/libopencv_img_hash.so
b287af3c
JR
587%attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so
588%attr(755,root,root) %{_libdir}/libopencv_optflow.so
09d132a9 589%attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so
b287af3c
JR
590%attr(755,root,root) %{_libdir}/libopencv_plot.so
591%attr(755,root,root) %{_libdir}/libopencv_reg.so
592%attr(755,root,root) %{_libdir}/libopencv_rgbd.so
593%attr(755,root,root) %{_libdir}/libopencv_saliency.so
594%attr(755,root,root) %{_libdir}/libopencv_sfm.so
595%attr(755,root,root) %{_libdir}/libopencv_stereo.so
596%attr(755,root,root) %{_libdir}/libopencv_structured_light.so
597%attr(755,root,root) %{_libdir}/libopencv_surface_matching.so
598%attr(755,root,root) %{_libdir}/libopencv_text.so
599%attr(755,root,root) %{_libdir}/libopencv_tracking.so
600%attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so
601%attr(755,root,root) %{_libdir}/libopencv_ximgproc.so
602%attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so
603%attr(755,root,root) %{_libdir}/libopencv_xphoto.so
09d132a9 604#%{_libdir}/libopencv_ts.a
cf32945e
JB
605# viz
606%if %{with vtk}
607%attr(755,root,root) %{_libdir}/libopencv_viz.so
0e077f8d 608%endif
901927d3 609%{_includedir}/opencv
509c07dc 610%{_includedir}/opencv2
da5d1e09 611%{_datadir}/OpenCV/OpenCV*.cmake
0c2d6b7d 612%{_pkgconfigdir}/opencv.pc
901927d3 613
9141b1e2
ER
614%files doc
615%defattr(644,root,root,755)
616# TODO: probably could rebuild them and package via make install
617%doc doc/*
618
200823d5
ER
619%if %{with examples}
620%files examples
621%defattr(644,root,root,755)
622%{_examplesdir}/%{name}-%{version}
623%endif
624
b07433c6
JB
625%if %{with java}
626%files -n java-opencv
627%defattr(644,root,root,755)
835e0cdd
ER
628%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
629%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
630%{_javadir}/opencv.jar
631%endif
632
901927d3
AM
633%files -n python-opencv
634%defattr(644,root,root,755)
452b38e1 635%attr(755,root,root) %{py_sitedir}/cv2.so
b221500a
JB
636
637%files -n python3-opencv
638%defattr(644,root,root,755)
639%attr(755,root,root) %{py3_sitedir}/cv2.cpython-*.so
This page took 0.185644 seconds and 4 git commands to generate.