]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- up to 4.5.1
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
ca2adc08
JB
2# - contrib subpackage(s)
3# - contrib BRs:
4# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7# opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8# opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9# opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
09d132a9
ER
10# unpackaged (3.4.0)
11#/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12#/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13#/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14#/usr/share/OpenCV/valgrind.supp
15#/usr/share/OpenCV/valgrind_3rdparty.supp
16
ca2adc08 17#
2acd8ac1 18# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 19# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 20# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 21#
0c2d6b7d 22# Conditional build:
a55ba198
JB
23# - general options:
24%bcond_with tbb # Threading Building Blocks support (everywhere)
25%bcond_with sse # use SSE instructions
26%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
27%bcond_with sse3 # use SSE3 instructions
28%bcond_with ssse3 # use SSSE3 instructions
29%bcond_with sse41 # use SSE4.1 instructions
30%bcond_with sse42 # use SSE4.2 instructions
31%bcond_with avx # use AVX instructions
8d5385eb
JB
32%bcond_without opencl # OpenCL support
33%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
34%bcond_with opencl_amdfft # AMD OpenCL FFT routines
35%bcond_without opengl # OpenGL support
4a401ecc 36%bcond_without openmp # OpenMP support (available when not using tbb)
200823d5 37%bcond_without examples # Install examples
b07433c6
JB
38# - bindings
39%bcond_without java # Java binding
a55ba198 40# - highgui options:
b3920a9d 41%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
42%bcond_without gstreamer # GStreamer support in highgui
43%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 44%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 45%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 46%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 47%bcond_without v4l # Video4Linux in highgui
a55ba198 48%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 49%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
50# - other modules
51%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 52
e36ac029 53%ifarch pentium3 pentium4 %{x8664} x32
1c9fe580
JB
54%define with_sse 1
55%endif
e36ac029 56%ifarch pentium4 %{x8664} x32
1c9fe580
JB
57%define with_sse2 1
58%endif
901927d3 59Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 60Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 61Name: opencv
701be548
JR
62Version: 4.5.1
63Release: 1
901927d3 64Epoch: 1
d5e56e66
JB
65%if %{with unicap} || %{with xine}
66License: GPL (enforced by used libraries), BSD (opencv itself)
67%else
901927d3 68License: BSD
d5e56e66 69%endif
901927d3 70Group: Libraries
200823d5 71Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
701be548 72# Source0-md5: 2205d3169238ec1f184438a96de68513
b287af3c 73Source1: https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
701be548 74# Source1-md5: 19a31bf7271978ab426112dbf5d1b83f
8a121398
JR
75# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76Source10: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77# Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78Source11: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79# Source11-md5: 232c966b13651bd0e46a1497b0852191
80Source12: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81# Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82Source13: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83# Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84Source14: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85# Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86Source15: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87# Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88Source16: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89# Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91Source20: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92# Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93Source21: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94# Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95Source22: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96# Source22-md5: 7cd47228edec52b6d82f46511af325c5
97Source23: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98# Source23-md5: 151805e03568c9f490a5e3a872777b75
454d8108 99# See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
8a121398
JR
100Source30: https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101# Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
701be548
JR
102# See opencv-4.5.1/modules/gapi/CMakeLists.txt
103Source40: https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
104# Source40-md5: b624b995ec9c439cbc2e9e6ee940d3a2
fe201543
JR
105Patch0: %{name}-ximea.patch
106Patch1: python-install.patch
200823d5 107URL: http://www.opencv.org/
d5e56e66 108%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 109%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 110BuildRequires: OpenEXR-devel
5df3cf1b 111%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 112%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 113# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 114%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 115%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 116%{?with_java:BuildRequires: ant}
8a121398 117BuildRequires: boost-devel
ef4af528
JB
118%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
119%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 120BuildRequires: cmake >= 2.8
0c2d6b7d 121BuildRequires: doxygen
809ce413 122BuildRequires: eigen3 >= 3
b3920a9d 123%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
4a401ecc 124%{?with_openmp:BuildRequires: gcc-c++ >= 6:4.2}
fb5ded39 125BuildRequires: gflags-devel
74cbdeb2 126BuildRequires: gl2ps-devel
debb38d4 127BuildRequires: glog-devel
0c2d6b7d 128%if %{with gstreamer}
158e0ccc
JB
129BuildRequires: gstreamer-devel >= 1.0
130BuildRequires: gstreamer-plugins-base-devel >= 1.0
0c2d6b7d 131%endif
901927d3 132BuildRequires: jasper-devel
b07433c6 133%{?with_java:BuildRequires: jdk}
158e0ccc 134BuildRequires: libdc1394-devel >= 2
4a401ecc 135%{?with_openmp:BuildRequires: libgomp-devel}
901927d3
AM
136BuildRequires: libjpeg-devel
137BuildRequires: libpng-devel
138BuildRequires: libraw1394-devel
0c2d6b7d 139BuildRequires: libstdc++-devel
901927d3 140BuildRequires: libtiff-devel
148338c5 141BuildRequires: libtool
d5e56e66
JB
142%if %{with unicap}
143BuildRequires: libucil-devel
144BuildRequires: libunicap-devel
145%endif
0c2d6b7d 146BuildRequires: libv4l-devel
af6d2888 147BuildRequires: pkgconfig
701be548 148BuildRequires: protobuf-devel
158e0ccc
JB
149BuildRequires: python >= 2.0
150BuildRequires: python-devel >= 2.0
0c2d6b7d 151BuildRequires: python-numpy-devel
b221500a
JB
152BuildRequires: python3 >= 1:3.2
153BuildRequires: python3-devel >= 1:3.2
154BuildRequires: python3-numpy-devel
901927d3 155BuildRequires: rpm-pythonprov
8d499a62 156BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 157BuildRequires: sed >= 4.0
158e0ccc 158BuildRequires: sphinx-pdg
996927aa 159BuildRequires: swig-python
f8e040cc 160%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
161%if %{with vtk}
162BuildRequires: vtk-devel >= 5.8.0
fba97d16 163BuildRequires: vtk-java >= 5.8.0
701be548 164BuildRequires: vtk-python3-devel >= 5.8.0
ae3d975d 165%endif
901927d3 166%{?with_xine:BuildRequires: xine-lib-devel}
158e0ccc 167BuildRequires: xorg-lib-libX11-devel
452b38e1 168BuildRequires: zlib-devel
4afb606b 169%if %{with qt}
4afb606b
JB
170BuildRequires: QtCore-devel >= 4
171BuildRequires: QtGui-devel >= 4
5df3cf1b 172%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
173BuildRequires: qt4-qmake >= 4
174%else
175BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 176%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 177%endif
da5d1e09 178Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
179BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
180
158e0ccc 181%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
71c2eb73 182%define sover %(echo %{version} | cut -d. -f1-2)
933de752 183
901927d3
AM
184%description
185OpenCV (Open Source Computer Vision) is a library of programming
186functions mainly aimed at real time computer vision.
187
0c2d6b7d
JB
188Example applications of the OpenCV library are:
189- Human-Computer Interaction (HCI)
190- Object Identification, Segmentation and Recognition
191- Face Recognition
192- Gesture Recognition
193- Motion Tracking
194- Ego Motion, Motion Understanding
195- Structure From Motion (SFM)
196- Stereo and Multi-Camera Calibration and Depth Computation
197- Mobile Robotics.
198
199%description -l pl.UTF-8
200OpenCV (Open Source Computer Vision) to biblioteka funkcji
201przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
202
203Przykładowe zastosowania biblioteki OpenCV to
204- interakcje człowiek-komputer (HCI)
205- identyfikacja, segmentacja i rozpoznawanie obiektów
206- rozpoznawanie twarzy
207- rozpoznawanie gestów
208- śledzenie ruchu
209- rozumienie ruchu
210- SFM (Structure From Motion)
211- kalibracja dwu- i wielokamerowa, obliczanie głębi
212- robotyka ruchu.
901927d3 213
933de752
ER
214%package core
215Summary: OpenCV core libraries
da5d1e09 216Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 217Group: Libraries
da5d1e09 218Conflicts: opencv < 2.4.6.2-1
933de752
ER
219
220%description core
221This package contains the OpenCV C/C++ core libraries.
222
da5d1e09
JB
223%description core -l pl.UTF-8
224Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
225
cf32945e
JB
226%package viz
227Summary: OpenCV viz library (VTK support)
228Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
229Group: Libraries
230Requires: %{name} = %{epoch}:%{version}-%{release}
231
232%description viz
233OpenCV viz library (VTK support).
234
235%description viz -l pl.UTF-8
236Biblioteka OpenCV viz (obsługa VTK).
237
901927d3 238%package devel
0c2d6b7d
JB
239Summary: Header files for OpenCV library
240Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
241Group: Development/Libraries
242Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
243%if %{with vtk}
244Requires: %{name}-viz = %{epoch}:%{version}-%{release}
245%endif
0c2d6b7d 246Obsoletes: opencv-static
901927d3
AM
247
248%description devel
0c2d6b7d 249Header files for OpenCV library.
901927d3 250
0c2d6b7d
JB
251%description devel -l pl.UTF-8
252Pliki nagłówkowe biblioteki OpenCV.
901927d3 253
9141b1e2
ER
254%package doc
255Summary: Manual for OpenCV
256Summary(fr.UTF-8): Documentation pour OpenCV
257Summary(it.UTF-8): Documentazione di OpenCV
258Summary(pl.UTF-8): Podręcznik dla OpenCV
259Group: Documentation
260# noarch subpackages only when building with rpm5
9141b1e2 261BuildArch: noarch
9141b1e2
ER
262
263%description doc
264Documentation for OpenCV.
265
266%description doc -l fr.UTF-8
267Documentation pour OpenCV.
268
269%description doc -l it.UTF-8
270Documentazione di OpenCV.
271
272%description doc -l pl.UTF-8
273Dokumentacja do OpenCV.
274
200823d5
ER
275%package examples
276Summary: OpenCV code examples
277Group: Documentation
200823d5 278BuildArch: noarch
200823d5
ER
279
280%description examples
281OpenCV code examples.
282
b07433c6
JB
283%package -n java-opencv
284Summary: OpenCV Java bindings
285Summary(pl.UTF-8): Wiązania Javy do OpenCV
286Group: Libraries/Java
287Requires: %{name} = %{epoch}:%{version}-%{release}
288Requires: jre
289
290%description -n java-opencv
291OpenCV Java bindings.
292
293%description -n java-opencv -l pl.UTF-8
294Wiązania Javy do OpenCV.
295
901927d3 296%package -n python-opencv
b221500a
JB
297Summary: OpenCV Python 2 bindings
298Summary(pl.UTF-8): Wiązania Pythona 2 do OpenCV
0c2d6b7d 299Group: Libraries/Python
cd1f0136 300Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 301Requires: python-libs
901927d3
AM
302
303%description -n python-opencv
b221500a 304OpenCV Python 2 bindings.
901927d3 305
0c2d6b7d 306%description -n python-opencv -l pl.UTF-8
b221500a
JB
307Wiązania Pythona 2 do OpenCV.
308
309%package -n python3-opencv
310Summary: OpenCV Python 3 bindings
311Summary(pl.UTF-8): Wiązania Pythona 3 do OpenCV
312Group: Libraries/Python
313Requires: %{name} = %{epoch}:%{version}-%{release}
314Requires: python3-libs
315
316%description -n python3-opencv
317OpenCV Python 3 bindings.
318
319%description -n python3-opencv -l pl.UTF-8
320Wiązania Pythona 3 do OpenCV.
0c2d6b7d 321
901927d3 322%prep
b287af3c 323%setup -q -a1
54551f29 324
da67222a 325%undos CMakeLists.txt
54551f29 326
8a121398 327%patch0 -p1
08b22f18 328%patch1 -p1
148338c5 329
701be548
JR
330cache_file() {
331 f="$1"
332 d="$2"
333 md5="$(md5sum "$f" | awk '{print $1}')"
334 file="$(basename "$f")"
335 mkdir -p ".cache/$d"
336 install "$f" ".cache/$d/$md5-$file"
337}
338for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
339 cache_file $f xfeatures2d/boostdesc
340done
341for f in %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}; do
342 cache_file $f xfeatures2d/vgg
343done
344cache_file %{SOURCE30} data
345cache_file %{SOURCE40} ade
346
901927d3 347%build
701be548 348mkdir -p build
95daeb66 349cd build
ea26b025
ER
350
351# handle cmake & ccache
352# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
353if [[ "%{__cc}" = *ccache* ]]; then
354 cc="%{__cc}"
355 cxx="%{__cxx}"
356 ccache="
357 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
358 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
359 "
360fi
361
0c2d6b7d 362%cmake .. \
ea26b025 363 $ccache \
08b22f18 364 -DENABLE_PRECOMPILED_HEADERS=OFF \
09d132a9 365 -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
b287af3c 366 -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
da5d1e09 367 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
368 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
369 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
370 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
371 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
372 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
373 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 374 -DBUILD_NEW_PYTHON_SUPPORT=ON \
701be548 375 -DOPENCV_GENERATE_PKGCONFIG:BOOL=ON \
200823d5
ER
376%if %{with examples}
377 -DINSTALL_C_EXAMPLES=ON \
378 -DINSTALL_PYTHON_EXAMPLES=ON \
379%endif
b3920a9d 380 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 381 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 382 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
383 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
384 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 385 %{?with_opengl:-DWITH_OPENGL=ON} \
4a401ecc 386 %{?with_openmp:-DWITH_OPENMP=ON} \
1c9fe580 387 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 388 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 389 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 390 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 391 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 392 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 393 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 394 %{?with_ximea:-DWITH_XIMEA=ON} \
33a5389a
JR
395 %{?with_xine:-DWITH_XINE=ON} \
396 -DWITH_IPP=OFF
54551f29 397
8b9f61f7 398%{__make}
901927d3
AM
399
400%install
401rm -rf $RPM_BUILD_ROOT
95daeb66 402%{__make} -C build install \
901927d3
AM
403 DESTDIR=$RPM_BUILD_ROOT
404
200823d5
ER
405%if %{with examples}
406install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
701be548 407mv $RPM_BUILD_ROOT%{_datadir}/opencv4/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
200823d5 408%endif
9141b1e2 409
7545129b 410# disable completeness check incompatible with split packaging
701be548 411%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules.cmake
7545129b 412
8d499a62
JB
413%py_comp $RPM_BUILD_ROOT%{py_sitedir}
414%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
415%py_postclean
416
b07433c6
JB
417%if %{with java}
418# move to proper directories, create symlink
419install -d $RPM_BUILD_ROOT%{_javadir}
701be548
JR
420%{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
421sed -i -e 's#/share/java/opencv4/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
422 $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules-pld.cmake
423%{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
424rmdir $RPM_BUILD_ROOT%{_javadir}/opencv4
b07433c6
JB
425ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
426%endif
427
901927d3
AM
428%clean
429rm -rf $RPM_BUILD_ROOT
430
431%post -p /sbin/ldconfig
432%postun -p /sbin/ldconfig
433
933de752
ER
434%post core -p /sbin/ldconfig
435%postun core -p /sbin/ldconfig
436
485d5dca
JB
437%post viz -p /sbin/ldconfig
438%postun viz -p /sbin/ldconfig
439
b07433c6
JB
440%post -n java-opencv -p /sbin/ldconfig
441%postun -n java-opencv -p /sbin/ldconfig
442
901927d3
AM
443%files
444%defattr(644,root,root,755)
f753ced4 445%attr(755,root,root) %{_bindir}/opencv_annotation
701be548 446#%attr(755,root,root) %{_bindir}/opencv_createsamples
09d132a9 447%attr(755,root,root) %{_bindir}/opencv_interactive-calibration
701be548 448#%attr(755,root,root) %{_bindir}/opencv_traincascade
09d132a9
ER
449%attr(755,root,root) %{_bindir}/opencv_version
450%attr(755,root,root) %{_bindir}/opencv_visualisation
701be548 451%attr(755,root,root) %{_bindir}/setup_vars_opencv4.sh
158e0ccc 452%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
71c2eb73 453%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
158e0ccc 454%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
71c2eb73 455%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
158e0ccc 456%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
71c2eb73 457%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
158e0ccc 458%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
71c2eb73 459%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
158e0ccc 460%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
71c2eb73 461%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
158e0ccc 462%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
71c2eb73 463%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
158e0ccc 464%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
71c2eb73 465%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
b287af3c
JR
466# contrib modules
467%attr(755,root,root) %{_bindir}/opencv_waldboost_detector
468%attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
469%attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
470%attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
471%attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
472%attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
473%attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
474%attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
475%attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
476%attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
477%attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
478%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
479%attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
c9cb1c24
JR
480%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
481%attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
b287af3c
JR
482%attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
483%attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
484%attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
485%attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
09d132a9
ER
486%attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
487%attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
b287af3c
JR
488%attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
489%attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
490%attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
491%attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
c9cb1c24
JR
492%attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
493%attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
09d132a9
ER
494%attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
495%attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
b287af3c
JR
496%attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
497%attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
3752412b
JR
498%attr(755,root,root) %ghost %{_libdir}/libopencv_ovis.so.%{sover}
499%attr(755,root,root) %{_libdir}/libopencv_ovis.so.*.*.*
b287af3c
JR
500%attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
501%attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
09d132a9
ER
502%attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
503%attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
b287af3c
JR
504%attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
505%attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
506%attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
507%attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
508%attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
509%attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
510%attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
511%attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
512%attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
513%attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
514%attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
515%attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
516%attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
517%attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
518%attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
519%attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
520%attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
521%attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
522%attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
523%attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
524%attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
525%attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
526%attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
527%attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
528%attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
529%attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
530%attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
531%attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
701be548
JR
532%attr(755,root,root) %ghost %{_libdir}/libopencv_alphamat.so.%{sover}
533%attr(755,root,root) %{_libdir}/libopencv_alphamat.so.*.*.*
534%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_superres.so.%{sover}
535%attr(755,root,root) %{_libdir}/libopencv_dnn_superres.so.*.*.*
536%attr(755,root,root) %ghost %{_libdir}/libopencv_gapi.so.%{sover}
537%attr(755,root,root) %{_libdir}/libopencv_gapi.so.*.*.*
538%attr(755,root,root) %ghost %{_libdir}/libopencv_intensity_transform.so.%{sover}
539%attr(755,root,root) %{_libdir}/libopencv_intensity_transform.so.*.*.*
540%attr(755,root,root) %ghost %{_libdir}/libopencv_mcc.so.%{sover}
541%attr(755,root,root) %{_libdir}/libopencv_mcc.so.*.*.*
542%attr(755,root,root) %ghost %{_libdir}/libopencv_quality.so.%{sover}
543%attr(755,root,root) %{_libdir}/libopencv_quality.so.*.*.*
544%attr(755,root,root) %ghost %{_libdir}/libopencv_rapid.so.%{sover}
545%attr(755,root,root) %{_libdir}/libopencv_rapid.so.*.*.*
546
547%dir %{_datadir}/opencv4
548%{_datadir}/opencv4/haarcascades
549%{_datadir}/opencv4/lbpcascades
550%{_datadir}/opencv4/quality
901927d3 551
933de752
ER
552%files core
553%defattr(644,root,root,755)
158e0ccc 554%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
71c2eb73 555%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
158e0ccc 556%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
71c2eb73 557%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
158e0ccc 558%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
71c2eb73 559%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
158e0ccc 560%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
71c2eb73 561%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
158e0ccc 562%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
71c2eb73 563%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
158e0ccc 564%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
71c2eb73 565%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
33a5389a 566%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
71c2eb73 567%attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
33a5389a 568%attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
71c2eb73 569%attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
33a5389a 570%attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
71c2eb73 571%attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
cf32945e
JB
572
573%if %{with vtk}
574%files viz
575%defattr(644,root,root,755)
158e0ccc 576%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
71c2eb73 577%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
cf32945e 578%endif
933de752 579
901927d3
AM
580%files devel
581%defattr(644,root,root,755)
cf32945e 582# core
701be548
JR
583%{_libdir}/libopencv_core.so
584%{_libdir}/libopencv_flann.so
585%{_libdir}/libopencv_imgproc.so
586%{_libdir}/libopencv_ml.so
587%{_libdir}/libopencv_photo.so
588%{_libdir}/libopencv_video.so
cf32945e 589# GUI/extensions (base package)
701be548
JR
590%{_libdir}/libopencv_calib3d.so
591%{_libdir}/libopencv_features2d.so
592%{_libdir}/libopencv_highgui.so
593%{_libdir}/libopencv_objdetect.so
594%{_libdir}/libopencv_stitching.so
595%{_libdir}/libopencv_superres.so
596%{_libdir}/libopencv_videostab.so
597%{_libdir}/libopencv_imgcodecs.so
598%{_libdir}/libopencv_shape.so
599%{_libdir}/libopencv_videoio.so
b287af3c 600# contrib
701be548
JR
601%{_libdir}/libopencv_aruco.so
602%{_libdir}/libopencv_bgsegm.so
603%{_libdir}/libopencv_bioinspired.so
604%{_libdir}/libopencv_ccalib.so
605%{_libdir}/libopencv_datasets.so
606%{_libdir}/libopencv_dnn.so
607%{_libdir}/libopencv_dnn_objdetect.so
608%{_libdir}/libopencv_dpm.so
609%{_libdir}/libopencv_face.so
610%{_libdir}/libopencv_freetype.so
611%{_libdir}/libopencv_fuzzy.so
612%{_libdir}/libopencv_hdf.so
613%{_libdir}/libopencv_hfs.so
614%{_libdir}/libopencv_img_hash.so
615%{_libdir}/libopencv_line_descriptor.so
616%{_libdir}/libopencv_optflow.so
617%{_libdir}/libopencv_ovis.so
618%{_libdir}/libopencv_phase_unwrapping.so
619%{_libdir}/libopencv_plot.so
620%{_libdir}/libopencv_reg.so
621%{_libdir}/libopencv_rgbd.so
622%{_libdir}/libopencv_saliency.so
623%{_libdir}/libopencv_sfm.so
624%{_libdir}/libopencv_stereo.so
625%{_libdir}/libopencv_structured_light.so
626%{_libdir}/libopencv_surface_matching.so
627%{_libdir}/libopencv_text.so
628%{_libdir}/libopencv_tracking.so
629%{_libdir}/libopencv_xfeatures2d.so
630%{_libdir}/libopencv_ximgproc.so
631%{_libdir}/libopencv_xobjdetect.so
632%{_libdir}/libopencv_xphoto.so
633%{_libdir}/libopencv_alphamat.so
634%{_libdir}/libopencv_dnn_superres.so
635%{_libdir}/libopencv_gapi.so
636%{_libdir}/libopencv_intensity_transform.so
637%{_libdir}/libopencv_mcc.so
638%{_libdir}/libopencv_quality.so
639%{_libdir}/libopencv_rapid.so
cf32945e
JB
640# viz
641%if %{with vtk}
701be548 642%{_libdir}/libopencv_viz.so
0e077f8d 643%endif
701be548
JR
644%{_includedir}/opencv4
645%{_libdir}/cmake/opencv4/OpenCV*.cmake
646%{_pkgconfigdir}/opencv4.pc
901927d3 647
9141b1e2
ER
648%files doc
649%defattr(644,root,root,755)
650# TODO: probably could rebuild them and package via make install
651%doc doc/*
652
200823d5
ER
653%if %{with examples}
654%files examples
655%defattr(644,root,root,755)
656%{_examplesdir}/%{name}-%{version}
657%endif
658
b07433c6
JB
659%if %{with java}
660%files -n java-opencv
661%defattr(644,root,root,755)
835e0cdd
ER
662%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
663%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
664%{_javadir}/opencv.jar
665%endif
666
901927d3
AM
667%files -n python-opencv
668%defattr(644,root,root,755)
fe201543
JR
669%dir %{py_sitedir}/cv2
670%dir %{py_sitedir}/cv2/python-*
671%attr(755,root,root) %{py_sitedir}/cv2/python-*/cv2.so
672%{py_sitedir}/cv2/*.py[co]
b221500a
JB
673
674%files -n python3-opencv
675%defattr(644,root,root,755)
fe201543
JR
676%dir %{py3_sitedir}/cv2
677%dir %{py3_sitedir}/cv2/python-*
678%attr(755,root,root) %{py3_sitedir}/cv2/python-*/cv2.cpython-*.so
679%{py3_sitedir}/cv2/*.py
This page took 0.218033 seconds and 4 git commands to generate.