]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- release 5 (by relup.sh)
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
ca2adc08
JB
2# - contrib subpackage(s)
3# - contrib BRs:
4# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7# opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8# opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9# opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
09d132a9
ER
10# unpackaged (3.4.0)
11#/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12#/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13#/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14#/usr/share/OpenCV/valgrind.supp
15#/usr/share/OpenCV/valgrind_3rdparty.supp
16
ca2adc08 17#
2acd8ac1 18# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 19# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 20# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 21#
0c2d6b7d 22# Conditional build:
a55ba198
JB
23# - general options:
24%bcond_with tbb # Threading Building Blocks support (everywhere)
25%bcond_with sse # use SSE instructions
26%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
27%bcond_with sse3 # use SSE3 instructions
28%bcond_with ssse3 # use SSSE3 instructions
29%bcond_with sse41 # use SSE4.1 instructions
30%bcond_with sse42 # use SSE4.2 instructions
31%bcond_with avx # use AVX instructions
8d5385eb
JB
32%bcond_without opencl # OpenCL support
33%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
34%bcond_with opencl_amdfft # AMD OpenCL FFT routines
35%bcond_without opengl # OpenGL support
4a401ecc 36%bcond_without openmp # OpenMP support (available when not using tbb)
200823d5 37%bcond_without examples # Install examples
b07433c6
JB
38# - bindings
39%bcond_without java # Java binding
a55ba198 40# - highgui options:
b3920a9d 41%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
42%bcond_without gstreamer # GStreamer support in highgui
43%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 44%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 45%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 46%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 47%bcond_without v4l # Video4Linux in highgui
a55ba198 48%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 49%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
50# - other modules
51%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 52
e36ac029 53%ifarch pentium3 pentium4 %{x8664} x32
1c9fe580
JB
54%define with_sse 1
55%endif
e36ac029 56%ifarch pentium4 %{x8664} x32
1c9fe580
JB
57%define with_sse2 1
58%endif
901927d3 59Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 60Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 61Name: opencv
01c6bd4e 62Version: 3.4.1
5463b5b1 63Release: 5
901927d3 64Epoch: 1
d5e56e66
JB
65%if %{with unicap} || %{with xine}
66License: GPL (enforced by used libraries), BSD (opencv itself)
67%else
901927d3 68License: BSD
d5e56e66 69%endif
901927d3 70Group: Libraries
200823d5 71Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
01c6bd4e 72# Source0-md5: a0b7a47899e67b3490ea31edc4f6e8e6
b287af3c 73Source1: https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
01c6bd4e 74# Source1-md5: dd0c63f4185ab8a4829d8154ae382266
8a121398
JR
75# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76Source10: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77# Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78Source11: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79# Source11-md5: 232c966b13651bd0e46a1497b0852191
80Source12: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81# Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82Source13: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83# Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84Source14: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85# Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86Source15: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87# Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88Source16: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89# Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91Source20: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92# Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93Source21: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94# Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95Source22: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96# Source22-md5: 7cd47228edec52b6d82f46511af325c5
97Source23: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98# Source23-md5: 151805e03568c9f490a5e3a872777b75
454d8108 99# See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
8a121398
JR
100Source30: https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101# Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
102Patch0: ix86-pause.patch
08b22f18 103Patch1: %{name}-ximea.patch
98716d5d 104Patch2: cplusplus.patch
08b22f18 105Patch3: cmake-install-path.patch
200823d5 106URL: http://www.opencv.org/
d5e56e66 107%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 108%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 109BuildRequires: OpenEXR-devel
5df3cf1b 110%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 111%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 112# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 113%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 114%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 115%{?with_java:BuildRequires: ant}
8a121398 116BuildRequires: boost-devel
ef4af528
JB
117%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
118%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 119BuildRequires: cmake >= 2.8
0c2d6b7d 120BuildRequires: doxygen
809ce413 121BuildRequires: eigen3 >= 3
b3920a9d 122%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
4a401ecc 123%{?with_openmp:BuildRequires: gcc-c++ >= 6:4.2}
fb5ded39 124BuildRequires: gflags-devel
74cbdeb2 125BuildRequires: gl2ps-devel
debb38d4 126BuildRequires: glog-devel
0c2d6b7d 127%if %{with gstreamer}
158e0ccc
JB
128BuildRequires: gstreamer-devel >= 1.0
129BuildRequires: gstreamer-plugins-base-devel >= 1.0
0c2d6b7d 130%endif
901927d3 131BuildRequires: jasper-devel
b07433c6 132%{?with_java:BuildRequires: jdk}
158e0ccc 133BuildRequires: libdc1394-devel >= 2
4a401ecc 134%{?with_openmp:BuildRequires: libgomp-devel}
901927d3
AM
135BuildRequires: libjpeg-devel
136BuildRequires: libpng-devel
137BuildRequires: libraw1394-devel
0c2d6b7d 138BuildRequires: libstdc++-devel
901927d3 139BuildRequires: libtiff-devel
148338c5 140BuildRequires: libtool
d5e56e66
JB
141%if %{with unicap}
142BuildRequires: libucil-devel
143BuildRequires: libunicap-devel
144%endif
0c2d6b7d 145BuildRequires: libv4l-devel
af6d2888 146BuildRequires: pkgconfig
158e0ccc
JB
147BuildRequires: python >= 2.0
148BuildRequires: python-devel >= 2.0
0c2d6b7d 149BuildRequires: python-numpy-devel
b221500a
JB
150BuildRequires: python3 >= 1:3.2
151BuildRequires: python3-devel >= 1:3.2
152BuildRequires: python3-numpy-devel
901927d3 153BuildRequires: rpm-pythonprov
8d499a62 154BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 155BuildRequires: sed >= 4.0
158e0ccc 156BuildRequires: sphinx-pdg
996927aa 157BuildRequires: swig-python
f8e040cc 158%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
159%if %{with vtk}
160BuildRequires: vtk-devel >= 5.8.0
fba97d16 161BuildRequires: vtk-java >= 5.8.0
ae3d975d
AM
162BuildRequires: vtk-tcl >= 5.8.0
163%endif
901927d3 164%{?with_xine:BuildRequires: xine-lib-devel}
158e0ccc 165BuildRequires: xorg-lib-libX11-devel
452b38e1 166BuildRequires: zlib-devel
4afb606b 167%if %{with qt}
4afb606b
JB
168BuildRequires: QtCore-devel >= 4
169BuildRequires: QtGui-devel >= 4
5df3cf1b 170%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
171BuildRequires: qt4-qmake >= 4
172%else
173BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 174%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 175%endif
da5d1e09 176Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
177BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
178
158e0ccc 179%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
71c2eb73 180%define sover %(echo %{version} | cut -d. -f1-2)
933de752 181
901927d3
AM
182%description
183OpenCV (Open Source Computer Vision) is a library of programming
184functions mainly aimed at real time computer vision.
185
0c2d6b7d
JB
186Example applications of the OpenCV library are:
187- Human-Computer Interaction (HCI)
188- Object Identification, Segmentation and Recognition
189- Face Recognition
190- Gesture Recognition
191- Motion Tracking
192- Ego Motion, Motion Understanding
193- Structure From Motion (SFM)
194- Stereo and Multi-Camera Calibration and Depth Computation
195- Mobile Robotics.
196
197%description -l pl.UTF-8
198OpenCV (Open Source Computer Vision) to biblioteka funkcji
199przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
200
201Przykładowe zastosowania biblioteki OpenCV to
202- interakcje człowiek-komputer (HCI)
203- identyfikacja, segmentacja i rozpoznawanie obiektów
204- rozpoznawanie twarzy
205- rozpoznawanie gestów
206- śledzenie ruchu
207- rozumienie ruchu
208- SFM (Structure From Motion)
209- kalibracja dwu- i wielokamerowa, obliczanie głębi
210- robotyka ruchu.
901927d3 211
933de752
ER
212%package core
213Summary: OpenCV core libraries
da5d1e09 214Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 215Group: Libraries
da5d1e09 216Conflicts: opencv < 2.4.6.2-1
933de752
ER
217
218%description core
219This package contains the OpenCV C/C++ core libraries.
220
da5d1e09
JB
221%description core -l pl.UTF-8
222Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
223
cf32945e
JB
224%package viz
225Summary: OpenCV viz library (VTK support)
226Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
227Group: Libraries
228Requires: %{name} = %{epoch}:%{version}-%{release}
229
230%description viz
231OpenCV viz library (VTK support).
232
233%description viz -l pl.UTF-8
234Biblioteka OpenCV viz (obsługa VTK).
235
901927d3 236%package devel
0c2d6b7d
JB
237Summary: Header files for OpenCV library
238Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
239Group: Development/Libraries
240Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
241%if %{with vtk}
242Requires: %{name}-viz = %{epoch}:%{version}-%{release}
243%endif
0c2d6b7d 244Obsoletes: opencv-static
901927d3
AM
245
246%description devel
0c2d6b7d 247Header files for OpenCV library.
901927d3 248
0c2d6b7d
JB
249%description devel -l pl.UTF-8
250Pliki nagłówkowe biblioteki OpenCV.
901927d3 251
9141b1e2
ER
252%package doc
253Summary: Manual for OpenCV
254Summary(fr.UTF-8): Documentation pour OpenCV
255Summary(it.UTF-8): Documentazione di OpenCV
256Summary(pl.UTF-8): Podręcznik dla OpenCV
257Group: Documentation
258# noarch subpackages only when building with rpm5
259%if "%{_rpmversion}" >= "5"
260BuildArch: noarch
261%endif
262
263%description doc
264Documentation for OpenCV.
265
266%description doc -l fr.UTF-8
267Documentation pour OpenCV.
268
269%description doc -l it.UTF-8
270Documentazione di OpenCV.
271
272%description doc -l pl.UTF-8
273Dokumentacja do OpenCV.
274
200823d5
ER
275%package examples
276Summary: OpenCV code examples
277Group: Documentation
278%if "%{_rpmversion}" >= "5"
279BuildArch: noarch
280%endif
281
282%description examples
283OpenCV code examples.
284
b07433c6
JB
285%package -n java-opencv
286Summary: OpenCV Java bindings
287Summary(pl.UTF-8): Wiązania Javy do OpenCV
288Group: Libraries/Java
289Requires: %{name} = %{epoch}:%{version}-%{release}
290Requires: jre
291
292%description -n java-opencv
293OpenCV Java bindings.
294
295%description -n java-opencv -l pl.UTF-8
296Wiązania Javy do OpenCV.
297
901927d3 298%package -n python-opencv
b221500a
JB
299Summary: OpenCV Python 2 bindings
300Summary(pl.UTF-8): Wiązania Pythona 2 do OpenCV
0c2d6b7d 301Group: Libraries/Python
cd1f0136 302Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 303Requires: python-libs
901927d3
AM
304
305%description -n python-opencv
b221500a 306OpenCV Python 2 bindings.
901927d3 307
0c2d6b7d 308%description -n python-opencv -l pl.UTF-8
b221500a
JB
309Wiązania Pythona 2 do OpenCV.
310
311%package -n python3-opencv
312Summary: OpenCV Python 3 bindings
313Summary(pl.UTF-8): Wiązania Pythona 3 do OpenCV
314Group: Libraries/Python
315Requires: %{name} = %{epoch}:%{version}-%{release}
316Requires: python3-libs
317
318%description -n python3-opencv
319OpenCV Python 3 bindings.
320
321%description -n python3-opencv -l pl.UTF-8
322Wiązania Pythona 3 do OpenCV.
0c2d6b7d 323
901927d3 324%prep
b287af3c 325%setup -q -a1
54551f29 326
da67222a 327%undos CMakeLists.txt
54551f29 328
8a121398 329%patch0 -p1
08b22f18 330%patch1 -p1
98716d5d 331%patch2 -p1
01c6bd4e 332%patch3 -p1
148338c5 333
901927d3 334%build
8a121398 335install -d build/{share/OpenCV/testdata/cv/face,downloads/xfeatures2d}
95daeb66 336cd build
ea26b025 337
8a121398
JR
338install %{SOURCE30} share/OpenCV/testdata/cv/face/
339install %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16} downloads/xfeatures2d/
340install %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} downloads/xfeatures2d/
341
ea26b025
ER
342# handle cmake & ccache
343# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
344if [[ "%{__cc}" = *ccache* ]]; then
345 cc="%{__cc}"
346 cxx="%{__cxx}"
347 ccache="
348 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
349 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
350 "
351fi
352
0c2d6b7d 353%cmake .. \
ea26b025 354 $ccache \
08b22f18 355 -DENABLE_PRECOMPILED_HEADERS=OFF \
09d132a9 356 -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
b287af3c 357 -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
da5d1e09 358 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
359 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
360 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
361 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
362 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
363 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
364 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 365 -DBUILD_NEW_PYTHON_SUPPORT=ON \
200823d5
ER
366%if %{with examples}
367 -DINSTALL_C_EXAMPLES=ON \
368 -DINSTALL_PYTHON_EXAMPLES=ON \
369%endif
b3920a9d 370 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 371 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 372 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
373 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
374 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 375 %{?with_opengl:-DWITH_OPENGL=ON} \
4a401ecc 376 %{?with_openmp:-DWITH_OPENMP=ON} \
1c9fe580 377 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 378 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 379 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 380 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 381 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 382 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 383 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 384 %{?with_ximea:-DWITH_XIMEA=ON} \
33a5389a
JR
385 %{?with_xine:-DWITH_XINE=ON} \
386 -DWITH_IPP=OFF
54551f29 387
8b9f61f7 388%{__make}
901927d3
AM
389
390%install
391rm -rf $RPM_BUILD_ROOT
95daeb66 392%{__make} -C build install \
901927d3
AM
393 DESTDIR=$RPM_BUILD_ROOT
394
200823d5
ER
395%if %{with examples}
396install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
397mv $RPM_BUILD_ROOT%{_datadir}/OpenCV/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
398%endif
9141b1e2 399
4bd2eae7 400install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
a4737151 401cp -p build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
4bd2eae7 402
7545129b
JB
403# disable completeness check incompatible with split packaging
404%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules.cmake
405
8d499a62
JB
406%py_comp $RPM_BUILD_ROOT%{py_sitedir}
407%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
408%py_postclean
409
b07433c6
JB
410%if %{with java}
411# move to proper directories, create symlink
412install -d $RPM_BUILD_ROOT%{_javadir}
413%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
c3075463
AM
414sed -i -e 's#/share/OpenCV/java/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
415 $RPM_BUILD_ROOT%{_datadir}/OpenCV/OpenCVModules-pld.cmake
b07433c6
JB
416%{__mv} $RPM_BUILD_ROOT%{_datadir}/OpenCV/java/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
417rmdir $RPM_BUILD_ROOT%{_datadir}/OpenCV/java
418ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
419%endif
420
901927d3
AM
421%clean
422rm -rf $RPM_BUILD_ROOT
423
424%post -p /sbin/ldconfig
425%postun -p /sbin/ldconfig
426
933de752
ER
427%post core -p /sbin/ldconfig
428%postun core -p /sbin/ldconfig
429
485d5dca
JB
430%post viz -p /sbin/ldconfig
431%postun viz -p /sbin/ldconfig
432
b07433c6
JB
433%post -n java-opencv -p /sbin/ldconfig
434%postun -n java-opencv -p /sbin/ldconfig
435
901927d3
AM
436%files
437%defattr(644,root,root,755)
f753ced4 438%attr(755,root,root) %{_bindir}/opencv_annotation
933de752 439%attr(755,root,root) %{_bindir}/opencv_createsamples
09d132a9 440%attr(755,root,root) %{_bindir}/opencv_interactive-calibration
933de752 441%attr(755,root,root) %{_bindir}/opencv_traincascade
09d132a9
ER
442%attr(755,root,root) %{_bindir}/opencv_version
443%attr(755,root,root) %{_bindir}/opencv_visualisation
158e0ccc 444%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
71c2eb73 445%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
158e0ccc 446%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
71c2eb73 447%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
158e0ccc 448%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
71c2eb73 449%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
158e0ccc 450%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
71c2eb73 451%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
158e0ccc 452%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
71c2eb73 453%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
158e0ccc 454%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
71c2eb73 455%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
158e0ccc 456%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
71c2eb73 457%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
b287af3c
JR
458# contrib modules
459%attr(755,root,root) %{_bindir}/opencv_waldboost_detector
460%attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
461%attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
462%attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
463%attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
464%attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
465%attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
466%attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
467%attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
468%attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
469%attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
470%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
471%attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
c9cb1c24
JR
472%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
473%attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
b287af3c
JR
474%attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
475%attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
476%attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
477%attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
09d132a9
ER
478%attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
479%attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
b287af3c
JR
480%attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
481%attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
482%attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
483%attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
c9cb1c24
JR
484%attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
485%attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
09d132a9
ER
486%attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
487%attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
b287af3c
JR
488%attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
489%attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
490%attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
491%attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
09d132a9
ER
492%attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
493%attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
b287af3c
JR
494%attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
495%attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
496%attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
497%attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
498%attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
499%attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
500%attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
501%attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
502%attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
503%attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
504%attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
505%attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
506%attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
507%attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
508%attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
509%attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
510%attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
511%attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
512%attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
513%attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
514%attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
515%attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
516%attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
517%attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
518%attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
519%attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
520%attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
521%attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
09d132a9 522
452b38e1 523%dir %{_datadir}/OpenCV
452b38e1 524%{_datadir}/OpenCV/haarcascades
525%{_datadir}/OpenCV/lbpcascades
901927d3 526
933de752
ER
527%files core
528%defattr(644,root,root,755)
158e0ccc 529%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
71c2eb73 530%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
158e0ccc 531%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
71c2eb73 532%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
158e0ccc 533%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
71c2eb73 534%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
158e0ccc 535%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
71c2eb73 536%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
158e0ccc 537%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
71c2eb73 538%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
158e0ccc 539%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
71c2eb73 540%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
33a5389a 541%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
71c2eb73 542%attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
33a5389a 543%attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
71c2eb73 544%attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
33a5389a 545%attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
71c2eb73 546%attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
cf32945e
JB
547
548%if %{with vtk}
549%files viz
550%defattr(644,root,root,755)
158e0ccc 551%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
71c2eb73 552%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
cf32945e 553%endif
933de752 554
901927d3
AM
555%files devel
556%defattr(644,root,root,755)
cf32945e
JB
557# core
558%attr(755,root,root) %{_libdir}/libopencv_core.so
559%attr(755,root,root) %{_libdir}/libopencv_flann.so
560%attr(755,root,root) %{_libdir}/libopencv_imgproc.so
561%attr(755,root,root) %{_libdir}/libopencv_ml.so
562%attr(755,root,root) %{_libdir}/libopencv_photo.so
563%attr(755,root,root) %{_libdir}/libopencv_video.so
564# GUI/extensions (base package)
565%attr(755,root,root) %{_libdir}/libopencv_calib3d.so
cf32945e 566%attr(755,root,root) %{_libdir}/libopencv_features2d.so
cf32945e 567%attr(755,root,root) %{_libdir}/libopencv_highgui.so
cf32945e 568%attr(755,root,root) %{_libdir}/libopencv_objdetect.so
cf32945e
JB
569%attr(755,root,root) %{_libdir}/libopencv_stitching.so
570%attr(755,root,root) %{_libdir}/libopencv_superres.so
cf32945e 571%attr(755,root,root) %{_libdir}/libopencv_videostab.so
33a5389a
JR
572%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so
573%attr(755,root,root) %{_libdir}/libopencv_shape.so
574%attr(755,root,root) %{_libdir}/libopencv_videoio.so
b287af3c
JR
575# contrib
576%attr(755,root,root) %{_libdir}/libopencv_aruco.so
577%attr(755,root,root) %{_libdir}/libopencv_bgsegm.so
578%attr(755,root,root) %{_libdir}/libopencv_bioinspired.so
579%attr(755,root,root) %{_libdir}/libopencv_ccalib.so
580%attr(755,root,root) %{_libdir}/libopencv_datasets.so
581%attr(755,root,root) %{_libdir}/libopencv_dnn.so
c9cb1c24 582%attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so
b287af3c
JR
583%attr(755,root,root) %{_libdir}/libopencv_dpm.so
584%attr(755,root,root) %{_libdir}/libopencv_face.so
09d132a9 585%attr(755,root,root) %{_libdir}/libopencv_freetype.so
b287af3c
JR
586%attr(755,root,root) %{_libdir}/libopencv_fuzzy.so
587%attr(755,root,root) %{_libdir}/libopencv_hdf.so
c9cb1c24 588%attr(755,root,root) %{_libdir}/libopencv_hfs.so
09d132a9 589%attr(755,root,root) %{_libdir}/libopencv_img_hash.so
b287af3c
JR
590%attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so
591%attr(755,root,root) %{_libdir}/libopencv_optflow.so
09d132a9 592%attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so
b287af3c
JR
593%attr(755,root,root) %{_libdir}/libopencv_plot.so
594%attr(755,root,root) %{_libdir}/libopencv_reg.so
595%attr(755,root,root) %{_libdir}/libopencv_rgbd.so
596%attr(755,root,root) %{_libdir}/libopencv_saliency.so
597%attr(755,root,root) %{_libdir}/libopencv_sfm.so
598%attr(755,root,root) %{_libdir}/libopencv_stereo.so
599%attr(755,root,root) %{_libdir}/libopencv_structured_light.so
600%attr(755,root,root) %{_libdir}/libopencv_surface_matching.so
601%attr(755,root,root) %{_libdir}/libopencv_text.so
602%attr(755,root,root) %{_libdir}/libopencv_tracking.so
603%attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so
604%attr(755,root,root) %{_libdir}/libopencv_ximgproc.so
605%attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so
606%attr(755,root,root) %{_libdir}/libopencv_xphoto.so
09d132a9 607#%{_libdir}/libopencv_ts.a
cf32945e
JB
608# viz
609%if %{with vtk}
610%attr(755,root,root) %{_libdir}/libopencv_viz.so
0e077f8d 611%endif
901927d3 612%{_includedir}/opencv
509c07dc 613%{_includedir}/opencv2
da5d1e09 614%{_datadir}/OpenCV/OpenCV*.cmake
0c2d6b7d 615%{_pkgconfigdir}/opencv.pc
901927d3 616
9141b1e2
ER
617%files doc
618%defattr(644,root,root,755)
619# TODO: probably could rebuild them and package via make install
620%doc doc/*
621
200823d5
ER
622%if %{with examples}
623%files examples
624%defattr(644,root,root,755)
625%{_examplesdir}/%{name}-%{version}
626%endif
627
b07433c6
JB
628%if %{with java}
629%files -n java-opencv
630%defattr(644,root,root,755)
835e0cdd
ER
631%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
632%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
633%{_javadir}/opencv.jar
634%endif
635
901927d3
AM
636%files -n python-opencv
637%defattr(644,root,root,755)
452b38e1 638%attr(755,root,root) %{py_sitedir}/cv2.so
b221500a
JB
639
640%files -n python3-opencv
641%defattr(644,root,root,755)
642%attr(755,root,root) %{py3_sitedir}/cv2.cpython-*.so
This page took 0.274295 seconds and 4 git commands to generate.