]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
Link not copy cache
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
ca2adc08
JB
2# - contrib subpackage(s)
3# - contrib BRs:
4# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7# opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8# opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9# opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
09d132a9
ER
10# unpackaged (3.4.0)
11#/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12#/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13#/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14#/usr/share/OpenCV/valgrind.supp
15#/usr/share/OpenCV/valgrind_3rdparty.supp
16
ca2adc08 17#
2acd8ac1 18# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 19# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 20# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 21#
0c2d6b7d 22# Conditional build:
a55ba198
JB
23# - general options:
24%bcond_with tbb # Threading Building Blocks support (everywhere)
25%bcond_with sse # use SSE instructions
26%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
27%bcond_with sse3 # use SSE3 instructions
28%bcond_with ssse3 # use SSSE3 instructions
29%bcond_with sse41 # use SSE4.1 instructions
30%bcond_with sse42 # use SSE4.2 instructions
31%bcond_with avx # use AVX instructions
8d5385eb
JB
32%bcond_without opencl # OpenCL support
33%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
34%bcond_with opencl_amdfft # AMD OpenCL FFT routines
35%bcond_without opengl # OpenGL support
4a401ecc 36%bcond_without openmp # OpenMP support (available when not using tbb)
200823d5 37%bcond_without examples # Install examples
b07433c6
JB
38# - bindings
39%bcond_without java # Java binding
a55ba198 40# - highgui options:
b3920a9d 41%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
42%bcond_without gstreamer # GStreamer support in highgui
43%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 44%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 45%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 46%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 47%bcond_without v4l # Video4Linux in highgui
a55ba198 48%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 49%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
50# - other modules
51%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 52
e36ac029 53%ifarch pentium3 pentium4 %{x8664} x32
1c9fe580
JB
54%define with_sse 1
55%endif
e36ac029 56%ifarch pentium4 %{x8664} x32
1c9fe580
JB
57%define with_sse2 1
58%endif
901927d3 59Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 60Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 61Name: opencv
701be548 62Version: 4.5.1
71876184 63Release: 3
901927d3 64Epoch: 1
d5e56e66
JB
65%if %{with unicap} || %{with xine}
66License: GPL (enforced by used libraries), BSD (opencv itself)
67%else
901927d3 68License: BSD
d5e56e66 69%endif
901927d3 70Group: Libraries
200823d5 71Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
701be548 72# Source0-md5: 2205d3169238ec1f184438a96de68513
b287af3c 73Source1: https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
701be548 74# Source1-md5: 19a31bf7271978ab426112dbf5d1b83f
8a121398
JR
75# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76Source10: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77# Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78Source11: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79# Source11-md5: 232c966b13651bd0e46a1497b0852191
80Source12: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81# Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82Source13: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83# Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84Source14: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85# Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86Source15: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87# Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88Source16: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89# Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91Source20: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92# Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93Source21: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94# Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95Source22: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96# Source22-md5: 7cd47228edec52b6d82f46511af325c5
97Source23: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98# Source23-md5: 151805e03568c9f490a5e3a872777b75
454d8108 99# See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
8a121398
JR
100Source30: https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101# Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
701be548
JR
102# See opencv-4.5.1/modules/gapi/CMakeLists.txt
103Source40: https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
104# Source40-md5: b624b995ec9c439cbc2e9e6ee940d3a2
fe201543
JR
105Patch0: %{name}-ximea.patch
106Patch1: python-install.patch
e652d7a7 107Patch2: pkgconfig-paths.patch
71876184 108Patch3: no-cxx-in-c-header.patch
200823d5 109URL: http://www.opencv.org/
d5e56e66 110%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 111%{?with_opencl:BuildRequires: OpenCL-devel}
57f80647 112BuildRequires: Mesa-khrplatform-devel
0c2d6b7d 113BuildRequires: OpenEXR-devel
5df3cf1b 114%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 115%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 116# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 117%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 118%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 119%{?with_java:BuildRequires: ant}
8a121398 120BuildRequires: boost-devel
ef4af528
JB
121%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
122%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 123BuildRequires: cmake >= 2.8
0c2d6b7d 124BuildRequires: doxygen
809ce413 125BuildRequires: eigen3 >= 3
b3920a9d 126%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
4a401ecc 127%{?with_openmp:BuildRequires: gcc-c++ >= 6:4.2}
fb5ded39 128BuildRequires: gflags-devel
74cbdeb2 129BuildRequires: gl2ps-devel
debb38d4 130BuildRequires: glog-devel
0c2d6b7d 131%if %{with gstreamer}
158e0ccc
JB
132BuildRequires: gstreamer-devel >= 1.0
133BuildRequires: gstreamer-plugins-base-devel >= 1.0
0c2d6b7d 134%endif
901927d3 135BuildRequires: jasper-devel
b07433c6 136%{?with_java:BuildRequires: jdk}
158e0ccc 137BuildRequires: libdc1394-devel >= 2
4a401ecc 138%{?with_openmp:BuildRequires: libgomp-devel}
901927d3
AM
139BuildRequires: libjpeg-devel
140BuildRequires: libpng-devel
141BuildRequires: libraw1394-devel
0c2d6b7d 142BuildRequires: libstdc++-devel
901927d3 143BuildRequires: libtiff-devel
148338c5 144BuildRequires: libtool
d5e56e66
JB
145%if %{with unicap}
146BuildRequires: libucil-devel
147BuildRequires: libunicap-devel
148%endif
0c2d6b7d 149BuildRequires: libv4l-devel
4836bff0 150BuildRequires: ogre-devel
af6d2888 151BuildRequires: pkgconfig
701be548 152BuildRequires: protobuf-devel
158e0ccc
JB
153BuildRequires: python >= 2.0
154BuildRequires: python-devel >= 2.0
0c2d6b7d 155BuildRequires: python-numpy-devel
b221500a
JB
156BuildRequires: python3 >= 1:3.2
157BuildRequires: python3-devel >= 1:3.2
158BuildRequires: python3-numpy-devel
901927d3 159BuildRequires: rpm-pythonprov
8d499a62 160BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 161BuildRequires: sed >= 4.0
158e0ccc 162BuildRequires: sphinx-pdg
996927aa 163BuildRequires: swig-python
f8e040cc 164%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
165%if %{with vtk}
166BuildRequires: vtk-devel >= 5.8.0
fba97d16 167BuildRequires: vtk-java >= 5.8.0
701be548 168BuildRequires: vtk-python3-devel >= 5.8.0
ae3d975d 169%endif
901927d3 170%{?with_xine:BuildRequires: xine-lib-devel}
158e0ccc 171BuildRequires: xorg-lib-libX11-devel
452b38e1 172BuildRequires: zlib-devel
4afb606b 173%if %{with qt}
4afb606b
JB
174BuildRequires: QtCore-devel >= 4
175BuildRequires: QtGui-devel >= 4
5df3cf1b 176%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
177BuildRequires: qt4-qmake >= 4
178%else
179BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 180%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 181%endif
da5d1e09 182Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
183BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
184
158e0ccc 185%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
71c2eb73 186%define sover %(echo %{version} | cut -d. -f1-2)
933de752 187
901927d3
AM
188%description
189OpenCV (Open Source Computer Vision) is a library of programming
190functions mainly aimed at real time computer vision.
191
0c2d6b7d
JB
192Example applications of the OpenCV library are:
193- Human-Computer Interaction (HCI)
194- Object Identification, Segmentation and Recognition
195- Face Recognition
196- Gesture Recognition
197- Motion Tracking
198- Ego Motion, Motion Understanding
199- Structure From Motion (SFM)
200- Stereo and Multi-Camera Calibration and Depth Computation
201- Mobile Robotics.
202
203%description -l pl.UTF-8
204OpenCV (Open Source Computer Vision) to biblioteka funkcji
205przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
206
207Przykładowe zastosowania biblioteki OpenCV to
208- interakcje człowiek-komputer (HCI)
209- identyfikacja, segmentacja i rozpoznawanie obiektów
210- rozpoznawanie twarzy
211- rozpoznawanie gestów
212- śledzenie ruchu
213- rozumienie ruchu
214- SFM (Structure From Motion)
215- kalibracja dwu- i wielokamerowa, obliczanie głębi
216- robotyka ruchu.
901927d3 217
933de752
ER
218%package core
219Summary: OpenCV core libraries
da5d1e09 220Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 221Group: Libraries
da5d1e09 222Conflicts: opencv < 2.4.6.2-1
933de752
ER
223
224%description core
225This package contains the OpenCV C/C++ core libraries.
226
da5d1e09
JB
227%description core -l pl.UTF-8
228Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
229
cf32945e
JB
230%package viz
231Summary: OpenCV viz library (VTK support)
232Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
233Group: Libraries
234Requires: %{name} = %{epoch}:%{version}-%{release}
235
236%description viz
237OpenCV viz library (VTK support).
238
239%description viz -l pl.UTF-8
240Biblioteka OpenCV viz (obsługa VTK).
241
901927d3 242%package devel
0c2d6b7d
JB
243Summary: Header files for OpenCV library
244Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
245Group: Development/Libraries
246Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
247%if %{with vtk}
248Requires: %{name}-viz = %{epoch}:%{version}-%{release}
249%endif
0c2d6b7d 250Obsoletes: opencv-static
901927d3
AM
251
252%description devel
0c2d6b7d 253Header files for OpenCV library.
901927d3 254
0c2d6b7d
JB
255%description devel -l pl.UTF-8
256Pliki nagłówkowe biblioteki OpenCV.
901927d3 257
9141b1e2
ER
258%package doc
259Summary: Manual for OpenCV
260Summary(fr.UTF-8): Documentation pour OpenCV
261Summary(it.UTF-8): Documentazione di OpenCV
262Summary(pl.UTF-8): Podręcznik dla OpenCV
263Group: Documentation
264# noarch subpackages only when building with rpm5
9141b1e2 265BuildArch: noarch
9141b1e2
ER
266
267%description doc
268Documentation for OpenCV.
269
270%description doc -l fr.UTF-8
271Documentation pour OpenCV.
272
273%description doc -l it.UTF-8
274Documentazione di OpenCV.
275
276%description doc -l pl.UTF-8
277Dokumentacja do OpenCV.
278
200823d5
ER
279%package examples
280Summary: OpenCV code examples
281Group: Documentation
200823d5 282BuildArch: noarch
200823d5
ER
283
284%description examples
285OpenCV code examples.
286
b07433c6
JB
287%package -n java-opencv
288Summary: OpenCV Java bindings
289Summary(pl.UTF-8): Wiązania Javy do OpenCV
290Group: Libraries/Java
291Requires: %{name} = %{epoch}:%{version}-%{release}
292Requires: jre
293
294%description -n java-opencv
295OpenCV Java bindings.
296
297%description -n java-opencv -l pl.UTF-8
298Wiązania Javy do OpenCV.
299
901927d3 300%package -n python-opencv
b221500a
JB
301Summary: OpenCV Python 2 bindings
302Summary(pl.UTF-8): Wiązania Pythona 2 do OpenCV
0c2d6b7d 303Group: Libraries/Python
cd1f0136 304Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 305Requires: python-libs
901927d3
AM
306
307%description -n python-opencv
b221500a 308OpenCV Python 2 bindings.
901927d3 309
0c2d6b7d 310%description -n python-opencv -l pl.UTF-8
b221500a
JB
311Wiązania Pythona 2 do OpenCV.
312
313%package -n python3-opencv
314Summary: OpenCV Python 3 bindings
315Summary(pl.UTF-8): Wiązania Pythona 3 do OpenCV
316Group: Libraries/Python
317Requires: %{name} = %{epoch}:%{version}-%{release}
318Requires: python3-libs
319
320%description -n python3-opencv
321OpenCV Python 3 bindings.
322
323%description -n python3-opencv -l pl.UTF-8
324Wiązania Pythona 3 do OpenCV.
0c2d6b7d 325
901927d3 326%prep
b287af3c 327%setup -q -a1
54551f29 328
da67222a 329%undos CMakeLists.txt
54551f29 330
8a121398 331%patch0 -p1
08b22f18 332%patch1 -p1
e652d7a7 333%patch2 -p1
71876184 334%patch3 -p1
148338c5 335
701be548
JR
336cache_file() {
337 f="$1"
338 d="$2"
339 md5="$(md5sum "$f" | awk '{print $1}')"
340 file="$(basename "$f")"
341 mkdir -p ".cache/$d"
4e016152 342 ln -s --relative "$f" ".cache/$d/$md5-$file"
701be548
JR
343}
344for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
345 cache_file $f xfeatures2d/boostdesc
346done
347for f in %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}; do
348 cache_file $f xfeatures2d/vgg
349done
350cache_file %{SOURCE30} data
351cache_file %{SOURCE40} ade
352
901927d3 353%build
701be548 354mkdir -p build
95daeb66 355cd build
ea26b025
ER
356
357# handle cmake & ccache
358# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
359if [[ "%{__cc}" = *ccache* ]]; then
360 cc="%{__cc}"
361 cxx="%{__cxx}"
362 ccache="
363 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
364 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
365 "
366fi
367
0c2d6b7d 368%cmake .. \
ea26b025 369 $ccache \
08b22f18 370 -DENABLE_PRECOMPILED_HEADERS=OFF \
09d132a9 371 -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
b287af3c 372 -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
da5d1e09 373 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
374 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
375 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
376 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
377 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
378 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
379 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 380 -DBUILD_NEW_PYTHON_SUPPORT=ON \
701be548 381 -DOPENCV_GENERATE_PKGCONFIG:BOOL=ON \
200823d5
ER
382%if %{with examples}
383 -DINSTALL_C_EXAMPLES=ON \
384 -DINSTALL_PYTHON_EXAMPLES=ON \
385%endif
b3920a9d 386 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 387 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 388 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
389 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
390 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 391 %{?with_opengl:-DWITH_OPENGL=ON} \
4a401ecc 392 %{?with_openmp:-DWITH_OPENMP=ON} \
1c9fe580 393 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 394 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 395 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 396 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 397 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 398 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 399 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 400 %{?with_ximea:-DWITH_XIMEA=ON} \
33a5389a
JR
401 %{?with_xine:-DWITH_XINE=ON} \
402 -DWITH_IPP=OFF
54551f29 403
8b9f61f7 404%{__make}
901927d3
AM
405
406%install
407rm -rf $RPM_BUILD_ROOT
95daeb66 408%{__make} -C build install \
901927d3
AM
409 DESTDIR=$RPM_BUILD_ROOT
410
200823d5
ER
411%if %{with examples}
412install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
701be548 413mv $RPM_BUILD_ROOT%{_datadir}/opencv4/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
200823d5 414%endif
9141b1e2 415
7545129b 416# disable completeness check incompatible with split packaging
701be548 417%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules.cmake
7545129b 418
8d499a62
JB
419%py_comp $RPM_BUILD_ROOT%{py_sitedir}
420%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
421%py_postclean
422
b07433c6
JB
423%if %{with java}
424# move to proper directories, create symlink
425install -d $RPM_BUILD_ROOT%{_javadir}
701be548
JR
426%{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
427sed -i -e 's#/share/java/opencv4/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
428 $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules-pld.cmake
429%{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
430rmdir $RPM_BUILD_ROOT%{_javadir}/opencv4
b07433c6
JB
431ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
432%endif
433
901927d3
AM
434%clean
435rm -rf $RPM_BUILD_ROOT
436
437%post -p /sbin/ldconfig
438%postun -p /sbin/ldconfig
439
933de752
ER
440%post core -p /sbin/ldconfig
441%postun core -p /sbin/ldconfig
442
485d5dca
JB
443%post viz -p /sbin/ldconfig
444%postun viz -p /sbin/ldconfig
445
b07433c6
JB
446%post -n java-opencv -p /sbin/ldconfig
447%postun -n java-opencv -p /sbin/ldconfig
448
901927d3
AM
449%files
450%defattr(644,root,root,755)
f753ced4 451%attr(755,root,root) %{_bindir}/opencv_annotation
701be548 452#%attr(755,root,root) %{_bindir}/opencv_createsamples
09d132a9 453%attr(755,root,root) %{_bindir}/opencv_interactive-calibration
701be548 454#%attr(755,root,root) %{_bindir}/opencv_traincascade
09d132a9
ER
455%attr(755,root,root) %{_bindir}/opencv_version
456%attr(755,root,root) %{_bindir}/opencv_visualisation
701be548 457%attr(755,root,root) %{_bindir}/setup_vars_opencv4.sh
158e0ccc 458%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
71c2eb73 459%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
158e0ccc 460%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
71c2eb73 461%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
158e0ccc 462%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
71c2eb73 463%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
158e0ccc 464%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
71c2eb73 465%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
158e0ccc 466%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
71c2eb73 467%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
158e0ccc 468%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
71c2eb73 469%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
158e0ccc 470%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
71c2eb73 471%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
b287af3c
JR
472# contrib modules
473%attr(755,root,root) %{_bindir}/opencv_waldboost_detector
474%attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
475%attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
476%attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
477%attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
478%attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
479%attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
480%attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
481%attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
482%attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
483%attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
484%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
485%attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
c9cb1c24
JR
486%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
487%attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
b287af3c
JR
488%attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
489%attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
490%attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
491%attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
09d132a9
ER
492%attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
493%attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
b287af3c
JR
494%attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
495%attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
496%attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
497%attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
c9cb1c24
JR
498%attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
499%attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
09d132a9
ER
500%attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
501%attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
b287af3c
JR
502%attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
503%attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
3752412b
JR
504%attr(755,root,root) %ghost %{_libdir}/libopencv_ovis.so.%{sover}
505%attr(755,root,root) %{_libdir}/libopencv_ovis.so.*.*.*
b287af3c
JR
506%attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
507%attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
09d132a9
ER
508%attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
509%attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
b287af3c
JR
510%attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
511%attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
512%attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
513%attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
514%attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
515%attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
516%attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
517%attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
518%attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
519%attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
520%attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
521%attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
522%attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
523%attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
524%attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
525%attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
526%attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
527%attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
528%attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
529%attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
530%attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
531%attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
532%attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
533%attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
534%attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
535%attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
536%attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
537%attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
701be548
JR
538%attr(755,root,root) %ghost %{_libdir}/libopencv_alphamat.so.%{sover}
539%attr(755,root,root) %{_libdir}/libopencv_alphamat.so.*.*.*
540%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_superres.so.%{sover}
541%attr(755,root,root) %{_libdir}/libopencv_dnn_superres.so.*.*.*
542%attr(755,root,root) %ghost %{_libdir}/libopencv_gapi.so.%{sover}
543%attr(755,root,root) %{_libdir}/libopencv_gapi.so.*.*.*
544%attr(755,root,root) %ghost %{_libdir}/libopencv_intensity_transform.so.%{sover}
545%attr(755,root,root) %{_libdir}/libopencv_intensity_transform.so.*.*.*
546%attr(755,root,root) %ghost %{_libdir}/libopencv_mcc.so.%{sover}
547%attr(755,root,root) %{_libdir}/libopencv_mcc.so.*.*.*
548%attr(755,root,root) %ghost %{_libdir}/libopencv_quality.so.%{sover}
549%attr(755,root,root) %{_libdir}/libopencv_quality.so.*.*.*
550%attr(755,root,root) %ghost %{_libdir}/libopencv_rapid.so.%{sover}
551%attr(755,root,root) %{_libdir}/libopencv_rapid.so.*.*.*
552
553%dir %{_datadir}/opencv4
554%{_datadir}/opencv4/haarcascades
555%{_datadir}/opencv4/lbpcascades
556%{_datadir}/opencv4/quality
901927d3 557
933de752
ER
558%files core
559%defattr(644,root,root,755)
158e0ccc 560%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
71c2eb73 561%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
158e0ccc 562%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
71c2eb73 563%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
158e0ccc 564%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
71c2eb73 565%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
158e0ccc 566%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
71c2eb73 567%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
158e0ccc 568%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
71c2eb73 569%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
158e0ccc 570%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
71c2eb73 571%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
33a5389a 572%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
71c2eb73 573%attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
33a5389a 574%attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
71c2eb73 575%attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
33a5389a 576%attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
71c2eb73 577%attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
cf32945e
JB
578
579%if %{with vtk}
580%files viz
581%defattr(644,root,root,755)
158e0ccc 582%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
71c2eb73 583%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
cf32945e 584%endif
933de752 585
901927d3
AM
586%files devel
587%defattr(644,root,root,755)
cf32945e 588# core
701be548
JR
589%{_libdir}/libopencv_core.so
590%{_libdir}/libopencv_flann.so
591%{_libdir}/libopencv_imgproc.so
592%{_libdir}/libopencv_ml.so
593%{_libdir}/libopencv_photo.so
594%{_libdir}/libopencv_video.so
cf32945e 595# GUI/extensions (base package)
701be548
JR
596%{_libdir}/libopencv_calib3d.so
597%{_libdir}/libopencv_features2d.so
598%{_libdir}/libopencv_highgui.so
599%{_libdir}/libopencv_objdetect.so
600%{_libdir}/libopencv_stitching.so
601%{_libdir}/libopencv_superres.so
602%{_libdir}/libopencv_videostab.so
603%{_libdir}/libopencv_imgcodecs.so
604%{_libdir}/libopencv_shape.so
605%{_libdir}/libopencv_videoio.so
b287af3c 606# contrib
701be548
JR
607%{_libdir}/libopencv_aruco.so
608%{_libdir}/libopencv_bgsegm.so
609%{_libdir}/libopencv_bioinspired.so
610%{_libdir}/libopencv_ccalib.so
611%{_libdir}/libopencv_datasets.so
612%{_libdir}/libopencv_dnn.so
613%{_libdir}/libopencv_dnn_objdetect.so
614%{_libdir}/libopencv_dpm.so
615%{_libdir}/libopencv_face.so
616%{_libdir}/libopencv_freetype.so
617%{_libdir}/libopencv_fuzzy.so
618%{_libdir}/libopencv_hdf.so
619%{_libdir}/libopencv_hfs.so
620%{_libdir}/libopencv_img_hash.so
621%{_libdir}/libopencv_line_descriptor.so
622%{_libdir}/libopencv_optflow.so
623%{_libdir}/libopencv_ovis.so
624%{_libdir}/libopencv_phase_unwrapping.so
625%{_libdir}/libopencv_plot.so
626%{_libdir}/libopencv_reg.so
627%{_libdir}/libopencv_rgbd.so
628%{_libdir}/libopencv_saliency.so
629%{_libdir}/libopencv_sfm.so
630%{_libdir}/libopencv_stereo.so
631%{_libdir}/libopencv_structured_light.so
632%{_libdir}/libopencv_surface_matching.so
633%{_libdir}/libopencv_text.so
634%{_libdir}/libopencv_tracking.so
635%{_libdir}/libopencv_xfeatures2d.so
636%{_libdir}/libopencv_ximgproc.so
637%{_libdir}/libopencv_xobjdetect.so
638%{_libdir}/libopencv_xphoto.so
639%{_libdir}/libopencv_alphamat.so
640%{_libdir}/libopencv_dnn_superres.so
641%{_libdir}/libopencv_gapi.so
642%{_libdir}/libopencv_intensity_transform.so
643%{_libdir}/libopencv_mcc.so
644%{_libdir}/libopencv_quality.so
645%{_libdir}/libopencv_rapid.so
cf32945e
JB
646# viz
647%if %{with vtk}
701be548 648%{_libdir}/libopencv_viz.so
0e077f8d 649%endif
701be548 650%{_includedir}/opencv4
e652d7a7 651%dir %{_libdir}/cmake/opencv4
701be548
JR
652%{_libdir}/cmake/opencv4/OpenCV*.cmake
653%{_pkgconfigdir}/opencv4.pc
901927d3 654
9141b1e2
ER
655%files doc
656%defattr(644,root,root,755)
657# TODO: probably could rebuild them and package via make install
658%doc doc/*
659
200823d5
ER
660%if %{with examples}
661%files examples
662%defattr(644,root,root,755)
663%{_examplesdir}/%{name}-%{version}
664%endif
665
b07433c6
JB
666%if %{with java}
667%files -n java-opencv
668%defattr(644,root,root,755)
835e0cdd
ER
669%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
670%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
671%{_javadir}/opencv.jar
672%endif
673
901927d3
AM
674%files -n python-opencv
675%defattr(644,root,root,755)
fe201543
JR
676%dir %{py_sitedir}/cv2
677%dir %{py_sitedir}/cv2/python-*
678%attr(755,root,root) %{py_sitedir}/cv2/python-*/cv2.so
679%{py_sitedir}/cv2/*.py[co]
b221500a
JB
680
681%files -n python3-opencv
682%defattr(644,root,root,755)
fe201543
JR
683%dir %{py3_sitedir}/cv2
684%dir %{py3_sitedir}/cv2/python-*
685%attr(755,root,root) %{py3_sitedir}/cv2/python-*/cv2.cpython-*.so
686%{py3_sitedir}/cv2/*.py
This page took 0.18611 seconds and 4 git commands to generate.