]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- BR ogre-devel for ovis contrib module
[packages/opencv.git] / opencv.spec
CommitLineData
8d499a62 1# TODO:
ca2adc08
JB
2# - contrib subpackage(s)
3# - contrib BRs:
4# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Caffe)
5# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Protobuf)
6# opencv_contrib-3.1.0/modules/cnn_3dobj/CMakeLists.txt:find_package(Glog)
7# opencv_contrib-3.1.0/modules/hdf/CMakeLists.txt:find_package(HDF5)
8# opencv_contrib-3.1.0/modules/sfm/CMakeLists.txt:find_package(Ceres QUIET)
9# opencv_contrib-3.1.0/modules/text/CMakeLists.txt:find_package(Tesseract)
09d132a9
ER
10# unpackaged (3.4.0)
11#/usr/share/OpenCV/3rdparty/usr/lib64/libcorrespondence.a
12#/usr/share/OpenCV/3rdparty/usr/lib64/libmultiview.a
13#/usr/share/OpenCV/3rdparty/usr/lib64/libnumeric.a
14#/usr/share/OpenCV/valgrind.supp
15#/usr/share/OpenCV/valgrind_3rdparty.supp
16
ca2adc08 17#
2acd8ac1 18# - Smartek GigEVisionSDK (http://www.smartekvision.com/ but I can't see SDK with Linux library?)
da5d1e09 19# - CUDA, CUFFT, CUBLAS, NVCUVID support (on bcond)
5df3cf1b 20# - ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
a8d52c2e 21#
0c2d6b7d 22# Conditional build:
a55ba198
JB
23# - general options:
24%bcond_with tbb # Threading Building Blocks support (everywhere)
25%bcond_with sse # use SSE instructions
26%bcond_with sse2 # use SSE2 instructions
da5d1e09
JB
27%bcond_with sse3 # use SSE3 instructions
28%bcond_with ssse3 # use SSSE3 instructions
29%bcond_with sse41 # use SSE4.1 instructions
30%bcond_with sse42 # use SSE4.2 instructions
31%bcond_with avx # use AVX instructions
8d5385eb
JB
32%bcond_without opencl # OpenCL support
33%bcond_with opencl_amdblas # AMD OpenCL BLAS routines
34%bcond_with opencl_amdfft # AMD OpenCL FFT routines
35%bcond_without opengl # OpenGL support
4a401ecc 36%bcond_without openmp # OpenMP support (available when not using tbb)
200823d5 37%bcond_without examples # Install examples
b07433c6
JB
38# - bindings
39%bcond_without java # Java binding
a55ba198 40# - highgui options:
b3920a9d 41%bcond_without ffmpeg # FFMpeg support in highgui
1c9fe580
JB
42%bcond_without gstreamer # GStreamer support in highgui
43%bcond_with openni # OpenNI (Natural Interaction) support in highgui
a55ba198 44%bcond_with pvapi # PvAPI (AVT GigE cameras) support in highgui (proprietary)
1c9fe580 45%bcond_with qt # Qt backend instead of GTK+ in highgui
1c9fe580 46%bcond_with unicap # Unicap support in highgui (GPL)
da5d1e09 47%bcond_without v4l # Video4Linux in highgui
a55ba198 48%bcond_with ximea # m3API (XIMEA cameras) support in highgui (proprietary)
1c9fe580 49%bcond_with xine # XINE support in highgui (GPL)
cf32945e
JB
50# - other modules
51%bcond_without vtk # VTK library support (opencv_viz module)
a4737151 52
e36ac029 53%ifarch pentium3 pentium4 %{x8664} x32
1c9fe580
JB
54%define with_sse 1
55%endif
e36ac029 56%ifarch pentium4 %{x8664} x32
1c9fe580
JB
57%define with_sse2 1
58%endif
901927d3 59Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 60Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 61Name: opencv
701be548
JR
62Version: 4.5.1
63Release: 1
901927d3 64Epoch: 1
d5e56e66
JB
65%if %{with unicap} || %{with xine}
66License: GPL (enforced by used libraries), BSD (opencv itself)
67%else
901927d3 68License: BSD
d5e56e66 69%endif
901927d3 70Group: Libraries
200823d5 71Source0: https://github.com/Itseez/opencv/archive/%{version}/%{name}-%{version}.tar.gz
701be548 72# Source0-md5: 2205d3169238ec1f184438a96de68513
b287af3c 73Source1: https://github.com/Itseez/opencv_contrib/archive/%{version}/%{name}_contrib-%{version}.tar.gz
701be548 74# Source1-md5: 19a31bf7271978ab426112dbf5d1b83f
8a121398
JR
75# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_boostdesc.cmake
76Source10: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm.i
77# Source10-md5: 0ea90e7a8f3f7876d450e4149c97c74f
78Source11: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_bi.i
79# Source11-md5: 232c966b13651bd0e46a1497b0852191
80Source12: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_bgm_hd.i
81# Source12-md5: 324426a24fa56ad9c5b8e3e0b3e5303e
82Source13: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_064.i
83# Source13-md5: 202e1b3e9fec871b04da31f7f016679f
84Source14: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_128.i
85# Source14-md5: 98ea99d399965c03d555cef3ea502a0b
86Source15: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_binboost_256.i
87# Source15-md5: e6dcfa9f647779eb1ce446a8d759b6ea
88Source16: https://raw.githubusercontent.com/opencv/opencv_3rdparty/34e4206aef44d50e6bbcd0ab06354b52e7466d26/boostdesc_lbgm.i
89# Source16-md5: 0ae0675534aa318d9668f2a179c2a052
90# See opencv_contrib-3.4.1/modules/xfeatures2d/cmake/download_vgg.cmake
91Source20: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_48.i
92# Source20-md5: e8d0dcd54d1bcfdc29203d011a797179
93Source21: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_64.i
94# Source21-md5: 7126a5d9a8884ebca5aea5d63d677225
95Source22: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_80.i
96# Source22-md5: 7cd47228edec52b6d82f46511af325c5
97Source23: https://raw.githubusercontent.com/opencv/opencv_3rdparty/fccf7cd6a4b12079f73bbfb21745f9babcd4eb1d/vgg_generated_120.i
98# Source23-md5: 151805e03568c9f490a5e3a872777b75
454d8108 99# See opencv_contrib-3.4.1/modules/face/CMakeLists.txt
8a121398
JR
100Source30: https://raw.githubusercontent.com/opencv/opencv_3rdparty/8afa57abc8229d611c4937165d20e2a2d9fc5a12/face_landmark_model.dat
101# Source30-md5: 7505c44ca4eb54b4ab1e4777cb96ac05
701be548
JR
102# See opencv-4.5.1/modules/gapi/CMakeLists.txt
103Source40: https://github.com/opencv/ade/archive/v0.1.1f/v0.1.1f.zip
104# Source40-md5: b624b995ec9c439cbc2e9e6ee940d3a2
fe201543
JR
105Patch0: %{name}-ximea.patch
106Patch1: python-install.patch
200823d5 107URL: http://www.opencv.org/
d5e56e66 108%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
8d5385eb 109%{?with_opencl:BuildRequires: OpenCL-devel}
0c2d6b7d 110BuildRequires: OpenEXR-devel
5df3cf1b 111%{?with_opengl:BuildRequires: OpenGL-GLU-devel}
9f0b035c 112%{?with_opengl:BuildRequires: OpenGL-devel}
5df3cf1b 113# as of OpenCV 2.3.1-2.4.3 there is also check for OpenNI-sensor-PrimeSense, but the result is not used
1c9fe580 114%{?with_openni:BuildRequires: OpenNI-devel}
da5d1e09 115%{?with_ximea:BuildRequires: XIMEA-devel >= 4}
b07433c6 116%{?with_java:BuildRequires: ant}
8a121398 117BuildRequires: boost-devel
ef4af528
JB
118%{?with_opencl_amdblas:BuildRequires: clAmdBlas-devel}
119%{?with_opencl_amdfft:BuildRequires: clAmdFft-devel}
b07433c6 120BuildRequires: cmake >= 2.8
0c2d6b7d 121BuildRequires: doxygen
809ce413 122BuildRequires: eigen3 >= 3
b3920a9d 123%{?with_ffmpeg:BuildRequires: ffmpeg-devel >= 0.7}
4a401ecc 124%{?with_openmp:BuildRequires: gcc-c++ >= 6:4.2}
fb5ded39 125BuildRequires: gflags-devel
74cbdeb2 126BuildRequires: gl2ps-devel
debb38d4 127BuildRequires: glog-devel
0c2d6b7d 128%if %{with gstreamer}
158e0ccc
JB
129BuildRequires: gstreamer-devel >= 1.0
130BuildRequires: gstreamer-plugins-base-devel >= 1.0
0c2d6b7d 131%endif
901927d3 132BuildRequires: jasper-devel
b07433c6 133%{?with_java:BuildRequires: jdk}
158e0ccc 134BuildRequires: libdc1394-devel >= 2
4a401ecc 135%{?with_openmp:BuildRequires: libgomp-devel}
901927d3
AM
136BuildRequires: libjpeg-devel
137BuildRequires: libpng-devel
138BuildRequires: libraw1394-devel
0c2d6b7d 139BuildRequires: libstdc++-devel
901927d3 140BuildRequires: libtiff-devel
148338c5 141BuildRequires: libtool
d5e56e66
JB
142%if %{with unicap}
143BuildRequires: libucil-devel
144BuildRequires: libunicap-devel
145%endif
0c2d6b7d 146BuildRequires: libv4l-devel
4836bff0 147BuildRequires: ogre-devel
af6d2888 148BuildRequires: pkgconfig
701be548 149BuildRequires: protobuf-devel
158e0ccc
JB
150BuildRequires: python >= 2.0
151BuildRequires: python-devel >= 2.0
0c2d6b7d 152BuildRequires: python-numpy-devel
b221500a
JB
153BuildRequires: python3 >= 1:3.2
154BuildRequires: python3-devel >= 1:3.2
155BuildRequires: python3-numpy-devel
901927d3 156BuildRequires: rpm-pythonprov
8d499a62 157BuildRequires: rpmbuild(macros) >= 1.606
1376dffe 158BuildRequires: sed >= 4.0
158e0ccc 159BuildRequires: sphinx-pdg
996927aa 160BuildRequires: swig-python
f8e040cc 161%{?with_tbb:BuildRequires: tbb-devel}
ae3d975d
AM
162%if %{with vtk}
163BuildRequires: vtk-devel >= 5.8.0
fba97d16 164BuildRequires: vtk-java >= 5.8.0
701be548 165BuildRequires: vtk-python3-devel >= 5.8.0
ae3d975d 166%endif
901927d3 167%{?with_xine:BuildRequires: xine-lib-devel}
158e0ccc 168BuildRequires: xorg-lib-libX11-devel
452b38e1 169BuildRequires: zlib-devel
4afb606b 170%if %{with qt}
4afb606b
JB
171BuildRequires: QtCore-devel >= 4
172BuildRequires: QtGui-devel >= 4
5df3cf1b 173%{?with_opengl:BuildRequires: QtOpenGL-devel >= 4}
4afb606b
JB
174BuildRequires: qt4-qmake >= 4
175%else
176BuildRequires: gtk+2-devel >= 2.0
5df3cf1b 177%{?with_opengl:BuildRequires: gtkglext-devel >= 1.0}
4afb606b 178%endif
da5d1e09 179Requires: %{name}-core = %{epoch}:%{version}-%{release}
901927d3
AM
180BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
181
158e0ccc 182%define jver %(echo %{version} | cut -d. -f1-3 | tr -d .)
71c2eb73 183%define sover %(echo %{version} | cut -d. -f1-2)
933de752 184
901927d3
AM
185%description
186OpenCV (Open Source Computer Vision) is a library of programming
187functions mainly aimed at real time computer vision.
188
0c2d6b7d
JB
189Example applications of the OpenCV library are:
190- Human-Computer Interaction (HCI)
191- Object Identification, Segmentation and Recognition
192- Face Recognition
193- Gesture Recognition
194- Motion Tracking
195- Ego Motion, Motion Understanding
196- Structure From Motion (SFM)
197- Stereo and Multi-Camera Calibration and Depth Computation
198- Mobile Robotics.
199
200%description -l pl.UTF-8
201OpenCV (Open Source Computer Vision) to biblioteka funkcji
202przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
203
204Przykładowe zastosowania biblioteki OpenCV to
205- interakcje człowiek-komputer (HCI)
206- identyfikacja, segmentacja i rozpoznawanie obiektów
207- rozpoznawanie twarzy
208- rozpoznawanie gestów
209- śledzenie ruchu
210- rozumienie ruchu
211- SFM (Structure From Motion)
212- kalibracja dwu- i wielokamerowa, obliczanie głębi
213- robotyka ruchu.
901927d3 214
933de752
ER
215%package core
216Summary: OpenCV core libraries
da5d1e09 217Summary(pl.UTF-8): Podstawowe biblioteki OpenCV
933de752 218Group: Libraries
da5d1e09 219Conflicts: opencv < 2.4.6.2-1
933de752
ER
220
221%description core
222This package contains the OpenCV C/C++ core libraries.
223
da5d1e09
JB
224%description core -l pl.UTF-8
225Ten pakiet zawiera podstawowe biblioteki C/C++ OpenCV.
226
cf32945e
JB
227%package viz
228Summary: OpenCV viz library (VTK support)
229Summary(pl.UTF-8): Biblioteka OpenCV viz (obsługa VTK)
230Group: Libraries
231Requires: %{name} = %{epoch}:%{version}-%{release}
232
233%description viz
234OpenCV viz library (VTK support).
235
236%description viz -l pl.UTF-8
237Biblioteka OpenCV viz (obsługa VTK).
238
901927d3 239%package devel
0c2d6b7d
JB
240Summary: Header files for OpenCV library
241Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
242Group: Development/Libraries
243Requires: %{name} = %{epoch}:%{version}-%{release}
cf32945e
JB
244%if %{with vtk}
245Requires: %{name}-viz = %{epoch}:%{version}-%{release}
246%endif
0c2d6b7d 247Obsoletes: opencv-static
901927d3
AM
248
249%description devel
0c2d6b7d 250Header files for OpenCV library.
901927d3 251
0c2d6b7d
JB
252%description devel -l pl.UTF-8
253Pliki nagłówkowe biblioteki OpenCV.
901927d3 254
9141b1e2
ER
255%package doc
256Summary: Manual for OpenCV
257Summary(fr.UTF-8): Documentation pour OpenCV
258Summary(it.UTF-8): Documentazione di OpenCV
259Summary(pl.UTF-8): Podręcznik dla OpenCV
260Group: Documentation
261# noarch subpackages only when building with rpm5
9141b1e2 262BuildArch: noarch
9141b1e2
ER
263
264%description doc
265Documentation for OpenCV.
266
267%description doc -l fr.UTF-8
268Documentation pour OpenCV.
269
270%description doc -l it.UTF-8
271Documentazione di OpenCV.
272
273%description doc -l pl.UTF-8
274Dokumentacja do OpenCV.
275
200823d5
ER
276%package examples
277Summary: OpenCV code examples
278Group: Documentation
200823d5 279BuildArch: noarch
200823d5
ER
280
281%description examples
282OpenCV code examples.
283
b07433c6
JB
284%package -n java-opencv
285Summary: OpenCV Java bindings
286Summary(pl.UTF-8): Wiązania Javy do OpenCV
287Group: Libraries/Java
288Requires: %{name} = %{epoch}:%{version}-%{release}
289Requires: jre
290
291%description -n java-opencv
292OpenCV Java bindings.
293
294%description -n java-opencv -l pl.UTF-8
295Wiązania Javy do OpenCV.
296
901927d3 297%package -n python-opencv
b221500a
JB
298Summary: OpenCV Python 2 bindings
299Summary(pl.UTF-8): Wiązania Pythona 2 do OpenCV
0c2d6b7d 300Group: Libraries/Python
cd1f0136 301Requires: %{name} = %{epoch}:%{version}-%{release}
9f0b035c 302Requires: python-libs
901927d3
AM
303
304%description -n python-opencv
b221500a 305OpenCV Python 2 bindings.
901927d3 306
0c2d6b7d 307%description -n python-opencv -l pl.UTF-8
b221500a
JB
308Wiązania Pythona 2 do OpenCV.
309
310%package -n python3-opencv
311Summary: OpenCV Python 3 bindings
312Summary(pl.UTF-8): Wiązania Pythona 3 do OpenCV
313Group: Libraries/Python
314Requires: %{name} = %{epoch}:%{version}-%{release}
315Requires: python3-libs
316
317%description -n python3-opencv
318OpenCV Python 3 bindings.
319
320%description -n python3-opencv -l pl.UTF-8
321Wiązania Pythona 3 do OpenCV.
0c2d6b7d 322
901927d3 323%prep
b287af3c 324%setup -q -a1
54551f29 325
da67222a 326%undos CMakeLists.txt
54551f29 327
8a121398 328%patch0 -p1
08b22f18 329%patch1 -p1
148338c5 330
701be548
JR
331cache_file() {
332 f="$1"
333 d="$2"
334 md5="$(md5sum "$f" | awk '{print $1}')"
335 file="$(basename "$f")"
336 mkdir -p ".cache/$d"
337 install "$f" ".cache/$d/$md5-$file"
338}
339for f in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16}; do
340 cache_file $f xfeatures2d/boostdesc
341done
342for f in %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}; do
343 cache_file $f xfeatures2d/vgg
344done
345cache_file %{SOURCE30} data
346cache_file %{SOURCE40} ade
347
901927d3 348%build
701be548 349mkdir -p build
95daeb66 350cd build
ea26b025
ER
351
352# handle cmake & ccache
353# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
354if [[ "%{__cc}" = *ccache* ]]; then
355 cc="%{__cc}"
356 cxx="%{__cxx}"
357 ccache="
358 -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
359 -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
360 "
361fi
362
0c2d6b7d 363%cmake .. \
ea26b025 364 $ccache \
08b22f18 365 -DENABLE_PRECOMPILED_HEADERS=OFF \
09d132a9 366 -DOPENCV_LIB_INSTALL_PATH=%{_libdir} \
b287af3c 367 -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
da5d1e09 368 -DENABLE_AVX=%{?with_avx:ON}%{!?with_avx:OFF} \
1c9fe580
JB
369 -DENABLE_SSE=%{?with_sse:ON}%{!?with_sse:OFF} \
370 -DENABLE_SSE2=%{?with_sse2:ON}%{!?with_sse2:OFF} \
da5d1e09
JB
371 -DENABLE_SSE3=%{?with_sse3:ON}%{!?with_sse3:OFF} \
372 -DENABLE_SSSE3=%{?with_ssse3:ON}%{!?with_ssse3:OFF} \
373 -DENABLE_SSE41=%{?with_sse41:ON}%{!?with_sse41:OFF} \
374 -DENABLE_SSE42=%{?with_sse42:ON}%{!?with_sse42:OFF} \
95daeb66 375 -DBUILD_NEW_PYTHON_SUPPORT=ON \
701be548 376 -DOPENCV_GENERATE_PKGCONFIG:BOOL=ON \
200823d5
ER
377%if %{with examples}
378 -DINSTALL_C_EXAMPLES=ON \
379 -DINSTALL_PYTHON_EXAMPLES=ON \
380%endif
b3920a9d 381 %{?with_ffmpeg:-DWITH_FFMPEG=ON} \
d5e56e66 382 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
8d5385eb 383 %{?with_opencl:-DWITH_OPENCL=ON} \
faf80a1c
JB
384 %{!?with_opencl_amdblas:-DWITH_OPENCLAMDBLAS=OFF} \
385 %{!?with_opencl_amdfft:-DWITH_OPENCLAMDFFT=OFF} \
5df3cf1b 386 %{?with_opengl:-DWITH_OPENGL=ON} \
4a401ecc 387 %{?with_openmp:-DWITH_OPENMP=ON} \
1c9fe580 388 %{?with_openni:-DWITH_OPENNI=ON} \
809ce413 389 %{?with_pvapi:-DPVAPI_LIBRARY=%{_libdir}/libPvAPI.so}%{!?with_pvapi:-DWITH_PVAPI=OFF} \
5df3cf1b 390 %{?with_qt:-DWITH_QT=ON %{?with_opengl:-DWITH_QT_OPENGL=ON} -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 391 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 392 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 393 %{!?with_v4l:-DWITH_V4L=OFF} \
cf32945e 394 %{?with_vtk:-DWITH_VTK=ON} \
a55ba198 395 %{?with_ximea:-DWITH_XIMEA=ON} \
33a5389a
JR
396 %{?with_xine:-DWITH_XINE=ON} \
397 -DWITH_IPP=OFF
54551f29 398
8b9f61f7 399%{__make}
901927d3
AM
400
401%install
402rm -rf $RPM_BUILD_ROOT
95daeb66 403%{__make} -C build install \
901927d3
AM
404 DESTDIR=$RPM_BUILD_ROOT
405
200823d5
ER
406%if %{with examples}
407install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
701be548 408mv $RPM_BUILD_ROOT%{_datadir}/opencv4/samples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
200823d5 409%endif
9141b1e2 410
7545129b 411# disable completeness check incompatible with split packaging
701be548 412%{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d' $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules.cmake
7545129b 413
8d499a62
JB
414%py_comp $RPM_BUILD_ROOT%{py_sitedir}
415%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
416%py_postclean
417
b07433c6
JB
418%if %{with java}
419# move to proper directories, create symlink
420install -d $RPM_BUILD_ROOT%{_javadir}
701be548
JR
421%{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/libopencv_java*.so $RPM_BUILD_ROOT%{_libdir}
422sed -i -e 's#/share/java/opencv4/libopencv_java%{jver}\.so#/%{_lib}/libopencv_java%{jver}.so#g' \
423 $RPM_BUILD_ROOT%{_libdir}/cmake/opencv4/OpenCVModules-pld.cmake
424%{__mv} $RPM_BUILD_ROOT%{_javadir}/opencv4/opencv-*.jar $RPM_BUILD_ROOT%{_javadir}
425rmdir $RPM_BUILD_ROOT%{_javadir}/opencv4
b07433c6
JB
426ln -sf $(basename $RPM_BUILD_ROOT%{_javadir}/opencv-*.jar) $RPM_BUILD_ROOT%{_javadir}/opencv.jar
427%endif
428
901927d3
AM
429%clean
430rm -rf $RPM_BUILD_ROOT
431
432%post -p /sbin/ldconfig
433%postun -p /sbin/ldconfig
434
933de752
ER
435%post core -p /sbin/ldconfig
436%postun core -p /sbin/ldconfig
437
485d5dca
JB
438%post viz -p /sbin/ldconfig
439%postun viz -p /sbin/ldconfig
440
b07433c6
JB
441%post -n java-opencv -p /sbin/ldconfig
442%postun -n java-opencv -p /sbin/ldconfig
443
901927d3
AM
444%files
445%defattr(644,root,root,755)
f753ced4 446%attr(755,root,root) %{_bindir}/opencv_annotation
701be548 447#%attr(755,root,root) %{_bindir}/opencv_createsamples
09d132a9 448%attr(755,root,root) %{_bindir}/opencv_interactive-calibration
701be548 449#%attr(755,root,root) %{_bindir}/opencv_traincascade
09d132a9
ER
450%attr(755,root,root) %{_bindir}/opencv_version
451%attr(755,root,root) %{_bindir}/opencv_visualisation
701be548 452%attr(755,root,root) %{_bindir}/setup_vars_opencv4.sh
158e0ccc 453%attr(755,root,root) %{_libdir}/libopencv_calib3d.so.*.*.*
71c2eb73 454%attr(755,root,root) %ghost %{_libdir}/libopencv_calib3d.so.%{sover}
158e0ccc 455%attr(755,root,root) %{_libdir}/libopencv_features2d.so.*.*.*
71c2eb73 456%attr(755,root,root) %ghost %{_libdir}/libopencv_features2d.so.%{sover}
158e0ccc 457%attr(755,root,root) %{_libdir}/libopencv_highgui.so.*.*.*
71c2eb73 458%attr(755,root,root) %ghost %{_libdir}/libopencv_highgui.so.%{sover}
158e0ccc 459%attr(755,root,root) %{_libdir}/libopencv_objdetect.so.*.*.*
71c2eb73 460%attr(755,root,root) %ghost %{_libdir}/libopencv_objdetect.so.%{sover}
158e0ccc 461%attr(755,root,root) %{_libdir}/libopencv_stitching.so.*.*.*
71c2eb73 462%attr(755,root,root) %ghost %{_libdir}/libopencv_stitching.so.%{sover}
158e0ccc 463%attr(755,root,root) %{_libdir}/libopencv_superres.so.*.*.*
71c2eb73 464%attr(755,root,root) %ghost %{_libdir}/libopencv_superres.so.%{sover}
158e0ccc 465%attr(755,root,root) %{_libdir}/libopencv_videostab.so.*.*.*
71c2eb73 466%attr(755,root,root) %ghost %{_libdir}/libopencv_videostab.so.%{sover}
b287af3c
JR
467# contrib modules
468%attr(755,root,root) %{_bindir}/opencv_waldboost_detector
469%attr(755,root,root) %ghost %{_libdir}/libopencv_aruco.so.%{sover}
470%attr(755,root,root) %{_libdir}/libopencv_aruco.so.*.*.*
471%attr(755,root,root) %ghost %{_libdir}/libopencv_bgsegm.so.%{sover}
472%attr(755,root,root) %{_libdir}/libopencv_bgsegm.so.*.*.*
473%attr(755,root,root) %ghost %{_libdir}/libopencv_bioinspired.so.%{sover}
474%attr(755,root,root) %{_libdir}/libopencv_bioinspired.so.*.*.*
475%attr(755,root,root) %ghost %{_libdir}/libopencv_ccalib.so.%{sover}
476%attr(755,root,root) %{_libdir}/libopencv_ccalib.so.*.*.*
477%attr(755,root,root) %ghost %{_libdir}/libopencv_datasets.so.%{sover}
478%attr(755,root,root) %{_libdir}/libopencv_datasets.so.*.*.*
479%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn.so.%{sover}
480%attr(755,root,root) %{_libdir}/libopencv_dnn.so.*.*.*
c9cb1c24
JR
481%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_objdetect.so.%{sover}
482%attr(755,root,root) %{_libdir}/libopencv_dnn_objdetect.so.*.*.*
b287af3c
JR
483%attr(755,root,root) %ghost %{_libdir}/libopencv_dpm.so.%{sover}
484%attr(755,root,root) %{_libdir}/libopencv_dpm.so.*.*.*
485%attr(755,root,root) %ghost %{_libdir}/libopencv_face.so.%{sover}
486%attr(755,root,root) %{_libdir}/libopencv_face.so.*.*.*
09d132a9
ER
487%attr(755,root,root) %ghost %{_libdir}/libopencv_freetype.so.%{sover}
488%attr(755,root,root) %{_libdir}/libopencv_freetype.so.*.*.*
b287af3c
JR
489%attr(755,root,root) %ghost %{_libdir}/libopencv_fuzzy.so.%{sover}
490%attr(755,root,root) %{_libdir}/libopencv_fuzzy.so.*.*.*
491%attr(755,root,root) %ghost %{_libdir}/libopencv_hdf.so.%{sover}
492%attr(755,root,root) %{_libdir}/libopencv_hdf.so.*.*.*
c9cb1c24
JR
493%attr(755,root,root) %ghost %{_libdir}/libopencv_hfs.so.%{sover}
494%attr(755,root,root) %{_libdir}/libopencv_hfs.so.*.*.*
09d132a9
ER
495%attr(755,root,root) %ghost %{_libdir}/libopencv_img_hash.so.%{sover}
496%attr(755,root,root) %{_libdir}/libopencv_img_hash.so.*.*.*
b287af3c
JR
497%attr(755,root,root) %ghost %{_libdir}/libopencv_line_descriptor.so.%{sover}
498%attr(755,root,root) %{_libdir}/libopencv_line_descriptor.so.*.*.*
3752412b
JR
499%attr(755,root,root) %ghost %{_libdir}/libopencv_ovis.so.%{sover}
500%attr(755,root,root) %{_libdir}/libopencv_ovis.so.*.*.*
b287af3c
JR
501%attr(755,root,root) %ghost %{_libdir}/libopencv_optflow.so.%{sover}
502%attr(755,root,root) %{_libdir}/libopencv_optflow.so.*.*.*
09d132a9
ER
503%attr(755,root,root) %ghost %{_libdir}/libopencv_phase_unwrapping.so.%{sover}
504%attr(755,root,root) %{_libdir}/libopencv_phase_unwrapping.so.*.*.*
b287af3c
JR
505%attr(755,root,root) %ghost %{_libdir}/libopencv_plot.so.%{sover}
506%attr(755,root,root) %{_libdir}/libopencv_plot.so.*.*.*
507%attr(755,root,root) %ghost %{_libdir}/libopencv_reg.so.%{sover}
508%attr(755,root,root) %{_libdir}/libopencv_reg.so.*.*.*
509%attr(755,root,root) %ghost %{_libdir}/libopencv_rgbd.so.%{sover}
510%attr(755,root,root) %{_libdir}/libopencv_rgbd.so.*.*.*
511%attr(755,root,root) %ghost %{_libdir}/libopencv_saliency.so.%{sover}
512%attr(755,root,root) %{_libdir}/libopencv_saliency.so.*.*.*
513%attr(755,root,root) %ghost %{_libdir}/libopencv_sfm.so.%{sover}
514%attr(755,root,root) %{_libdir}/libopencv_sfm.so.*.*.*
515%attr(755,root,root) %ghost %{_libdir}/libopencv_stereo.so.%{sover}
516%attr(755,root,root) %{_libdir}/libopencv_stereo.so.*.*.*
517%attr(755,root,root) %ghost %{_libdir}/libopencv_structured_light.so.%{sover}
518%attr(755,root,root) %{_libdir}/libopencv_structured_light.so.*.*.*
519%attr(755,root,root) %ghost %{_libdir}/libopencv_surface_matching.so.%{sover}
520%attr(755,root,root) %{_libdir}/libopencv_surface_matching.so.*.*.*
521%attr(755,root,root) %ghost %{_libdir}/libopencv_text.so.%{sover}
522%attr(755,root,root) %{_libdir}/libopencv_text.so.*.*.*
523%attr(755,root,root) %ghost %{_libdir}/libopencv_tracking.so.%{sover}
524%attr(755,root,root) %{_libdir}/libopencv_tracking.so.*.*.*
525%attr(755,root,root) %ghost %{_libdir}/libopencv_xfeatures2d.so.%{sover}
526%attr(755,root,root) %{_libdir}/libopencv_xfeatures2d.so.*.*.*
527%attr(755,root,root) %ghost %{_libdir}/libopencv_ximgproc.so.%{sover}
528%attr(755,root,root) %{_libdir}/libopencv_ximgproc.so.*.*.*
529%attr(755,root,root) %ghost %{_libdir}/libopencv_xobjdetect.so.%{sover}
530%attr(755,root,root) %{_libdir}/libopencv_xobjdetect.so.*.*.*
531%attr(755,root,root) %ghost %{_libdir}/libopencv_xphoto.so.%{sover}
532%attr(755,root,root) %{_libdir}/libopencv_xphoto.so.*.*.*
701be548
JR
533%attr(755,root,root) %ghost %{_libdir}/libopencv_alphamat.so.%{sover}
534%attr(755,root,root) %{_libdir}/libopencv_alphamat.so.*.*.*
535%attr(755,root,root) %ghost %{_libdir}/libopencv_dnn_superres.so.%{sover}
536%attr(755,root,root) %{_libdir}/libopencv_dnn_superres.so.*.*.*
537%attr(755,root,root) %ghost %{_libdir}/libopencv_gapi.so.%{sover}
538%attr(755,root,root) %{_libdir}/libopencv_gapi.so.*.*.*
539%attr(755,root,root) %ghost %{_libdir}/libopencv_intensity_transform.so.%{sover}
540%attr(755,root,root) %{_libdir}/libopencv_intensity_transform.so.*.*.*
541%attr(755,root,root) %ghost %{_libdir}/libopencv_mcc.so.%{sover}
542%attr(755,root,root) %{_libdir}/libopencv_mcc.so.*.*.*
543%attr(755,root,root) %ghost %{_libdir}/libopencv_quality.so.%{sover}
544%attr(755,root,root) %{_libdir}/libopencv_quality.so.*.*.*
545%attr(755,root,root) %ghost %{_libdir}/libopencv_rapid.so.%{sover}
546%attr(755,root,root) %{_libdir}/libopencv_rapid.so.*.*.*
547
548%dir %{_datadir}/opencv4
549%{_datadir}/opencv4/haarcascades
550%{_datadir}/opencv4/lbpcascades
551%{_datadir}/opencv4/quality
901927d3 552
933de752
ER
553%files core
554%defattr(644,root,root,755)
158e0ccc 555%attr(755,root,root) %{_libdir}/libopencv_core.so.*.*.*
71c2eb73 556%attr(755,root,root) %ghost %{_libdir}/libopencv_core.so.%{sover}
158e0ccc 557%attr(755,root,root) %{_libdir}/libopencv_flann.so.*.*.*
71c2eb73 558%attr(755,root,root) %ghost %{_libdir}/libopencv_flann.so.%{sover}
158e0ccc 559%attr(755,root,root) %{_libdir}/libopencv_imgproc.so.*.*.*
71c2eb73 560%attr(755,root,root) %ghost %{_libdir}/libopencv_imgproc.so.%{sover}
158e0ccc 561%attr(755,root,root) %{_libdir}/libopencv_ml.so.*.*.*
71c2eb73 562%attr(755,root,root) %ghost %{_libdir}/libopencv_ml.so.%{sover}
158e0ccc 563%attr(755,root,root) %{_libdir}/libopencv_photo.so.*.*.*
71c2eb73 564%attr(755,root,root) %ghost %{_libdir}/libopencv_photo.so.%{sover}
158e0ccc 565%attr(755,root,root) %{_libdir}/libopencv_video.so.*.*.*
71c2eb73 566%attr(755,root,root) %ghost %{_libdir}/libopencv_video.so.%{sover}
33a5389a 567%attr(755,root,root) %{_libdir}/libopencv_imgcodecs.so.*.*.*
71c2eb73 568%attr(755,root,root) %ghost %{_libdir}/libopencv_imgcodecs.so.%{sover}
33a5389a 569%attr(755,root,root) %{_libdir}/libopencv_shape.so.*.*.*
71c2eb73 570%attr(755,root,root) %ghost %{_libdir}/libopencv_shape.so.%{sover}
33a5389a 571%attr(755,root,root) %{_libdir}/libopencv_videoio.so.*.*.*
71c2eb73 572%attr(755,root,root) %ghost %{_libdir}/libopencv_videoio.so.%{sover}
cf32945e
JB
573
574%if %{with vtk}
575%files viz
576%defattr(644,root,root,755)
158e0ccc 577%attr(755,root,root) %{_libdir}/libopencv_viz.so.*.*.*
71c2eb73 578%attr(755,root,root) %ghost %{_libdir}/libopencv_viz.so.%{sover}
cf32945e 579%endif
933de752 580
901927d3
AM
581%files devel
582%defattr(644,root,root,755)
cf32945e 583# core
701be548
JR
584%{_libdir}/libopencv_core.so
585%{_libdir}/libopencv_flann.so
586%{_libdir}/libopencv_imgproc.so
587%{_libdir}/libopencv_ml.so
588%{_libdir}/libopencv_photo.so
589%{_libdir}/libopencv_video.so
cf32945e 590# GUI/extensions (base package)
701be548
JR
591%{_libdir}/libopencv_calib3d.so
592%{_libdir}/libopencv_features2d.so
593%{_libdir}/libopencv_highgui.so
594%{_libdir}/libopencv_objdetect.so
595%{_libdir}/libopencv_stitching.so
596%{_libdir}/libopencv_superres.so
597%{_libdir}/libopencv_videostab.so
598%{_libdir}/libopencv_imgcodecs.so
599%{_libdir}/libopencv_shape.so
600%{_libdir}/libopencv_videoio.so
b287af3c 601# contrib
701be548
JR
602%{_libdir}/libopencv_aruco.so
603%{_libdir}/libopencv_bgsegm.so
604%{_libdir}/libopencv_bioinspired.so
605%{_libdir}/libopencv_ccalib.so
606%{_libdir}/libopencv_datasets.so
607%{_libdir}/libopencv_dnn.so
608%{_libdir}/libopencv_dnn_objdetect.so
609%{_libdir}/libopencv_dpm.so
610%{_libdir}/libopencv_face.so
611%{_libdir}/libopencv_freetype.so
612%{_libdir}/libopencv_fuzzy.so
613%{_libdir}/libopencv_hdf.so
614%{_libdir}/libopencv_hfs.so
615%{_libdir}/libopencv_img_hash.so
616%{_libdir}/libopencv_line_descriptor.so
617%{_libdir}/libopencv_optflow.so
618%{_libdir}/libopencv_ovis.so
619%{_libdir}/libopencv_phase_unwrapping.so
620%{_libdir}/libopencv_plot.so
621%{_libdir}/libopencv_reg.so
622%{_libdir}/libopencv_rgbd.so
623%{_libdir}/libopencv_saliency.so
624%{_libdir}/libopencv_sfm.so
625%{_libdir}/libopencv_stereo.so
626%{_libdir}/libopencv_structured_light.so
627%{_libdir}/libopencv_surface_matching.so
628%{_libdir}/libopencv_text.so
629%{_libdir}/libopencv_tracking.so
630%{_libdir}/libopencv_xfeatures2d.so
631%{_libdir}/libopencv_ximgproc.so
632%{_libdir}/libopencv_xobjdetect.so
633%{_libdir}/libopencv_xphoto.so
634%{_libdir}/libopencv_alphamat.so
635%{_libdir}/libopencv_dnn_superres.so
636%{_libdir}/libopencv_gapi.so
637%{_libdir}/libopencv_intensity_transform.so
638%{_libdir}/libopencv_mcc.so
639%{_libdir}/libopencv_quality.so
640%{_libdir}/libopencv_rapid.so
cf32945e
JB
641# viz
642%if %{with vtk}
701be548 643%{_libdir}/libopencv_viz.so
0e077f8d 644%endif
701be548
JR
645%{_includedir}/opencv4
646%{_libdir}/cmake/opencv4/OpenCV*.cmake
647%{_pkgconfigdir}/opencv4.pc
901927d3 648
9141b1e2
ER
649%files doc
650%defattr(644,root,root,755)
651# TODO: probably could rebuild them and package via make install
652%doc doc/*
653
200823d5
ER
654%if %{with examples}
655%files examples
656%defattr(644,root,root,755)
657%{_examplesdir}/%{name}-%{version}
658%endif
659
b07433c6
JB
660%if %{with java}
661%files -n java-opencv
662%defattr(644,root,root,755)
835e0cdd
ER
663%attr(755,root,root) %{_libdir}/libopencv_java%{jver}.so
664%{_javadir}/opencv-%{jver}.jar
b07433c6
JB
665%{_javadir}/opencv.jar
666%endif
667
901927d3
AM
668%files -n python-opencv
669%defattr(644,root,root,755)
fe201543
JR
670%dir %{py_sitedir}/cv2
671%dir %{py_sitedir}/cv2/python-*
672%attr(755,root,root) %{py_sitedir}/cv2/python-*/cv2.so
673%{py_sitedir}/cv2/*.py[co]
b221500a
JB
674
675%files -n python3-opencv
676%defattr(644,root,root,755)
fe201543
JR
677%dir %{py3_sitedir}/cv2
678%dir %{py3_sitedir}/cv2/python-*
679%attr(755,root,root) %{py3_sitedir}/cv2/python-*/cv2.cpython-*.so
680%{py3_sitedir}/cv2/*.py
This page took 0.17954 seconds and 4 git commands to generate.