]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- strict internal dep for python-opencv, release 4
[packages/opencv.git] / opencv.spec
CommitLineData
901927d3
AM
1%bcond_with xine
2%define snap pre1
3Summary: A library of programming functions mainly aimed at real time computer vision
4Name: opencv
5Version: 1.1
cd1f0136 6Release: 0.%{snap}.4
901927d3
AM
7Epoch: 1
8License: BSD
9Group: Libraries
10Source0: http://dl.sourceforge.net/opencvlibrary/%{name}-%{version}%{snap}.tar.gz
11# Source0-md5: b147b7cd3c059831c415c5a2bcecdf95
148338c5 12Patch0: %{name}-ffmpeg.patch
4b75cbf1 13Patch1: %{name}-am.patch
901927d3
AM
14URL: http://opencv.willowgarage.com
15BuildRequires: autoconf >= 2.53
16BuildRequires: automake
17BuildRequires: ffmpeg-devel
18BuildRequires: jasper-devel
19BuildRequires: libdc1394-devel
20BuildRequires: libjpeg-devel
21BuildRequires: libpng-devel
22BuildRequires: libraw1394-devel
23BuildRequires: libtiff-devel
148338c5 24BuildRequires: libtool
901927d3
AM
25BuildRequires: python-devel
26BuildRequires: rpm-pythonprov
996927aa 27BuildRequires: swig-python
901927d3
AM
28BuildRequires: zlib-devel
29%pyrequires_eq python-libs
30%{?with_xine:BuildRequires: xine-lib-devel}
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34OpenCV (Open Source Computer Vision) is a library of programming
35functions mainly aimed at real time computer vision.
36
37Example applications of the OpenCV library are Human-Computer
38Interaction (HCI); Object Identification, Segmentation and
39Recognition; Face Recognition; Gesture Recognition; Motion Tracking,
40Ego Motion, Motion Understanding; Structure From Motion (SFM); Stereo
41and Multi-Camera Calibration and Depth Computation; Mobile Robotics.
42
43%package devel
44Summary: Header files and develpment documentation for opencv
45Group: Development/Libraries
46Requires: %{name} = %{epoch}:%{version}-%{release}
47
48%description devel
49Header files and opencv documentation.
50
51%package static
52Summary: Static opencv library
53Group: Development/Libraries
54Requires: %{name}-devel = %{epoch}:%{version}-%{release}
55
56%description static
57This package contains the static library used for development.
58
59%package -n python-opencv
60Summary: OpenCV Python bindings
61Group: Development/Languages/Python
62%pyrequires_eq python
cd1f0136 63Requires: %{name} = %{epoch}:%{version}-%{release}
901927d3
AM
64
65%description -n python-opencv
66OpenCV Python bindings.
67
68%prep
69%setup -q -n %{name}-%{version}.0
148338c5 70%patch0 -p0
4b75cbf1 71%patch1 -p1
148338c5
AM
72
73sed -i -e 's#ACLOCAL_AMFLAGS.*##g' Makefile.am
74sed -i -e 's#pkgpython#pkgpyexec#g' interfaces/swig/python/Makefile.am
75sed -i -e 's#-L$(SWIG_PYTHON_LIBS)#$(NOTING_NOT_EMPTY_LINE)#g' interfaces/swig/python/Makefile.am
901927d3
AM
76
77%build
148338c5
AM
78%{__libtoolize}
79%{__aclocal} -I autotools/aclocal
80%{__autoconf}
81%{__automake}
901927d3
AM
82%configure \
83%ifarch i686 pentium4 athlon %{x8664}
84 --enable-sse2 \
85%else
86 --disable-sse2 \
87%endif
88 --with-python \
148338c5 89 --with%{!?with_xine:out}-xine \
901927d3
AM
90 --with-ffmpeg \
91 --with-1394libs \
92 --with-v4l \
93 --with-gtk \
94 --without-gstreamer \
95 --without-quicktime
96%{__make}
97
98%install
99rm -rf $RPM_BUILD_ROOT
100
101%{__make} install \
102 DESTDIR=$RPM_BUILD_ROOT
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(644,root,root,755)
112%doc AUTHORS COPYING ChangeLog THANKS TODO
113%doc docs/*.{htm,rtf,png,txt} docs/papers docs/ref
114%attr(755,root,root) %{_bindir}/*
115%attr(755,root,root) %{_libdir}/lib*so.*.*
116%attr(755,root,root) %ghost %{_libdir}/lib*.so.2
117
118%files devel
119%defattr(644,root,root,755)
120%attr(755,root,root) %{_libdir}/lib*.so
121%{_libdir}/lib*.la
122%{_includedir}/opencv
123%{_pkgconfigdir}/*.pc
124
125%files static
126%defattr(644,root,root,755)
127%{_libdir}/lib*.a
128
129%files -n python-opencv
130%defattr(644,root,root,755)
131%dir %{py_sitedir}/opencv
132%attr(755,root,root) %{py_sitedir}/opencv/*.so
133%{py_sitedir}/opencv/*.py[co]
This page took 0.083436 seconds and 4 git commands to generate.