]> git.pld-linux.org Git - packages/opencv.git/blame - opencv.spec
- upstream support lib64 now
[packages/opencv.git] / opencv.spec
CommitLineData
452b38e1 1#
2# TODO: - CUDA support (on bcond)
3# - consider name change to OpenCV
a8d52c2e 4#
0c2d6b7d 5# Conditional build:
d5e56e66
JB
6%bcond_without gstreamer # GStreamer support
7%bcond_with pvapi # PvAPI (AVT GigE cameras) support
4afb606b 8%bcond_with qt # Qt backend instead of GTK+
f8e040cc 9%bcond_with tbb # Threading Building Blocks support
d5e56e66 10%bcond_with unicap # Unicap support (GPL)
ed358224 11%bcond_with v4l # Video4Linux (even V4L2 support currently relies on V4L1 API)
0c2d6b7d 12%bcond_with xine # XINE support (GPL)
a8d52c2e 13#
901927d3 14Summary: A library of programming functions mainly aimed at real time computer vision
0c2d6b7d 15Summary(pl.UTF-8): Biblioteka funkcji do grafiki komputerowej w czasie rzeczywistym
901927d3 16Name: opencv
452b38e1 17Version: 2.3.1
18Release: 1
901927d3 19Epoch: 1
d5e56e66
JB
20%if %{with unicap} || %{with xine}
21License: GPL (enforced by used libraries), BSD (opencv itself)
22%else
901927d3 23License: BSD
d5e56e66 24%endif
901927d3 25Group: Libraries
452b38e1 26Source0: http://downloads.sourceforge.net/opencvlibrary/OpenCV-%{version}a.tar.bz2
27# Source0-md5: 82e4b6bfa349777233eea09b075e931e
28Patch0: %{name}-cflags.patch
29Patch1: %{name}-link.patch
30Patch2: %{name}-unicap-c++.patch
31Patch3: %{name}-c.patch
32Patch4: %{name}-gcc.patch
0c2d6b7d 33URL: http://opencv.willowgarage.com/
d5e56e66 34%{?with_pvapi:BuildRequires: AVT_GigE_SDK-devel}
0c2d6b7d
JB
35BuildRequires: OpenEXR-devel
36BuildRequires: cmake >= 2.4
37BuildRequires: doxygen
f8e040cc 38BuildRequires: eigen >= 2
2812da73 39BuildRequires: ffmpeg-devel >= 0.7
0c2d6b7d
JB
40%if %{with gstreamer}
41BuildRequires: gstreamer-devel >= 0.10
42BuildRequires: gstreamer-plugins-base-devel >= 0.10
43%endif
901927d3
AM
44BuildRequires: jasper-devel
45BuildRequires: libdc1394-devel
46BuildRequires: libjpeg-devel
47BuildRequires: libpng-devel
48BuildRequires: libraw1394-devel
0c2d6b7d 49BuildRequires: libstdc++-devel
901927d3 50BuildRequires: libtiff-devel
148338c5 51BuildRequires: libtool
d5e56e66
JB
52%if %{with unicap}
53BuildRequires: libucil-devel
54BuildRequires: libunicap-devel
55%endif
0c2d6b7d 56BuildRequires: libv4l-devel
af6d2888 57BuildRequires: pkgconfig
901927d3 58BuildRequires: python-devel
0c2d6b7d 59BuildRequires: python-numpy-devel
901927d3 60BuildRequires: rpm-pythonprov
452b38e1 61BuildRequires: rpmbuild(macros) >= 1.600
1376dffe 62BuildRequires: sed >= 4.0
996927aa 63BuildRequires: swig-python
f8e040cc 64%{?with_tbb:BuildRequires: tbb-devel}
901927d3 65%{?with_xine:BuildRequires: xine-lib-devel}
452b38e1 66BuildRequires: zlib-devel
4afb606b
JB
67%if %{with qt}
68BuildRequires: OpenGL-devel
69BuildRequires: QtCore-devel >= 4
70BuildRequires: QtGui-devel >= 4
71BuildRequires: QtOpenGL-devel >= 4
72BuildRequires: qt4-qmake >= 4
73%else
74BuildRequires: gtk+2-devel >= 2.0
75%endif
76# ipp (libippi): http://software.intel.com/en-us/articles/intel-ipp/ (proprietary)
901927d3
AM
77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79%description
80OpenCV (Open Source Computer Vision) is a library of programming
81functions mainly aimed at real time computer vision.
82
0c2d6b7d
JB
83Example applications of the OpenCV library are:
84- Human-Computer Interaction (HCI)
85- Object Identification, Segmentation and Recognition
86- Face Recognition
87- Gesture Recognition
88- Motion Tracking
89- Ego Motion, Motion Understanding
90- Structure From Motion (SFM)
91- Stereo and Multi-Camera Calibration and Depth Computation
92- Mobile Robotics.
93
94%description -l pl.UTF-8
95OpenCV (Open Source Computer Vision) to biblioteka funkcji
96przeznaczonych głównie do grafiki komputerowej w czasie rzeczywistym.
97
98Przykładowe zastosowania biblioteki OpenCV to
99- interakcje człowiek-komputer (HCI)
100- identyfikacja, segmentacja i rozpoznawanie obiektów
101- rozpoznawanie twarzy
102- rozpoznawanie gestów
103- śledzenie ruchu
104- rozumienie ruchu
105- SFM (Structure From Motion)
106- kalibracja dwu- i wielokamerowa, obliczanie głębi
107- robotyka ruchu.
901927d3
AM
108
109%package devel
0c2d6b7d
JB
110Summary: Header files for OpenCV library
111Summary(pl.UTF-8): Pliki nagłówkowe biblioteki OpenCV
901927d3
AM
112Group: Development/Libraries
113Requires: %{name} = %{epoch}:%{version}-%{release}
0c2d6b7d 114Obsoletes: opencv-static
901927d3
AM
115
116%description devel
0c2d6b7d 117Header files for OpenCV library.
901927d3 118
0c2d6b7d
JB
119%description devel -l pl.UTF-8
120Pliki nagłówkowe biblioteki OpenCV.
901927d3
AM
121
122%package -n python-opencv
123Summary: OpenCV Python bindings
0c2d6b7d
JB
124Summary(pl.UTF-8): Wiązania Pythona do OpenCV
125Group: Libraries/Python
cd1f0136 126Requires: %{name} = %{epoch}:%{version}-%{release}
0c2d6b7d 127%pyrequires_eq python-libs
901927d3
AM
128
129%description -n python-opencv
130OpenCV Python bindings.
131
0c2d6b7d
JB
132%description -n python-opencv -l pl.UTF-8
133Wiązania Pythona do OpenCV.
134
901927d3 135%prep
95daeb66 136%setup -q -n OpenCV-%{version}
54551f29 137
da67222a 138%undos CMakeLists.txt
1376dffe 139%undos modules/gpu/CMakeLists.txt
54551f29 140
1376dffe 141%patch0 -p1
142%patch1 -p1
29d82ddf 143%patch2 -p1
f8e040cc 144%patch3 -p1
75b912e9 145%patch4 -p1
148338c5 146
901927d3 147%build
95daeb66
AM
148install -d build
149cd build
0c2d6b7d 150%cmake .. \
8b9f61f7
JB
151 -DCMAKE_C_FLAGS_RELEASE="-DNDEBUG" \
152 -DCMAKE_CXX_FLAGS_RELEASE="-DNDEBUG" \
153%ifarch pentium4 %{x8664}
154 -DENABLE_SSE=ON \
95daeb66 155 -DENABLE_SSE2=ON \
8b9f61f7
JB
156%else
157 -DENABLE_SSE=OFF \
158 -DENABLE_SSE2=OFF \
95daeb66
AM
159%endif
160 -DBUILD_NEW_PYTHON_SUPPORT=ON \
8b9f61f7 161 -DUSE_O3=OFF \
d5e56e66
JB
162 %{!?with_gstreamer:-DWITH_GSTREAMER=OFF} \
163 %{!?with_pvapi:-DWITH_PVAPI=OFF} \
4afb606b 164 %{?with_qt:-DWITH_QT=ON -DWITH_QT_OPENGL=ON -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4} \
f8e040cc 165 %{?with_tbb:-DWITH_TBB=ON} \
d5e56e66 166 %{?with_unicap:-DWITH_UNICAP=ON} \
ed358224 167 %{!?with_v4l:-DWITH_V4L=OFF} \
d5e56e66 168 %{?with_xine:-DWITH_XINE=ON}
54551f29 169
8b9f61f7 170%{__make}
901927d3
AM
171
172%install
173rm -rf $RPM_BUILD_ROOT
174
95daeb66 175%{__make} -C build install \
901927d3
AM
176 DESTDIR=$RPM_BUILD_ROOT
177
4bd2eae7
AM
178install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
179install build/unix-install/opencv.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
180
901927d3
AM
181%clean
182rm -rf $RPM_BUILD_ROOT
183
184%post -p /sbin/ldconfig
185%postun -p /sbin/ldconfig
186
187%files
188%defattr(644,root,root,755)
0c2d6b7d
JB
189%attr(755,root,root) %{_bindir}/opencv_*
190%attr(755,root,root) %{_libdir}/libopencv_*.so.*.*.*
452b38e1 191%attr(755,root,root) %ghost %{_libdir}/libopencv_*.so.2.3
192%dir %{_datadir}/OpenCV
193%doc %{_datadir}/OpenCV/doc
194%{_datadir}/OpenCV/haarcascades
195%{_datadir}/OpenCV/lbpcascades
901927d3
AM
196
197%files devel
198%defattr(644,root,root,755)
0c2d6b7d 199%attr(755,root,root) %{_libdir}/libopencv_*.so
901927d3 200%{_includedir}/opencv
509c07dc 201%{_includedir}/opencv2
452b38e1 202%{_datadir}/OpenCV/OpenCVConfig*.cmake
0c2d6b7d 203%{_pkgconfigdir}/opencv.pc
901927d3
AM
204
205%files -n python-opencv
206%defattr(644,root,root,755)
452b38e1 207%attr(755,root,root) %{py_sitedir}/cv2.so
208%{py_sitedir}/cv.py
This page took 0.088544 seconds and 4 git commands to generate.