]> git.pld-linux.org Git - packages/openchange.git/commitdiff
- partial fix for building with samba 4.15
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 16 Nov 2021 21:07:50 +0000 (22:07 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 16 Nov 2021 21:07:50 +0000 (22:07 +0100)
openchange.spec
samba-4.15.patch [new file with mode: 0644]

index bfd43cff3c96e2fbc97b27bd8ed12eb7da599fce..8c3b08359d999ca0cf79dbc41e11cd8f1cc1022d 100644 (file)
@@ -30,6 +30,7 @@ Patch8:               %{name}-libical.patch
 Patch9:                samba-4.11.patch
 Patch10:       samba-4.12.patch
 Patch11:       %{name}-nanomsg.patch
+Patch12:       samba-4.15.patch
 URL:           https://github.com/openchange
 BuildRequires: QtCore-devel >= 4.3.0
 BuildRequires: QtGui-devel >= 4.3.0
@@ -226,6 +227,7 @@ Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange.
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
+%patch12 -p1
 
 # no switch for verbose mode, enable manually :/
 %{__sed} -i -e 's/^    @\(\$(\(PIDL\|CC\|CXX\|MOC\)\)/ \1/' Makefile
diff --git a/samba-4.15.patch b/samba-4.15.patch
new file mode 100644 (file)
index 0000000..219ff14
--- /dev/null
@@ -0,0 +1,41 @@
+--- openchange-openchange-2.3-VULCAN/libmapi/IProfAdmin.c~     2015-05-16 17:22:04.000000000 +0200
++++ openchange-openchange-2.3-VULCAN/libmapi/IProfAdmin.c      2021-11-16 21:59:10.069774286 +0100
+@@ -753,7 +753,7 @@
+ _PUBLIC_ enum MAPISTATUS LoadProfile(struct mapi_context *mapi_ctx, 
+                                    struct mapi_profile *profile)
+ {
+-      enum credentials_use_kerberos use_krb = CRED_AUTO_USE_KERBEROS;
++      enum credentials_use_kerberos use_krb = CRED_USE_KERBEROS_DESIRED;
+       /* Sanity checks */
+       OPENCHANGE_RETVAL_IF(!mapi_ctx, MAPI_E_NOT_INITIALIZED, NULL);
+@@ -777,9 +777,9 @@
+        * another API in the profile */
+       if (profile->kerberos) {
+               if (!strncmp(profile->kerberos, "yes", 3)) {
+-                      use_krb = CRED_MUST_USE_KERBEROS;
++                      use_krb = CRED_USE_KERBEROS_REQUIRED;
+               } else {
+-                      use_krb = CRED_DONT_USE_KERBEROS;
++                      use_krb = CRED_USE_KERBEROS_DISABLED;
+               }
+       }
+       /* additionally, don't set the username in the ccache if kerberos
+@@ -787,14 +787,14 @@
+        * credentials.  cli_credentials_guess probably gets the right
+        * thing anyway in the situations where kerberos is in use */
+       if (profile->username && *(profile->username)
+-          && use_krb != CRED_MUST_USE_KERBEROS) {
++          && use_krb != CRED_USE_KERBEROS_REQUIRED) {
+               cli_credentials_set_username(profile->credentials, profile->username, CRED_SPECIFIED);
+       }
+       if (profile->password && *(profile->password)) {
+               cli_credentials_set_password(profile->credentials, profile->password, CRED_SPECIFIED);
+       }
+-      if (use_krb != CRED_AUTO_USE_KERBEROS) {
+-              cli_credentials_set_kerberos_state(profile->credentials, use_krb);
++      if (use_krb != CRED_USE_KERBEROS_DESIRED) {
++              cli_credentials_set_kerberos_state(profile->credentials, use_krb, CRED_SPECIFIED);
+       }
+       return MAPI_E_SUCCESS;
This page took 0.038307 seconds and 4 git commands to generate.