]> git.pld-linux.org Git - packages/openchange.git/commitdiff
- rediffed
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 26 Mar 2021 18:18:54 +0000 (19:18 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 26 Mar 2021 18:18:54 +0000 (19:18 +0100)
openchange-covscan.patch
openchange-libical.patch
openchange-link.patch
openchange-samba-4.10-macros.patch
samba-4.4.patch

index 69b289030bd82c6ab12bf1bde0669c5bb5c42187..ec8be44350289055a720967b3f470bde8f96b8b9 100644 (file)
@@ -38,14 +38,6 @@ diff -up openchange-openchange-2.3-VULCAN/libexchange2ical/exchange2ical_utils.c
  
        tt.year   = tm->tm_year+1900;
        tt.month  = tm->tm_mon+1;
-@@ -267,6 +267,7 @@ struct icaltimetype get_icaldate_from_tm
-       tt.hour   = 0;
-       tt.minute = 0;
-       tt.second = 0;
-+      tt.zone   = NULL;
-       tt.is_date     = 1;
-       tt.is_daylight = 0;
 @@ -292,7 +293,7 @@ struct tm *get_tm_from_FILETIME(const st
  
  struct icaltimetype get_icaltime_from_FILETIME(const struct FILETIME *ft)
index 1dfbbf9eef041530e4e4c69d22cd77ab32cb187a..f73b1132c81c8dfa6c0e1e256f692a666b6b27c6 100644 (file)
@@ -9,9 +9,9 @@
                                if (exchange2ical->apptEndWhole){
                                        dttime = get_icaltime_from_FILETIME_UTC(exchange2ical->apptStartWhole);
                                        icaltime.hour   = dttime.hour;
---- openchange-openchange-2.3-VULCAN/libexchange2ical/exchange2ical_utils.c.orig       2019-07-03 05:47:28.580770627 +0200
-+++ openchange-openchange-2.3-VULCAN/libexchange2ical/exchange2ical_utils.c    2019-07-03 17:25:46.117125535 +0200
-@@ -241,10 +241,9 @@
+--- openchange-openchange-2.3-VULCAN/libexchange2ical/exchange2ical_utils.c.orig       2021-03-26 19:02:03.857346951 +0100
++++ openchange-openchange-2.3-VULCAN/libexchange2ical/exchange2ical_utils.c    2021-03-26 19:14:41.946490441 +0100
+@@ -241,10 +241,9 @@ struct icaltimetype get_icaltimetype_fro
        tt.minute = tm->tm_min;
        tt.second = tm->tm_sec;
  
@@ -23,7 +23,7 @@
  
        return tt;
  }
-@@ -254,7 +253,7 @@
+@@ -254,7 +253,7 @@ struct icaltimetype get_icaltimetype_fro
        struct icaltimetype tt;
        
        tt = get_icaltimetype_from_tm(tm);
        
        return tt;
  }
-@@ -269,12 +268,10 @@
-       tt.hour   = 0;
+@@ -270,10 +269,9 @@ struct icaltimetype get_icaldate_from_tm
        tt.minute = 0;
        tt.second = 0;
--      tt.zone   = NULL;
  
 -      tt.is_utc      = 1;
        tt.is_date     = 1;
@@ -46,7 +44,7 @@
  
        return tt;
  }
-@@ -314,7 +311,6 @@
+@@ -313,7 +311,6 @@ struct icaltimetype get_icaltime_from_FI
        tt.minute = tm->tm_min;                                                
        tt.second = tm->tm_sec;
        tt.is_date = 0;
@@ -54,7 +52,7 @@
        tt.is_daylight = 0;
        tt.zone = NULL;
  
-@@ -340,9 +336,8 @@
+@@ -339,9 +336,8 @@ struct icaltimetype get_icaltime_from_FI
        tt.minute = tm->tm_min;                                                
        tt.second = tm->tm_sec;
        tt.is_date = 0;
@@ -65,7 +63,7 @@
  
        return tt;
  }
-@@ -372,9 +367,8 @@
+@@ -371,9 +367,8 @@ struct icaltimetype get_icaldate_from_FI
        tt.minute = 0;                                                
        tt.second = 0;
        tt.is_date = 1;
@@ -76,7 +74,7 @@
  
        return tt;
  }
-@@ -391,10 +385,9 @@
+@@ -390,10 +385,9 @@ struct icaltimetype get_icaldate_from_Gl
        tt.minute = 0;
        tt.second = 0;
  
index e6448549d3b2f8f1591c3a35b8c8fa5ecbfc2ec2..8eb00b664bfe02924a13c516ca3fb3d3a37780bf 100644 (file)
@@ -9,11 +9,11 @@
  LDFLAGS+=@LDFLAGS@
  
  THREAD_LIBS=@THREAD_LIBS@
---- openchange-openchange-2.3-VULCAN/Makefile.orig     2015-05-23 19:28:30.857562616 +0200
-+++ openchange-openchange-2.3-VULCAN/Makefile  2015-05-23 21:04:14.893988228 +0200
+--- openchange-openchange-2.3-VULCAN/Makefile.orig     2015-05-16 17:22:04.000000000 +0200
++++ openchange-openchange-2.3-VULCAN/Makefile  2021-03-26 18:48:45.049437480 +0100
 @@ -368,6 +368,9 @@
        @echo "Linking $@"
-       $(CXX) $(DSOOPT) $(CXX11FLAGS) $(CXXFLAGS) $(LDFLAGS) -Wl,-soname,libmapipp.$(SHLIBEXT).$(LIBMAPIPP_SO_VERSION) -o $@ $^ $(LIBS) 
+       @$(CXX) $(DSOOPT) $(CXX11FLAGS) $(CXXFLAGS) $(LDFLAGS) -Wl,-soname,libmapipp.$(SHLIBEXT).$(LIBMAPIPP_SO_VERSION) -o $@ $^ $(LIBS) 
  
 +libmapipp.$(SHLIBEXT).$(LIBMAPI_SO_VERSION): libmapipp.$(SHLIBEXT).$(PACKAGE_VERSION)
 +      ln -fs $< $@
@@ -31,7 +31,7 @@
        @echo "Linking $@"
        @$(CC) -o $@ $(DSOOPT) $(LDFLAGS) -Wl,-soname,libmapiserver.$(SHLIBEXT).$(LIBMAPIPROXY_SO_VERSION) $^ $(LIBS)
  
-@@ -1885,9 +1888,11 @@
+@@ -1887,9 +1889,11 @@
  
  libqtmapi.$(SHLIBEXT).$(PACKAGE_VERSION):     \
        qt/lib/foldermodel.o                    \
index 0e8e2b915673c1413edbadadd6076e665e6feaa0..103e43f8048ac182d2f10e2f9048f00719ce37d2 100644 (file)
@@ -37,12 +37,11 @@ diff -up openchange-openchange-2.3-VULCAN/libmapiadmin/mapiadmin_user.c.samba-4.
        s.in.user_handle = &mapiadmin_ctx->user_ctx->user_handle;
        s.in.info = &u;
        s.in.level = 21;
-diff -up openchange-openchange-2.3-VULCAN/libmapi/libmapi_private.h.samba-4.10-macros openchange-openchange-2.3-VULCAN/libmapi/libmapi_private.h
---- openchange-openchange-2.3-VULCAN/libmapi/libmapi_private.h.samba-4.10-macros       2019-02-14 15:19:53.313769411 +0100
-+++ openchange-openchange-2.3-VULCAN/libmapi/libmapi_private.h 2019-02-14 15:19:53.331769410 +0100
-@@ -141,6 +141,11 @@ const char                *libmapi_iface_best_ip(struc
- bool                  libmapi_iface_is_local(struct interface *, const char *);
- bool                  libmapi_iface_same_net(const char *, const char *, const char *);
+--- openchange-openchange-2.3-VULCAN/libmapi/libmapi_private.h.orig    2021-03-26 18:59:00.581217605 +0100
++++ openchange-openchange-2.3-VULCAN/libmapi/libmapi_private.h 2021-03-26 19:01:10.224577853 +0100
+@@ -141,6 +141,11 @@ const char                *iface_best_ip(struct interf
+ bool                  iface_is_local(struct interface *, const char *);
+ bool                  iface_same_net(const char *, const char *, const char *);
  
 +#define OC_ZERO_STRUCT(x) memset((char *)&(x), 0, sizeof(x))
 +#define OC_ZERO_STRUCTP(x) do { if ((x) != NULL) memset((char *)(x), 0, sizeof(*(x))); } while(0)
index 20b9061c2b8eaaab86eebe1d2ba37cfb22a77a80..efdc8a1a4f78b0b7fb30b7381e83855c66ce7d62 100644 (file)
@@ -1,6 +1,5 @@
-diff -up openchange-openchange-2.3-VULCAN/configure.ac.samba44 openchange-openchange-2.3-VULCAN/configure.ac
---- openchange-openchange-2.3-VULCAN/configure.ac.samba44      2016-02-09 11:51:31.089982153 +0100
-+++ openchange-openchange-2.3-VULCAN/configure.ac      2016-02-09 12:04:55.985948047 +0100
+--- openchange-openchange-2.3-VULCAN/configure.ac.orig 2021-03-26 18:49:09.587370999 +0100
++++ openchange-openchange-2.3-VULCAN/configure.ac      2021-03-26 18:50:40.332056045 +0100
 @@ -657,10 +657,11 @@ AC_CHECK_LIB([popt], [poptFreeContext],
               enable_libpopt="no"
               ])
@@ -16,7 +15,7 @@ diff -up openchange-openchange-2.3-VULCAN/configure.ac.samba44 openchange-opench
        if test x"$enable_libocpf" = x"yes"; then
 @@ -692,7 +693,7 @@ OC_RULE_ADD(mapipropsdump, TOOLS)
  OC_RULE_ADD(exchange2ical, TOOLS)
#OC_RULE_ADD(rpcextract, TOOLS)
+ OC_RULE_ADD(rpcextract, TOOLS)
  OC_RULE_ADD(openchangepfadmin, TOOLS)
 -OC_RULE_ADD(mapitest, TOOLS)
 +#OC_RULE_ADD(mapitest, TOOLS)
This page took 0.129803 seconds and 4 git commands to generate.