]> git.pld-linux.org Git - packages/openchange.git/blobdiff - openchange.spec
- release 17 (rebuild with samba 4.6.3)
[packages/openchange.git] / openchange.spec
index 63abfc11bbd3689ff3865a2389858eb95a8af891..98c8cf180b8ecdfdb7b3bcd0fc61c024004355d9 100644 (file)
@@ -3,13 +3,16 @@
 #
 # Conditional build:
 %bcond_without apidocs         # do not build and package API docs
+%bcond_with    mapiproxy       # mapiproxy suite (disabled with Samba 4.4+)
+%bcond_with    mapitest        # mapitest utility (disabled with Samba 4.4+)
+%bcond_with    python          # build python package (requires disabled mapiproxy)
 
 %define        cname   VULCAN
 Summary:       OpenChange - portable implementation of MS Exchange Server and Exchange protocols
 Summary(pl.UTF-8):     OpenChange - przenośna implementacja serwera oraz protokołów MS Exchange
 Name:          openchange
 Version:       2.3
-Release:       11
+Release:       17
 License:       GPL v3+
 Group:         Libraries
 Source0:       https://github.com/openchange/openchange/archive/%{name}-%{version}-%{cname}.tar.gz
@@ -38,8 +41,10 @@ BuildRequires:       nanomsg-devel >= 0.5
 BuildRequires: perl-base
 BuildRequires: pkgconfig >= 1:0.20
 BuildRequires: popt-devel
+%if %{with python}
 BuildRequires: python-devel >= 1:2.7
 BuildRequires: python-samba >= 4.2.2
+%endif
 BuildRequires: rpmbuild(macros) >= 1.219
 # with DCERCP multiplex and pending call support (upstream 4.1.18+ or 4.2.2+)
 BuildRequires: samba-devel >= 4.2.2
@@ -50,7 +55,7 @@ BuildRequires:        talloc-devel
 BuildRequires: tdb-devel
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      python-openchange = %{version}-%{release}
+%{?with_python:Requires:       python-openchange = %{version}-%{release}}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -217,7 +222,7 @@ Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange.
 %configure \
        --datadir=%{_datadir}/openchange \
        --enable-openchange-qt4 \
-       --enable-pyopenchange \
+       %{?with_python:--enable-pyopenchange} \
        --with-modulesdir=%{_libdir}/openchange/modules
 %{__make}
 
@@ -247,6 +252,13 @@ cp -a libqtmapi.so.*.* libqtmapi.so $RPM_BUILD_ROOT%{_libdir}
 
 # tests
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{check_fasttransfer,openchange-testsuite,test_asyncnotif}
+%if %{without mapiproxy}
+# requires mapiproxy
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/ocnotify
+%endif
+%if %{without mapitest}
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/mapitest.1
+%endif
 
 /sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir}
 
@@ -273,7 +285,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/exchange2mbox
 %attr(755,root,root) %{_bindir}/mapiprofile
 %attr(755,root,root) %{_bindir}/mapipropsdump
-%attr(755,root,root) %{_bindir}/ocnotify
 %attr(755,root,root) %{_bindir}/openchangeclient
 %attr(755,root,root) %{_bindir}/openchangemapidump
 %attr(755,root,root) %{_bindir}/openchangepfadmin
@@ -285,9 +296,43 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/exchange2ical.1*
 %{_mandir}/man1/exchange2mbox.1*
 %{_mandir}/man1/mapiprofile.1*
-%{_mandir}/man1/mapitest.1*
 %{_mandir}/man1/openchangeclient.1*
 %{_mandir}/man1/openchangepfadmin.1*
+%if %{with mapiproxy}
+%attr(755,root,root) %{_bindir}/ocnotify
+%attr(755,root,root) %{_sbindir}/openchange_group
+%attr(755,root,root) %{_sbindir}/openchange_migrate
+%attr(755,root,root) %{_sbindir}/openchange_neworganization
+%attr(755,root,root) %{_sbindir}/openchange_newuser
+%attr(755,root,root) %{_sbindir}/openchange_provision
+# XXX: dir specified by dcerpc_server.pc file, should belong to samba or samba-libs
+%dir %{_libdir}/samba/dcerpc_server
+%attr(755,root,root) %{_libdir}/samba/dcerpc_server/dcesrv_asyncemsmdb.so
+%attr(755,root,root) %{_libdir}/samba/dcerpc_server/dcesrv_mapiproxy.so
+%dir %{_libdir}/openchange
+%dir %{_libdir}/openchange/modules
+%dir %{_libdir}/openchange/modules/dcerpc_mapiproxy
+%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_cache.so
+%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_downgrade.so
+%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_dummy.so
+%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_pack.so
+%dir %{_libdir}/openchange/modules/dcerpc_mapiproxy_server
+%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_ds_rfr.so
+%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_emsmdb.so
+%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_nsp.so
+%{_datadir}/openchange/setup/mapistore
+%{_datadir}/openchange/setup/openchangedb
+%dir %{_datadir}/samba/setup/AD
+%{_datadir}/samba/setup/AD/oc_provision_*.ldif
+%{_datadir}/samba/setup/AD/provision_schema_basedn_modify.ldif
+%{_datadir}/samba/setup/AD/update_now.ldif
+%{_datadir}/samba/setup/AD/prefixMap.txt
+%endif
+%if %{with mapitest}
+%attr(755,root,root) %{_bindir}/mapitest
+%{_datadir}/openchange/mapitest
+%{_mandir}/man1/mapitest.1*
+%endif
 
 %files libs
 %defattr(644,root,root,755)
@@ -297,6 +342,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libmapiadmin.so.0
 %attr(755,root,root) %{_libdir}/libocpf.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libocpf.so.0
+%if %{with mapiproxy}
+%attr(755,root,root) %{_libdir}/libmapiproxy.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libmapiproxy.so.0
+%attr(755,root,root) %{_libdir}/libmapiserver.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libmapiserver.so.0
+%attr(755,root,root) %{_libdir}/libmapistore.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libmapistore.so.0
+%endif
 
 %files devel
 %defattr(644,root,root,755)
@@ -310,6 +363,17 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/libmapi.pc
 %{_pkgconfigdir}/libmapiadmin.pc
 %{_pkgconfigdir}/libocpf.pc
+%if %{with mapiproxy}
+%attr(755,root,root) %{_libdir}/libmapiproxy.so
+%attr(755,root,root) %{_libdir}/libmapiserver.so
+%attr(755,root,root) %{_libdir}/libmapistore.so
+%{_includedir}/mapistore
+%{_includedir}/libmapiproxy.h
+%{_includedir}/libmapiserver.h
+%{_pkgconfigdir}/libmapiproxy.pc
+%{_pkgconfigdir}/libmapiserver.pc
+%{_pkgconfigdir}/libmapistore.pc
+%endif
 
 %files c++
 %defattr(644,root,root,755)
@@ -338,11 +402,20 @@ rm -rf $RPM_BUILD_ROOT
 %doc apidocs/html/*
 %endif
 
+%if %{with python}
 %files -n python-openchange
 %defattr(644,root,root,755)
 %dir %{py_sitedir}/openchange
 %attr(755,root,root) %{py_sitedir}/openchange/mapi.so
 %attr(755,root,root) %{py_sitedir}/openchange/mapistore.so
+%if %{with mapiproxy}
+%{py_sitedir}/openchange/*.py[co]
+%{py_sitedir}/openchange/migration
+%{py_sitedir}/openchange/tests
+%{py_sitedir}/openchange/utils
+%{py_sitedir}/openchange/web
+%endif
+%endif
 
 %files -n nagios-plugin-openchange
 %defattr(644,root,root,755)
This page took 0.065513 seconds and 4 git commands to generate.