]> git.pld-linux.org Git - packages/openchange.git/blobdiff - openchange.spec
- BR: python-samba
[packages/openchange.git] / openchange.spec
index 4caf83cae8997abe2368752f9687644f8ad7a47e..3166cc4ee02aec770e9ca7c3a2d4fc114c70a7b0 100644 (file)
@@ -33,10 +33,11 @@ BuildRequires:      perl-base
 BuildRequires: pkgconfig >= 1:0.20
 BuildRequires: popt-devel
 BuildRequires: python-devel >= 1:2.7
+BuildRequires: python-samba >= 4.2.2
 BuildRequires: rpmbuild(macros) >= 1.219
-# with DCERCP multiplex and pending call support (upstream 4.1.18+ or 4.2.>1)
-BuildRequires: samba-devel >= 4.2.1
-BuildRequires: samba-pidl >= 4.2.1
+# with DCERCP multiplex and pending call support (upstream 4.1.18+ or 4.2.2+)
+BuildRequires: samba-devel >= 4.2.2
+BuildRequires: samba-pidl >= 4.2.2
 BuildRequires: sed >= 4.0
 BuildRequires: subunit-devel
 BuildRequires: talloc-devel
@@ -46,9 +47,6 @@ Requires:     %{name}-libs = %{version}-%{release}
 Requires:      python-openchange = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# libraries use symbols also from samba libs pulled indirectly, from outside %{_libdir}
-#define                filterout_ld    -Wl,--no-copy-dt-needed-entries
-
 %description
 OpenChange is a portable Open Source implementation of Microsoft
 Exchange server and Exchange protocols. It provides a complete
@@ -90,6 +88,11 @@ Summary:     Header files for OpenChange libraries
 Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek OpenChange
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
+Requires:      ldb-devel
+Requires:      samba-devel >= 4.2.2
+Requires:      talloc-devel
+Requires:      tevent-devel
+Requires:      zlib-devel
 
 %description devel
 Header files for OpenChange libraries.
@@ -101,6 +104,7 @@ Pliki nagłówkowe bibliotek OpenChange.
 Summary:       C++ interface to OpenChange MAPI library
 Summary(pl.UTF-8):     Interfejs C++ do biblioteki OpenChange MAPI
 Group:         Libraries
+Requires:      %{name}-libs = %{version}-%{release}
 
 %description c++
 C++ interface to OpenChange MAPI library.
@@ -113,6 +117,8 @@ Summary:    Header files of C++ interface to OpenChange MAPI library
 Summary(pl.UTF-8):     Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI
 Group:         Development/Libraries
 Requires:      %{name}-c++ = %{version}-%{release}
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      libstdc++-devel
 
 %description c++-devel
 Header files of C++ interface to OpenChange MAPI library.
@@ -124,6 +130,9 @@ Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI.
 Summary:       Qt interface to OpenChange MAPI library
 Summary(pl.UTF-8):     Interfejs Qt do biblioteki OpenChange MAPI
 Group:         Libraries
+Requires:      %{name}-c++ = %{version}-%{release}
+Requires:      QtCore >= 4.3.0
+Requires:      QtGui >= 4.3.0
 
 %description qt
 Qt interface to OpenChange MAPI library.
@@ -136,6 +145,7 @@ Summary:    Header files of Qt interface to OpenChange MAPI library
 Summary(pl.UTF-8):     Pliki nagłówkowe interfejsu Qt do biblioteki OpenChange MAPI
 Group:         Development/Libraries
 Requires:      %{name}-qt = %{version}-%{release}
+Requires:      QtGui-devel >= 4.3.0
 
 %description qt-devel
 Header files of Qt interface to OpenChange MAPI library.
@@ -234,8 +244,14 @@ cp -a libqtmapi.so.*.* libqtmapi.so $RPM_BUILD_ROOT%{_libdir}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
+
+%post  c++ -p /sbin/ldconfig
+%postun        c++ -p /sbin/ldconfig
+
+%post  qt -p /sbin/ldconfig
+%postun        qt -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
@@ -295,8 +311,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libmapi.so.0
 %attr(755,root,root) %{_libdir}/libmapiadmin.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libmapiadmin.so.0
-%attr(755,root,root) %{_libdir}/libmapipp.so.*.*
-%attr(755,root,root) %ghost %{_libdir}/libmapipp.so.0
 %attr(755,root,root) %{_libdir}/libmapiproxy.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libmapiproxy.so.0
 %attr(755,root,root) %{_libdir}/libmapiserver.so.*.*
@@ -310,27 +324,35 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libmapi.so
 %attr(755,root,root) %{_libdir}/libmapiadmin.so
-%attr(755,root,root) %{_libdir}/libmapipp.so
 %attr(755,root,root) %{_libdir}/libmapiproxy.so
 %attr(755,root,root) %{_libdir}/libmapiserver.so
 %attr(755,root,root) %{_libdir}/libmapistore.so
 %attr(755,root,root) %{_libdir}/libocpf.so
 %{_includedir}/gen_ndr
 %{_includedir}/libmapi
-%{_includedir}/libmapi++
 %{_includedir}/libmapiadmin
 %{_includedir}/libocpf
 %{_includedir}/mapistore
 %{_includedir}/libmapiproxy.h
 %{_includedir}/libmapiserver.h
 %{_pkgconfigdir}/libmapi.pc
-%{_pkgconfigdir}/libmapi++.pc
 %{_pkgconfigdir}/libmapiadmin.pc
 %{_pkgconfigdir}/libmapiproxy.pc
 %{_pkgconfigdir}/libmapiserver.pc
 %{_pkgconfigdir}/libmapistore.pc
 %{_pkgconfigdir}/libocpf.pc
 
+%files c++
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libmapipp.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libmapipp.so.0
+
+%files c++-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libmapipp.so
+%{_includedir}/libmapi++
+%{_pkgconfigdir}/libmapi++.pc
+
 %files qt
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libqtmapi.so.*.*
This page took 0.038837 seconds and 4 git commands to generate.