]> git.pld-linux.org Git - packages/openchange.git/blob - openchange.spec
- rel 11
[packages/openchange.git] / openchange.spec
1 # TODO
2 # - nagios plugin (see it's files section for details)
3 #
4 # Conditional build:
5 %bcond_without  apidocs         # do not build and package API docs
6
7 %define cname   VULCAN
8 Summary:        OpenChange - portable implementation of MS Exchange Server and Exchange protocols
9 Summary(pl.UTF-8):      OpenChange - przenośna implementacja serwera oraz protokołów MS Exchange
10 Name:           openchange
11 Version:        2.3
12 Release:        11
13 License:        GPL v3+
14 Group:          Libraries
15 Source0:        https://github.com/openchange/openchange/archive/%{name}-%{version}-%{cname}.tar.gz
16 # Source0-md5:  96c13c78c2bcbd7040f7848746284b9f
17 Patch0:         disable-mapiproxy.patch
18 Patch1:         %{name}-link.patch
19 Patch2:         flex2.6.patch
20 Patch3:         samba-4.2.patch
21 Patch4:         fix-connection-args.patch
22 Patch5:         samba-4.4.patch
23 URL:            http://www.openchange.org/
24 BuildRequires:  QtCore-devel >= 4.3.0
25 BuildRequires:  QtGui-devel >= 4.3.0
26 BuildRequires:  autoconf >= 2.57
27 BuildRequires:  automake
28 BuildRequires:  check-devel
29 BuildRequires:  doxygen
30 BuildRequires:  ldb-devel
31 BuildRequires:  libical-devel >= 0.46
32 BuildRequires:  libmagic-devel
33 BuildRequires:  libmemcached-devel >= 1.0.18
34 BuildRequires:  libpcap-devel
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  mysql-devel
37 BuildRequires:  nanomsg-devel >= 0.5
38 BuildRequires:  perl-base
39 BuildRequires:  pkgconfig >= 1:0.20
40 BuildRequires:  popt-devel
41 BuildRequires:  python-devel >= 1:2.7
42 BuildRequires:  python-samba >= 4.2.2
43 BuildRequires:  rpmbuild(macros) >= 1.219
44 # with DCERCP multiplex and pending call support (upstream 4.1.18+ or 4.2.2+)
45 BuildRequires:  samba-devel >= 4.2.2
46 BuildRequires:  samba-pidl >= 4.2.2
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  subunit-devel
49 BuildRequires:  talloc-devel
50 BuildRequires:  tdb-devel
51 BuildRequires:  zlib-devel
52 Requires:       %{name}-libs = %{version}-%{release}
53 Requires:       python-openchange = %{version}-%{release}
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 OpenChange is a portable Open Source implementation of Microsoft
58 Exchange server and Exchange protocols. It provides a complete
59 solution to interoperate with Microsoft Outlook clients or Microsoft
60 Exchange servers.
61
62 OpenChange client-side library is used in existing messaging clients
63 and is the solution in new projects to communicate natively with
64 Microsoft Exchange and Exchange-compatible servers. OpenChange server
65 is a transparent Microsoft Exchange server replacement using native
66 Exchange protocols and does not require any plugin installation in
67 Outlook.
68
69 %description -l pl.UTF-8
70 OpenChange to przenośna, mająca otwarte źródła implementacja serwera
71 oraz protokołów Microsoft Exchange. Dostarcza kompletne rozwiązanie
72 pozwalające współpracować z klientami Microsoft Outlook oraz serwerami
73 Microsoft Exchange.
74
75 Biblioteka kliencka OpenChange jest używana przez istniejących
76 klientów pocztowych i pozwalają na natywną komunikację z serwerami
77 Microsoft Exchange oraz zgodnymi. Serwer OpenChange to przezroczysty
78 zamiennik serwera Microsoft Exchange wykorzystujący natywne protokoły
79 Exchange, nie wymagający instalowania żadnych wtyczek w Outlooku.
80
81 %package libs
82 Summary:        OpenChange client libraries
83 Summary(pl.UTF-8):      Biblioteki klienckie OpenChange
84 Group:          Libraries
85
86 %description libs
87 OpenChange client libraries.
88
89 %description libs -l pl.UTF-8
90 Biblioteki klienckie OpenChange.
91
92 %package devel
93 Summary:        Header files for OpenChange libraries
94 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek OpenChange
95 Group:          Development/Libraries
96 Requires:       %{name}-libs = %{version}-%{release}
97 Requires:       ldb-devel
98 Requires:       samba-devel >= 4.2.2
99 Requires:       talloc-devel
100 Requires:       tevent-devel
101 Requires:       zlib-devel
102
103 %description devel
104 Header files for OpenChange libraries.
105
106 %description devel -l pl.UTF-8
107 Pliki nagłówkowe bibliotek OpenChange.
108
109 %package c++
110 Summary:        C++ interface to OpenChange MAPI library
111 Summary(pl.UTF-8):      Interfejs C++ do biblioteki OpenChange MAPI
112 Group:          Libraries
113 Requires:       %{name}-libs = %{version}-%{release}
114
115 %description c++
116 C++ interface to OpenChange MAPI library.
117
118 %description c++ -l pl.UTF-8
119 Interfejs C++ do biblioteki OpenChange MAPI.
120
121 %package c++-devel
122 Summary:        Header files of C++ interface to OpenChange MAPI library
123 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI
124 Group:          Development/Libraries
125 Requires:       %{name}-c++ = %{version}-%{release}
126 Requires:       %{name}-devel = %{version}-%{release}
127 Requires:       libstdc++-devel
128
129 %description c++-devel
130 Header files of C++ interface to OpenChange MAPI library.
131
132 %description c++-devel -l pl.UTF-8
133 Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI.
134
135 %package qt
136 Summary:        Qt interface to OpenChange MAPI library
137 Summary(pl.UTF-8):      Interfejs Qt do biblioteki OpenChange MAPI
138 Group:          Libraries
139 Requires:       %{name}-c++ = %{version}-%{release}
140 Requires:       QtCore >= 4.3.0
141 Requires:       QtGui >= 4.3.0
142
143 %description qt
144 Qt interface to OpenChange MAPI library.
145
146 %description qt -l pl.UTF-8
147 Interfejs Qt do biblioteki OpenChange MAPI.
148
149 %package qt-devel
150 Summary:        Header files of Qt interface to OpenChange MAPI library
151 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu Qt do biblioteki OpenChange MAPI
152 Group:          Development/Libraries
153 Requires:       %{name}-qt = %{version}-%{release}
154 Requires:       QtGui-devel >= 4.3.0
155
156 %description qt-devel
157 Header files of Qt interface to OpenChange MAPI library.
158
159 %description qt-devel -l pl.UTF-8
160 Pliki nagłówkowe interfejsu Qt do biblioteki OpenChange MAPI.
161
162 %package apidocs
163 Summary:        API documentation for OpenChange libraries
164 Summary(pl.UTF-8):      Dokumentacja API bibliotek OpenChange
165 Group:          Documentation
166 %if "%{_rpmversion}" >= "5"
167 BuildArch:      noarch
168 %endif
169
170 %description apidocs
171 API documentation for OpenChange libraries.
172
173 %description apidocs -l pl.UTF-8
174 Dokumentacja API bibliotek OpenChange.
175
176 %package -n python-openchange
177 Summary:        Python interface to OpenChange libraries
178 Summary(pl.UTF-8):      Interfejs Pythona do bibliotek OpenChange
179 Group:          Libraries/Python
180 Requires:       %{name}-libs = %{version}-%{release}
181
182 %description -n python-openchange
183 Python interface to OpenChange libraries.
184
185 %description -n python-openchange -l pl.UTF-8
186 Interfejs Pythona do bibliotek OpenChange.
187
188 %package -n nagios-plugin-openchange
189 Summary:        Nagios plugin to check Exchange/OpenChange services
190 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange
191 Group:          Networking
192 Requires:       %{name} = %{version}-%{release}
193 Requires:       nagios
194
195 %description -n nagios-plugin-openchange
196 Nagios plugin to check Exchange/OpenChange services.
197
198 %description -n nagios-plugin-openchange -l pl.UTF-8
199 Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange.
200
201 %prep
202 %setup -q -n %{name}-%{name}-%{version}-%{cname}
203 %patch0 -p1
204 %patch1 -p1
205 %patch2 -p1
206 %patch3 -p1
207 %patch4 -p1
208 %patch5 -p1
209
210 # no switch for verbose mode, enable manually :/
211 %{__sed} -i -e 's/^     @\(\$(\(PIDL\|CC\|CXX\|MOC\)\)/ \1/' Makefile
212
213 %build
214 %{__aclocal}
215 %{__autoconf}
216 %{__autoheader}
217 %configure \
218         --datadir=%{_datadir}/openchange \
219         --enable-openchange-qt4 \
220         --enable-pyopenchange \
221         --with-modulesdir=%{_libdir}/openchange/modules
222 %{__make}
223
224 %if %{with apidocs}
225 %{__make} doxygen
226 %endif
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230
231 %{__make} install \
232         DESTDIR=$RPM_BUILD_ROOT
233
234 # doxygen generated man pages are messy; use HTML docs and install man1 pages manually
235 %if 0
236 %{__make} installman \
237         DESTDIR=$RPM_BUILD_ROOT
238 %else
239 install -d $RPM_BUILD_ROOT%{_mandir}/man1
240 cp doc/man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
241 %endif
242
243 # missing from make install
244 install -d $RPM_BUILD_ROOT%{_includedir}/libqtmapi
245 cp -p qt/lib/*.h $RPM_BUILD_ROOT%{_includedir}/libqtmapi
246 cp -a libqtmapi.so.*.* libqtmapi.so $RPM_BUILD_ROOT%{_libdir}
247
248 # tests
249 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{check_fasttransfer,openchange-testsuite,test_asyncnotif}
250
251 /sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir}
252
253 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
254 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
255 %py_postclean
256
257 %clean
258 rm -rf $RPM_BUILD_ROOT
259
260 %post   libs -p /sbin/ldconfig
261 %postun libs -p /sbin/ldconfig
262
263 %post   c++ -p /sbin/ldconfig
264 %postun c++ -p /sbin/ldconfig
265
266 %post   qt -p /sbin/ldconfig
267 %postun qt -p /sbin/ldconfig
268
269 %files
270 %defattr(644,root,root,755)
271 %doc CHANGES.md IDL_LICENSE.txt README.md README.smbconf.md doc/howto.txt
272 %attr(755,root,root) %{_bindir}/exchange2ical
273 %attr(755,root,root) %{_bindir}/exchange2mbox
274 %attr(755,root,root) %{_bindir}/mapiprofile
275 %attr(755,root,root) %{_bindir}/mapipropsdump
276 %attr(755,root,root) %{_bindir}/ocnotify
277 %attr(755,root,root) %{_bindir}/openchangeclient
278 %attr(755,root,root) %{_bindir}/openchangemapidump
279 %attr(755,root,root) %{_bindir}/openchangepfadmin
280 %attr(755,root,root) %{_bindir}/rpcextract
281 %attr(755,root,root) %{_bindir}/schemaIDGUID
282 %dir %{_datadir}/openchange
283 %dir %{_datadir}/openchange/setup
284 %{_datadir}/openchange/setup/profiles
285 %{_mandir}/man1/exchange2ical.1*
286 %{_mandir}/man1/exchange2mbox.1*
287 %{_mandir}/man1/mapiprofile.1*
288 %{_mandir}/man1/mapitest.1*
289 %{_mandir}/man1/openchangeclient.1*
290 %{_mandir}/man1/openchangepfadmin.1*
291
292 %files libs
293 %defattr(644,root,root,755)
294 %attr(755,root,root) %{_libdir}/libmapi.so.*.*
295 %attr(755,root,root) %ghost %{_libdir}/libmapi.so.0
296 %attr(755,root,root) %{_libdir}/libmapiadmin.so.*.*
297 %attr(755,root,root) %ghost %{_libdir}/libmapiadmin.so.0
298 %attr(755,root,root) %{_libdir}/libocpf.so.*.*
299 %attr(755,root,root) %ghost %{_libdir}/libocpf.so.0
300
301 %files devel
302 %defattr(644,root,root,755)
303 %attr(755,root,root) %{_libdir}/libmapi.so
304 %attr(755,root,root) %{_libdir}/libmapiadmin.so
305 %attr(755,root,root) %{_libdir}/libocpf.so
306 %{_includedir}/gen_ndr
307 %{_includedir}/libmapi
308 %{_includedir}/libmapiadmin
309 %{_includedir}/libocpf
310 %{_pkgconfigdir}/libmapi.pc
311 %{_pkgconfigdir}/libmapiadmin.pc
312 %{_pkgconfigdir}/libocpf.pc
313
314 %files c++
315 %defattr(644,root,root,755)
316 %attr(755,root,root) %{_libdir}/libmapipp.so.*.*
317 %attr(755,root,root) %ghost %{_libdir}/libmapipp.so.0
318
319 %files c++-devel
320 %defattr(644,root,root,755)
321 %attr(755,root,root) %{_libdir}/libmapipp.so
322 %{_includedir}/libmapi++
323 %{_pkgconfigdir}/libmapi++.pc
324
325 %files qt
326 %defattr(644,root,root,755)
327 %attr(755,root,root) %{_libdir}/libqtmapi.so.*.*
328 %attr(755,root,root) %ghost %{_libdir}/libqtmapi.so.0
329
330 %files qt-devel
331 %defattr(644,root,root,755)
332 %attr(755,root,root) %{_libdir}/libqtmapi.so
333 %{_includedir}/libqtmapi
334
335 %if %{with apidocs}
336 %files apidocs
337 %defattr(644,root,root,755)
338 %doc apidocs/html/*
339 %endif
340
341 %files -n python-openchange
342 %defattr(644,root,root,755)
343 %dir %{py_sitedir}/openchange
344 %attr(755,root,root) %{py_sitedir}/openchange/mapi.so
345 %attr(755,root,root) %{py_sitedir}/openchange/mapistore.so
346
347 %files -n nagios-plugin-openchange
348 %defattr(644,root,root,755)
349 # R: perl, openchangeclient
350 # FIXME: use /usr/lib/nagios/plugins dir and make package noarch
351 %attr(755,root,root) %{_libdir}/nagios/check_exchange
352 # default profile database - should be /etc/...
353 #%config(noreplace) %verify(not md5 mtime size) %{_libdir}/nagios/plugins/check_exchange.ldb
This page took 0.06439 seconds and 4 git commands to generate.