]> git.pld-linux.org Git - packages/openchange.git/blob - openchange.spec
514d3e483e79c0247c4f97e94a798fd7cdcee707
[packages/openchange.git] / openchange.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 #
5 Summary:        OpenChange - portable implementation of MS Exchange Server and Exchange protocols
6 Summary(pl.UTF-8):      OpenChange - przenośna implementacja serwera oraz protokołów MS Exchange
7 Name:           openchange
8 Version:        2.3
9 Release:        1
10 License:        GPL v3+
11 Group:          Libraries
12 %define cname   VULCAN
13 Source0:        https://github.com/openchange/openchange/archive/%{name}-%{version}-%{cname}.tar.gz
14 # Source0-md5:  96c13c78c2bcbd7040f7848746284b9f
15 Patch0:         %{name}-samba-private.patch
16 Patch1:         %{name}-link.patch
17 URL:            http://www.openchange.org/
18 BuildRequires:  QtCore-devel >= 4.3.0
19 BuildRequires:  QtGui-devel >= 4.3.0
20 BuildRequires:  autoconf >= 2.57
21 BuildRequires:  automake
22 BuildRequires:  check-devel
23 BuildRequires:  doxygen
24 BuildRequires:  ldb-devel
25 BuildRequires:  libical-devel >= 0.46
26 BuildRequires:  libmagic-devel
27 BuildRequires:  libmemcached-devel >= 1.0.18
28 BuildRequires:  libpcap-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  mysql-devel
31 BuildRequires:  nanomsg-devel >= 0.5
32 BuildRequires:  perl-base
33 BuildRequires:  pkgconfig >= 1:0.20
34 BuildRequires:  popt-devel
35 BuildRequires:  python-devel >= 1:2.7
36 BuildRequires:  rpmbuild(macros) >= 1.219
37 # with DCERCP multiplex and pending call support (upstream 4.1.18+ or 4.2.>1)
38 BuildRequires:  samba-devel >= 4.2.1-0.2
39 BuildRequires:  samba-pidl >= 4.2.1
40 BuildRequires:  sed >= 4.0
41 BuildRequires:  subunit-devel
42 BuildRequires:  talloc-devel
43 BuildRequires:  tdb-devel
44 BuildRequires:  zlib-devel
45 Requires:       %{name}-libs = %{version}-%{release}
46 Requires:       python-openchange = %{version}-%{release}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 OpenChange is a portable Open Source implementation of Microsoft
51 Exchange server and Exchange protocols. It provides a complete
52 solution to interoperate with Microsoft Outlook clients or Microsoft
53 Exchange servers.
54
55 OpenChange client-side library is used in existing messaging clients
56 and is the solution in new projects to communicate natively with
57 Microsoft Exchange and Exchange-compatible servers. OpenChange server
58 is a transparent Microsoft Exchange server replacement using native
59 Exchange protocols and does not require any plugin installation in
60 Outlook.
61
62 %description -l pl.UTF-8
63 OpenChange to przenośna, mająca otwarte źródła implementacja serwera
64 oraz protokołów Microsoft Exchange. Dostarcza kompletne rozwiązanie
65 pozwalające współpracować z klientami Microsoft Outlook oraz serwerami
66 Microsoft Exchange.
67
68 Biblioteka kliencka OpenChange jest używana przez istniejących
69 klientów pocztowych i pozwalają na natywną komunikację z serwerami
70 Microsoft Exchange oraz zgodnymi. Serwer OpenChange to przezroczysty
71 zamiennik serwera Microsoft Exchange wykorzystujący natywne protokoły
72 Exchange, nie wymagający instalowania żadnych wtyczek w Outlooku.
73
74 %package libs
75 Summary:        OpenChange client libraries
76 Summary(pl.UTF-8):      Biblioteki klienckie OpenChange
77 Group:          Libraries
78
79 %description libs
80 OpenChange client libraries.
81
82 %description libs -l pl.UTF-8
83 Biblioteki klienckie OpenChange.
84
85 %package devel
86 Summary:        Header files for OpenChange libraries
87 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek OpenChange
88 Group:          Development/Libraries
89 Requires:       %{name}-libs = %{version}-%{release}
90 Requires:       ldb-devel
91 Requires:       samba-devel >= 4.2.1-0.2
92 Requires:       talloc-devel
93 Requires:       tevent-devel
94 Requires:       zlib-devel
95
96 %description devel
97 Header files for OpenChange libraries.
98
99 %description devel -l pl.UTF-8
100 Pliki nagłówkowe bibliotek OpenChange.
101
102 %package c++
103 Summary:        C++ interface to OpenChange MAPI library
104 Summary(pl.UTF-8):      Interfejs C++ do biblioteki OpenChange MAPI
105 Group:          Libraries
106 Requires:       %{name}-libs = %{version}-%{release}
107
108 %description c++
109 C++ interface to OpenChange MAPI library.
110
111 %description c++ -l pl.UTF-8
112 Interfejs C++ do biblioteki OpenChange MAPI.
113
114 %package c++-devel
115 Summary:        Header files of C++ interface to OpenChange MAPI library
116 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI
117 Group:          Development/Libraries
118 Requires:       %{name}-c++ = %{version}-%{release}
119 Requires:       %{name}-devel = %{version}-%{release}
120 Requires:       libstdc++-devel
121
122 %description c++-devel
123 Header files of C++ interface to OpenChange MAPI library.
124
125 %description c++-devel -l pl.UTF-8
126 Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI.
127
128 %package qt
129 Summary:        Qt interface to OpenChange MAPI library
130 Summary(pl.UTF-8):      Interfejs Qt do biblioteki OpenChange MAPI
131 Group:          Libraries
132 Requires:       %{name}-c++ = %{version}-%{release}
133 Requires:       QtCore >= 4.3.0
134 Requires:       QtGui >= 4.3.0
135
136 %description qt
137 Qt interface to OpenChange MAPI library.
138
139 %description qt -l pl.UTF-8
140 Interfejs Qt do biblioteki OpenChange MAPI.
141
142 %package qt-devel
143 Summary:        Header files of Qt interface to OpenChange MAPI library
144 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu Qt do biblioteki OpenChange MAPI
145 Group:          Development/Libraries
146 Requires:       %{name}-qt = %{version}-%{release}
147 Requires:       QtGui-devel >= 4.3.0
148
149 %description qt-devel
150 Header files of Qt interface to OpenChange MAPI library.
151
152 %description qt-devel -l pl.UTF-8
153 Pliki nagłówkowe interfejsu Qt do biblioteki OpenChange MAPI.
154
155 %package apidocs
156 Summary:        API documentation for OpenChange libraries
157 Summary(pl.UTF-8):      Dokumentacja API bibliotek OpenChange
158 Group:          Documentation
159
160 %description apidocs
161 API documentation for OpenChange libraries.
162
163 %description apidocs -l pl.UTF-8
164 Dokumentacja API bibliotek OpenChange.
165
166 %package -n python-openchange
167 Summary:        Python interface to OpenChange libraries
168 Summary(pl.UTF-8):      Interfejs Pythona do bibliotek OpenChange
169 Group:          Libraries/Python
170 Requires:       %{name}-libs = %{version}-%{release}
171
172 %description -n python-openchange
173 Python interface to OpenChange libraries.
174
175 %description -n python-openchange -l pl.UTF-8
176 Interfejs Pythona do bibliotek OpenChange.
177
178 %package -n nagios-plugin-openchange
179 Summary:        Nagios plugin to check Exchange/OpenChange services
180 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange
181 Group:          Networking
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       nagios
184
185 %description -n nagios-plugin-openchange
186 Nagios plugin to check Exchange/OpenChange services.
187
188 %description -n nagios-plugin-openchange -l pl.UTF-8
189 Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange.
190
191 %prep
192 %setup -q -n %{name}-%{name}-%{version}-%{cname}
193 %patch0 -p1
194 %patch1 -p1
195
196 # no switch for verbose mode, enable manually :/
197 %{__sed} -i -e 's/^     @\(\$(\(PIDL\|CC\|CXX\|MOC\)\)/ \1/' Makefile
198
199 %build
200 %{__aclocal}
201 %{__autoconf}
202 %{__autoheader}
203 %configure \
204         --datadir=%{_datadir}/openchange \
205         --enable-openchange-qt4 \
206         --enable-pyopenchange \
207         --with-modulesdir=%{_libdir}/openchange/modules
208 %{__make}
209
210 %if %{with apidocs}
211 %{__make} doxygen
212 %endif
213
214 %install
215 rm -rf $RPM_BUILD_ROOT
216
217 %{__make} install \
218         DESTDIR=$RPM_BUILD_ROOT
219
220 # doxygen generated man pages are messy; use HTML docs and install man1 pages manually
221 %if 0
222 %{__make} installman \
223         DESTDIR=$RPM_BUILD_ROOT
224 %else
225 install -d $RPM_BUILD_ROOT%{_mandir}/man1
226 cp doc/man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
227 %endif
228
229 # missing from make install
230 install -d $RPM_BUILD_ROOT%{_includedir}/libqtmapi
231 cp -p qt/lib/*.h $RPM_BUILD_ROOT%{_includedir}/libqtmapi
232 cp -a libqtmapi.so.*.* libqtmapi.so $RPM_BUILD_ROOT%{_libdir}
233
234 # tests
235 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{check_fasttransfer,openchange-testsuite,test_asyncnotif}
236
237 /sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir}
238
239 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
240 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
241 %py_postclean
242
243 %clean
244 rm -rf $RPM_BUILD_ROOT
245
246 %post   libs -p /sbin/ldconfig
247 %postun libs -p /sbin/ldconfig
248
249 %post   c++ -p /sbin/ldconfig
250 %postun c++ -p /sbin/ldconfig
251
252 %post   qt -p /sbin/ldconfig
253 %postun qt -p /sbin/ldconfig
254
255 %files
256 %defattr(644,root,root,755)
257 %doc CHANGES.md IDL_LICENSE.txt README.md README.smbconf.md doc/howto.txt
258 %attr(755,root,root) %{_bindir}/exchange2ical
259 %attr(755,root,root) %{_bindir}/exchange2mbox
260 %attr(755,root,root) %{_bindir}/mapiprofile
261 %attr(755,root,root) %{_bindir}/mapipropsdump
262 %attr(755,root,root) %{_bindir}/mapitest
263 %attr(755,root,root) %{_bindir}/ocnotify
264 %attr(755,root,root) %{_bindir}/openchangeclient
265 %attr(755,root,root) %{_bindir}/openchangemapidump
266 %attr(755,root,root) %{_bindir}/openchangepfadmin
267 %attr(755,root,root) %{_bindir}/rpcextract
268 %attr(755,root,root) %{_bindir}/schemaIDGUID
269 %attr(755,root,root) %{_sbindir}/openchange_group
270 %attr(755,root,root) %{_sbindir}/openchange_migrate
271 %attr(755,root,root) %{_sbindir}/openchange_neworganization
272 %attr(755,root,root) %{_sbindir}/openchange_newuser
273 %attr(755,root,root) %{_sbindir}/openchange_provision
274 # XXX: dir specified by dcerpc_server.pc file, should belong to samba or samba-libs
275 %dir %{_libdir}/samba/dcerpc_server
276 %attr(755,root,root) %{_libdir}/samba/dcerpc_server/dcesrv_asyncemsmdb.so
277 %attr(755,root,root) %{_libdir}/samba/dcerpc_server/dcesrv_mapiproxy.so
278 %dir %{_libdir}/openchange
279 %dir %{_libdir}/openchange/modules
280 %dir %{_libdir}/openchange/modules/dcerpc_mapiproxy
281 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_cache.so
282 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_downgrade.so
283 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_dummy.so
284 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_pack.so
285 %dir %{_libdir}/openchange/modules/dcerpc_mapiproxy_server
286 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_ds_rfr.so
287 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_emsmdb.so
288 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_nsp.so
289 %dir %{_datadir}/openchange
290 %{_datadir}/openchange/mapitest
291 %dir %{_datadir}/openchange/setup
292 %{_datadir}/openchange/setup/mapistore
293 %{_datadir}/openchange/setup/openchangedb
294 %{_datadir}/openchange/setup/profiles
295 %dir %{_datadir}/samba/setup/AD
296 %{_datadir}/samba/setup/AD/oc_provision_*.ldif
297 %{_datadir}/samba/setup/AD/provision_schema_basedn_modify.ldif
298 %{_datadir}/samba/setup/AD/update_now.ldif
299 %{_datadir}/samba/setup/AD/prefixMap.txt
300 %{_mandir}/man1/exchange2ical.1*
301 %{_mandir}/man1/exchange2mbox.1*
302 %{_mandir}/man1/mapiprofile.1*
303 %{_mandir}/man1/mapitest.1*
304 %{_mandir}/man1/openchangeclient.1*
305 %{_mandir}/man1/openchangepfadmin.1*
306
307 %files libs
308 %defattr(644,root,root,755)
309 %attr(755,root,root) %{_libdir}/libmapi.so.*.*
310 %attr(755,root,root) %ghost %{_libdir}/libmapi.so.0
311 %attr(755,root,root) %{_libdir}/libmapiadmin.so.*.*
312 %attr(755,root,root) %ghost %{_libdir}/libmapiadmin.so.0
313 %attr(755,root,root) %{_libdir}/libmapiproxy.so.*.*
314 %attr(755,root,root) %ghost %{_libdir}/libmapiproxy.so.0
315 %attr(755,root,root) %{_libdir}/libmapiserver.so.*.*
316 %attr(755,root,root) %ghost %{_libdir}/libmapiserver.so.0
317 %attr(755,root,root) %{_libdir}/libmapistore.so.*.*
318 %attr(755,root,root) %ghost %{_libdir}/libmapistore.so.0
319 %attr(755,root,root) %{_libdir}/libocpf.so.*.*
320 %attr(755,root,root) %ghost %{_libdir}/libocpf.so.0
321
322 %files devel
323 %defattr(644,root,root,755)
324 %attr(755,root,root) %{_libdir}/libmapi.so
325 %attr(755,root,root) %{_libdir}/libmapiadmin.so
326 %attr(755,root,root) %{_libdir}/libmapiproxy.so
327 %attr(755,root,root) %{_libdir}/libmapiserver.so
328 %attr(755,root,root) %{_libdir}/libmapistore.so
329 %attr(755,root,root) %{_libdir}/libocpf.so
330 %{_includedir}/gen_ndr
331 %{_includedir}/libmapi
332 %{_includedir}/libmapiadmin
333 %{_includedir}/libocpf
334 %{_includedir}/mapistore
335 %{_includedir}/libmapiproxy.h
336 %{_includedir}/libmapiserver.h
337 %{_pkgconfigdir}/libmapi.pc
338 %{_pkgconfigdir}/libmapiadmin.pc
339 %{_pkgconfigdir}/libmapiproxy.pc
340 %{_pkgconfigdir}/libmapiserver.pc
341 %{_pkgconfigdir}/libmapistore.pc
342 %{_pkgconfigdir}/libocpf.pc
343
344 %files c++
345 %defattr(644,root,root,755)
346 %attr(755,root,root) %{_libdir}/libmapipp.so.*.*
347 %attr(755,root,root) %ghost %{_libdir}/libmapipp.so.0
348
349 %files c++-devel
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_libdir}/libmapipp.so
352 %{_includedir}/libmapi++
353 %{_pkgconfigdir}/libmapi++.pc
354
355 %files qt
356 %defattr(644,root,root,755)
357 %attr(755,root,root) %{_libdir}/libqtmapi.so.*.*
358 %attr(755,root,root) %ghost %{_libdir}/libqtmapi.so.0
359
360 %files qt-devel
361 %defattr(644,root,root,755)
362 %attr(755,root,root) %{_libdir}/libqtmapi.so
363 %{_includedir}/libqtmapi
364
365 %if %{with apidocs}
366 %files apidocs
367 %defattr(644,root,root,755)
368 %doc apidocs/html/*
369 %endif
370
371 %files -n python-openchange
372 %defattr(644,root,root,755)
373 %dir %{py_sitedir}/openchange
374 %attr(755,root,root) %{py_sitedir}/openchange/mapi.so
375 %attr(755,root,root) %{py_sitedir}/openchange/mapistore.so
376 %{py_sitedir}/openchange/*.py[co]
377 %{py_sitedir}/openchange/migration
378 %{py_sitedir}/openchange/tests
379 %{py_sitedir}/openchange/utils
380 %{py_sitedir}/openchange/web
381
382 %files -n nagios-plugin-openchange
383 %defattr(644,root,root,755)
384 # R: perl, openchangeclient
385 %attr(755,root,root) %{_libdir}/nagios/check_exchange
386 # default profile database - should be /etc/...
387 #%config(noreplace) %verify(not md5 mtime size) %{_libdir}/nagios/plugins/check_exchange.ldb
This page took 0.071274 seconds and 3 git commands to generate.