]> git.pld-linux.org Git - packages/openchange.git/blob - openchange.spec
- new
[packages/openchange.git] / openchange.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 #
5 Summary:        OpenChange - portable implementation of MS Exchange Server and Exchange protocols
6 Summary(pl.UTF-8):      OpenChange - przenośna implementacja serwera oraz protokołów MS Exchange
7 Name:           openchange
8 Version:        2.3
9 Release:        1
10 License:        GPL v3+
11 Group:          Libraries
12 %define cname   VULCAN
13 Source0:        https://github.com/openchange/openchange/archive/%{name}-%{version}-%{cname}.tar.gz
14 # Source0-md5:  96c13c78c2bcbd7040f7848746284b9f
15 Patch0:         %{name}-samba-private.patch
16 Patch1:         %{name}-link.patch
17 URL:            http://www.openchange.org/
18 BuildRequires:  QtCore-devel >= 4.3.0
19 BuildRequires:  QtGui-devel >= 4.3.0
20 BuildRequires:  autoconf >= 2.57
21 BuildRequires:  automake
22 BuildRequires:  check-devel
23 BuildRequires:  doxygen
24 BuildRequires:  ldb-devel
25 BuildRequires:  libical-devel >= 0.46
26 BuildRequires:  libmagic-devel
27 BuildRequires:  libmemcached-devel >= 1.0.18
28 BuildRequires:  libpcap-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  mysql-devel
31 BuildRequires:  nanomsg-devel >= 0.5
32 BuildRequires:  perl-base
33 BuildRequires:  pkgconfig >= 1:0.20
34 BuildRequires:  popt-devel
35 BuildRequires:  python-devel >= 1:2.7
36 BuildRequires:  rpmbuild(macros) >= 1.219
37 # with DCERCP multiplex and pending call support (upstream 4.1.18+ or 4.2.>1)
38 BuildRequires:  samba-devel >= 4.2.1
39 BuildRequires:  samba-pidl >= 4.2.1
40 BuildRequires:  sed >= 4.0
41 BuildRequires:  subunit-devel
42 BuildRequires:  talloc-devel
43 BuildRequires:  tdb-devel
44 BuildRequires:  zlib-devel
45 Requires:       %{name}-libs = %{version}-%{release}
46 Requires:       python-openchange = %{version}-%{release}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 # libraries use symbols also from samba libs pulled indirectly, from outside %{_libdir}
50 #define         filterout_ld    -Wl,--no-copy-dt-needed-entries
51
52 %description
53 OpenChange is a portable Open Source implementation of Microsoft
54 Exchange server and Exchange protocols. It provides a complete
55 solution to interoperate with Microsoft Outlook clients or Microsoft
56 Exchange servers.
57
58 OpenChange client-side library is used in existing messaging clients
59 and is the solution in new projects to communicate natively with
60 Microsoft Exchange and Exchange-compatible servers. OpenChange server
61 is a transparent Microsoft Exchange server replacement using native
62 Exchange protocols and does not require any plugin installation in
63 Outlook.
64
65 %description -l pl.UTF-8
66 OpenChange to przenośna, mająca otwarte źródła implementacja serwera
67 oraz protokołów Microsoft Exchange. Dostarcza kompletne rozwiązanie
68 pozwalające współpracować z klientami Microsoft Outlook oraz serwerami
69 Microsoft Exchange.
70
71 Biblioteka kliencka OpenChange jest używana przez istniejących
72 klientów pocztowych i pozwalają na natywną komunikację z serwerami
73 Microsoft Exchange oraz zgodnymi. Serwer OpenChange to przezroczysty
74 zamiennik serwera Microsoft Exchange wykorzystujący natywne protokoły
75 Exchange, nie wymagający instalowania żadnych wtyczek w Outlooku.
76
77 %package libs
78 Summary:        OpenChange client libraries
79 Summary(pl.UTF-8):      Biblioteki klienckie OpenChange
80 Group:          Libraries
81
82 %description libs
83 OpenChange client libraries.
84
85 %description libs -l pl.UTF-8
86 Biblioteki klienckie OpenChange.
87
88 %package devel
89 Summary:        Header files for OpenChange libraries
90 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek OpenChange
91 Group:          Development/Libraries
92 Requires:       %{name}-libs = %{version}-%{release}
93
94 %description devel
95 Header files for OpenChange libraries.
96
97 %description devel -l pl.UTF-8
98 Pliki nagłówkowe bibliotek OpenChange.
99
100 %package c++
101 Summary:        C++ interface to OpenChange MAPI library
102 Summary(pl.UTF-8):      Interfejs C++ do biblioteki OpenChange MAPI
103 Group:          Libraries
104
105 %description c++
106 C++ interface to OpenChange MAPI library.
107
108 %description c++ -l pl.UTF-8
109 Interfejs C++ do biblioteki OpenChange MAPI.
110
111 %package c++-devel
112 Summary:        Header files of C++ interface to OpenChange MAPI library
113 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI
114 Group:          Development/Libraries
115 Requires:       %{name}-c++ = %{version}-%{release}
116
117 %description c++-devel
118 Header files of C++ interface to OpenChange MAPI library.
119
120 %description c++-devel -l pl.UTF-8
121 Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI.
122
123 %package qt
124 Summary:        Qt interface to OpenChange MAPI library
125 Summary(pl.UTF-8):      Interfejs Qt do biblioteki OpenChange MAPI
126 Group:          Libraries
127
128 %description qt
129 Qt interface to OpenChange MAPI library.
130
131 %description qt -l pl.UTF-8
132 Interfejs Qt do biblioteki OpenChange MAPI.
133
134 %package qt-devel
135 Summary:        Header files of Qt interface to OpenChange MAPI library
136 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu Qt do biblioteki OpenChange MAPI
137 Group:          Development/Libraries
138 Requires:       %{name}-qt = %{version}-%{release}
139
140 %description qt-devel
141 Header files of Qt interface to OpenChange MAPI library.
142
143 %description qt-devel -l pl.UTF-8
144 Pliki nagłówkowe interfejsu Qt do biblioteki OpenChange MAPI.
145
146 %package apidocs
147 Summary:        API documentation for OpenChange libraries
148 Summary(pl.UTF-8):      Dokumentacja API bibliotek OpenChange
149 Group:          Documentation
150
151 %description apidocs
152 API documentation for OpenChange libraries.
153
154 %description apidocs -l pl.UTF-8
155 Dokumentacja API bibliotek OpenChange.
156
157 %package -n python-openchange
158 Summary:        Python interface to OpenChange libraries
159 Summary(pl.UTF-8):      Interfejs Pythona do bibliotek OpenChange
160 Group:          Libraries/Python
161 Requires:       %{name}-libs = %{version}-%{release}
162
163 %description -n python-openchange
164 Python interface to OpenChange libraries.
165
166 %description -n python-openchange -l pl.UTF-8
167 Interfejs Pythona do bibliotek OpenChange.
168
169 %package -n nagios-plugin-openchange
170 Summary:        Nagios plugin to check Exchange/OpenChange services
171 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange
172 Group:          Networking
173 Requires:       %{name} = %{version}-%{release}
174 Requires:       nagios
175
176 %description -n nagios-plugin-openchange
177 Nagios plugin to check Exchange/OpenChange services.
178
179 %description -n nagios-plugin-openchange -l pl.UTF-8
180 Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange.
181
182 %prep
183 %setup -q -n %{name}-%{name}-%{version}-%{cname}
184 %patch0 -p1
185 %patch1 -p1
186
187 # no switch for verbose mode, enable manually :/
188 %{__sed} -i -e 's/^     @\(\$(\(PIDL\|CC\|CXX\|MOC\)\)/ \1/' Makefile
189
190 %build
191 %{__aclocal}
192 %{__autoconf}
193 %{__autoheader}
194 %configure \
195         --datadir=%{_datadir}/openchange \
196         --enable-openchange-qt4 \
197         --enable-pyopenchange \
198         --with-modulesdir=%{_libdir}/openchange/modules
199 %{__make}
200
201 %if %{with apidocs}
202 %{__make} doxygen
203 %endif
204
205 %install
206 rm -rf $RPM_BUILD_ROOT
207
208 %{__make} install \
209         DESTDIR=$RPM_BUILD_ROOT
210
211 # doxygen generated man pages are messy; use HTML docs and install man1 pages manually
212 %if 0
213 %{__make} installman \
214         DESTDIR=$RPM_BUILD_ROOT
215 %else
216 install -d $RPM_BUILD_ROOT%{_mandir}/man1
217 cp doc/man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
218 %endif
219
220 # missing from make install
221 install -d $RPM_BUILD_ROOT%{_includedir}/libqtmapi
222 cp -p qt/lib/*.h $RPM_BUILD_ROOT%{_includedir}/libqtmapi
223 cp -a libqtmapi.so.*.* libqtmapi.so $RPM_BUILD_ROOT%{_libdir}
224
225 # tests
226 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{check_fasttransfer,openchange-testsuite,test_asyncnotif}
227
228 /sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir}
229
230 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
231 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
232 %py_postclean
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %post   -p /sbin/ldconfig
238 %postun -p /sbin/ldconfig
239
240 %files
241 %defattr(644,root,root,755)
242 %doc CHANGES.md IDL_LICENSE.txt README.md README.smbconf.md doc/howto.txt
243 %attr(755,root,root) %{_bindir}/exchange2ical
244 %attr(755,root,root) %{_bindir}/exchange2mbox
245 %attr(755,root,root) %{_bindir}/mapiprofile
246 %attr(755,root,root) %{_bindir}/mapipropsdump
247 %attr(755,root,root) %{_bindir}/mapitest
248 %attr(755,root,root) %{_bindir}/ocnotify
249 %attr(755,root,root) %{_bindir}/openchangeclient
250 %attr(755,root,root) %{_bindir}/openchangemapidump
251 %attr(755,root,root) %{_bindir}/openchangepfadmin
252 %attr(755,root,root) %{_bindir}/rpcextract
253 %attr(755,root,root) %{_bindir}/schemaIDGUID
254 %attr(755,root,root) %{_sbindir}/openchange_group
255 %attr(755,root,root) %{_sbindir}/openchange_migrate
256 %attr(755,root,root) %{_sbindir}/openchange_neworganization
257 %attr(755,root,root) %{_sbindir}/openchange_newuser
258 %attr(755,root,root) %{_sbindir}/openchange_provision
259 # XXX: dir specified by dcerpc_server.pc file, should belong to samba or samba-libs
260 %dir %{_libdir}/samba/dcerpc_server
261 %attr(755,root,root) %{_libdir}/samba/dcerpc_server/dcesrv_asyncemsmdb.so
262 %attr(755,root,root) %{_libdir}/samba/dcerpc_server/dcesrv_mapiproxy.so
263 %dir %{_libdir}/openchange
264 %dir %{_libdir}/openchange/modules
265 %dir %{_libdir}/openchange/modules/dcerpc_mapiproxy
266 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_cache.so
267 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_downgrade.so
268 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_dummy.so
269 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_pack.so
270 %dir %{_libdir}/openchange/modules/dcerpc_mapiproxy_server
271 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_ds_rfr.so
272 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_emsmdb.so
273 %attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_nsp.so
274 %dir %{_datadir}/openchange
275 %{_datadir}/openchange/mapitest
276 %dir %{_datadir}/openchange/setup
277 %{_datadir}/openchange/setup/mapistore
278 %{_datadir}/openchange/setup/openchangedb
279 %{_datadir}/openchange/setup/profiles
280 %dir %{_datadir}/samba/setup/AD
281 %{_datadir}/samba/setup/AD/oc_provision_*.ldif
282 %{_datadir}/samba/setup/AD/provision_schema_basedn_modify.ldif
283 %{_datadir}/samba/setup/AD/update_now.ldif
284 %{_datadir}/samba/setup/AD/prefixMap.txt
285 %{_mandir}/man1/exchange2ical.1*
286 %{_mandir}/man1/exchange2mbox.1*
287 %{_mandir}/man1/mapiprofile.1*
288 %{_mandir}/man1/mapitest.1*
289 %{_mandir}/man1/openchangeclient.1*
290 %{_mandir}/man1/openchangepfadmin.1*
291
292 %files libs
293 %defattr(644,root,root,755)
294 %attr(755,root,root) %{_libdir}/libmapi.so.*.*
295 %attr(755,root,root) %ghost %{_libdir}/libmapi.so.0
296 %attr(755,root,root) %{_libdir}/libmapiadmin.so.*.*
297 %attr(755,root,root) %ghost %{_libdir}/libmapiadmin.so.0
298 %attr(755,root,root) %{_libdir}/libmapipp.so.*.*
299 %attr(755,root,root) %ghost %{_libdir}/libmapipp.so.0
300 %attr(755,root,root) %{_libdir}/libmapiproxy.so.*.*
301 %attr(755,root,root) %ghost %{_libdir}/libmapiproxy.so.0
302 %attr(755,root,root) %{_libdir}/libmapiserver.so.*.*
303 %attr(755,root,root) %ghost %{_libdir}/libmapiserver.so.0
304 %attr(755,root,root) %{_libdir}/libmapistore.so.*.*
305 %attr(755,root,root) %ghost %{_libdir}/libmapistore.so.0
306 %attr(755,root,root) %{_libdir}/libocpf.so.*.*
307 %attr(755,root,root) %ghost %{_libdir}/libocpf.so.0
308
309 %files devel
310 %defattr(644,root,root,755)
311 %attr(755,root,root) %{_libdir}/libmapi.so
312 %attr(755,root,root) %{_libdir}/libmapiadmin.so
313 %attr(755,root,root) %{_libdir}/libmapipp.so
314 %attr(755,root,root) %{_libdir}/libmapiproxy.so
315 %attr(755,root,root) %{_libdir}/libmapiserver.so
316 %attr(755,root,root) %{_libdir}/libmapistore.so
317 %attr(755,root,root) %{_libdir}/libocpf.so
318 %{_includedir}/gen_ndr
319 %{_includedir}/libmapi
320 %{_includedir}/libmapi++
321 %{_includedir}/libmapiadmin
322 %{_includedir}/libocpf
323 %{_includedir}/mapistore
324 %{_includedir}/libmapiproxy.h
325 %{_includedir}/libmapiserver.h
326 %{_pkgconfigdir}/libmapi.pc
327 %{_pkgconfigdir}/libmapi++.pc
328 %{_pkgconfigdir}/libmapiadmin.pc
329 %{_pkgconfigdir}/libmapiproxy.pc
330 %{_pkgconfigdir}/libmapiserver.pc
331 %{_pkgconfigdir}/libmapistore.pc
332 %{_pkgconfigdir}/libocpf.pc
333
334 %files qt
335 %defattr(644,root,root,755)
336 %attr(755,root,root) %{_libdir}/libqtmapi.so.*.*
337 %attr(755,root,root) %ghost %{_libdir}/libqtmapi.so.0
338
339 %files qt-devel
340 %defattr(644,root,root,755)
341 %attr(755,root,root) %{_libdir}/libqtmapi.so
342 %{_includedir}/libqtmapi
343
344 %if %{with apidocs}
345 %files apidocs
346 %defattr(644,root,root,755)
347 %doc apidocs/html/*
348 %endif
349
350 %files -n python-openchange
351 %defattr(644,root,root,755)
352 %dir %{py_sitedir}/openchange
353 %attr(755,root,root) %{py_sitedir}/openchange/mapi.so
354 %attr(755,root,root) %{py_sitedir}/openchange/mapistore.so
355 %{py_sitedir}/openchange/*.py[co]
356 %{py_sitedir}/openchange/migration
357 %{py_sitedir}/openchange/tests
358 %{py_sitedir}/openchange/utils
359 %{py_sitedir}/openchange/web
360
361 %files -n nagios-plugin-openchange
362 %defattr(644,root,root,755)
363 # R: perl, openchangeclient
364 %attr(755,root,root) %{_libdir}/nagios/check_exchange
365 # default profile database - should be /etc/...
366 #%config(noreplace) %verify(not md5 mtime size) %{_libdir}/nagios/plugins/check_exchange.ldb
This page took 0.064941 seconds and 3 git commands to generate.