]> git.pld-linux.org Git - packages/openchange.git/blame_incremental - openchange.spec
- release 3 (samba 4.2.5 in Th)
[packages/openchange.git] / openchange.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4#
5Summary: OpenChange - portable implementation of MS Exchange Server and Exchange protocols
6Summary(pl.UTF-8): OpenChange - przenośna implementacja serwera oraz protokołów MS Exchange
7Name: openchange
8Version: 2.3
9Release: 3
10License: GPL v3+
11Group: Libraries
12%define cname VULCAN
13Source0: https://github.com/openchange/openchange/archive/%{name}-%{version}-%{cname}.tar.gz
14# Source0-md5: 96c13c78c2bcbd7040f7848746284b9f
15Patch0: %{name}-samba-private.patch
16Patch1: %{name}-link.patch
17URL: http://www.openchange.org/
18BuildRequires: QtCore-devel >= 4.3.0
19BuildRequires: QtGui-devel >= 4.3.0
20BuildRequires: autoconf >= 2.57
21BuildRequires: automake
22BuildRequires: check-devel
23BuildRequires: doxygen
24BuildRequires: ldb-devel
25BuildRequires: libical-devel >= 0.46
26BuildRequires: libmagic-devel
27BuildRequires: libmemcached-devel >= 1.0.18
28BuildRequires: libpcap-devel
29BuildRequires: libstdc++-devel
30BuildRequires: mysql-devel
31BuildRequires: nanomsg-devel >= 0.5
32BuildRequires: perl-base
33BuildRequires: pkgconfig >= 1:0.20
34BuildRequires: popt-devel
35BuildRequires: python-devel >= 1:2.7
36BuildRequires: python-samba >= 4.2.2
37BuildRequires: rpmbuild(macros) >= 1.219
38# with DCERCP multiplex and pending call support (upstream 4.1.18+ or 4.2.2+)
39BuildRequires: samba-devel >= 4.2.2
40BuildRequires: samba-pidl >= 4.2.2
41BuildRequires: sed >= 4.0
42BuildRequires: subunit-devel
43BuildRequires: talloc-devel
44BuildRequires: tdb-devel
45BuildRequires: zlib-devel
46Requires: %{name}-libs = %{version}-%{release}
47Requires: python-openchange = %{version}-%{release}
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51OpenChange is a portable Open Source implementation of Microsoft
52Exchange server and Exchange protocols. It provides a complete
53solution to interoperate with Microsoft Outlook clients or Microsoft
54Exchange servers.
55
56OpenChange client-side library is used in existing messaging clients
57and is the solution in new projects to communicate natively with
58Microsoft Exchange and Exchange-compatible servers. OpenChange server
59is a transparent Microsoft Exchange server replacement using native
60Exchange protocols and does not require any plugin installation in
61Outlook.
62
63%description -l pl.UTF-8
64OpenChange to przenośna, mająca otwarte źródła implementacja serwera
65oraz protokołów Microsoft Exchange. Dostarcza kompletne rozwiązanie
66pozwalające współpracować z klientami Microsoft Outlook oraz serwerami
67Microsoft Exchange.
68
69Biblioteka kliencka OpenChange jest używana przez istniejących
70klientów pocztowych i pozwalają na natywną komunikację z serwerami
71Microsoft Exchange oraz zgodnymi. Serwer OpenChange to przezroczysty
72zamiennik serwera Microsoft Exchange wykorzystujący natywne protokoły
73Exchange, nie wymagający instalowania żadnych wtyczek w Outlooku.
74
75%package libs
76Summary: OpenChange client libraries
77Summary(pl.UTF-8): Biblioteki klienckie OpenChange
78Group: Libraries
79
80%description libs
81OpenChange client libraries.
82
83%description libs -l pl.UTF-8
84Biblioteki klienckie OpenChange.
85
86%package devel
87Summary: Header files for OpenChange libraries
88Summary(pl.UTF-8): Pliki nagłówkowe bibliotek OpenChange
89Group: Development/Libraries
90Requires: %{name}-libs = %{version}-%{release}
91Requires: ldb-devel
92Requires: samba-devel >= 4.2.2
93Requires: talloc-devel
94Requires: tevent-devel
95Requires: zlib-devel
96
97%description devel
98Header files for OpenChange libraries.
99
100%description devel -l pl.UTF-8
101Pliki nagłówkowe bibliotek OpenChange.
102
103%package c++
104Summary: C++ interface to OpenChange MAPI library
105Summary(pl.UTF-8): Interfejs C++ do biblioteki OpenChange MAPI
106Group: Libraries
107Requires: %{name}-libs = %{version}-%{release}
108
109%description c++
110C++ interface to OpenChange MAPI library.
111
112%description c++ -l pl.UTF-8
113Interfejs C++ do biblioteki OpenChange MAPI.
114
115%package c++-devel
116Summary: Header files of C++ interface to OpenChange MAPI library
117Summary(pl.UTF-8): Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI
118Group: Development/Libraries
119Requires: %{name}-c++ = %{version}-%{release}
120Requires: %{name}-devel = %{version}-%{release}
121Requires: libstdc++-devel
122
123%description c++-devel
124Header files of C++ interface to OpenChange MAPI library.
125
126%description c++-devel -l pl.UTF-8
127Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI.
128
129%package qt
130Summary: Qt interface to OpenChange MAPI library
131Summary(pl.UTF-8): Interfejs Qt do biblioteki OpenChange MAPI
132Group: Libraries
133Requires: %{name}-c++ = %{version}-%{release}
134Requires: QtCore >= 4.3.0
135Requires: QtGui >= 4.3.0
136
137%description qt
138Qt interface to OpenChange MAPI library.
139
140%description qt -l pl.UTF-8
141Interfejs Qt do biblioteki OpenChange MAPI.
142
143%package qt-devel
144Summary: Header files of Qt interface to OpenChange MAPI library
145Summary(pl.UTF-8): Pliki nagłówkowe interfejsu Qt do biblioteki OpenChange MAPI
146Group: Development/Libraries
147Requires: %{name}-qt = %{version}-%{release}
148Requires: QtGui-devel >= 4.3.0
149
150%description qt-devel
151Header files of Qt interface to OpenChange MAPI library.
152
153%description qt-devel -l pl.UTF-8
154Pliki nagłówkowe interfejsu Qt do biblioteki OpenChange MAPI.
155
156%package apidocs
157Summary: API documentation for OpenChange libraries
158Summary(pl.UTF-8): Dokumentacja API bibliotek OpenChange
159Group: Documentation
160
161%description apidocs
162API documentation for OpenChange libraries.
163
164%description apidocs -l pl.UTF-8
165Dokumentacja API bibliotek OpenChange.
166
167%package -n python-openchange
168Summary: Python interface to OpenChange libraries
169Summary(pl.UTF-8): Interfejs Pythona do bibliotek OpenChange
170Group: Libraries/Python
171Requires: %{name}-libs = %{version}-%{release}
172
173%description -n python-openchange
174Python interface to OpenChange libraries.
175
176%description -n python-openchange -l pl.UTF-8
177Interfejs Pythona do bibliotek OpenChange.
178
179%package -n nagios-plugin-openchange
180Summary: Nagios plugin to check Exchange/OpenChange services
181Summary(pl.UTF-8): Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange
182Group: Networking
183Requires: %{name} = %{version}-%{release}
184Requires: nagios
185
186%description -n nagios-plugin-openchange
187Nagios plugin to check Exchange/OpenChange services.
188
189%description -n nagios-plugin-openchange -l pl.UTF-8
190Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange.
191
192%prep
193%setup -q -n %{name}-%{name}-%{version}-%{cname}
194%patch0 -p1
195%patch1 -p1
196
197# no switch for verbose mode, enable manually :/
198%{__sed} -i -e 's/^ @\(\$(\(PIDL\|CC\|CXX\|MOC\)\)/ \1/' Makefile
199
200%build
201%{__aclocal}
202%{__autoconf}
203%{__autoheader}
204%configure \
205 --datadir=%{_datadir}/openchange \
206 --enable-openchange-qt4 \
207 --enable-pyopenchange \
208 --with-modulesdir=%{_libdir}/openchange/modules
209%{__make}
210
211%if %{with apidocs}
212%{__make} doxygen
213%endif
214
215%install
216rm -rf $RPM_BUILD_ROOT
217
218%{__make} install \
219 DESTDIR=$RPM_BUILD_ROOT
220
221# doxygen generated man pages are messy; use HTML docs and install man1 pages manually
222%if 0
223%{__make} installman \
224 DESTDIR=$RPM_BUILD_ROOT
225%else
226install -d $RPM_BUILD_ROOT%{_mandir}/man1
227cp doc/man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
228%endif
229
230# missing from make install
231install -d $RPM_BUILD_ROOT%{_includedir}/libqtmapi
232cp -p qt/lib/*.h $RPM_BUILD_ROOT%{_includedir}/libqtmapi
233cp -a libqtmapi.so.*.* libqtmapi.so $RPM_BUILD_ROOT%{_libdir}
234
235# tests
236%{__rm} $RPM_BUILD_ROOT%{_bindir}/{check_fasttransfer,openchange-testsuite,test_asyncnotif}
237
238/sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir}
239
240%py_comp $RPM_BUILD_ROOT%{py_sitedir}
241%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
242%py_postclean
243
244%clean
245rm -rf $RPM_BUILD_ROOT
246
247%post libs -p /sbin/ldconfig
248%postun libs -p /sbin/ldconfig
249
250%post c++ -p /sbin/ldconfig
251%postun c++ -p /sbin/ldconfig
252
253%post qt -p /sbin/ldconfig
254%postun qt -p /sbin/ldconfig
255
256%files
257%defattr(644,root,root,755)
258%doc CHANGES.md IDL_LICENSE.txt README.md README.smbconf.md doc/howto.txt
259%attr(755,root,root) %{_bindir}/exchange2ical
260%attr(755,root,root) %{_bindir}/exchange2mbox
261%attr(755,root,root) %{_bindir}/mapiprofile
262%attr(755,root,root) %{_bindir}/mapipropsdump
263%attr(755,root,root) %{_bindir}/mapitest
264%attr(755,root,root) %{_bindir}/ocnotify
265%attr(755,root,root) %{_bindir}/openchangeclient
266%attr(755,root,root) %{_bindir}/openchangemapidump
267%attr(755,root,root) %{_bindir}/openchangepfadmin
268%attr(755,root,root) %{_bindir}/rpcextract
269%attr(755,root,root) %{_bindir}/schemaIDGUID
270%attr(755,root,root) %{_sbindir}/openchange_group
271%attr(755,root,root) %{_sbindir}/openchange_migrate
272%attr(755,root,root) %{_sbindir}/openchange_neworganization
273%attr(755,root,root) %{_sbindir}/openchange_newuser
274%attr(755,root,root) %{_sbindir}/openchange_provision
275# XXX: dir specified by dcerpc_server.pc file, should belong to samba or samba-libs
276%dir %{_libdir}/samba/dcerpc_server
277%attr(755,root,root) %{_libdir}/samba/dcerpc_server/dcesrv_asyncemsmdb.so
278%attr(755,root,root) %{_libdir}/samba/dcerpc_server/dcesrv_mapiproxy.so
279%dir %{_libdir}/openchange
280%dir %{_libdir}/openchange/modules
281%dir %{_libdir}/openchange/modules/dcerpc_mapiproxy
282%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_cache.so
283%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_downgrade.so
284%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_dummy.so
285%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy/mpm_pack.so
286%dir %{_libdir}/openchange/modules/dcerpc_mapiproxy_server
287%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_ds_rfr.so
288%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_emsmdb.so
289%attr(755,root,root) %{_libdir}/openchange/modules/dcerpc_mapiproxy_server/exchange_nsp.so
290%dir %{_datadir}/openchange
291%{_datadir}/openchange/mapitest
292%dir %{_datadir}/openchange/setup
293%{_datadir}/openchange/setup/mapistore
294%{_datadir}/openchange/setup/openchangedb
295%{_datadir}/openchange/setup/profiles
296%dir %{_datadir}/samba/setup/AD
297%{_datadir}/samba/setup/AD/oc_provision_*.ldif
298%{_datadir}/samba/setup/AD/provision_schema_basedn_modify.ldif
299%{_datadir}/samba/setup/AD/update_now.ldif
300%{_datadir}/samba/setup/AD/prefixMap.txt
301%{_mandir}/man1/exchange2ical.1*
302%{_mandir}/man1/exchange2mbox.1*
303%{_mandir}/man1/mapiprofile.1*
304%{_mandir}/man1/mapitest.1*
305%{_mandir}/man1/openchangeclient.1*
306%{_mandir}/man1/openchangepfadmin.1*
307
308%files libs
309%defattr(644,root,root,755)
310%attr(755,root,root) %{_libdir}/libmapi.so.*.*
311%attr(755,root,root) %ghost %{_libdir}/libmapi.so.0
312%attr(755,root,root) %{_libdir}/libmapiadmin.so.*.*
313%attr(755,root,root) %ghost %{_libdir}/libmapiadmin.so.0
314%attr(755,root,root) %{_libdir}/libmapiproxy.so.*.*
315%attr(755,root,root) %ghost %{_libdir}/libmapiproxy.so.0
316%attr(755,root,root) %{_libdir}/libmapiserver.so.*.*
317%attr(755,root,root) %ghost %{_libdir}/libmapiserver.so.0
318%attr(755,root,root) %{_libdir}/libmapistore.so.*.*
319%attr(755,root,root) %ghost %{_libdir}/libmapistore.so.0
320%attr(755,root,root) %{_libdir}/libocpf.so.*.*
321%attr(755,root,root) %ghost %{_libdir}/libocpf.so.0
322
323%files devel
324%defattr(644,root,root,755)
325%attr(755,root,root) %{_libdir}/libmapi.so
326%attr(755,root,root) %{_libdir}/libmapiadmin.so
327%attr(755,root,root) %{_libdir}/libmapiproxy.so
328%attr(755,root,root) %{_libdir}/libmapiserver.so
329%attr(755,root,root) %{_libdir}/libmapistore.so
330%attr(755,root,root) %{_libdir}/libocpf.so
331%{_includedir}/gen_ndr
332%{_includedir}/libmapi
333%{_includedir}/libmapiadmin
334%{_includedir}/libocpf
335%{_includedir}/mapistore
336%{_includedir}/libmapiproxy.h
337%{_includedir}/libmapiserver.h
338%{_pkgconfigdir}/libmapi.pc
339%{_pkgconfigdir}/libmapiadmin.pc
340%{_pkgconfigdir}/libmapiproxy.pc
341%{_pkgconfigdir}/libmapiserver.pc
342%{_pkgconfigdir}/libmapistore.pc
343%{_pkgconfigdir}/libocpf.pc
344
345%files c++
346%defattr(644,root,root,755)
347%attr(755,root,root) %{_libdir}/libmapipp.so.*.*
348%attr(755,root,root) %ghost %{_libdir}/libmapipp.so.0
349
350%files c++-devel
351%defattr(644,root,root,755)
352%attr(755,root,root) %{_libdir}/libmapipp.so
353%{_includedir}/libmapi++
354%{_pkgconfigdir}/libmapi++.pc
355
356%files qt
357%defattr(644,root,root,755)
358%attr(755,root,root) %{_libdir}/libqtmapi.so.*.*
359%attr(755,root,root) %ghost %{_libdir}/libqtmapi.so.0
360
361%files qt-devel
362%defattr(644,root,root,755)
363%attr(755,root,root) %{_libdir}/libqtmapi.so
364%{_includedir}/libqtmapi
365
366%if %{with apidocs}
367%files apidocs
368%defattr(644,root,root,755)
369%doc apidocs/html/*
370%endif
371
372%files -n python-openchange
373%defattr(644,root,root,755)
374%dir %{py_sitedir}/openchange
375%attr(755,root,root) %{py_sitedir}/openchange/mapi.so
376%attr(755,root,root) %{py_sitedir}/openchange/mapistore.so
377%{py_sitedir}/openchange/*.py[co]
378%{py_sitedir}/openchange/migration
379%{py_sitedir}/openchange/tests
380%{py_sitedir}/openchange/utils
381%{py_sitedir}/openchange/web
382
383%files -n nagios-plugin-openchange
384%defattr(644,root,root,755)
385# R: perl, openchangeclient
386%attr(755,root,root) %{_libdir}/nagios/check_exchange
387# default profile database - should be /etc/...
388#%config(noreplace) %verify(not md5 mtime size) %{_libdir}/nagios/plugins/check_exchange.ldb
This page took 0.031151 seconds and 4 git commands to generate.