]> git.pld-linux.org Git - packages/openchange.git/blame - openchange.spec
- rel 11
[packages/openchange.git] / openchange.spec
CommitLineData
b3ba35a0
ER
1# TODO
2# - nagios plugin (see it's files section for details)
cc90af90
JB
3#
4# Conditional build:
5%bcond_without apidocs # do not build and package API docs
b3ba35a0
ER
6
7%define cname VULCAN
cc90af90
JB
8Summary: OpenChange - portable implementation of MS Exchange Server and Exchange protocols
9Summary(pl.UTF-8): OpenChange - przenośna implementacja serwera oraz protokołów MS Exchange
10Name: openchange
11Version: 2.3
db79d4b2 12Release: 11
cc90af90
JB
13License: GPL v3+
14Group: Libraries
cc90af90
JB
15Source0: https://github.com/openchange/openchange/archive/%{name}-%{version}-%{cname}.tar.gz
16# Source0-md5: 96c13c78c2bcbd7040f7848746284b9f
db79d4b2 17Patch0: disable-mapiproxy.patch
cc90af90 18Patch1: %{name}-link.patch
2407fd75 19Patch2: flex2.6.patch
db79d4b2
JR
20Patch3: samba-4.2.patch
21Patch4: fix-connection-args.patch
22Patch5: samba-4.4.patch
cc90af90
JB
23URL: http://www.openchange.org/
24BuildRequires: QtCore-devel >= 4.3.0
25BuildRequires: QtGui-devel >= 4.3.0
26BuildRequires: autoconf >= 2.57
27BuildRequires: automake
28BuildRequires: check-devel
29BuildRequires: doxygen
30BuildRequires: ldb-devel
31BuildRequires: libical-devel >= 0.46
32BuildRequires: libmagic-devel
33BuildRequires: libmemcached-devel >= 1.0.18
34BuildRequires: libpcap-devel
35BuildRequires: libstdc++-devel
36BuildRequires: mysql-devel
37BuildRequires: nanomsg-devel >= 0.5
38BuildRequires: perl-base
39BuildRequires: pkgconfig >= 1:0.20
40BuildRequires: popt-devel
41BuildRequires: python-devel >= 1:2.7
ce2c05b9 42BuildRequires: python-samba >= 4.2.2
cc90af90 43BuildRequires: rpmbuild(macros) >= 1.219
e0431659
JB
44# with DCERCP multiplex and pending call support (upstream 4.1.18+ or 4.2.2+)
45BuildRequires: samba-devel >= 4.2.2
46BuildRequires: samba-pidl >= 4.2.2
cc90af90
JB
47BuildRequires: sed >= 4.0
48BuildRequires: subunit-devel
49BuildRequires: talloc-devel
50BuildRequires: tdb-devel
51BuildRequires: zlib-devel
52Requires: %{name}-libs = %{version}-%{release}
53Requires: python-openchange = %{version}-%{release}
54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
cc90af90
JB
56%description
57OpenChange is a portable Open Source implementation of Microsoft
58Exchange server and Exchange protocols. It provides a complete
59solution to interoperate with Microsoft Outlook clients or Microsoft
60Exchange servers.
61
62OpenChange client-side library is used in existing messaging clients
63and is the solution in new projects to communicate natively with
64Microsoft Exchange and Exchange-compatible servers. OpenChange server
65is a transparent Microsoft Exchange server replacement using native
66Exchange protocols and does not require any plugin installation in
67Outlook.
68
69%description -l pl.UTF-8
70OpenChange to przenośna, mająca otwarte źródła implementacja serwera
71oraz protokołów Microsoft Exchange. Dostarcza kompletne rozwiązanie
72pozwalające współpracować z klientami Microsoft Outlook oraz serwerami
73Microsoft Exchange.
74
75Biblioteka kliencka OpenChange jest używana przez istniejących
76klientów pocztowych i pozwalają na natywną komunikację z serwerami
77Microsoft Exchange oraz zgodnymi. Serwer OpenChange to przezroczysty
78zamiennik serwera Microsoft Exchange wykorzystujący natywne protokoły
79Exchange, nie wymagający instalowania żadnych wtyczek w Outlooku.
80
81%package libs
82Summary: OpenChange client libraries
83Summary(pl.UTF-8): Biblioteki klienckie OpenChange
84Group: Libraries
85
86%description libs
87OpenChange client libraries.
88
89%description libs -l pl.UTF-8
90Biblioteki klienckie OpenChange.
91
92%package devel
93Summary: Header files for OpenChange libraries
94Summary(pl.UTF-8): Pliki nagłówkowe bibliotek OpenChange
95Group: Development/Libraries
96Requires: %{name}-libs = %{version}-%{release}
f6e502a6 97Requires: ldb-devel
e0431659 98Requires: samba-devel >= 4.2.2
f6e502a6
JB
99Requires: talloc-devel
100Requires: tevent-devel
101Requires: zlib-devel
cc90af90
JB
102
103%description devel
104Header files for OpenChange libraries.
105
106%description devel -l pl.UTF-8
107Pliki nagłówkowe bibliotek OpenChange.
108
109%package c++
110Summary: C++ interface to OpenChange MAPI library
111Summary(pl.UTF-8): Interfejs C++ do biblioteki OpenChange MAPI
112Group: Libraries
f6e502a6 113Requires: %{name}-libs = %{version}-%{release}
cc90af90
JB
114
115%description c++
116C++ interface to OpenChange MAPI library.
117
118%description c++ -l pl.UTF-8
119Interfejs C++ do biblioteki OpenChange MAPI.
120
121%package c++-devel
122Summary: Header files of C++ interface to OpenChange MAPI library
123Summary(pl.UTF-8): Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI
124Group: Development/Libraries
125Requires: %{name}-c++ = %{version}-%{release}
f6e502a6
JB
126Requires: %{name}-devel = %{version}-%{release}
127Requires: libstdc++-devel
cc90af90
JB
128
129%description c++-devel
130Header files of C++ interface to OpenChange MAPI library.
131
132%description c++-devel -l pl.UTF-8
133Pliki nagłówkowe interfejsu C++ do biblioteki OpenChange MAPI.
134
135%package qt
136Summary: Qt interface to OpenChange MAPI library
137Summary(pl.UTF-8): Interfejs Qt do biblioteki OpenChange MAPI
138Group: Libraries
f6e502a6
JB
139Requires: %{name}-c++ = %{version}-%{release}
140Requires: QtCore >= 4.3.0
141Requires: QtGui >= 4.3.0
cc90af90
JB
142
143%description qt
144Qt interface to OpenChange MAPI library.
145
146%description qt -l pl.UTF-8
147Interfejs Qt do biblioteki OpenChange MAPI.
148
149%package qt-devel
150Summary: Header files of Qt interface to OpenChange MAPI library
151Summary(pl.UTF-8): Pliki nagłówkowe interfejsu Qt do biblioteki OpenChange MAPI
152Group: Development/Libraries
153Requires: %{name}-qt = %{version}-%{release}
f6e502a6 154Requires: QtGui-devel >= 4.3.0
cc90af90
JB
155
156%description qt-devel
157Header files of Qt interface to OpenChange MAPI library.
158
159%description qt-devel -l pl.UTF-8
160Pliki nagłówkowe interfejsu Qt do biblioteki OpenChange MAPI.
161
162%package apidocs
163Summary: API documentation for OpenChange libraries
164Summary(pl.UTF-8): Dokumentacja API bibliotek OpenChange
165Group: Documentation
b3ba35a0
ER
166%if "%{_rpmversion}" >= "5"
167BuildArch: noarch
168%endif
cc90af90
JB
169
170%description apidocs
171API documentation for OpenChange libraries.
172
173%description apidocs -l pl.UTF-8
174Dokumentacja API bibliotek OpenChange.
175
176%package -n python-openchange
177Summary: Python interface to OpenChange libraries
178Summary(pl.UTF-8): Interfejs Pythona do bibliotek OpenChange
179Group: Libraries/Python
180Requires: %{name}-libs = %{version}-%{release}
181
182%description -n python-openchange
183Python interface to OpenChange libraries.
184
185%description -n python-openchange -l pl.UTF-8
186Interfejs Pythona do bibliotek OpenChange.
187
188%package -n nagios-plugin-openchange
189Summary: Nagios plugin to check Exchange/OpenChange services
190Summary(pl.UTF-8): Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange
191Group: Networking
192Requires: %{name} = %{version}-%{release}
193Requires: nagios
194
195%description -n nagios-plugin-openchange
196Nagios plugin to check Exchange/OpenChange services.
197
198%description -n nagios-plugin-openchange -l pl.UTF-8
199Wtyczka Nagiosa do sprawdzania usług Exchange/OpenChange.
200
201%prep
202%setup -q -n %{name}-%{name}-%{version}-%{cname}
203%patch0 -p1
204%patch1 -p1
2407fd75 205%patch2 -p1
db79d4b2
JR
206%patch3 -p1
207%patch4 -p1
208%patch5 -p1
cc90af90
JB
209
210# no switch for verbose mode, enable manually :/
211%{__sed} -i -e 's/^ @\(\$(\(PIDL\|CC\|CXX\|MOC\)\)/ \1/' Makefile
212
213%build
214%{__aclocal}
215%{__autoconf}
216%{__autoheader}
217%configure \
218 --datadir=%{_datadir}/openchange \
219 --enable-openchange-qt4 \
220 --enable-pyopenchange \
221 --with-modulesdir=%{_libdir}/openchange/modules
222%{__make}
223
224%if %{with apidocs}
225%{__make} doxygen
226%endif
227
228%install
229rm -rf $RPM_BUILD_ROOT
230
231%{__make} install \
232 DESTDIR=$RPM_BUILD_ROOT
233
234# doxygen generated man pages are messy; use HTML docs and install man1 pages manually
235%if 0
236%{__make} installman \
237 DESTDIR=$RPM_BUILD_ROOT
238%else
239install -d $RPM_BUILD_ROOT%{_mandir}/man1
240cp doc/man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
241%endif
242
243# missing from make install
244install -d $RPM_BUILD_ROOT%{_includedir}/libqtmapi
245cp -p qt/lib/*.h $RPM_BUILD_ROOT%{_includedir}/libqtmapi
246cp -a libqtmapi.so.*.* libqtmapi.so $RPM_BUILD_ROOT%{_libdir}
247
248# tests
249%{__rm} $RPM_BUILD_ROOT%{_bindir}/{check_fasttransfer,openchange-testsuite,test_asyncnotif}
250
251/sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir}
252
253%py_comp $RPM_BUILD_ROOT%{py_sitedir}
254%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
255%py_postclean
256
257%clean
258rm -rf $RPM_BUILD_ROOT
259
c949a72b
JB
260%post libs -p /sbin/ldconfig
261%postun libs -p /sbin/ldconfig
262
263%post c++ -p /sbin/ldconfig
264%postun c++ -p /sbin/ldconfig
265
503206d3
JB
266%post qt -p /sbin/ldconfig
267%postun qt -p /sbin/ldconfig
cc90af90
JB
268
269%files
270%defattr(644,root,root,755)
271%doc CHANGES.md IDL_LICENSE.txt README.md README.smbconf.md doc/howto.txt
272%attr(755,root,root) %{_bindir}/exchange2ical
273%attr(755,root,root) %{_bindir}/exchange2mbox
274%attr(755,root,root) %{_bindir}/mapiprofile
275%attr(755,root,root) %{_bindir}/mapipropsdump
cc90af90
JB
276%attr(755,root,root) %{_bindir}/ocnotify
277%attr(755,root,root) %{_bindir}/openchangeclient
278%attr(755,root,root) %{_bindir}/openchangemapidump
279%attr(755,root,root) %{_bindir}/openchangepfadmin
280%attr(755,root,root) %{_bindir}/rpcextract
281%attr(755,root,root) %{_bindir}/schemaIDGUID
cc90af90 282%dir %{_datadir}/openchange
cc90af90 283%dir %{_datadir}/openchange/setup
cc90af90 284%{_datadir}/openchange/setup/profiles
cc90af90
JB
285%{_mandir}/man1/exchange2ical.1*
286%{_mandir}/man1/exchange2mbox.1*
287%{_mandir}/man1/mapiprofile.1*
288%{_mandir}/man1/mapitest.1*
289%{_mandir}/man1/openchangeclient.1*
290%{_mandir}/man1/openchangepfadmin.1*
291
292%files libs
293%defattr(644,root,root,755)
294%attr(755,root,root) %{_libdir}/libmapi.so.*.*
295%attr(755,root,root) %ghost %{_libdir}/libmapi.so.0
296%attr(755,root,root) %{_libdir}/libmapiadmin.so.*.*
297%attr(755,root,root) %ghost %{_libdir}/libmapiadmin.so.0
cc90af90
JB
298%attr(755,root,root) %{_libdir}/libocpf.so.*.*
299%attr(755,root,root) %ghost %{_libdir}/libocpf.so.0
300
301%files devel
302%defattr(644,root,root,755)
303%attr(755,root,root) %{_libdir}/libmapi.so
304%attr(755,root,root) %{_libdir}/libmapiadmin.so
cc90af90
JB
305%attr(755,root,root) %{_libdir}/libocpf.so
306%{_includedir}/gen_ndr
307%{_includedir}/libmapi
cc90af90
JB
308%{_includedir}/libmapiadmin
309%{_includedir}/libocpf
cc90af90 310%{_pkgconfigdir}/libmapi.pc
cc90af90 311%{_pkgconfigdir}/libmapiadmin.pc
cc90af90
JB
312%{_pkgconfigdir}/libocpf.pc
313
c949a72b
JB
314%files c++
315%defattr(644,root,root,755)
316%attr(755,root,root) %{_libdir}/libmapipp.so.*.*
317%attr(755,root,root) %ghost %{_libdir}/libmapipp.so.0
318
319%files c++-devel
320%defattr(644,root,root,755)
321%attr(755,root,root) %{_libdir}/libmapipp.so
322%{_includedir}/libmapi++
323%{_pkgconfigdir}/libmapi++.pc
324
cc90af90
JB
325%files qt
326%defattr(644,root,root,755)
327%attr(755,root,root) %{_libdir}/libqtmapi.so.*.*
328%attr(755,root,root) %ghost %{_libdir}/libqtmapi.so.0
329
330%files qt-devel
331%defattr(644,root,root,755)
332%attr(755,root,root) %{_libdir}/libqtmapi.so
333%{_includedir}/libqtmapi
334
335%if %{with apidocs}
336%files apidocs
337%defattr(644,root,root,755)
338%doc apidocs/html/*
339%endif
340
341%files -n python-openchange
342%defattr(644,root,root,755)
343%dir %{py_sitedir}/openchange
344%attr(755,root,root) %{py_sitedir}/openchange/mapi.so
345%attr(755,root,root) %{py_sitedir}/openchange/mapistore.so
cc90af90
JB
346
347%files -n nagios-plugin-openchange
348%defattr(644,root,root,755)
349# R: perl, openchangeclient
b3ba35a0 350# FIXME: use /usr/lib/nagios/plugins dir and make package noarch
cc90af90
JB
351%attr(755,root,root) %{_libdir}/nagios/check_exchange
352# default profile database - should be /etc/...
353#%config(noreplace) %verify(not md5 mtime size) %{_libdir}/nagios/plugins/check_exchange.ldb
This page took 0.102214 seconds and 4 git commands to generate.