]> git.pld-linux.org Git - packages/open-vm-tools.git/commitdiff
- updated to 11.0.5 auto/th/open-vm-tools-11.0.5-1
authorBartek Szady <bszx@bszx.eu>
Mon, 11 May 2020 08:30:08 +0000 (10:30 +0200)
committerBartek Szady <bszx@bszx.eu>
Mon, 11 May 2020 12:06:40 +0000 (14:06 +0200)
- dropped support for vmsync. It is needed on kernels older than 3.0
- added patch to enable running on kernel without IOPERM and IOPL Emulation

iopl.patch [new file with mode: 0644]
log.patch [new file with mode: 0644]
open-vm-tools-init
open-vm-tools.spec

diff --git a/iopl.patch b/iopl.patch
new file mode 100644 (file)
index 0000000..bd6cfe7
--- /dev/null
@@ -0,0 +1,11 @@
+--- open-vm-tools-stable-11.0.5/open-vm-tools/lib/misc/hostinfoPosix.c.orig    2020-01-15 23:24:15.000000000 +0100
++++ open-vm-tools-stable-11.0.5/open-vm-tools/lib/misc/hostinfoPosix.c 2020-05-11 11:30:05.938853674 +0200
+@@ -2498,7 +2498,7 @@
+       err = iopl(0);
+ #endif
+       Id_SetEUid(euid);
+-      VERIFY(err == 0);
++      VERIFY(err == 0 || (err == -1 && errno == ENOSYS));
+    }
+ #endif
+ }
diff --git a/log.patch b/log.patch
new file mode 100644 (file)
index 0000000..a4bf451
--- /dev/null
+++ b/log.patch
@@ -0,0 +1,39 @@
+commit c53e54623f537e96a66811e16d48a2523f4833f8
+Author: Oliver Kurth <okurth@vmware.com>
+Date:   Wed Mar 4 12:07:11 2020 -0800
+
+    Rectify a log spew in vmsvc logging (vmware-vmsvc-root.log)
+    
+    When a LSI Logic Parallel SCSI controller sits in PCI bus 0
+    (SCSI controller 0), the Linux disk device enumeration does not provide
+    a "label" file with the controller name.  This results in messages like
+    
+    'GuestInfoGetDiskDevice: Missing disk device name; VMDK mapping
+    unavailable for "/var/log", fsName: "/dev/sda2"'
+    
+    repeatedly appearing in the vmsvc logging.  The patch converts what
+    previously was a warning message to a debug message and thus avoids
+    the log spew.
+    
+    This patch has been made available for open-vm-tools 11.0.x on the
+    open-vm-tools github repo.
+    
+    https://github.com/vmware/open-vm-tools/issues/404
+
+diff --git a/open-vm-tools/services/plugins/guestInfo/diskInfo.c b/open-vm-tools/services/plugins/guestInfo/diskInfo.c
+index 878276ce..032c0928 100644
+--- a/open-vm-tools/services/plugins/guestInfo/diskInfo.c
++++ b/open-vm-tools/services/plugins/guestInfo/diskInfo.c
+@@ -846,9 +846,9 @@ GuestInfoGetDiskDevice(const char *fsName,
+     */
+    for (indx = 0; indx < partEntry->diskDevCnt; indx++) {
+       if (partEntry->diskDevNames[indx][0] == '\0') {
+-         g_warning("%s: Missing disk device name; VMDK mapping unavailable "
+-                   "for \"%s\", fsName: \"%s\"\n", __FUNCTION__,
+-                   partEntry->name, fsName);
++         g_debug("%s: Missing disk device name; VMDK mapping unavailable "
++                 "for \"%s\", fsName: \"%s\"\n", __FUNCTION__,
++                 partEntry->name, fsName);
+          partEntry->diskDevCnt = 0;
+          free(partEntry->diskDevNames);
+          partEntry->diskDevNames = NULL;
index 6ba5d0dbf128e5ef2f9e31741e569067fad8bee7..c6588cd37eb69397396b7487b446d8d506420238 100755 (executable)
@@ -115,7 +115,6 @@ start_vmsync() {
                return
        fi
 
-       _modprobe single vmsync
        msg_starting "Open Virtual Machine vmsync script"
        daemon /usr/bin/vmtoolsd --background /var/run/vmtoolsd.pid
        RETVAL=$?
index 704d512226cc8f2b10d5951396769fedc3ba6f64..a008c224b2c291ce02bfbbf124841cd8669c8231 100644 (file)
 Summary:       VMWare guest utilities
 Summary(pl.UTF-8):     Narzędzia dla systemu-gościa dla VMware
 Name:          open-vm-tools
-Version:       11.0.1
+Version:       11.0.5
 Release:       1
 Epoch:         1
 License:       GPL
 Group:         Applications/System
 Source0:       https://github.com/vmware/open-vm-tools/archive/stable-%{version}.tar.gz
-# Source0-md5: 5545010bb96f745b5fca4f18777d00d8
+# Source0-md5: e05302d339b5282b97e769be421b22b1
 Source1:       %{name}-packaging
 Source2:       %{name}-modprobe.d
 Source3:       %{name}-init
@@ -25,6 +25,8 @@ Source4:      %{name}-vmware-user.desktop
 Source5:       vmware-vmblock-fuse.service
 Source6:       vmtoolsd.pamd
 Patch0:                %{name}-dnd.patch
+Patch1:                iopl.patch
+Patch2:                log.patch
 URL:           https://github.com/vmware/open-vm-tools
 BuildRequires: autoconf
 BuildRequires: doxygen
@@ -137,6 +139,8 @@ Reguły UDEV dla open-vm-tools.
 %prep
 %setup -q -n %{name}-stable-%{version}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 cp %{SOURCE1} open-vm-tools/packaging
 
@@ -201,12 +205,13 @@ fi
 %systemd_preun vmware-vmblock-fuse.service
 
 
-%postun -p /sbin/ldconfig
+%postun
+/sbin/ldconfig
 %systemd_reload
 
 %files
 %defattr(644,root,root,755)
-%doc open-vm-tools/AUTHORS open-vm-tools/ChangeLog open-vm-tools/NEWS open-vm-tools/README open-vm-tools/packaging
+%doc README.md ReleaseNotes.md open-vm-tools/AUTHORS open-vm-tools/ChangeLog open-vm-tools/README open-vm-tools/packaging
 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/vmtoolsd
 %dir /etc/vmware-tools
 %attr(755,root,root) /etc/vmware-tools/*vm-*
@@ -229,6 +234,7 @@ fi
 %attr(755,root,root) %{_bindir}/vmware-toolbox-cmd
 %attr(755,root,root) %{_bindir}/vmware-xferlogs
 %attr(755,root,root) %{_bindir}/vmware-vgauth-cmd
+%attr(755,root,root) %{_bindir}/vmware-vgauth-smoketest
 %attr(755,root,root) %{_bindir}/vmware-vmblock-fuse
 %attr(755,root,root) %{_sbindir}/mount.vmhgfs
 %attr(755,root,root) %{_libdir}/libDeployPkg.so.*.*.*
This page took 0.34519 seconds and 4 git commands to generate.