]> git.pld-linux.org Git - packages/opal.git/commitdiff
- changed exceptions patch so that it affects only vpb plugin;
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 2 Feb 2013 16:58:00 +0000 (17:58 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 2 Feb 2013 16:58:00 +0000 (17:58 +0100)
  enabled vpb by default, as -lid-vpb subpackage
- added ruby patch, completed java and ruby bconds (but JNI and Ruby support looks incomplete,
  so not enabling by default)

opal-exceptions.patch
opal-ruby.patch [new file with mode: 0644]
opal.spec

index 8e81415ff8fea94eb10f9206a365220deeffbb1c..4bc1aeccd641f62a4dc096bf98acfb551cb7e196 100644 (file)
@@ -1,19 +1,9 @@
---- opal-3.10.9/opal.m4.orig   2013-02-01 20:14:24.184072390 +0100
-+++ opal-3.10.9/opal.m4        2013-02-01 20:53:31.337356800 +0100
-@@ -292,7 +292,7 @@
-           OSTYPE=`$PKG_CONFIG ptlib --variable=ostype`
+--- opal-3.10.9/plugins/LID/VPB/Makefile.in.orig       2012-11-26 11:48:28.000000000 +0100
++++ opal-3.10.9/plugins/LID/VPB/Makefile.in    2013-02-02 12:57:10.136151676 +0100
+@@ -47,5 +47,6 @@
+ INSTALL_DIR := @LID_PLUGIN_DIR@
+ PLUGINDIR   := @PLUGINDIR@
+ include $(PLUGINDIR)/plugin-inc.mak
++CFLAGS += -fexceptions
  
-             PTLIB_VERSION=`$PKG_CONFIG ptlib --modversion`
--            PTLIB_CFLAGS=`$PKG_CONFIG ptlib --cflags`
-+            PTLIB_CFLAGS=`$PKG_CONFIG ptlib --cflags | sed -e 's, *-fno-exceptions,,'`
-             PTLIB_CXXFLAGS=`$PKG_CONFIG ptlib --variable=cxxflags`
-             PTLIB_LIBS=`$PKG_CONFIG ptlib --libs`
-@@ -311,6 +311,7 @@
-           OSTYPE=`$PKG_CONFIG ptlib --variable=ostype`
-             PTLIB_VERSION=`$PKG_CONFIG ptlib --modversion`
-+            PTLIB_CFLAGS=`$PKG_CONFIG ptlib --cflags | sed -e 's, *-fno-exceptions,,'`
-             PTLIB_CXXFLAGS=`$PKG_CONFIG ptlib --variable=cxxflags` 
-             DEBUG_LIBS=`$PKG_CONFIG ptlib --define-variable=suffix=_d --libs`
-             RELEASE_LIBS="$PTLIB_LIBS"
+ ###########################################
diff --git a/opal-ruby.patch b/opal-ruby.patch
new file mode 100644 (file)
index 0000000..4420744
--- /dev/null
@@ -0,0 +1,21 @@
+--- opal-3.10.9/configure.ac.orig      2013-02-02 11:32:55.486257032 +0100
++++ opal-3.10.9/configure.ac   2013-02-02 12:55:44.492820131 +0100
+@@ -453,7 +453,7 @@
+ if test "x$OPAL_RUBY" = "xyes" ; then
+   AC_CHECK_PROG(HAS_RUBY,ruby,yes)
+   if test "x$HAS_RUBY" = "xyes" ; then
+-    RUBY_CFLAGS=-I`ruby -e 'puts $:.join(" -I")'`
++    RUBY_CFLAGS="$(ruby -r rbconfig -e 'printf("-I%s -I%s/%s", Config::CONFIG[["rubyhdrdir"]], Config::CONFIG[["rubyhdrdir"]], Config::CONFIG[["arch"]])' 2>/dev/null)"
+     oldCFLAGS="$CFLAGS"
+     oldCPPFLAGS="$CPPFLAGS"
+     CFLAGS="$CFLAGS $RUBY_CFLAGS"
+--- opal-3.10.9/opal_defs.mak.in.orig  2012-11-26 11:49:22.000000000 +0100
++++ opal-3.10.9/opal_defs.mak.in       2013-02-02 17:03:28.472510316 +0100
+@@ -111,6 +111,7 @@
+ OPAL_T38_CAP    = @OPAL_T38_CAPABILITY@
+ OPAL_FAX          = @OPAL_FAX@
+ OPAL_JAVA         = @OPAL_JAVA@
++OPAL_RUBY         = @OPAL_RUBY@
+ SPEEXDSP_SYSTEM   = @SPEEXDSP_SYSTEM@
+ OPAL_HAS_MSRP   = @OPAL_HAS_MSRP@
+ OPAL_HAS_SIPIM          = @OPAL_HAS_SIPIM@
index 9a5a1098486dfd656e9b9a4e65c86a8d8f7f667b..a85a9c47a14bd93905e8039df8d258376ef37e72 100644 (file)
--- a/opal.spec
+++ b/opal.spec
 %bcond_without srtp            # SRTP protocol support (mutually exclusive with zrtp)
 %bcond_with    zrtp            # ZRTP protocol support (mutually exclusive with zrtp; broken as of 3.10.9)
 %bcond_without capi            # CAPI support
-%bcond_with    vpb             # Voicetronix VPB support
-%bcond_with    java            # Java JNI support
-%bcond_with    ruby            # Ruby support
+%bcond_without vpb             # Voicetronix VPB support
+%bcond_with    java            # Java JNI interface (only swig wrapper, Java part not built)
+%bcond_with    ruby            # Ruby interface (very initial, only swig wrapper)
 #
 %if %{with zrtp}
 %undefine      with_srtp
 %endif
 %if %{with sip_fax_only}
+%undefine      with_java
+%undefine      with_ruby
 %undefine      with_srtp
 %undefine      with_zrtp
 %endif
@@ -39,6 +41,7 @@ Patch2:               %{name}-sh.patch
 Patch3:                %{name}-libilbc.patch
 Patch4:                %{name}-ah.patch
 Patch5:                %{name}-exceptions.patch
+Patch6:                %{name}-ruby.patch
 URL:           http://www.opalvoip.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -85,6 +88,18 @@ wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
 który może być używany przez użytkowników prywatnych i komercyjnych
 bez opłat.
 
+%package lid-vpb
+Summary:       Opal LID plugin for Voicetronix VPB devices
+Summary(pl.UTF-8):     Wtyczka Opal LID dla urządzeń VPB firmy Voicetronix
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description lid-vpb
+Opal LID plugin for Voicetronix VPB devices.
+
+%description lid-vpb -l pl.UTF-8
+Wtyczka Opal LID dla urządzeń VPB firmy Voicetronix.
+
 %package devel
 Summary:       Opal development files
 Summary(pl.UTF-8):     Pliki dla developerów Opal
@@ -123,7 +138,8 @@ Biblioteki statyczne OPAL.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%{?with_vpb:%patch5 -p1}
+%patch5 -p1
+%patch6 -p1
 
 %build
 PWLIBDIR=%{_prefix}; export PWLIBDIR
@@ -139,6 +155,7 @@ cd plugins
 cd ..
 # Run  grep '^OPAL_.*=' configure.ac|grep 'yes\|no'  to check current defaults
 %configure \
+       %{?with_java:JDK_ROOT=%{_jvmdir}/java} \
 %if %{with sip_fax_only}
        --disable-aec \
        --disable-g711plc \
@@ -150,7 +167,6 @@ cd ..
        --disable-h501 \
        --disable-iax \
        --disable-ivr \
-       --disable-java \
        --disable-lid \
        --disable-plugins
        --disable-rfc4103 \
@@ -158,11 +174,12 @@ cd ..
        --disable-sipim \
        --disable-video \
 %else
+       --enable-ixj \
+%endif
        %{!?with_capi:--disable-capi} \
        %{!?with_celt:--disable-celt} \
-       --enable-ixj \
-       %{?with_java:--enable-java} \
-       %{?with_ruby:--enable-ruby} \
+       %{!?with_java:--disable-java} \
+       %{!?with_ruby:--disable-ruby} \
        %{!?with_srtp:--disable-srtp} \
        %{?with_vpb:--enable-vpb} \
 %if %{with zrtp}
@@ -172,7 +189,6 @@ cd ..
        --with-zrtp-includedir=/usr/include/libzrtp \
        --with-zrtp-libdir=%{_libdir}
 %endif
-%endif
 
 %{__make} %{?debug:debug}%{!?debug:opt} \
        CC="%{__cc}" \
@@ -244,7 +260,12 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/opal-%{version}/fax/spandsp_ptplugin.so
 %dir %{_libdir}/opal-%{version}/lid
 %attr(755,root,root) %{_libdir}/opal-%{version}/lid/ixj_lid_pwplugin.so
-%{?with_vpb:%attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_ptplugin.so}
+%endif
+
+%if %{with vpb}
+%files lid-vpb
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_ptplugin.so
 %endif
 
 %files devel
This page took 0.093572 seconds and 4 git commands to generate.