]> git.pld-linux.org Git - packages/opal.git/blobdiff - opal.spec
- BR: expat-devel, unixODBC-devel
[packages/opal.git] / opal.spec
index 3616dfe0d19e88331001660efe7c6729064c30da..d662928182694753538530165df0d654c91f0d9e 100644 (file)
--- a/opal.spec
+++ b/opal.spec
+# TODO:
+#      fix static libname (libopal_s.a)
+#      IPv6 support requires IPv6 support in ptlib
+#      x264+ffmpeg detection sucks - it doesn't work with --as-needed
+#       SpanDSP FAX support requires t38_indicator symbol
+#      MPEG4 rate control correction requires libavcodec sources
+#       CAPI support
+#
+# Don't touch this! strip removes all symbols from library
+%define                no_install_post_strip           1
+#
 Summary:       Open Phone Abstraction Library (aka OpenH323 v2)
-Summary(pl):   Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
+Summary(pl.UTF-8):     Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
 Name:          opal
-Version:       2.2.1
-Release:       0.1
+Version:       3.6.6
+Release:       2
 License:       MPL
 Group:         Libraries
-#Source0:      http://dl.sourceforge.net/sourceforge/openh323/%{name}-Phobos_rc1-src-tar.gz
-Source0:       http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
-# Source0-md5: bc6079100e831cf117597bb99b266a0c
-#Patch0:               %{name}-opaldir.patch
+Source0:       http://ftp.gnome.org/pub/gnome/sources/opal/3.6/%{name}-%{version}.tar.bz2
+# Source0-md5: 43b363c860780e7f1a0361cfee8f9f4a
+#Source0:      http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
+Patch0:                %{name}-libname.patch
+Patch1:                %{name}-mak_files.patch
+Patch2:                %{name}-ac.patch
+Patch3:                %{name}-build.patch
 URL:           http://www.openh323.org/
-BuildRequires: pwlib-devel >= 1.10.0
-BuildRequires: speex-devel >= 1:1.1.5
+BuildRequires: SDL-devel
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: expat-devel
+BuildRequires: ffmpeg-devel
+BuildRequires: libgsm-devel
 BuildRequires: libstdc++-devel
-%requires_eq   pwlib
-Obsoletes:     openh323
+BuildRequires: libtheora-devel
+BuildRequires: libx264-devel
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
+BuildRequires: ptlib-devel >= 2.4.2-3
+BuildRequires: sed >= 4.0
+BuildRequires: speex-devel >= 1:1.1.5
+BuildRequires: unixODBC-devel
+%requires_eq   ptlib
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                filterout_ld    -Wl,--as-needed
+
 %description
-The OpenH323 project aims to create a full featured, interoperable,
+The OPAL project aims to create a full featured, interoperable,
 Open Source implementation of the ITU H.323 teleconferencing protocol
 that can be used by personal developers and commercial users without
 charge.
 
-%description -l pl
-Celem projektu OpenH323 jest stworzenie w pe³ni funkcjonalnej i
-wyposa¿onej implementacji protoko³u telekonferencyjnego ITU H.323,
-który mo¿e byæ u¿ywany przez u¿ytkowników prywatnych i komercyjnych
-bez op³at.
+%description -l pl.UTF-8
+Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
+wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
+który może być używany przez użytkowników prywatnych i komercyjnych
+bez opłat.
 
 %package devel
 Summary:       Opal development files
-Summary(pl):   Pliki dla developerów Opal
+Summary(pl.UTF-8):     Pliki dla developerów Opal
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Requires:      libstdc++-devel
-Requires:      pwlib-devel
-Obsoletes:     openh323-devel
+Requires:      ptlib-devel
 
 %description devel
 Header files and libraries for developing applications that use
-Opal.
+OPAL.
 
-%description devel -l pl
-Pliki nag³ówkowe i biblioteki konieczne do rozwoju aplikacji
-u¿ywaj±cych Opal.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
+używających OPAL.
 
-#%package static
-#Summary:      Opal static libraries
-#Summary(pl):  Biblioteki statyczne Opal
-#Group:                Development/Libraries
-#Requires:     %{name}-devel = %{version}
-#Obsoletes:    openh323-static
+%package static
+Summary:       OPAL static libraries
+Summary(pl.UTF-8):     Biblioteki statyczne OPAL
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
 
-#%description static
-#OpenH323 static libraries.
+%description static
+OPAL static libraries.
 
-#%description static -l pl
-#Biblioteki statyczne OpenH323.
+%description static -l pl.UTF-8
+Biblioteki statyczne OPAL.
 
 %prep
 %setup -q
-#%patch0 -p1
+#patch0 -p1
+#patch1 -p1
+#%patch2 -p1
+%patch3 -p1
 
 %build
 PWLIBDIR=%{_prefix}; export PWLIBDIR
-#OPALDESTDIR=%{_prefix}; export OPALDIR
-#OPENH323_BUILD="yes"; export OPENH323_BUILD
-#cp -f /usr/share/automake/config.sub .
+OPALDIR=`pwd`; export OPALDIR
+OPAL_BUILD="yes"; export OPAL_BUILD
+%{__aclocal}
 %{__autoconf}
-%configure 
-#      --disable-iax
-#touch .asnparser.version
+%configure \
+       --enable-ixj
 
-%{__make}
+%{__make} %{?debug:debug}%{!?debug:opt} \
+       CC="%{__cc}" \
+       CPLUS="%{__cxx}" \
+       OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
 
-#%{__make} %{?debug:debug}%{!?debug:opt} \
-#              CC="%{__cc}" CPLUS=%{__cxx} \
-#              PWLIB_MAKE=%{_datadir}/pwlib \
-#              ASNPARSER=%{_bindir}/asnparser \
-#              OPTCCFLAGS="%{rpmcflags}"
-
-#%%{__make} -C samples/simple %{?debug:debugshared}%{!?debug:optshared} \
-#              CC="%{__cc}" CPLUS=%{__cxx} \
-#              OPTCCFLAGS="%{rpmcflags}"
+%{__cp} -a */libopal* .
+%{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
+       CC="%{__cc}" \
+       CPLUS=%{__cxx} \
+       CFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG} -I`pwd`/include" \
+       LDFLAGS="%{rpmldflags} -L`pwd` -lpt -lopal"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-#install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/openh323,%{_bindir},%{_datadir}/misc}
+install -d $RPM_BUILD_ROOT%{_bindir}
 
 %{__make} install \
         DESTDIR=$RPM_BUILD_ROOT
 
-#using cp as install won't preserve links
-#cp -d lib/lib* $RPM_BUILD_ROOT%{_libdir}
-#install include/*.h $RPM_BUILD_ROOT%{_includedir}/openh323
-#install version.h $RPM_BUILD_ROOT%{_includedir}/openh323
-#install samples/simple/obj_*/simph323 $RPM_BUILD_ROOT%{_bindir}
-
-#sed -e's@\$(OPALDIR)/include@&/opal@' < opal_inc.mak \
-#      > $RPM_BUILD_ROOT%{_datadir}/opal/opal_inc1.mak
+install samples/simple/obj/simpleopal $RPM_BUILD_ROOT%{_bindir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -109,16 +129,37 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-#%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
+%dir %{_libdir}/opal-%{version}
+%dir %{_libdir}/opal-%{version}/codecs
+%dir %{_libdir}/opal-%{version}/codecs/audio
+%dir %{_libdir}/opal-%{version}/codecs/video
+%dir %{_libdir}/opal-%{version}/lid
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g722_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/g726_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsm0610_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/gsmamrcodec_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ilbc_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/ima_adpcm_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/lpc10_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/audio/speex_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h261-vic_video_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263-1998_video_pwplugin.so
+#%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h263-ffmpeg_video_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin_helper
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/h264_video_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/mpeg4-ffmpeg_video_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/theora_video_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/lid/ixj_lid_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_lid_pwplugin.so
 
 %files devel
 %defattr(644,root,root,755)
-#%doc *.txt
 %attr(755,root,root) %{_libdir}/*.so
-%{_includedir}/*
-%{_datadir}/%{name}
+%{_includedir}/opal
+%{_pkgconfigdir}/opal.pc
 
-#%files static
-#%defattr(644,root,root,755)
-#%{_libdir}/*.a
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/*.a
This page took 0.088727 seconds and 4 git commands to generate.