]> git.pld-linux.org Git - packages/opal.git/blobdiff - opal.spec
- now devel requires ptlib-devel
[packages/opal.git] / opal.spec
index dc6de6af72633ede7f722595770324a24577f765..b621db92fc78f68e2f5fcf37f4fb3e4d931f0c39 100644 (file)
--- a/opal.spec
+++ b/opal.spec
@@ -1,3 +1,19 @@
+# TODO:
+#      fix static libname (libopal_s.a)
+#      check why:
+#              checking PTLIB has expat... no
+#              checking PTLIB has vxml... no
+#              checking PTLIB has ipv6... no
+#              checking PTLIB has ldap... no
+#      ... and check plugin configuration:
+#                              GSM :  yes (internal)
+#                           H.263+ :  
+#                           H.264  :  no
+#                          THEORA  :  no
+#                    MPEG4 Part 2  :  no
+#                     SpanDSP FAX  :  no
+#                            CAPI  :  no
+#           Quicknet xJACK support :  no
 #
 # Don't touch this! strip removes all symbols from library
 %define                no_install_post_strip           1
 Summary:       Open Phone Abstraction Library (aka OpenH323 v2)
 Summary(pl.UTF-8):     Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
 Name:          opal
-Version:       2.2.6
-Release:       2
+Version:       3.4.2
+Release:       0.2
 License:       MPL
 Group:         Libraries
-Source0:       http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
-# Source0-md5: 7c83abfe93fbe6a868f5230d5bbec7aa
+Source0:       http://ftp.gnome.org/pub/gnome/sources/opal/3.4/%{name}-%{version}.tar.bz2
+# Source0-md5: a1d11099fa00d77a79dcfe513872e8dc
+#Source0:      http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
 Patch0:                %{name}-libname.patch
 Patch1:                %{name}-mak_files.patch
+Patch2:                %{name}-ac.patch
+Patch3:                %{name}-build.patch
 URL:           http://www.openh323.org/
+BuildRequires: SDL-devel
+BuildRequires: automake
+BuildRequires: autoconf
 BuildRequires: libstdc++-devel
-BuildRequires: pwlib-devel >= 1.10.5
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
+BuildRequires: ptlib-devel
 BuildRequires: sed >= 4.0
 BuildRequires: speex-devel >= 1:1.1.5
 %requires_eq   pwlib
@@ -39,7 +63,7 @@ Summary(pl.UTF-8):    Pliki dla developerów Opal
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      libstdc++-devel
-Requires:      pwlib-devel
+Requires:      ptlib-devel
 
 %description devel
 Header files and libraries for developing applications that use
@@ -63,38 +87,39 @@ Biblioteki statyczne OPAL.
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
+#patch0 -p1
+#patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
 PWLIBDIR=%{_prefix}; export PWLIBDIR
 OPALDIR=`pwd`; export OPALDIR
 OPAL_BUILD="yes"; export OPAL_BUILD
-%configure 
+%{__aclocal}
+%{__autoconf}
+%configure
 
 %{__make} %{?debug:debug}%{!?debug:opt} \
        CC="%{__cc}" \
        CPLUS="%{__cxx}" \
        OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
 
+%{__cp} -a */libopal* .
 %{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
        CC="%{__cc}" \
        CPLUS=%{__cxx} \
-       OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
+       CFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG} -I`pwd`/include" \
+       LDFLAGS="%{rpmldflags} -L`pwd` -lpt -lopal"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/opal,%{_bindir},%{_datadir}/%{name}}
+install -d $RPM_BUILD_ROOT%{_bindir}
 
 %{__make} install \
         DESTDIR=$RPM_BUILD_ROOT
 
-# using cp as install won't preserve links
-cp -d lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
-install version.h $RPM_BUILD_ROOT%{_includedir}/opal
-install samples/simple/obj_*/simpleopal $RPM_BUILD_ROOT%{_bindir}
-sed -i -e 's@\$(OPALDIR)/include@&/opal@' \
-       -e 's@\$(OPALDIR)/lib@\$(OPALDIR)/%{_lib}@' $RPM_BUILD_ROOT%{_datadir}/opal/opal_inc.mak
+install samples/simple/obj/simpleopal $RPM_BUILD_ROOT%{_bindir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -106,12 +131,27 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
+%dir %{_libdir}/opal-3.4.2
+%dir %{_libdir}/opal-3.4.2/codecs
+%dir %{_libdir}/opal-3.4.2/codecs/audio
+%dir %{_libdir}/opal-3.4.2/codecs/video
+%dir %{_libdir}/opal-3.4.2/lid
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/g726_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/gsm0610_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/gsmamrcodec_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/ilbc_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/ima_adpcm_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/lpc10_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/speex_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/video/h261-vic_video_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/video/h263-ffmpeg_video_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/lid/vpb_lid_pwplugin.so
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/*.so
-%{_includedir}/*
-%{_datadir}/%{name}
+%{_includedir}/opal
+%{_pkgconfigdir}/opal.pc
 
 %files static
 %defattr(644,root,root,755)
This page took 0.074889 seconds and 4 git commands to generate.