]> git.pld-linux.org Git - packages/opal.git/blobdiff - opal.spec
- now devel requires ptlib-devel
[packages/opal.git] / opal.spec
index 0d2f9e6f7c0092936eb9dcd93bd8797cb4ea506f..b621db92fc78f68e2f5fcf37f4fb3e4d931f0c39 100644 (file)
--- a/opal.spec
+++ b/opal.spec
@@ -1,22 +1,47 @@
+# TODO:
+#      fix static libname (libopal_s.a)
+#      check why:
+#              checking PTLIB has expat... no
+#              checking PTLIB has vxml... no
+#              checking PTLIB has ipv6... no
+#              checking PTLIB has ldap... no
+#      ... and check plugin configuration:
+#                              GSM :  yes (internal)
+#                           H.263+ :  
+#                           H.264  :  no
+#                          THEORA  :  no
+#                    MPEG4 Part 2  :  no
+#                     SpanDSP FAX  :  no
+#                            CAPI  :  no
+#           Quicknet xJACK support :  no
 #
 # Don't touch this! strip removes all symbols from library
 %define                no_install_post_strip           1
 #
 Summary:       Open Phone Abstraction Library (aka OpenH323 v2)
-Summary(pl):   Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
+Summary(pl.UTF-8):     Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
 Name:          opal
-Version:       2.2.1
-Release:       1
+Version:       3.4.2
+Release:       0.2
 License:       MPL
 Group:         Libraries
-Source0:       http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
-# Source0-md5: bc6079100e831cf117597bb99b266a0c
+Source0:       http://ftp.gnome.org/pub/gnome/sources/opal/3.4/%{name}-%{version}.tar.bz2
+# Source0-md5: a1d11099fa00d77a79dcfe513872e8dc
+#Source0:      http://www.ekiga.org/admin/downloads/latest/sources/sources/%{name}-%{version}.tar.gz
 Patch0:                %{name}-libname.patch
 Patch1:                %{name}-mak_files.patch
+Patch2:                %{name}-ac.patch
+Patch3:                %{name}-build.patch
 URL:           http://www.openh323.org/
-BuildRequires: pwlib-devel >= 1.10.0
-BuildRequires: speex-devel >= 1:1.1.5
+BuildRequires: SDL-devel
+BuildRequires: automake
+BuildRequires: autoconf
 BuildRequires: libstdc++-devel
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
+BuildRequires: ptlib-devel
+BuildRequires: sed >= 4.0
+BuildRequires: speex-devel >= 1:1.1.5
 %requires_eq   pwlib
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -26,73 +51,75 @@ Open Source implementation of the ITU H.323 teleconferencing protocol
 that can be used by personal developers and commercial users without
 charge.
 
-%description -l pl
-Celem projektu OPAL jest stworzenie w pe³ni funkcjonalnej i
-wyposa¿onej implementacji protoko³u telekonferencyjnego ITU H.323,
-który mo¿e byæ u¿ywany przez u¿ytkowników prywatnych i komercyjnych
-bez op³at.
+%description -l pl.UTF-8
+Celem projektu OPAL jest stworzenie w pełni funkcjonalnej i
+wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
+który może być używany przez użytkowników prywatnych i komercyjnych
+bez opłat.
 
 %package devel
 Summary:       Opal development files
-Summary(pl):   Pliki dla developerów Opal
+Summary(pl.UTF-8):     Pliki dla developerów Opal
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 Requires:      libstdc++-devel
-Requires:      pwlib-devel
+Requires:      ptlib-devel
 
 %description devel
 Header files and libraries for developing applications that use
 OPAL.
 
-%description devel -l pl
-Pliki nag³ówkowe i biblioteki konieczne do rozwoju aplikacji
-u¿ywaj±cych OPAL.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe i biblioteki konieczne do rozwoju aplikacji
+używających OPAL.
 
 %package static
 Summary:       OPAL static libraries
-Summary(pl):   Biblioteki statyczne OPAL
+Summary(pl.UTF-8):     Biblioteki statyczne OPAL
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 OPAL static libraries.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Biblioteki statyczne OPAL.
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
+#patch0 -p1
+#patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
 PWLIBDIR=%{_prefix}; export PWLIBDIR
 OPALDIR=`pwd`; export OPALDIR
 OPAL_BUILD="yes"; export OPAL_BUILD
-%configure 
+%{__aclocal}
+%{__autoconf}
+%configure
 
 %{__make} %{?debug:debug}%{!?debug:opt} \
        CC="%{__cc}" \
        CPLUS="%{__cxx}" \
        OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
 
+%{__cp} -a */libopal* .
 %{__make} -C samples/simple %{?debug:debug}%{!?debug:opt} \
        CC="%{__cc}" \
        CPLUS=%{__cxx} \
-       OPTCCFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG}"
+       CFLAGS="%{rpmcflags} %{!?debug:-DNDEBUG} -I`pwd`/include" \
+       LDFLAGS="%{rpmldflags} -L`pwd` -lpt -lopal"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/opal,%{_bindir},%{_datadir}/%{name}}
+install -d $RPM_BUILD_ROOT%{_bindir}
 
 %{__make} install \
         DESTDIR=$RPM_BUILD_ROOT
 
-# using cp as install won't preserve links
-cp -d %{_lib}/lib*.a $RPM_BUILD_ROOT%{_libdir}
-install version.h $RPM_BUILD_ROOT%{_includedir}/opal
-install samples/simple/obj_*/simpleopal $RPM_BUILD_ROOT%{_bindir}
-sed -i -e 's@\$(OPALDIR)/include@&/opal@' $RPM_BUILD_ROOT%{_datadir}/opal/opal_inc.mak
+install samples/simple/obj/simpleopal $RPM_BUILD_ROOT%{_bindir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -104,12 +131,27 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/lib*.so.*.*
+%dir %{_libdir}/opal-3.4.2
+%dir %{_libdir}/opal-3.4.2/codecs
+%dir %{_libdir}/opal-3.4.2/codecs/audio
+%dir %{_libdir}/opal-3.4.2/codecs/video
+%dir %{_libdir}/opal-3.4.2/lid
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/g726_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/gsm0610_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/gsmamrcodec_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/ilbc_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/ima_adpcm_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/lpc10_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/audio/speex_audio_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/video/h261-vic_video_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/codecs/video/h263-ffmpeg_video_pwplugin.so
+%attr(755,root,root) %{_libdir}/opal-3.4.2/lid/vpb_lid_pwplugin.so
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/*.so
-%{_includedir}/*
-%{_datadir}/%{name}
+%{_includedir}/opal
+%{_pkgconfigdir}/opal.pc
 
 %files static
 %defattr(644,root,root,755)
This page took 0.81251 seconds and 4 git commands to generate.