]> git.pld-linux.org Git - packages/opal.git/blobdiff - opal.spec
- libx264 rebuild
[packages/opal.git] / opal.spec
index 9a5a1098486dfd656e9b9a4e65c86a8d8f7f667b..767eca01654e6b735f8efe3f6adee21641d27798 100644 (file)
--- a/opal.spec
+++ b/opal.spec
@@ -6,39 +6,44 @@
 #
 # WARNING: opal version should match Ekiga and ptlib versions
 #      Recommendations: http://wiki.ekiga.org/index.php/Download_Ekiga_sources
+#      (for ekiga 4.0.x it's ptlib 2.10.x + opal 3.10.x)
 #
 # Conditional build:
 %bcond_with    sip_fax_only    # minimal build for t38modem + SIP
 %bcond_without celt            # CELT codec support
 %bcond_without srtp            # SRTP protocol support (mutually exclusive with zrtp)
-%bcond_with    zrtp            # ZRTP protocol support (mutually exclusive with zrtp; broken as of 3.10.9)
+%bcond_with    zrtp            # ZRTP protocol support (mutually exclusive with srtp; broken as of 3.10.9)
 %bcond_without capi            # CAPI support
-%bcond_with    vpb             # Voicetronix VPB support
-%bcond_with    java            # Java JNI support
-%bcond_with    ruby            # Ruby support
+%bcond_without vpb             # Voicetronix VPB support
+%bcond_with    java            # Java JNI interface (only swig wrapper, Java part not built)
+%bcond_with    ruby            # Ruby interface (very initial, only swig wrapper)
 #
 %if %{with zrtp}
 %undefine      with_srtp
 %endif
 %if %{with sip_fax_only}
+%undefine      with_java
+%undefine      with_ruby
 %undefine      with_srtp
 %undefine      with_zrtp
 %endif
 Summary:       Open Phone Abstraction Library (aka OpenH323 v2)
 Summary(pl.UTF-8):     Biblioteka Open Phone Abstraction Library (aka OpenH323 v2)
 Name:          opal
-Version:       3.10.9
-Release:       1
+Version:       3.10.11
+Release:       6
 License:       MPL v1.0
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/opalvoip/%{name}-%{version}.tar.bz2
-# Source0-md5: f5dee986b7ae0d840bcc502785ea5bd7
+# Source0-md5: fc36a30d2cbce0fbf7cb6ef33b8d63c3
 Patch0:                %{name}-build.patch
-Patch1:                %{name}-ffmpeg10.patch
+Patch1:                ffmpeg.patch
 Patch2:                %{name}-sh.patch
 Patch3:                %{name}-libilbc.patch
 Patch4:                %{name}-ah.patch
 Patch5:                %{name}-exceptions.patch
+Patch6:                %{name}-ruby.patch
+Patch7:                srtp.patch
 URL:           http://www.opalvoip.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -50,9 +55,9 @@ BuildRequires:        libstdc++-devel
 BuildRequires: pkgconfig
 BuildRequires: ptlib-devel >= 1:2.10.9
 BuildRequires: sed >= 4.0
-# with speexdsp
 BuildRequires: speex-devel >= 1:1.2
-%{?with_srtp:BuildRequires:    srtp-devel}
+BuildRequires: speexdsp-devel >= 1.2
+%{?with_srtp:BuildRequires:    libsrtp2-devel}
 %if %{without sip_fax_only}
 BuildRequires: SDL-devel
 # libavcodec >= 51.11.0 libavutil
@@ -85,6 +90,18 @@ wyposażonej implementacji protokołu telekonferencyjnego ITU H.323,
 który może być używany przez użytkowników prywatnych i komercyjnych
 bez opłat.
 
+%package lid-vpb
+Summary:       Opal LID plugin for Voicetronix VPB devices
+Summary(pl.UTF-8):     Wtyczka Opal LID dla urządzeń VPB firmy Voicetronix
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description lid-vpb
+Opal LID plugin for Voicetronix VPB devices.
+
+%description lid-vpb -l pl.UTF-8
+Wtyczka Opal LID dla urządzeń VPB firmy Voicetronix.
+
 %package devel
 Summary:       Opal development files
 Summary(pl.UTF-8):     Pliki dla developerów Opal
@@ -95,7 +112,7 @@ Requires:    libstdc++-devel
 %{?with_zrtp:Requires: libzrtp-devel}
 Requires:      ptlib-devel >= 1:2.10.9
 Requires:      speex-devel >= 1:1.2
-%{?with_srtp:Requires: srtp-devel}
+%{?with_srtp:Requires: libsrtp2-devel}
 
 %description devel
 Header files and libraries for developing applications that use OPAL.
@@ -123,7 +140,9 @@ Biblioteki statyczne OPAL.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%{?with_vpb:%patch5 -p1}
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
 %build
 PWLIBDIR=%{_prefix}; export PWLIBDIR
@@ -139,6 +158,9 @@ cd plugins
 cd ..
 # Run  grep '^OPAL_.*=' configure.ac|grep 'yes\|no'  to check current defaults
 %configure \
+       CFLAGS="%{rpmcflags} -std=gnu++98" \
+       CXXFLAGS="%{rpmcxxflags} -std=gnu++98" \
+       %{?with_java:JDK_ROOT=%{_jvmdir}/java} \
 %if %{with sip_fax_only}
        --disable-aec \
        --disable-g711plc \
@@ -150,7 +172,6 @@ cd ..
        --disable-h501 \
        --disable-iax \
        --disable-ivr \
-       --disable-java \
        --disable-lid \
        --disable-plugins
        --disable-rfc4103 \
@@ -158,11 +179,12 @@ cd ..
        --disable-sipim \
        --disable-video \
 %else
+       --enable-ixj \
+%endif
        %{!?with_capi:--disable-capi} \
        %{!?with_celt:--disable-celt} \
-       --enable-ixj \
-       %{?with_java:--enable-java} \
-       %{?with_ruby:--enable-ruby} \
+       %{!?with_java:--disable-java} \
+       %{!?with_ruby:--disable-ruby} \
        %{!?with_srtp:--disable-srtp} \
        %{?with_vpb:--enable-vpb} \
 %if %{with zrtp}
@@ -172,7 +194,6 @@ cd ..
        --with-zrtp-includedir=/usr/include/libzrtp \
        --with-zrtp-libdir=%{_libdir}
 %endif
-%endif
 
 %{__make} %{?debug:debug}%{!?debug:opt} \
        CC="%{__cc}" \
@@ -242,9 +263,13 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/opal-%{version}/codecs/video/theora_ptplugin.so
 %dir %{_libdir}/opal-%{version}/fax
 %attr(755,root,root) %{_libdir}/opal-%{version}/fax/spandsp_ptplugin.so
+%endif
 %dir %{_libdir}/opal-%{version}/lid
-%attr(755,root,root) %{_libdir}/opal-%{version}/lid/ixj_lid_pwplugin.so
-%{?with_vpb:%attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_ptplugin.so}
+
+%if %{with vpb}
+%files lid-vpb
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/opal-%{version}/lid/vpb_ptplugin.so
 %endif
 
 %files devel
This page took 0.445237 seconds and 4 git commands to generate.