]> git.pld-linux.org Git - packages/ocfs2-tools.git/commitdiff
- updated to 1.6.4
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 21 Dec 2015 17:05:02 +0000 (18:05 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 21 Dec 2015 17:05:02 +0000 (18:05 +0100)
- updated format patch
- removed obsolete vla-initializer patch

ocfs2-tools-format.patch
ocfs2-tools-vla-initializer.patch [deleted file]
ocfs2-tools.spec

index 97698827d37e90edab375d11db7194453683678e..583f2037f5c736e9421632e186da4a3c99a343df 100644 (file)
                return -1;
        }
  
---- ocfs2-tools-1.4.4/fswreck/corrupt.c.orig   2010-03-17 01:11:06.000000000 +0100
-+++ ocfs2-tools-1.4.4/fswreck/corrupt.c        2015-12-13 19:27:51.333624758 +0100
-@@ -49,7 +49,7 @@
-       case 10:
-       case 11:
-       case 12:
--              snprintf(sysfile, sizeof(sysfile),
-+              snprintf(sysfile, sizeof(sysfile), "%s",
-                        ocfs2_system_inodes[GLOBAL_BITMAP_SYSTEM_INODE].si_name);
-               break;
- #ifdef _LATER_
 --- ocfs2-tools-1.4.4/fswreck/chain.c.orig     2010-02-25 03:06:23.000000000 +0100
 +++ ocfs2-tools-1.4.4/fswreck/chain.c  2015-12-13 19:28:24.540290032 +0100
 @@ -345,7 +345,7 @@
                ocfs2_system_inodes[GLOBAL_BITMAP_SYSTEM_INODE].si_name);
        else
                snprintf(sysfile, sizeof(sysfile),
+--- ocfs2-tools-1.6.4/extras/check_metaecc.c.orig      2010-12-10 20:37:07.000000000 +0100
++++ ocfs2-tools-1.6.4/extras/check_metaecc.c   2015-12-20 22:26:27.487793994 +0100
+@@ -163,7 +163,7 @@
+               if (crc == new_check.bc_crc32e) {
+                       snprintf(outbuf + result_offset,
+                               sizeof(outbuf) - result_offset, "PASS\n");
+-                      fprintf(stderr, outbuf);
++                      fputs(outbuf, stderr);
+                       goto do_check_end;
+               }
+@@ -176,13 +176,13 @@
+               if (crc == new_check.bc_crc32e) {
+                       snprintf(outbuf + result_offset,
+                               sizeof(outbuf) - result_offset, "ECC Fixup\n");
+-                      fprintf(stderr, outbuf);
++                      fputs(outbuf, stderr);
+                       goto do_check_end;
+               }
+               snprintf(outbuf + result_offset,
+                       sizeof(outbuf) - result_offset, "FAIL\n");
+-              fprintf(stderr, outbuf);
++              fputs(outbuf, stderr);
+               offset = snprintf(outbuf, sizeof(outbuf), "Calculated");
+               while (offset < crc_offset)
+@@ -190,7 +190,7 @@
+               snprintf(outbuf + crc_offset, sizeof(outbuf) - crc_offset,
+                       "CRC32: %.8"PRIx32"    ECC: %.4"PRIx16"\n",
+                       crc, ecc);
+-              fprintf(stderr, outbuf);
++              fputs(outbuf, stderr);
+               err = -1;
+ do_check_end:
+               check.bc_crc32e = cpu_to_le32(new_check.bc_crc32e);
diff --git a/ocfs2-tools-vla-initializer.patch b/ocfs2-tools-vla-initializer.patch
deleted file mode 100644 (file)
index 164272b..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- ocfs2-tools-1.4.4/mount.ocfs2/mount.ocfs2.c.orig   2009-04-14 00:10:40.000000000 +0200
-+++ ocfs2-tools-1.4.4/mount.ocfs2/mount.ocfs2.c        2010-07-27 19:03:39.454928969 +0200
-@@ -261,7 +261,7 @@
-       char *extra = NULL;
-       int dev_ro = 0;
-       char *hbstr = NULL;
--      char stackstr[strlen(OCFS2_CLUSTER_STACK_ARG) + OCFS2_STACK_LABEL_LEN + 1] = "";
-+      char stackstr[strlen(OCFS2_CLUSTER_STACK_ARG) + OCFS2_STACK_LABEL_LEN + 1];
-       ocfs2_filesys *fs = NULL;
-       struct o2cb_cluster_desc cluster;
-       struct o2cb_region_desc desc;
-@@ -269,6 +269,7 @@
-       int hb_started = 0;
-       struct stat statbuf;
-+      memset(stackstr, 0, sizeof(stackstr));
-       initialize_ocfs_error_table();
-       initialize_o2dl_error_table();
-       initialize_o2cb_error_table();
index 635f7040684891446758608b39ffc6028fe1024d..3390b54ff3a588408b53ecf05da06e57f5157747 100644 (file)
 Summary:       Tools for the OCFS2 filesystem
 Summary(pl.UTF-8):     Narzędzia dla systemu plików OCFS2
 Name:          ocfs2-tools
-Version:       1.4.4
-Release:       5
+Version:       1.6.4
+Release:       1
 License:       GPL v2+
 Group:         Applications/System
 #Source0Download: https://oss.oracle.com/projects/ocfs2-tools/files/source/
-Source0:       https://oss.oracle.com/projects/ocfs2-tools/dist/files/source/v1.4/%{name}-%{version}.tar.gz
-# Source0-md5: f7ae245e8baa499aa56d7af25a7885d5
+Source0:       https://oss.oracle.com/projects/ocfs2-tools/dist/files/source/v1.6/%{name}-%{version}.tar.gz
+# Source0-md5: 2e94423507b63fcc08f93c094e789be8
 Source1:       ocfs2.init
 Source2:       o2cb.init
 Source3:       o2cb.sysconfig
 Patch0:                %{name}-tinfo.patch
-Patch1:                %{name}-vla-initializer.patch
 Patch2:                %{name}-linux.patch
 Patch3:                %{name}-format.patch
 Patch4:                %{name}-link.patch
@@ -85,7 +84,6 @@ Interfejs GTK+ do narzędzi OCFS2.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
@@ -167,10 +165,13 @@ fi
 %attr(755,root,root) /sbin/ocfs2_controld.pcmk
 %endif
 %endif
+%attr(755,root,root) %{_bindir}/o2info
+%attr(755,root,root) %{_sbindir}/o2hbmonitor
 %dir %{_sysconfdir}/ocfs2
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ocfs2/cluster.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/o2cb
 %dir /dlm
+%{_mandir}/man1/o2info.1*
 %{_mandir}/man7/o2cb.7*
 %{_mandir}/man8/debugfs.ocfs2.8*
 %{_mandir}/man8/fsck.ocfs2.8*
This page took 0.050751 seconds and 4 git commands to generate.