]> git.pld-linux.org Git - packages/ocaml.git/commitdiff
- updated to 3.07beta2
authorMichal Moskal <michal@moskal.me>
Tue, 26 Aug 2003 09:27:07 +0000 (09:27 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ocaml-db3.patch -> 1.3
    ocaml-mano.patch -> 1.2

ocaml-db3.patch
ocaml-mano.patch

index 62b7a1b4247883b866f26a768d7984d23ccb3c28..5a2847210a6eddb73381580041958ee7f33c02e7 100644 (file)
@@ -1,26 +1,14 @@
-diff -ur ocaml-3.04--/otherlibs/dbm/cldbm.c ocaml-3.04/otherlibs/dbm/cldbm.c
---- ocaml-3.04--/otherlibs/dbm/cldbm.c Fri Dec  7 14:39:51 2001
-+++ ocaml-3.04/otherlibs/dbm/cldbm.c   Sat Feb  2 02:38:17 2002
-@@ -15,7 +15,8 @@
- #include <string.h>
- #include <fcntl.h>
--#include <ndbm.h>
-+#define DB_DBM_HSEARCH 1
-+#include <db.h>
- #include <mlvalues.h>
- #include <alloc.h>
- #include <memory.h>
-
-diff -ur ocaml-3.04/configure ocaml-3.04-/configure
---- ocaml-3.04/configure       Fri Dec  7 14:23:01 2001
-+++ ocaml-3.04-/configure      Mon Jun  3 15:25:25 2002
-@@ -1065,38 +1065,11 @@
+diff -ur ocaml-3.07beta2/configure ocaml-3.07beta2-/configure
+--- ocaml-3.07beta2/configure  2003-08-20 17:10:58.000000000 +0200
++++ ocaml-3.07beta2-/configure 2003-08-26 11:12:29.000000000 +0200
+@@ -1225,49 +1225,12 @@
  
  # See if we can compile the dbm library
  
 -dbm_include="not found"
 -dbm_link="not found"
  
  # See if we can compile the dbm library
  
 -dbm_include="not found"
 -dbm_link="not found"
+ use_gdbm_ndbm=no
+-
 -for dir in /usr/include /usr/include/db1 /usr/include/gdbm; do
 -  if test -f $dir/ndbm.h; then
 -    dbm_include=$dir
 -for dir in /usr/include /usr/include/db1 /usr/include/gdbm; do
 -  if test -f $dir/ndbm.h; then
 -    dbm_include=$dir
@@ -32,13 +20,19 @@ diff -ur ocaml-3.04/configure ocaml-3.04-/configure
 -      dbm_link="-ldb1"
 -    elif sh ./hasgot -lgdbm dbm_open; then
 -      dbm_link="-lgdbm"
 -      dbm_link="-ldb1"
 -    elif sh ./hasgot -lgdbm dbm_open; then
 -      dbm_link="-lgdbm"
--    else
--      dbm_include="not found"
 -    fi
 -    break
 -  fi
 -    fi
 -    break
 -  fi
+-  if test -f $dir/gdbm-ndbm.h; then
+-    dbm_include=$dir
+-    use_gdbm_ndbm=yes
+-    if sh ./hasgot -lgdbm_compat -lgdbm dbm_open; then
+-      dbm_link="-lgdbm_compat -lgdbm"
+-    fi
+-    break   
+-  fi
 -done
 -done
--if test "$dbm_include" = "not found"; then
+-if test "$dbm_include" = "not found" || test "$dbm_link" = "not found"; then
 -  echo "NDBM not found, the \"dbm\" library will not be supported."
 -else
 -  echo "NDBM found (in $dbm_include)"
 -  echo "NDBM not found, the \"dbm\" library will not be supported."
 -else
 -  echo "NDBM found (in $dbm_include)"
@@ -49,6 +43,9 @@ diff -ur ocaml-3.04/configure ocaml-3.04-/configure
 -  fi
 -  echo "DBM_INCLUDES=$dbm_include" >> Makefile
 -  echo "DBM_LINK=$dbm_link" >> Makefile
 -  fi
 -  echo "DBM_INCLUDES=$dbm_include" >> Makefile
 -  echo "DBM_LINK=$dbm_link" >> Makefile
+-  if test "$use_gdbm_ndbm" = "yes"; then
+-    echo "#define DBM_USES_GDBM_NDBM" >> s.h
+-  fi
 -  otherlibraries="$otherlibraries dbm"
 -fi
 +dbm_include=""
 -  otherlibraries="$otherlibraries dbm"
 -fi
 +dbm_include=""
@@ -59,3 +56,16 @@ diff -ur ocaml-3.04/configure ocaml-3.04-/configure
  
  # Look for tcl/tk
  
  
  # Look for tcl/tk
  
+diff -ur ocaml-3.07beta2/otherlibs/dbm/cldbm.c ocaml-3.07beta2-/otherlibs/dbm/cldbm.c
+--- ocaml-3.07beta2/otherlibs/dbm/cldbm.c      2003-07-08 15:50:31.000000000 +0200
++++ ocaml-3.07beta2-/otherlibs/dbm/cldbm.c     2003-08-26 11:11:19.000000000 +0200
+@@ -24,7 +24,8 @@
+ #ifdef DBM_USES_GDBM_NDBM
+ #include <gdbm-ndbm.h>
+ #else
+-#include <ndbm.h>
++#define DB_DBM_HSEARCH 1
++#include <db.h>
+ #endif
+ /* Quite close to sys_open_flags, but we need RDWR */
index 73bed4790bcae12705245aa15435f674eb169aa5..cc32791e3845662adb7c7157c8d4845454bb2122 100644 (file)
@@ -1,33 +1,3 @@
-diff -ur ocaml-3.05/ocamldoc/Makefile ocaml-3.05-/ocamldoc/Makefile
---- ocaml-3.05/ocamldoc/Makefile       Tue Jul 23 15:21:14 2002
-+++ ocaml-3.05-/ocamldoc/Makefile      Thu Aug  8 14:11:16 2002
-@@ -40,7 +40,7 @@
- OCAMLDOC_LIBA=odoc_info.a
- INSTALL_LIBDIR=$(OCAMLLIB)/ocamldoc
- INSTALL_BINDIR=$(OCAMLBIN)
--INSTALL_MANODIR=$(MANDIR)/mano
-+INSTALL_MANODIR=$(MANDIR)/man3
- INSTALL_MLIS=odoc_info.mli odoc_args.mli
- INSTALL_CMIS=$(INSTALL_MLIS:.mli=.cmi)
-@@ -196,7 +196,7 @@
- $(OCAMLDOC_LIBCMXA): $(LIBCMXFILES)
-       $(OCAMLOPT) -a -o $@ $(LINKFLAGS) $(OCAMLCMXFILES) $(LIBCMXFILES)
--manpages: stdlib_man/Pervasives.o
-+manpages: stdlib_man/Pervasives.3o
- odoc_crc.ml: $(CMIFILES)
-       $(EXTRAC_CRC) $(INCLUDES) \
-@@ -315,7 +315,7 @@
-       $(MKDIR) $@ 
-       $(OCAMLDOC_RUN) -texi -d $@ $(INCLUDES) odoc*.ml odoc*.mli
--stdlib_man/Pervasives.o: $(STDLIB_MLIS)
-+stdlib_man/Pervasives.3o: $(STDLIB_MLIS)
-       $(MKDIR) stdlib_man
-       $(OCAMLDOC_RUN) -man -d stdlib_man $(INCLUDES) \
-       -t "OCaml library" -man-mini \
 diff -ur ocaml-3.05/ocamldoc/odoc_messages.ml ocaml-3.05-/ocamldoc/odoc_messages.ml
 --- ocaml-3.05/ocamldoc/odoc_messages.ml       Tue Jul 23 16:11:51 2002
 +++ ocaml-3.05-/ocamldoc/odoc_messages.ml      Thu Aug  8 14:09:56 2002
 diff -ur ocaml-3.05/ocamldoc/odoc_messages.ml ocaml-3.05-/ocamldoc/odoc_messages.ml
 --- ocaml-3.05/ocamldoc/odoc_messages.ml       Tue Jul 23 16:11:51 2002
 +++ ocaml-3.05-/ocamldoc/odoc_messages.ml      Thu Aug  8 14:09:56 2002
This page took 0.03687 seconds and 4 git commands to generate.