]> git.pld-linux.org Git - packages/ocaml.git/commitdiff
- enable building without emacs - inspired by Zbigniew Bryczkowski :) thx auto/ac/ocaml-3_07-3
authorciesiel <ciesiel@pld-linux.org>
Mon, 3 Nov 2003 20:28:16 +0000 (20:28 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ocaml-emacs_batch_mode.patch -> 1.1
    ocaml.spec -> 1.79

ocaml-emacs_batch_mode.patch [new file with mode: 0644]
ocaml.spec

diff --git a/ocaml-emacs_batch_mode.patch b/ocaml-emacs_batch_mode.patch
new file mode 100644 (file)
index 0000000..95dfbf3
--- /dev/null
@@ -0,0 +1,88 @@
+diff -urN ocaml-3.07/emacs/Makefile ocaml-3.07.zm/emacs/Makefile
+--- ocaml-3.07/emacs/Makefile  2003-08-29 17:38:28.000000000 +0200
++++ ocaml-3.07.zm/emacs/Makefile       2003-11-03 20:48:40.000000000 +0100
+@@ -28,7 +28,7 @@
+ install:
+       @if test "$(EMACSDIR)" = ""; then \
+-          set xxx `($(EMACS) --batch --eval "(mapcar 'print load-path)") \
++          set xxx `($(EMACS) -batch -l -f -eval "(mapcar 'print load-path)") \
+                    2>/dev/null | \
+                    sed -n -e '/\/site-lisp/s/"//gp'`; \
+           if test "$$2" = ""; then \
+@@ -49,7 +49,7 @@
+       if test -d $(EMACSDIR); then : ; else mkdir -p $(EMACSDIR); fi
+       cp $(FILES) $(EMACSDIR)
+       if [ -z "$(NOCOMPILE)" ]; then \
+-        cd $(EMACSDIR); $(EMACS) --batch --eval '$(COMPILECMD)'; \
++        cd $(EMACSDIR); $(EMACS) -batch -l -f -eval '$(COMPILECMD)'; \
+       fi
+ ocamltags:    ocamltags.in
+diff -urN ocaml-3.07/emacs/Makefile~ ocaml-3.07.zm/emacs/Makefile~
+--- ocaml-3.07/emacs/Makefile~ 1970-01-01 01:00:00.000000000 +0100
++++ ocaml-3.07.zm/emacs/Makefile~      2003-08-29 17:38:28.000000000 +0200
+@@ -0,0 +1,63 @@
++# $Id$
++
++include ../config/Makefile
++
++# Files to install
++FILES=        caml-font.el caml-hilit.el caml.el camldebug.el \
++      inf-caml.el caml-compat.el caml-help.el caml-types.el \
++      caml-xemacs.el caml-emacs.el
++
++# Where to install. If empty, automatically determined.
++#EMACSDIR=
++
++# Name of Emacs executable
++EMACS=emacs
++
++# Where to install ocamltags script
++SCRIPTDIR = $(BINDIR)
++
++# Command for byte-compiling the files
++COMPILECMD=(progn \
++              (setq load-path (cons "." load-path)) \
++              (byte-compile-file "caml-xemacs.el") \
++            (byte-compile-file "caml-emacs.el") \
++              (byte-compile-file "caml.el") \
++              (byte-compile-file "inf-caml.el") \
++              (byte-compile-file "caml-help.el") \
++              (byte-compile-file "camldebug.el"))
++
++install:
++      @if test "$(EMACSDIR)" = ""; then \
++          set xxx `($(EMACS) --batch --eval "(mapcar 'print load-path)") \
++                   2>/dev/null | \
++                   sed -n -e '/\/site-lisp/s/"//gp'`; \
++          if test "$$2" = ""; then \
++            echo "Cannot determine Emacs site-lisp directory"; \
++            exit 2; \
++          fi; \
++          $(MAKE) EMACSDIR="$$2" simple-install; \
++        else \
++          $(MAKE) simple-install; \
++        fi
++
++# install the .el files, but do not compile them.
++install-el:
++      $(MAKE) NOCOMPILE=true install
++
++simple-install:
++      @echo "Installing in $(EMACSDIR)..."
++      if test -d $(EMACSDIR); then : ; else mkdir -p $(EMACSDIR); fi
++      cp $(FILES) $(EMACSDIR)
++      if [ -z "$(NOCOMPILE)" ]; then \
++        cd $(EMACSDIR); $(EMACS) --batch --eval '$(COMPILECMD)'; \
++      fi
++
++ocamltags:    ocamltags.in
++      sed -e 's:@EMACS@:$(EMACS):' ocamltags.in >ocamltags
++      chmod a+x ocamltags
++
++install-ocamltags: ocamltags
++      cp ocamltags $(SCRIPTDIR)/ocamltags
++
++clean:
++      rm -f ocamltags *~ #*#
index 7fa91c58bedae05f0802553764b5a756f398e49d..f25257c3db10517c6f557b18007df20292588c51 100644 (file)
@@ -43,13 +43,13 @@ Patch2:             %{name}-objinfo.patch
 Patch3:                %{name}-mano.patch
 Patch4:                %{name}-unused-var-warning.patch
 Patch5:                %{name}-3.07-patch2.diffs
+Patch6:                %{name}-emacs_batch_mode.patch
 URL:           http://caml.inria.fr/
 %{?with_x:BuildRequires:               XFree86-devel}
 %{?with_db3:BuildRequires:     db3-devel}
 %{!?with_db3:BuildRequires:    db-devel >= 4.1}
 %{?with_tk:BuildRequires:              tk-devel}
 %if %{with emacs}
-BuildRequires: emacs
 BuildRequires: xemacs
 BuildRequires: xemacs-common
 BuildRequires: xemacs-fsf-compat-pkg
@@ -292,6 +292,7 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
 
 %build
 ./configure \
This page took 0.051612 seconds and 4 git commands to generate.