]> git.pld-linux.org Git - packages/ocaml.git/commitdiff
- split make invocation to make parallel build work
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 17 Mar 2021 07:41:11 +0000 (08:41 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 17 Mar 2021 07:41:11 +0000 (08:41 +0100)
- fix non optimized build

ocaml.spec

index 67b6fea292e02e4c3119e39d4fd366882868a36a..4801c32fd868b99b73b2224206653883ffc2670b 100644 (file)
@@ -171,9 +171,14 @@ mv htmlman docs/html/ocaml
 %configure \
        AS=%{__as} \
        ASPP="%{__cc} -c" \
-       --libdir=%{_libdir}/ocaml
+       --libdir=%{_libdir}/ocaml \
+       %{!?with_ocaml_opt:--disable-native-compiler}
 
-%{__make} -j1 world bootstrap %{?with_ocaml_opt:opt.opt}
+%{__make} world
+%{__make} bootstrap
+%if %{with ocaml_opt}
+%{__make} opt opt.opt
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -194,7 +199,7 @@ EOF
 ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/ocaml/caml
 
 # compiled sources of compiler, needed by some programs
-for f in {asm,byte}comp parsing typing utils ; do
+for f in %{?with_ocaml_opt:asmcomp} bytecomp parsing typing utils ; do
        install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
        cp $f/*.{cmi,cmo} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
        %{?with_ocaml_opt:cp $f/*.{cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f}
This page took 0.064428 seconds and 4 git commands to generate.