]> git.pld-linux.org Git - packages/ocaml.git/commitdiff
- updated for 3.10.0
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 15 Jul 2007 18:47:07 +0000 (18:47 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ocaml-CFLAGS.patch -> 1.3
    ocaml-build.patch -> 1.4
    ocaml-db3.patch -> 1.6

ocaml-CFLAGS.patch
ocaml-build.patch
ocaml-db3.patch

index f1f6394dfac25dc13a4d248d543da1eb764f3612..d787a66186aee0fd064c653a7a50bf1c73040818 100644 (file)
@@ -172,10 +172,10 @@ diff -Nur b.ocaml-3.08.4/otherlibs/num/Makefile n.ocaml-3.08.4/otherlibs/num/Mak
  # Compilation options
  CC=$(BYTECC)
 -CFLAGS=-O -I../../byterun $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS) \
-+override CFLAGS += -I../../byterun $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS) \
++override CFLAGS += -O -I../../byterun $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS) \
            -DBNG_ARCH_$(BNG_ARCH) -DBNG_ASM_LEVEL=$(BNG_ASM_LEVEL)
- CAMLC=../../ocamlcomp.sh -w s
- CAMLOPT=../../ocamlcompopt.sh -w s
+ CAMLC=../../boot/ocamlrun ../../ocamlc -I ../../boot -w s
+ CAMLOPT=../../boot/ocamlrun ../../ocamlopt -I ../../stdlib -w s
 diff -Nur b.ocaml-3.08.4/otherlibs/num/Makefile.nt n.ocaml-3.08.4/otherlibs/num/Makefile.nt
 --- b.ocaml-3.08.4/otherlibs/num/Makefile.nt   2004-11-29 09:50:23.000000000 +0100
 +++ n.ocaml-3.08.4/otherlibs/num/Makefile.nt   2005-11-04 21:26:14.779320248 +0100
@@ -183,7 +183,7 @@ diff -Nur b.ocaml-3.08.4/otherlibs/num/Makefile.nt n.ocaml-3.08.4/otherlibs/num/
  
  # Compilation options
  CC=$(BYTECC)
--CFLAGS=-O -I../../byterun \
+-CFLAGS=-I../../byterun \
 +override CFLAGS += -I../../byterun \
            -DBNG_ARCH_$(BNG_ARCH) -DBNG_ASM_LEVEL=$(BNG_ASM_LEVEL)
  CAMLC=../../boot/ocamlrun ../../ocamlc -I ../../boot -w s
index 45d278a56e960f104857efddd91baae067a852dc..5e32db69a30baa517269c41465151100b7285546 100644 (file)
@@ -1,27 +1,3 @@
-diff -ur ocaml-3.05/camlp4/meta/Makefile ocaml-3.05-/camlp4/meta/Makefile
---- ocaml-3.05/camlp4/meta/Makefile    Fri Jul 19 16:53:49 2002
-+++ ocaml-3.05-/camlp4/meta/Makefile   Thu Aug  8 13:19:11 2002
-@@ -2,7 +2,7 @@
- include ../config/Makefile
--INCLUDES=-I ../camlp4 -I ../boot -I $(OTOP)/utils
-+INCLUDES=-I ../camlp4 -I ../boot -I $(OTOP)/utils -I $(OTOP)/parsing
- OCAMLCFLAGS=-warn-error A $(INCLUDES)
- OBJS=q_MLast.cmo pa_r.cmo pa_rp.cmo pa_extend.cmo pa_extend_m.cmo pa_ifdef.cmo pr_dump.cmo
- CAMLP4RM=pa_r.cmo pa_rp.cmo pr_dump.cmo
-diff -ur ocaml-3.05/camlp4/ocaml_src/meta/Makefile ocaml-3.05-/camlp4/ocaml_src/meta/Makefile
---- ocaml-3.05/camlp4/ocaml_src/meta/Makefile  Fri Jul 19 16:53:53 2002
-+++ ocaml-3.05-/camlp4/ocaml_src/meta/Makefile Thu Aug  8 13:19:37 2002
-@@ -2,7 +2,7 @@
- include ../../config/Makefile
--INCLUDES=-I ../camlp4 -I ../../boot -I $(OTOP)/utils
-+INCLUDES=-I ../camlp4 -I ../../boot -I $(OTOP)/utils -I $(OTOP)/parsing
- OCAMLCFLAGS=-warn-error A $(INCLUDES)
- OBJS=q_MLast.cmo pa_r.cmo pa_rp.cmo pa_extend.cmo pa_extend_m.cmo pa_ifdef.cmo pr_dump.cmo
- CAMLP4RM=pa_r.cmo pa_rp.cmo pr_dump.cmo
 --- ocaml-3.08.3/configure.orig        2005-04-29 22:58:18.000000000 +0200
 +++ ocaml-3.08.3/configure     2005-04-29 23:06:30.000000000 +0200
 @@ -1322,6 +1322,7 @@
index e6fd10e7ee698e84db058540cbaeab1827b3f79f..30dc6dfdc797879435f5552cf24bc012897b722e 100644 (file)
@@ -1,13 +1,14 @@
---- ocaml-3.09.2/configure.orig        2006-04-19 22:15:48.276544500 +0200
-+++ ocaml-3.09.2/configure     2006-04-22 23:49:10.045620750 +0200
-@@ -1238,51 +1238,12 @@
+diff -urN ocaml-3.10.0.org/configure ocaml-3.10.0/configure
+--- ocaml-3.10.0.org/configure 2007-05-03 14:49:56.000000000 +0200
++++ ocaml-3.10.0/configure     2007-07-15 20:20:19.325848428 +0200
+@@ -1252,51 +1252,13 @@
  
  # See if we can compile the dbm library
  
 -dbm_include="not found"
 -dbm_link="not found"
  use_gdbm_ndbm=no
--
 -for dir in /usr/include /usr/include/db1 /usr/include/gdbm; do
 -  if test -f $dir/ndbm.h; then
 -    dbm_include=$dir
@@ -42,8 +43,6 @@
 -  else
 -    dbm_include="-I$dbm_include"
 -  fi
--  echo "DBM_INCLUDES=$dbm_include" >> Makefile
--  echo "DBM_LINK=$dbm_link" >> Makefile
 -  if test "$use_gdbm_ndbm" = "yes"; then
 -    echo "#define DBM_USES_GDBM_NDBM" >> s.h
 -  fi
@@ -51,8 +50,8 @@
 -fi
 +dbm_include=""
 +dbm_link="-ldb"
-+echo "DBM_INCLUDES=$dbm_include" >> Makefile
-+echo "DBM_LINK=$dbm_link" >> Makefile
+ echo "DBM_INCLUDES=$dbm_include" >> Makefile
+ echo "DBM_LINK=$dbm_link" >> Makefile
 +otherlibraries="$otherlibraries dbm"
  
  # Look for tcl/tk
This page took 0.04132 seconds and 4 git commands to generate.