]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - x32.patch
- fix files
[packages/ocaml.git] / x32.patch
index 38242a58e8337332fc3458e1c8e2c8e1a4d1ab86..c46f1f388fe1a8b24ca970fd746474b7e8b98fdd 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -14,8 +14,9 @@ As you can see, the main problem is the current code confusing x32 for
 sometimes amd64 sometimes i386.  I guess adding native optimized support
 wouldn't be hard (copying parts of i386 and parts of amd64...), but, not
 knowing anything about ocaml or the compiler, I preferred to keep it safe.
-</pre><pre>--- ocaml-4.02.1.orig/byterun/signals_machdep.h
-+++ ocaml-4.02.1/byterun/signals_machdep.h
+</pre><pre>
+--- ocaml-4.02.1.orig/byterun/caml/signals_machdep.h
++++ ocaml-4.02.1/byterun/caml/signals_machdep.h
 @@ -25,10 +25,19 @@
  
  #elif defined(__GNUC__) && defined(__x86_64__)
@@ -90,14 +91,3 @@ knowing anything about ocaml or the compiler, I preferred to keep it safe.
  }
  
  #define BNG_SETUP_OPS bng_ia32_setup_ops()
---- ocaml-4.02.1.orig/testsuite/makefiles/Makefile.common
-+++ ocaml-4.02.1/testsuite/makefiles/Makefile.common
-@@ -68,7 +68,7 @@ OCAMLMKLIB=$(OCAMLRUN) $(OTOPDIR)/tools/
- OCAMLYACC=$(TOPDIR)/yacc/ocamlyacc$(EXE)
- OCAMLBUILD=$(TOPDIR)/_build/ocamlbuild/ocamlbuild.native
- DUMPOBJ=$(OCAMLRUN) $(OTOPDIR)/tool/dumpobj
--BYTECODE_ONLY=[ "$(ARCH)" = "none" -o "$(ASM)" = "none" ]
-+BYTECODE_ONLY=[ "$(ARCH)" = "none" -o "$(ARCH)" = "x32" -o "$(ASM)" = "none" ]
- #FORTRAN_COMPILER=
- #FORTRAN_LIBRARY=
This page took 0.035185 seconds and 4 git commands to generate.