]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- ocaml-x11graphics* Obsoletes moved to ocaml-graphics*
[packages/ocaml.git] / ocaml.spec
index a82294c37b01b1769bccad06cf7e4841f55bfa09..f1b8781d047d446a8fa54c6522cf9910a3294ff3 100644 (file)
@@ -1,43 +1,51 @@
+#
+# Conditional build:
+%bcond_without ocaml_opt       # native, optimized compiler
+
+# ppc64, sparc64 and x32 variants not supported currently
+# alpha, hppa, ia64, mips removed since 4.00
+%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
+%undefine      with_ocaml_opt
+%endif
 
-# conditional build:
-# --without emacs
-# --without tk
-# --without x11  (implies --without tk)
-
-%{?_without_x11:%define        _without_tk     1}
+%define                sver    4.12
 
 Summary:       The Objective Caml compiler and programming environment
-Summary(pl):   Kompilator Objektowego Camla oraz ¶rodowisko programistyczne
+Summary(pl.UTF-8):     Kompilator OCamla (Objective Caml) oraz środowisko programistyczne
 Name:          ocaml
-Version:       3.04
-Release:       9
-License:       distributable
-Vendor:                Group of implementors <caml-light@inria.fr>
+Version:       4.12.0
+Release:       5
+Epoch:         1
+License:       QPL v1.0 with linking exception (compiler), LGPL v2 with linking exception (library)
 Group:         Development/Languages
-Source0:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}.tar.gz
-Source1:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}-refman.html.tar.gz
-Source2:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}-refman.ps.gz
-Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-refman.html.tar.gz
-Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-refman.ps.gz
-Source5:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.html.tar.gz
-Source6:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.ps.gz
-Patch0:                %{name}-build.patch
-Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-manlinks.patch
-Patch3:                %{name}-db3.patch
-Patch4:                %{name}-powerpcfix.patch
-Patch5:                %{name}-objinfo.patch
-Patch6:                %{name}-opt-symbols.patch
-URL:           http://caml.inria.fr/
-Requires:      ocaml-runtime = %{version}-%{release}
-BuildRequires: db3-devel
-%{!?_without_tk:BuildRequires:         tk-devel}
-%{!?_without_x11:BuildRequires:                XFree86-devel}
-%{!?_without_emacs:BuildRequires:      xemacs}
-%{!?_without_emacs:BuildRequires:      xemacs-common}
-%{!?_without_emacs:BuildRequires:      xemacs-fsf-compat-pkg}
+Source0:       http://caml.inria.fr/distrib/ocaml-%{sver}/%{name}-%{version}.tar.xz
+# Source0-md5: 7343cd398d477001db2c3f2ac92e12ea
+Source1:       http://caml.inria.fr/distrib/ocaml-%{sver}/%{name}-%{sver}-refman-html.tar.gz
+# Source1-md5: 1bda3d0a46328a985c817d551423e2c6
+Source3:       http://caml.inria.fr/distrib/ocaml-%{sver}/%{name}-%{sver}-refman.info.tar.gz
+# Source3-md5: c808dbbe35a6cc5d14da6c3b2f175d2c
+Source4:       https://github.com/mmottl/pure-fun/archive/v1.0.13/pure-fun-1.0.13.tar.gz
+# Source4-md5: 0a6ff033df78d0880fe4883ace025ebe
+# note: dead URL
+Source5:       http://www.ocaml.info/ocaml_sources/ds-contrib.tar.gz
+# Source5-md5: 77fa1da7375dea1393cc0b6cd802d7e1
+Patch0:                %{name}-10266.patch
+Patch1:                %{name}-info.patch
+URL:           https://www.ocaml.org/
+Requires:      %{name}-runtime = %{epoch}:%{version}-%{release}
+Provides:      ocaml-bytes-devel
+Provides:      ocaml-ocamldoc
+Obsoletes:     ocaml-bytes-devel < 1.4
+Obsoletes:     ocaml-doc-ps < 1:4.12
+Obsoletes:     ocaml-emacs < 1:4.12
+Obsoletes:     ocaml-ocamldoc <= pre4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                specflags       -fno-strict-aliasing
+
+%if %{without ocaml_opt}
+%define                _noautoreq      Backend_intf Inlining_decision_intf Simplify_boxed_integer_ops_intf
+%endif
 
 %description
 Objective Caml is a high-level, strongly-typed, functional and
@@ -48,338 +56,300 @@ and an optimizing native-code compiler), an interactive toplevel
 system, Lex&Yacc tools, a replay debugger, and a comprehensive
 library.
 
-%description -l pl
-Objektowy Caml jest funkcjonalnym, obiektowo zorientowanym jêzykiem
-wysokiego poziomu z rodziny jêzyków ML.
+%description -l pl.UTF-8
+OCaml (Objective Caml) jest funkcyjnym, obiektowo zorientowanym
+językiem wysokiego poziomu z silnym typowaniem. Należy do rodziny
+języków ML.
 
-Ten pakiet zawiera dwa kompilatory (szybki kompilator bytecode oraz
-zoptymalizowany natywny kompilator), interaktywny g³ówny system,
-narzêdzia Lex&Yacc, odpluskwiacz i biblioteki.
-
-%package doc-ps
-Summary:       PostScript documentation for OCaml
-Summary(pl):   Dokumentacja dla OCaml-a w formacie PostSript
-Group:         Development/Tools
-
-%description doc-ps
-PostScript documentation for OCaml.
-
-%description doc-ps -l pl
-Dokumentacja dla OCamla w formacie PostSript.
-
-%package emacs
-Summary:       Emacs mode for OCaml
-Summary(pl):   Tryb Emacsa dla OCaml
-Group:         Development/Tools
-Requires:      %{name} = %{version}
-
-%description emacs
-Emacs mode files for Objective Caml language.
-
-%description emacs -l pl
-Pliki trybu Emacsa dla jêzyka Objektowego Camla.
+Ten pakiet zawiera dwa kompilatory (szybki kompilator do bajtkodu oraz
+optymalizujący kompilator do kodu natywnego), interaktywne środowisko
+pracy, narzędzia do tworzenia analizatorów leksykalnych oraz
+składniowych (ocamllex, ocamlyacc), odpluskwiacz (ocamldebug) i
+biblioteki.
 
 %package runtime
 Summary:       Runtime system for OCaml
-Summary(pl):   ¦rodowisko uruchomieniowe dla OCamla
+Summary(pl.UTF-8):     Środowisko uruchomieniowe dla OCamla
 Group:         Libraries
 
 %description runtime
 This package contains binaries needed to run bytecode OCaml programs:
 ocamlrun bytecode interpreter, and basic dynamic link libraries.
 
-%description runtime -l pl
-Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
-OCamlu skompilowanych do bytecodu: interpreter bytecodu ocamlrun oraz
-podstawowe bibliotki linkowane dynamicznie.
-
-%package labltk-devel
-Summary:       LabelTk library for OCaml
-Summary(pl):   Biblioteka LablTk dla OCamla
-Group:         Development/Libraries
-Requires:      %{name}-labltk = %{version}-%{release}
-
-%description labltk-devel
-LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
-contains files needed to develop OCaml programs using LablTk.
-
-%description labltk-devel -l pl
-Biblioteka LablTk daje programom napisanym w OCamlu dostêp do widgetów
-Tcl/Tk. Pakiet ten zawiera pliki niezbêdne do tworzenia programów
-u¿ywaj±cych LablTk.
-
-%package labltk
-Summary:       Runtime for LabelTk library
-Summary(pl):   ¦rodowisko uruchomieniowe dla biblioteki LablTk
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description labltk
-LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
-contains files needed to run bytecode OCaml programs using LablTk.
-
-%description labltk -l pl
-Biblioteka LablTk daje programom napisanym w OCamlu dostêp do widgetów
-Tcl/Tk. Pakiet ten zawiera binaria potrzebne do uruchamiania programów
-u¿ywaj±cych LablTk.
-
-%package x11graphics-devel
-Summary:       X11 graphic output for OCaml
-Summary(pl):   Iksowe wyj¶cie graficzne dla OCamla
-Group:         Development/Libraries
-Requires:      %{name}-x11graphics = %{version}-%{release}
-
-%description x11graphics-devel
-x11graphics module gives OCaml program access to drawing in X11
-windows. This package contains files needed to develop OCaml programs
-using x11graphics.
-
-%description x11graphics-devel -l pl
-Modu³ x11graphics daje programom napisanym w OCamlu dostêp do
-rysowania po oknach X11. Pakiet ten zawiera pliki niezbêdne do
-tworzenia programów u¿ywaj±cych x11graphics.
-
-%package x11graphics
-Summary:       X11 graphic output for OCaml
-Summary(pl):   Iksowe wyj¶cie graficzne dla OCamla
-Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description x11graphics
-x11graphics module gives OCaml program access to drawing in X11
-windows. This package contains files needed to run bytecode OCaml
-programs using x11graphics.
-
-%description x11graphics -l pl
-Modu³ x11graphics daje programom napisanym w OCamlu dostêp do
-rysowania po oknach X11. Pakiet ten zawiera binaria potrzebne do
-uruchamiania programów u¿ywaj±cych x11graphics.
-
-%package camlp4
-Summary:       Objective Caml Preprocessor
-Summary(pl):   Preprocesor Ocamla
+%description runtime -l pl.UTF-8
+Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
+OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun)
+oraz podstawowe biblioteki linkowane dynamicznie.
+
+%package lib-source
+Summary:       Sources of OCaml standard library
+Summary(pl.UTF-8):     Źródła biblioteki standardowej OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
-Provides:      camlp4 = %{version}-%{release}
-Obsoletes:     camlp4
-
-%description camlp4
-Camlp4 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
-tools for syntax (grammars) and the ability to modify the concrete
-syntax of the language (quotations, syntax extensions).
-
-Camlp4 can parse normal Ocaml concrete syntax or any other
-user-definable syntax. As an example, an alternative syntax is
-provided, named revised, because it tries to fix some small problems
-of the normal syntax.
-
-Camlp4 can pretty print the normal Ocaml concrete syntax or the
-revised one. It is therefore always possible to have a version of your
-sources compilable by the compiler Objective Caml without
-preprocessing.
-
-%description camlp4 -l pl
-Camlp4 jest preprocesorem dla Ocamla. Oferuje narzêdzia do sk³adni
-(gramatyki) oraz umiejêtno¶æ modyfikowania konkretnej sk³adni jêzyka
-(cytowania, rozszerzenia).
-
-Camlp4 mo¿e sparsowaæ normaln± sk³adniê Ocamla lub inn± dowoln±
-definiowaln± przez u¿ytkownika. Jako przyk³ad jest podana alternatywna
-sk³adnia, nazwana "poprawiona", poniewa¿ próbuje poprawiæ drobne
-problemy ze zwyk³± sk³adni±.
-
-Camlp4 umie ³adnie wypisaæ normaln± sk³adniê Camla lub "poprawion±".
-Dziêki temu jest mo¿liwe posiadanie wersji swoich ¼róde³
-kompilowalnych przez kompilatora Ocamla bez preprocesingu.
-
-%package devel
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description lib-source
+This sources come helpful during debugging of user programs with
+ocamldebug.
+
+%description lib-source -l pl.UTF-8
+Źródła te są przydatne przy odpluskwianiu programów użytkownika z
+użyciem ocamldebug.
+
+%package doc-html
+Summary:       HTML documentation for OCaml
+Summary(pl.UTF-8):     Dokumentacja dla OCamla w formacie HTML
+Group:         Development/Tools
+
+%description doc-html
+HTML documentation for OCaml.
+
+%description doc-html -l pl.UTF-8
+Dokumentacja dla OCamla w formacie HTML.
+
+%package doc-info
+Summary:       Info documentation for OCaml
+Summary(pl.UTF-8):     Dokumentacja info dla OCamla
+Group:         Development/Tools
+
+%description doc-info
+Info documentation for OCaml.
+
+%description doc-info -l pl.UTF-8
+Dokumentacja info dla OCamla.
+
+%package compiler-objects
 Summary:       Compiled parts of OCaml compiler
-Summary(pl):   Skompilowane kawa³ki kompilatora OCamla
+Summary(pl.UTF-8):     Skompilowane części kompilatora OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Provides:      ocaml-devel
+Obsoletes:     ocaml-devel < 3.06-3
 
-%description devel
+%description compiler-objects
 This package contains *.cmi and *.cmo files being parts of OCaml
 compiler. They are needed to compile some programs.
 
-%description devel -l pl
-Pakiet ten zawiera pliki *.cmi oraz *.cmo bêd±ce cze¶ciami kompilatora
-OCamla. S± one wymagane do kompilacji niektórych programów.
+%description compiler-objects -l pl.UTF-8
+Pakiet ten zawiera pliki *.cmi oraz *.cmo będące częściami kompilatora
+OCamla. Są one wymagane do kompilacji niektórych programów.
 
-%prep
-%setup -q -T -b 0
-%setup -q -T -D -a 1
-# order mess with docs somewhat
-mkdir docs
-mkdir docs/html
-mv htmlman docs/html/ocaml
-cp %{SOURCE2} docs/ocaml.ps.gz
-%setup -q -T -D -a 3
-mv camlp4-%{version}-refman.html docs/html/camlp4
-cp %{SOURCE4} docs/camlp4.ps.gz
-%setup -q -T -D -a 5
-mv camlp4-%{version}-tutorial.html docs/html/camlp4-tutorial
-cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
+%package ocamldoc-devel
+Summary:       Files needed to develop programs using ocamldoc
+Summary(pl.UTF-8):     Pliki potrzebne do tworzenia programów używających ocamldoc
+Group:         Development/Languages
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description ocamldoc-devel
+You need this package if you are going to write ocamldoc front end or
+something like that.
+
+%description ocamldoc-devel -l pl.UTF-8
+Będziesz potrzebować tego pakietu, jeśli zamierzasz pisać front end
+dla ocamldoc lub coś podobnego.
+
+# maybe we'll want to add some more stuff here?
+%package examples
+Summary:       Example source code for OCaml
+Summary(pl.UTF-8):     Przykładowe kody źródłowe w OCamlu
+Group:         Development/Languages
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description examples
+This packages contains sources for Okasaki's Purely Functional
+Datastructures in OCaml, along with some contributions.
 
+%description examples -l pl.UTF-8
+Pakiet ten zawiera źródła Czysto Funkcyjnych Struktur Danych autorstwa
+Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
+
+%prep
+%setup -q -a1 -a3
 %patch0 -p1
+gunzip infoman/ocaml.info.gz
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%ifarch ppc
-%patch4 -p1
-%endif
-%patch5 -p1
-%patch6 -p1
+
+mkdir examples
+tar xzf %{SOURCE4} -C examples
+tar xzf %{SOURCE5} -C examples
+# order mess with docs somewhat
+mkdir -p docs/html
+%{__mv} htmlman docs/html/ocaml
 
 %build
-./configure \
-        -cc "%{__cc} %{rpmcflags}" \
-       -bindir %{_bindir} \
-       -libdir %{_libdir}/%{name} \
-       -mandir %{_mandir}/man1 \
-       -host %{_host} \
-       %{?_without_tk:-notk} \
-       -with-pthread
-
-%{__make} world bootstrap opt ocamlc.opt ocamlopt.opt
-%{__make} -C camlp4 optp4
-%{__make} -C tools objinfo
+%configure \
+       AS=%{__as} \
+       ASPP="%{__cc} -c" \
+       --libdir=%{_libdir}/ocaml \
+       %{!?with_ocaml_opt:--disable-native-compiler}
+
+%{__make} world
+%{__make} bootstrap
+%if %{with ocaml_opt}
+%{__make} opt
+%{__make} opt.opt
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-%{version}}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
-%if %{!?_without_emacs:1}%{?_without_emacs:0}
-%{__make} -C emacs DESTDIR=$RPM_BUILD_ROOT install \
-       EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
-               else echo xemacs; fi`" \
-       EMACSDIR="%{_libdir}/emacs/site-lisp"
-%endif
-
-# symlink .opt versions of compilers (if present)
-for f in ocamlc ocamlopt; do
-       if test -f $RPM_BUILD_ROOT%{_bindir}/$f.opt; then
-               mv -f $RPM_BUILD_ROOT%{_bindir}/$f \
-                       $RPM_BUILD_ROOT%{_bindir}/$f.byte
-               ln -sf %{_bindir}/$f.opt $RPM_BUILD_ROOT%{_bindir}/$f
-       fi
-done
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.ml{,i}
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*/*.ml{,i}
+cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
+%{_libdir}/%{name}/stublibs
+%{_libdir}/%{name}
+EOF
 
 # move includes to the proper place
-install -d $RPM_BUILD_ROOT%{_includedir}
-mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/ocaml/caml $RPM_BUILD_ROOT%{_includedir}/caml
 # but leave compatibility symlink
-ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
+ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/ocaml/caml
 
 # compiled sources of compiler, needed by some programs
-for f in {asm,byte}comp parsing typing utils ; do
+for f in %{?with_ocaml_opt:asmcomp} bytecomp parsing typing utils ; do
        install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
-       cp $f/*.{cmi,cmo,cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
+       cp $f/*.{cmi,cmo} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
+       %{?with_ocaml_opt:cp $f/*.{cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f}
 done
 
-# this isn't installed by default, but is useful
-install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
-
-# instead of adding new directories to ld.conf, we use single dirctory
-# for dlls comming from other packages, they should be symlinked here
-echo %{_libdir}/%{name} > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf
-
-%{!?_without_tk:(cd $RPM_BUILD_ROOT%{_libdir}/%{name} && ln -s labltk/dll*.so .)}
+cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 
-install -d $RPM_BUILD_ROOT%{_examplesdir}
-mv otherlibs/labltk/example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
+# shutup checkfiles
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/man3
 
-ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
+# install info pages
+cp -p infoman/ocaml.info $RPM_BUILD_ROOT%{_infodir}
+cp -p infoman/ocaml.info.body-*.gz $RPM_BUILD_ROOT%{_infodir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files runtime
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/ocamlrun
-%attr(755,root,root) %{_libdir}/%{name}/dll[bmnstu]*.so
+%post  doc-info -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
+
+%postun        doc-info -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files
 %defattr(644,root,root,755)
-%doc LICENSE Changes README Upgrading
-%doc docs/html/ocaml
+%doc Changes LICENSE README.adoc
+%attr(755,root,root) %{_bindir}/addlabels
 %attr(755,root,root) %{_bindir}/ocaml
-%attr(755,root,root) %{_bindir}/ocaml[cmdlopy]*
-%attr(755,root,root) %{_bindir}/*labels
+%attr(755,root,root) %{_bindir}/ocamlc
+%attr(755,root,root) %{_bindir}/ocamlc.byte
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlc.opt}
+%attr(755,root,root) %{_bindir}/ocamlcmt
+%attr(755,root,root) %{_bindir}/ocamlcp
+%attr(755,root,root) %{_bindir}/ocamlcp.byte
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlcp.opt}
+%attr(755,root,root) %{_bindir}/ocamldebug
+%attr(755,root,root) %{_bindir}/ocamldep
+%attr(755,root,root) %{_bindir}/ocamldep.byte
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamldep.opt}
+%attr(755,root,root) %{_bindir}/ocamldoc
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamldoc.opt}
+%attr(755,root,root) %{_bindir}/ocamllex
+%attr(755,root,root) %{_bindir}/ocamllex.byte
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamllex.opt}
+%attr(755,root,root) %{_bindir}/ocamlmklib
+%attr(755,root,root) %{_bindir}/ocamlmklib.byte
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlmklib.opt}
+%attr(755,root,root) %{_bindir}/ocamlmktop
+%attr(755,root,root) %{_bindir}/ocamlmktop.byte
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlmktop.opt}
+%attr(755,root,root) %{_bindir}/ocamlobjinfo
+%attr(755,root,root) %{_bindir}/ocamlobjinfo.byte
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlobjinfo.opt}
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlopt}
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlopt.byte}
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlopt.opt}
+%attr(755,root,root) %{_bindir}/ocamloptp
+%attr(755,root,root) %{_bindir}/ocamloptp.byte
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamloptp.opt}
+%attr(755,root,root) %{_bindir}/ocamlprof
+%attr(755,root,root) %{_bindir}/ocamlprof.byte
+%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlprof.opt}
+%attr(755,root,root) %{_bindir}/ocamlyacc
+%attr(755,root,root) %{_bindir}/scrapelabels
 %{_includedir}/caml
 %{_libdir}/%{name}/caml
-%{_libdir}/%{name}/threads
-%{_libdir}/%{name}/[abefhimnopqrstuw]*.*
-%{_libdir}/%{name}/callback.*
-%{_libdir}/%{name}/char.*
-%{_libdir}/%{name}/dbm.*
-%{_libdir}/%{name}/digest.*
-%{_libdir}/%{name}/dynlink.*
-%{_libdir}/%{name}/g[ce]*.*
-%{_libdir}/%{name}/l*.cm*
-%{_libdir}/%{name}/lib[abc]*.a
-%{_libdir}/%{name}/libmldbm.a
-%{_libdir}/%{name}/lib[nstu]*.a
+%dir %{_libdir}/%{name}/compiler-libs
+%{_libdir}/%{name}/compiler-libs/*.cm*
+%{_libdir}/%{name}/compiler-libs/ocaml*.a
+%{?with_ocaml_opt:%{_libdir}/%{name}/compiler-libs/*.o}
+%dir %{_libdir}/%{name}/ocamldoc
+%{_libdir}/%{name}/ocamldoc/*.hva
+%dir %{_libdir}/%{name}/threads
+%{_libdir}/%{name}/threads/*.cm*
+%{_libdir}/%{name}/threads/threads.a
+%{_libdir}/%{name}/*.a
+%{?with_ocaml_opt:%{_libdir}/%{name}/*.o}
+%{_libdir}/%{name}/*.cm*
+%{_libdir}/%{name}/Makefile.config
 %{_libdir}/%{name}/ld.conf
-%attr(755,root,root) %{_libdir}/%{name}/expunge
-%attr(755,root,root) %{_libdir}/%{name}/extract_crc
 %{_libdir}/%{name}/camlheader
+%{_libdir}/%{name}/camlheaderd
+%{_libdir}/%{name}/camlheaderi
 %{_libdir}/%{name}/camlheader_ur
-%attr(755,root,root) %{_libdir}/%{name}/*labels
-%{_mandir}/man*/*ocaml*
-
-%files devel
-%defattr(644,root,root,755)
-%{_libdir}/%{name}/compiler
+%attr(755,root,root) %{_libdir}/%{name}/expunge
+%attr(755,root,root) %{_libdir}/%{name}/extract_crc
+%{_mandir}/man1/ocaml.1*
+%{_mandir}/man1/ocamlc.1*
+%{?with_ocaml_opt:%{_mandir}/man1/ocamlc.opt.1*}
+%{_mandir}/man1/ocamlcp.1*
+%{_mandir}/man1/ocamldebug.1*
+%{_mandir}/man1/ocamldep.1*
+%{_mandir}/man1/ocamldoc.1*
+%{_mandir}/man1/ocamllex.1*
+%{_mandir}/man1/ocamlmktop.1*
+%{?with_ocaml_opt:%{_mandir}/man1/ocamlopt.1*}
+%{?with_ocaml_opt:%{_mandir}/man1/ocamlopt.opt.1*}
+%{_mandir}/man1/ocamloptp.1*
+%{_mandir}/man1/ocamlprof.1*
+%{_mandir}/man1/ocamlyacc.1*
 
-%files camlp4
+%files runtime
 %defattr(644,root,root,755)
-%doc docs/html/camlp4*
-%attr(755,root,root) %{_bindir}/*camlp4*
-%attr(755,root,root) %{_bindir}/ocpp
-%attr(755,root,root) %{_bindir}/odyl
-%{_libdir}/%{name}/camlp4
-%{_mandir}/man*/*camlp4*
-%{_mandir}/man*/*ocpp*
-
-%if %{!?_without_tk:1}%{?_without_tk:0}
-%files labltk-devel
+%attr(755,root,root) %{_bindir}/ocamlrun
+%attr(755,root,root) %{_bindir}/ocamlrund
+%attr(755,root,root) %{_bindir}/ocamlruni
+%dir %{_libdir}/%{name}
+%{_libdir}/%{name}/eventlog_metadata
+%{?with_ocaml_opt:%attr(755,root,root) %{_libdir}/%{name}/libasmrun_shared.so}
+%dir %{_libdir}/%{name}/stublibs
+%attr(755,root,root) %{_libdir}/%{name}/stublibs/dllcamlstr.so
+%attr(755,root,root) %{_libdir}/%{name}/stublibs/dllthreads.so
+%attr(755,root,root) %{_libdir}/%{name}/stublibs/dllunix.so
+%attr(755,root,root) %{_libdir}/%{name}/libcamlrun_shared.so
+%{_mandir}/man1/ocamlrun.1*
+
+%files lib-source
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/labltk
-%attr(755,root,root) %{_bindir}/ocamlbrowser
-%dir %{_libdir}/%{name}/labltk
-%{_libdir}/%{name}/labltk/*.cm*
-%{_libdir}/%{name}/labltk/*.a
-%attr(755,root,root) %{_libdir}/%{name}/labltk/tkcompiler
-%{_examplesdir}/%{name}-labltk-%{version}
-
-%files labltk
+%{_libdir}/%{name}/*.ml
+%{_libdir}/%{name}/*.mli
+%{_libdir}/%{name}/compiler-libs/*.mli
+%{_libdir}/%{name}/ocamldoc/*.mli
+%{_libdir}/%{name}/threads/*.mli
+
+%files doc-html
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/labltk/dlllabltk*
-%{_libdir}/%{name}/dlllabltk*
-%endif
+%doc docs/html/ocaml/*
 
-%if %{!?_without_x11:1}%{?_without_x11:0}
-%files x11graphics-devel
+%files doc-info
 %defattr(644,root,root,755)
-%{_libdir}/%{name}/graphics*
-%{_libdir}/%{name}/libgraphics.a
+%{_infodir}/ocaml.info*
 
-%files x11graphics
+%files compiler-objects
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/dllgraphics.so
-%endif
+%{_libdir}/%{name}/compiler
 
-%if %{!?_without_emacs:1}%{?_without_emacs:0}
-%files emacs
+%files ocamldoc-devel
 %defattr(644,root,root,755)
-%{_libdir}/emacs/site-lisp/*.el
-%endif
+%{_libdir}/%{name}/ocamldoc/*.cm*
+%{?with_ocaml_opt:%{_libdir}/%{name}/ocamldoc/*.a}
 
-%files doc-ps
+%files examples
 %defattr(644,root,root,755)
-%doc docs/*.ps.gz
+%{_examplesdir}/%{name}-%{version}
This page took 0.17764 seconds and 4 git commands to generate.