]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- fixed x11graphics build; release 8
[packages/ocaml.git] / ocaml.spec
index 88e62b8651d9889ed5571924705523b5d6a0f432..e65abec3bc0a2f8874db04ff62b203b8ba030bd4 100644 (file)
@@ -1,47 +1,65 @@
+#
+# Conditional build:
 
-# conditional build:
-# --without emacs
-# --without tk
-# --without x11  (implies --without tk)
+%bcond_without emacs   # without emacs subpackage
+%bcond_without x       # without X11 support 
+%bcond_without tk      # without Tcl/Tk support
+%bcond_with    db3     # use db3 instead of db 4.x
 
-%{?_without_x11:%define        _without_tk     1}
+# --without x11 implies --without tk
+%{!?with_x:%undefine   with_tk}
+
+%define p4ver 3.06
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl):   Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
 Name:          ocaml
-Version:       3.06
-Release:       2
+Version:       3.07
+Release:       8
 License:       distributable
 Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
-Source0:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}/%{name}-%{version}.tar.gz
-Source1:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}/%{name}-%{version}-refman.html.tar.gz
-Source2:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}/%{name}-%{version}-refman.ps.gz
-Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-manual.html.tar.gz
-Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-manual.dvi.gz
-Source5:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.html.tar.gz
-Source6:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.dvi.gz
+Source0:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 2dd038055f5e1350078ad81270411b78
+Source1:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.html.tar.gz
+# Source1-md5: 9ac1f7e9e381b95504f0e7868d9fbf52
+Source2:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.ps.gz
+# Source2-md5: 09a9ac4bc1ec90ca4d16743ffbe76c78
+Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
+# Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
+Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
+# Source4-md5: 035915d1a530aa7ec9b194d9a7d258eb
+Source5:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.html.tar.gz
+# Source5-md5: 96d8eb4ca5abd58c9a280ba59f73b192
+Source6:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.dvi.gz
+# Source6-md5: fcd87c235109364242a0c9ccf176dff8
 Source7:       http://www.oefai.at/~markus/ocaml_sources/pure-fun-1.0.4.tar.bz2
+# Source7-md5: 567bc681b4cc1cfcbbfb6fa5f012019b
 Source8:       http://www.oefai.at/~markus/ocaml_sources/ds-contrib.tar.gz
+# Source8-md5: 77fa1da7375dea1393cc0b6cd802d7e1
 Patch0:                %{name}-build.patch
-Patch1:                %{name}-manlinks.patch
-Patch2:                %{name}-db3.patch
-Patch3:                %{name}-objinfo.patch
-Patch4:                %{name}-opt-symbols.patch
-Patch5:                %{name}-mano.patch
+Patch1:                %{name}-db3.patch
+Patch2:                %{name}-objinfo.patch
+Patch3:                %{name}-mano.patch
+Patch4:                %{name}-unused-var-warning.patch
+Patch5:                %{name}-3.07-patch2.diffs
+#Patch6:               %{name}-emacs_batch_mode.patch
 URL:           http://caml.inria.fr/
+%{?with_x:BuildRequires:               XFree86-devel}
+%{?with_db3:BuildRequires:     db3-devel}
+%{!?with_db3:BuildRequires:    db-devel >= 4.1}
+%{?with_tk:BuildRequires:              tk-devel}
+%if %{with emacs}
+BuildRequires: xemacs
+BuildRequires: xemacs-common
+BuildRequires: xemacs-fsf-compat-pkg
+
+%endif
 Requires:      ocaml-runtime = %{version}-%{release}
-Obsoletes:     ocaml-ocamldoc
 Provides:      ocaml-ocamldoc
-BuildRequires: db3-devel
-%{!?_without_tk:BuildRequires:         tk-devel}
-%{!?_without_x11:BuildRequires:                XFree86-devel}
-%{!?_without_emacs:BuildRequires:      xemacs}
-%{!?_without_emacs:BuildRequires:      xemacs-common}
-%{!?_without_emacs:BuildRequires:      xemacs-fsf-compat-pkg}
+Obsoletes:     ocaml-ocamldoc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-
 %description
 Objective Caml is a high-level, strongly-typed, functional and
 object-oriented programming language from the ML family of languages.
@@ -197,17 +215,19 @@ Camlp4 umie 
 poprawionej sk³adni OCamla. Potrafi tak¿e t³umaczyæ programy z jednej
 sk³adni na drug±.
 
-%package devel
+%package compiler-objects
 Summary:       Compiled parts of OCaml compiler
 Summary(pl):   Skompilowane czê¶ci kompilatora OCamla
 Group:         Development/Languages
 Requires:      %{name} = %{version}-%{release}
+Obsoletes:     ocaml-devel
+Provides:      ocaml-devel
 
-%description devel
+%description compiler-objects
 This package contains *.cmi and *.cmo files being parts of OCaml
 compiler. They are needed to compile some programs.
 
-%description devel -l pl
+%description compiler-objects -l pl
 Pakiet ten zawiera pliki *.cmi oraz *.cmo bêd±ce cze¶ciami kompilatora
 OCamla. S± one wymagane do kompilacji niektórych programów.
 
@@ -246,7 +266,7 @@ Group:              Development/Languages
 Requires:      %{name} = %{version}-%{release}
 
 %description examples
-This packages contains sources for Okasaki's Purely Functional 
+This packages contains sources for Okasaki's Purely Functional
 Datastructures in OCaml, along with some contributions.
 
 %description examples -l pl
@@ -254,43 +274,45 @@ Pakiet ten zawiera 
 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -T -b 0
-%setup -q -T -D -a 1
-%setup -q -T -D -c -n %{name}-%{version}/examples -a 7
-%setup -q -T -D -c -n %{name}-%{version}/examples -a 8
-%setup -q -T -D -n %{name}-%{version} -a 3
-%setup -q -T -D -n %{name}-%{version} -a 5
+%setup -q -a1 -a3 -a5
+mkdir examples
+tar xjf %{SOURCE7} -C examples
+tar xzf %{SOURCE8} -C examples
 # order mess with docs somewhat
 mkdir docs
 mkdir docs/html
 mv htmlman docs/html/ocaml
 cp %{SOURCE2} docs/ocaml.ps.gz
-mv camlp4-%{version}-manual.html docs/html/camlp4
+mv camlp4-%{p4ver}-manual.html docs/html/camlp4
 cp %{SOURCE4} docs/camlp4.ps.gz
-mv camlp4-%{version}-tutorial.html docs/html/camlp4-tutorial
+mv camlp4-%{p4ver}-tutorial.html docs/html/camlp4-tutorial
 cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-#%patch4 -p1
+%patch4 -p1
 %patch5 -p1
+#%patch6 -p1
 
 %build
+cp /usr/share/automake/config.sub config/gnu
 ./configure \
         -cc "%{__cc} %{rpmcflags}" \
        -bindir %{_bindir} \
        -libdir %{_libdir}/%{name} \
        -mandir %{_mandir}/man1 \
        -host %{_host} \
-       %{?_without_tk:-no-tk} \
-       -with-pthread
+       %{!?with_tk:-no-tk} \
+       -with-pthread \
+       -x11lib /usr/X11R6/%{_lib}
 
 %{__make} world bootstrap opt.opt
 %{__make} -C tools objinfo
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_includedir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
 
 %{__make} install \
        BINDIR=$RPM_BUILD_ROOT%{_bindir} \
@@ -302,7 +324,7 @@ cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
 %{_libdir}/%{name}
 EOF
 
-%if %{!?_without_emacs:1}%{?_without_emacs:0}
+%if %{with emacs}
 %{__make} -C emacs DESTDIR=$RPM_BUILD_ROOT install \
        EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
                else echo xemacs; fi`" \
@@ -320,7 +342,6 @@ for f in ocamlc ocamlopt ocamldoc ocamllex; do
 done
 
 # move includes to the proper place
-install -d $RPM_BUILD_ROOT%{_includedir}
 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
 # but leave compatibility symlink
 ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
@@ -333,13 +354,8 @@ done
 
 # this isn't installed by default, but is useful
 install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
 cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
-
 ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 
 # shutup checkfiles
@@ -356,8 +372,10 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/%{name}/stublibs
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
 %exclude %{_libdir}/%{name}/stublibs/dllgraphics.so
-%{!?_without_tk:%exclude %{_libdir}/%{name}/stublibs/dlllabltk.so}
-%{!?_without_tk:%exclude %{_libdir}/%{name}/stublibs/dlltkanim.so}
+%if %{with tk}
+%exclude %{_libdir}/%{name}/stublibs/dlllabltk.so
+%exclude %{_libdir}/%{name}/stublibs/dlltkanim.so
+%endif
 
 %files
 %defattr(644,root,root,755)
@@ -370,6 +388,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/caml
 %{_libdir}/%{name}/caml
 %{_libdir}/%{name}/threads
+%dir %{_libdir}/%{name}/vmthreads
+%dir %{_libdir}/%{name}/vmthreads/*.cm*
+%dir %{_libdir}/%{name}/vmthreads/*.a
 %{_libdir}/%{name}/*.a
 %{_libdir}/%{name}/*.o
 %{_libdir}/%{name}/*.cm*
@@ -378,7 +399,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/camlheader
 %{_libdir}/%{name}/camlheader_ur
 %dir %{_libdir}/%{name}/ocamldoc
-%{_libdir}/%{name}/ocamldoc/*.sty
 %{_libdir}/%{name}/ocamldoc/*.hva
 %attr(755,root,root) %{_libdir}/%{name}/expunge
 %attr(755,root,root) %{_libdir}/%{name}/extract_crc
@@ -389,6 +409,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/*.ml
 %{_libdir}/%{name}/*.mli
+%{_libdir}/%{name}/*/*.mli
 
 %files examples
 %defattr(644,root,root,755)
@@ -396,9 +417,9 @@ rm -rf $RPM_BUILD_ROOT
 
 # they are poor, html is much better
 #%files manpages
-#%{_mandir}/man3/*
+#%%{_mandir}/man3/*
 
-%files devel
+%files compiler-objects
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/compiler
 
@@ -413,7 +434,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man*/*camlp4*
 %{_mandir}/man*/*ocpp*
 
-%if %{!?_without_tk:1}%{?_without_tk:0}
+%if %{with tk}
 %files labltk-devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/labltk
@@ -430,7 +451,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dlltkanim.so
 %endif
 
-%if %{!?_without_x11:1}%{?_without_x11:0}
+%if %{with x}
 %files x11graphics-devel
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/graphics*.cm*
@@ -442,7 +463,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dllgraphics.so
 %endif
 
-%if %{!?_without_emacs:1}%{?_without_emacs:0}
+%if %{with emacs}
 %files emacs
 %defattr(644,root,root,755)
 %{_datadir}/emacs/site-lisp/*.el*
This page took 0.076562 seconds and 4 git commands to generate.