]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- epoch 1 follow AC-branch
[packages/ocaml.git] / ocaml.spec
index a084ff4b052f008bebe3398f100e1122e6a63e89..c79540dbff6e153222da6c0699f8100ca5442f33 100644 (file)
@@ -1,31 +1,31 @@
 #
 # Conditional build:
-
-%bcond_without emacs   # emacs subpackage
-%bcond_without x11     # without X11 support 
-%bcond_without tk      # tk support
-%bcond_with db3                # use db3 instead of db 4.x
-
+%bcond_without emacs   # without emacs subpackage
+%bcond_without x       # without X11 support 
+%bcond_without tk      # without Tcl/Tk support
+%bcond_with    db3     # use db3 instead of db 4.x
+#
 # --without x11 implies --without tk
-%{!?with_x11:%undefine with_tk}
+%{!?with_x:%undefine   with_tk}
 
-%define beta beta2
-%define p4ver 3.06
+%define                p4ver   3.06
+%define                sver    3.08
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl):   Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
 Name:          ocaml
-Version:       3.07
-Release:       0.%{beta}.1
+Version:       3.08.1
+Release:       1
+Epoch:         1
 License:       distributable
 Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
-Source0:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}.tar.gz
-# Source0-md5: ecc68d67871aeae91bd807f3a3e388cb
-Source1:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}-refman.html.tar.gz
-# Source1-md5: 6f92dcb308c6e6923c39f7aac3749f2d
-Source2:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}-refman.ps.gz
-# Source2-md5: 98b87b91c6ac5fd0ae1be7a732e49094
+Source0:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.gz
+# Source0-md5: 8a32dd665d0d8fc08a027e1b8f68a001
+Source1:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.html.tar.gz
+# Source1-md5: 0daee5643db6960682c1a7d84467885f
+Source2:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
+# Source2-md5: 35a5d4318456c0982e72ee3f33364bf5
 Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
 # Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
 Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
@@ -42,19 +42,21 @@ Patch0:             %{name}-build.patch
 Patch1:                %{name}-db3.patch
 Patch2:                %{name}-objinfo.patch
 Patch3:                %{name}-mano.patch
+# needs update for ocaml 3.08
+#Patch4:               %{name}-unused-var-warning.patch
 URL:           http://caml.inria.fr/
-Requires:      ocaml-runtime = %{version}-%{release}
-Obsoletes:     ocaml-ocamldoc
-Provides:      ocaml-ocamldoc
-%{?with_x11:BuildRequires:             XFree86-devel}
+%{?with_x:BuildRequires:       XFree86-devel}
 %{?with_db3:BuildRequires:     db3-devel}
 %{!?with_db3:BuildRequires:    db-devel >= 4.1}
-%{?with_tk:BuildRequires:              tk-devel}
+%{?with_tk:BuildRequires:      tk-devel}
 %if %{with emacs}
 BuildRequires: xemacs
 BuildRequires: xemacs-common
 BuildRequires: xemacs-fsf-compat-pkg
 %endif
+Requires:      ocaml-runtime = %{epoch}:%{version}-%{release}
+Provides:      ocaml-ocamldoc
+Obsoletes:     ocaml-ocamldoc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -91,7 +93,7 @@ w g
 Summary:       Emacs mode for OCaml
 Summary(pl):   Tryb OCamla dla Emacsa
 Group:         Development/Tools
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description emacs
 Emacs mode files for Objective Caml language.
@@ -117,7 +119,7 @@ podstawowe bibliotki linkowane dynamicznie.
 Summary:       LablTk library for OCaml
 Summary(pl):   Biblioteka LablTk dla OCamla
 Group:         Development/Libraries
-Requires:      %{name}-labltk = %{version}-%{release}
+Requires:      %{name}-labltk = %{epoch}:%{version}-%{release}
 
 %description labltk-devel
 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
@@ -132,7 +134,7 @@ u
 Summary:       Runtime for LablTk library
 Summary(pl):   ¦rodowisko uruchomieniowe dla biblioteki LablTk
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description labltk
 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
@@ -147,7 +149,7 @@ u
 Summary:       X11 graphic output for OCaml
 Summary(pl):   Dostêp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name}-x11graphics = %{version}-%{release}
+Requires:      %{name}-x11graphics = %{epoch}:%{version}-%{release}
 
 %description x11graphics-devel
 x11graphics module gives OCaml program access to drawing in X11
@@ -163,7 +165,7 @@ niezb
 Summary:       X11 graphic output for OCaml
 Summary(pl):   Dostêp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description x11graphics
 x11graphics module gives OCaml program access to drawing in X11
@@ -179,8 +181,8 @@ potrzebne do uruchamiania program
 Summary:       Objective Caml Preprocessor
 Summary(pl):   Preprocesor OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
-Provides:      camlp4 = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Provides:      camlp4 = %{epoch}:%{version}-%{release}
 Obsoletes:     camlp4
 
 %description camlp4
@@ -216,8 +218,9 @@ sk
 Summary:       Compiled parts of OCaml compiler
 Summary(pl):   Skompilowane czê¶ci kompilatora OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Obsoletes:     ocaml-devel
+Provides:      ocaml-devel
 
 %description compiler-objects
 This package contains *.cmi and *.cmo files being parts of OCaml
@@ -231,7 +234,7 @@ OCamla. S
 Summary:       Files needed to develop programs using ocamldoc
 Summary(pl):   Pliki potrzebne do tworzenia programów u¿ywaj±cych ocamldoc
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description ocamldoc-devel
 You need this package if you are going to write ocamldoc front end or
@@ -245,7 +248,7 @@ dla ocamldoc lub co
 Summary:       Sources of OCaml standard library
 Summary(pl):   ¬ród³a biblioteki standardowej OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description lib-source
 This sources come helpful during debugging of user programs with ocamldebug.
@@ -259,7 +262,7 @@ z u
 Summary:       Example source code for OCaml
 Summary(pl):   Przyk³adowe kody ¼ród³owe w OCamlu
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description examples
 This packages contains sources for Okasaki's Purely Functional
@@ -270,7 +273,7 @@ Pakiet ten zawiera 
 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -n %{name}-%{version}%{beta} -a1 -a3 -a5
+%setup -q -a1 -a3 -a5  
 mkdir examples
 tar xjf %{SOURCE7} -C examples
 tar xzf %{SOURCE8} -C examples
@@ -287,8 +290,10 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+#%patch4 -p1
 
 %build
+cp -f /usr/share/automake/config.sub config/gnu
 ./configure \
         -cc "%{__cc} %{rpmcflags}" \
        -bindir %{_bindir} \
@@ -296,13 +301,15 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
        -mandir %{_mandir}/man1 \
        -host %{_host} \
        %{!?with_tk:-no-tk} \
-       -with-pthread
+       -with-pthread \
+       -x11lib /usr/X11R6/%{_lib}
 
 %{__make} world bootstrap opt.opt
 %{__make} -C tools objinfo
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_includedir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
 
 %{__make} install \
        BINDIR=$RPM_BUILD_ROOT%{_bindir} \
@@ -332,7 +339,6 @@ for f in ocamlc ocamlopt ocamldoc ocamllex; do
 done
 
 # move includes to the proper place
-install -d $RPM_BUILD_ROOT%{_includedir}
 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
 # but leave compatibility symlink
 ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
@@ -345,13 +351,8 @@ done
 
 # this isn't installed by default, but is useful
 install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
 cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
-
 ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 
 # shutup checkfiles
@@ -447,7 +448,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dlltkanim.so
 %endif
 
-%if %{with x11}
+%if %{with x}
 %files x11graphics-devel
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/graphics*.cm*
This page took 0.07393 seconds and 4 git commands to generate.