]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- added P: ocaml-devel for clean upgrade from Ra.
[packages/ocaml.git] / ocaml.spec
index e265230d322b11ecfc83d4684cf0662755d755cf..b84df6b2ba2704551eca8eb9e6ce3ecca46a489a 100644 (file)
@@ -1,37 +1,63 @@
+#
+# Conditional build:
 
-# conditional build:
-# --without emacs
-# --without tk
-# --without x11  (implies --without tk)
+%bcond_without emacs   # emacs subpackage
+%bcond_without x       # without X11 support 
+%bcond_without tk      # tk support
+%bcond_with db3                # use db3 instead of db 4.x
 
-%{?_without_x11:%define        _without_tk     1}
+# --without x11 implies --without tk
+%{!?with_x:%undefine   with_tk}
+
+%define p4ver 3.06
 
 Summary:       The Objective Caml compiler and programming environment
-Summary(pl):   Kompilator Objektowego Caml oraz ¶rodowisko programistyczne
+Summary(pl):   Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
 Name:          ocaml
-Version:       3.04
-Release:       4
+Version:       3.07
+Release:       7
 License:       distributable
 Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
-Source0:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}.tar.gz
-Source1:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}-refman.info.tar.gz
-Source2:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}-refman.html.tar.gz
-Source3:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}-refman.ps.gz
-Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-refman.html.tar.gz
-Source5:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-refman.ps.gz
-Source6:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.html.tar.gz
-Source7:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.ps.gz
+Source0:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 2dd038055f5e1350078ad81270411b78
+Source1:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.html.tar.gz
+# Source1-md5: 9ac1f7e9e381b95504f0e7868d9fbf52
+Source2:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.ps.gz
+# Source2-md5: 09a9ac4bc1ec90ca4d16743ffbe76c78
+Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
+# Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
+Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
+# Source4-md5: 035915d1a530aa7ec9b194d9a7d258eb
+Source5:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.html.tar.gz
+# Source5-md5: 96d8eb4ca5abd58c9a280ba59f73b192
+Source6:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.dvi.gz
+# Source6-md5: fcd87c235109364242a0c9ccf176dff8
+Source7:       http://www.oefai.at/~markus/ocaml_sources/pure-fun-1.0.4.tar.bz2
+# Source7-md5: 567bc681b4cc1cfcbbfb6fa5f012019b
+Source8:       http://www.oefai.at/~markus/ocaml_sources/ds-contrib.tar.gz
+# Source8-md5: 77fa1da7375dea1393cc0b6cd802d7e1
 Patch0:                %{name}-build.patch
-Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-manlinks.patch
-Patch3:                %{name}-db3.patch
+Patch1:                %{name}-db3.patch
+Patch2:                %{name}-objinfo.patch
+Patch3:                %{name}-mano.patch
+Patch4:                %{name}-unused-var-warning.patch
+Patch5:                %{name}-3.07-patch2.diffs
+#Patch6:               %{name}-emacs_batch_mode.patch
 URL:           http://caml.inria.fr/
-BuildRequires: db3-devel
-%{!?_without_tk:BuildRequires:         tk-devel}
-%{!?_without_x11:BuildRequires:                XFree86-devel}
-%{!?_without_emacs:BuildRequires:      xemacs-common}
-%{!?_without_emacs:BuildRequires:      xemacs-fsf-compat-pkg}
+%{?with_x:BuildRequires:               XFree86-devel}
+%{?with_db3:BuildRequires:     db3-devel}
+%{!?with_db3:BuildRequires:    db-devel >= 4.1}
+%{?with_tk:BuildRequires:              tk-devel}
+%if %{with emacs}
+BuildRequires: xemacs
+BuildRequires: xemacs-common
+BuildRequires: xemacs-fsf-compat-pkg
+
+%endif
+Requires:      ocaml-runtime = %{version}-%{release}
+Provides:      ocaml-ocamldoc
+Obsoletes:     ocaml-ocamldoc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -44,81 +70,120 @@ system, Lex&Yacc tools, a replay debugger, and a comprehensive
 library.
 
 %description -l pl
-Objektowy Caml jest funkcjonalnym, obiektowo zorientowanym jêzykiem
-wysokiego poziomu z rodziny jêzyków ML.
+OCaml (Objective Caml) jest funkcyjnym, obiektowo zorientowanym jêzykiem
+wysokiego poziomu z silnym typowaniem. Nale¿y do rodziny jêzyków ML.
 
-Ten pakiet zawiera dwa kompilatory (szybki kompilator bytecode oraz
-zoptymalizowany natywny kompilator), interaktywny g³ówny system,
-narzêdzia Lex&Yacc, odpluskwiacz i biblioteki.
+Ten pakiet zawiera dwa kompilatory (szybki kompilator do bajtkodu
+oraz optymalizuj±cy kompilator do kodu natywnego), interaktywne ¶rodowisko
+pracy, narzêdzia do tworzenia analizatorów leksykalnych oraz sk³adniowych
+(ocamllex, ocamlyacc), odpluskwiacz (ocamldebug) i biblioteki.
 
 %package doc-ps
 Summary:       PostScript documentation for OCaml
-Summary(pl):   Dokumentacja dla OCaml-a w formacie PostSript
+Summary(pl):   Dokumentacja dla OCamla w formacie PostScript
 Group:         Development/Tools
-Requires:      %{name} = %{version}
 
 %description doc-ps
-PostScript documentation for OCaml
+PostScript documentation for OCaml. HTML documentation is in main package.
 
 %description doc-ps -l pl
-Dokumentacja dla OCaml-a w formacie PostSript
-
-%package doc-html
-Summary:       HTML documentation for OCaml
-Summary(pl):   Dokumentacja dla OCaml-a w formacie HTML
-Group:         Development/Tools
-Requires:      %{name} = %{version}
-
-%description doc-html
-HTML documentation for OCaml
-
-%description doc-html -l pl
-Dokumentacja dla OCaml-a w formacie HTML
+Dokumentacja dla OCamla w formacie PostScript. Dokumentacja HTML jest
+w g³ównym pakiecie.
 
 %package emacs
 Summary:       Emacs mode for OCaml
-Summary(pl):   Tryb Emacsa dla OCaml
+Summary(pl):   Tryb OCamla dla Emacsa
 Group:         Development/Tools
 Requires:      %{name} = %{version}
 
 %description emacs
-Emacs mode files for Objective Caml language
+Emacs mode files for Objective Caml language.
 
 %description emacs -l pl
-Pliki trybu Emacsa dla jêzyka Objektowego Caml
+Pliki trybu OCamla dla Emacsa.
 
-%package labltk
-Summary:       LabelTk library for OCaml
+%package runtime
+Summary:       Runtime system for OCaml
+Summary(pl):   ¦rodowisko uruchomieniowe dla OCamla
+Group:         Libraries
+
+%description runtime
+This package contains binaries needed to run bytecode OCaml programs:
+ocamlrun bytecode interpreter, and basic dynamic link libraries.
+
+%description runtime -l pl
+Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
+OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun) oraz
+podstawowe bibliotki linkowane dynamicznie.
+
+%package labltk-devel
+Summary:       LablTk library for OCaml
 Summary(pl):   Biblioteka LablTk dla OCamla
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name}-labltk = %{version}-%{release}
+
+%description labltk-devel
+LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
+contains files needed to develop OCaml programs using LablTk.
+
+%description labltk-devel -l pl
+Biblioteka LablTk daje programom napisanym w OCamlu dostêp do widgetów
+Tcl/Tk. Pakiet ten zawiera pliki niezbêdne do tworzenia programów
+u¿ywaj±cych LablTk.
+
+%package labltk
+Summary:       Runtime for LablTk library
+Summary(pl):   ¦rodowisko uruchomieniowe dla biblioteki LablTk
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
 
 %description labltk
-LablTk gives OCaml program access to Tcl/Tk GUI widgets.
+LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
+contains files needed to run bytecode OCaml programs using LablTk.
 
 %description labltk -l pl
 Biblioteka LablTk daje programom napisanym w OCamlu dostêp do widgetów
-Tcl/Tk.
+Tcl/Tk. Pakiet ten zawiera binaria potrzebne do uruchamiania programów
+u¿ywaj±cych LablTk.
+
+%package x11graphics-devel
+Summary:       X11 graphic output for OCaml
+Summary(pl):   Dostêp do X11 dla OCamla
+Group:         Development/Libraries
+Requires:      %{name}-x11graphics = %{version}-%{release}
+
+%description x11graphics-devel
+x11graphics module gives OCaml program access to drawing in X11
+windows. This package contains files needed to develop OCaml programs
+using x11graphics.
+
+%description x11graphics-devel -l pl
+Modu³ x11graphics daje programom napisanym w OCamlu mo¿liwo¶æ
+korzystania z interfejsu graficznego X11. Pakiet ten zawiera pliki
+niezbêdne do tworzenia programów u¿ywaj±cych x11graphics.
 
 %package x11graphics
 Summary:       X11 graphic output for OCaml
-Summary(pl):   Iksowe wyj¶cie graficzne dla OCamla
+Summary(pl):   Dostêp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{version}-%{release}
 
 %description x11graphics
-This package gives OCaml program access to drawing in X11 windows.
+x11graphics module gives OCaml program access to drawing in X11
+windows. This package contains files needed to run bytecode OCaml
+programs using x11graphics.
 
 %description x11graphics -l pl
-Ten pakiet daje programom napisanym w OCamlu dostêp do rysowania po
-oknach X11.
+Modu³ x11graphics daje programom napisanym w OCamlu mo¿liwo¶æ
+korzystania z interfejsu graficznego X11. Pakiet ten zawiera binaria
+potrzebne do uruchamiania programów u¿ywaj±cych x11graphics.
 
 %package camlp4
 Summary:       Objective Caml Preprocessor
-Summary(pl):   Preprocesor Ocamla
+Summary(pl):   Preprocesor OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}
-Provides:      camlp4 = %{version}
+Requires:      %{name} = %{version}-%{release}
+Provides:      camlp4 = %{version}-%{release}
 Obsoletes:     camlp4
 
 %description camlp4
@@ -133,91 +198,142 @@ of the normal syntax.
 
 Camlp4 can pretty print the normal Ocaml concrete syntax or the
 revised one. It is therefore always possible to have a version of your
-sources compilable by the compiler Objective Caml without
+sources compilable by the Objective Caml compiler without
 preprocessing.
 
 %description camlp4 -l pl
-Camlp4 jest preprocesorem dla Ocamla. Oferuje narzêdzia do sk³adni
-(gramatyki) oraz umiejêtno¶æ modyfikowania konkretnej sk³adni jêzyka
-(cytowania, rozszerzenia).
+Camlp4 jest preprocesorem OCamla. Oferuje narzêdzia do manipulowania
+sk³adni± (gramatyki) oraz mo¿liwo¶æ modyfikowania oryginalnej sk³adni
+jêzyka (cytowania, rozszerzenia).
+
+Camlp4 mo¿e sparsowaæ oryginaln± sk³adniê Ocamla lub dowoln± inn±
+definiowaln± przez u¿ytkownika. Jako przyk³ad podana jest alternatywna
+sk³adnia (revised syntax), która próbuje poprawiæ drobne problemy
+wystêpuj±ce w sk³adni oryginalnej.
+
+Camlp4 umie ³adnie formatowaæ ¼ród³a zarówno w oryginalnej jak i
+poprawionej sk³adni OCamla. Potrafi tak¿e t³umaczyæ programy z jednej
+sk³adni na drug±.
+
+%package compiler-objects
+Summary:       Compiled parts of OCaml compiler
+Summary(pl):   Skompilowane czê¶ci kompilatora OCamla
+Group:         Development/Languages
+Requires:      %{name} = %{version}-%{release}
+Obsoletes:     ocaml-devel
+Provides:      ocaml-devel
+
+%description compiler-objects
+This package contains *.cmi and *.cmo files being parts of OCaml
+compiler. They are needed to compile some programs.
+
+%description compiler-objects -l pl
+Pakiet ten zawiera pliki *.cmi oraz *.cmo bêd±ce cze¶ciami kompilatora
+OCamla. S± one wymagane do kompilacji niektórych programów.
+
+%package ocamldoc-devel
+Summary:       Files needed to develop programs using ocamldoc
+Summary(pl):   Pliki potrzebne do tworzenia programów u¿ywaj±cych ocamldoc
+Group:         Development/Languages
+Requires:      %{name} = %{version}-%{release}
+
+%description ocamldoc-devel
+You need this package if you are going to write ocamldoc front end or
+something like that.
+
+%description ocamldoc-devel -l pl
+Bêdziesz potrzebowaæ tego pakietu, je¶li zamierzasz pisaæ front end
+dla ocamldoc lub co¶ podobnego.
+
+%package lib-source
+Summary:       Sources of OCaml standard library
+Summary(pl):   ¬ród³a biblioteki standardowej OCamla
+Group:         Development/Languages
+Requires:      %{name} = %{version}-%{release}
 
-Camlp4 mo¿e sparsowaæ normaln± sk³adniê Ocamla lub inn± dowoln±
-definiowaln± przez u¿ytkownika. Jako przyk³ad jest podana alternatywna
-sk³adnia, nazwana "poprawiona", poniewa¿ próbuje poprawiæ drobne
-problemy ze zwyk³± sk³adni±.
+%description lib-source
+This sources come helpful during debugging of user programs with ocamldebug.
 
-Camlp4 umie ³adnie wypisaæ normaln± sk³adniê Camla lub "poprawion±".
-Dziêki temu jest mo¿liwe posiadanie wersji swoich ¼róde³
-kompilowalnych przez kompilatora Ocamla bez preprocesingu.
+%description lib-source -l pl
+¬ród³a te s± przydatne przy odpluskwianiu programów u¿ytkownika
+z u¿yciem ocamldebug.
+
+# maybe we'll want to add some more stuff here?
+%package examples
+Summary:       Example source code for OCaml
+Summary(pl):   Przyk³adowe kody ¼ród³owe w OCamlu
+Group:         Development/Languages
+Requires:      %{name} = %{version}-%{release}
+
+%description examples
+This packages contains sources for Okasaki's Purely Functional
+Datastructures in OCaml, along with some contributions.
+
+%description examples -l pl
+Pakiet ten zawiera ¼ród³a Czysto Funkcyjnych Struktur Danych
+autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -T -b 0
-%setup -q -T -D -a 1
-%setup -q -T -D -a 2
+%setup -q -a1 -a3 -a5
+mkdir examples
+tar xjf %{SOURCE7} -C examples
+tar xzf %{SOURCE8} -C examples
 # order mess with docs somewhat
 mkdir docs
 mkdir docs/html
 mv htmlman docs/html/ocaml
-cp %{SOURCE3} docs/ocaml.ps.gz
-%setup -q -T -D -a 4
-mv camlp4-%{version}-refman.html docs/html/camlp4
-cp %{SOURCE5} docs/camlp4.ps.gz
-%setup -q -T -D -a 6
-mv camlp4-%{version}-tutorial.html docs/html/camlp4-tutorial
-cp %{SOURCE7} docs/camlp4-tutorial.ps.gz
-
+cp %{SOURCE2} docs/ocaml.ps.gz
+mv camlp4-%{p4ver}-manual.html docs/html/camlp4
+cp %{SOURCE4} docs/camlp4.ps.gz
+mv camlp4-%{p4ver}-tutorial.html docs/html/camlp4-tutorial
+cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+#%patch6 -p1
 
 %build
+cp /usr/share/automake/config.sub config/gnu
 ./configure \
         -cc "%{__cc} %{rpmcflags}" \
        -bindir %{_bindir} \
        -libdir %{_libdir}/%{name} \
        -mandir %{_mandir}/man1 \
        -host %{_host} \
-       %{?_without_tk:-notk} \
-       -with-pthread
+       %{!?with_tk:-no-tk} \
+       -with-pthread \
+       -x11lib /usr/X11R6/%{_lib}
 
-# this is crude hack (works in addition to ocaml-db3.patch)
-cp config/Makefile config/Makefile.tmp
-sed -e 's|-ldb1|-ldb|; s|-I%{_includedir}/db1||' < config/Makefile.tmp > config/Makefile
-
-%{__make} world bootstrap opt ocamlc.opt ocamlopt.opt
-%ifnarch ppc
-%{__make} -C camlp4 optp4
-%endif
-
-# hack info pages to contain dir entry
-cat <<EOF >infoman/ocaml.info
-INFO-DIR-SECTION Programming Languages:
-START-INFO-DIR-ENTRY
-* Ocaml: (ocaml).                             The Ocaml language
-END-INFO-DIR-ENTRY
-EOF
-zcat infoman/ocaml.info.gz >> infoman/ocaml.info
-
-gzip -9nf infoman/ocaml.info
+%{__make} world bootstrap opt.opt
+%{__make} -C tools objinfo
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_infodir}
+install -d $RPM_BUILD_ROOT{%{_includedir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       BINDIR=$RPM_BUILD_ROOT%{_bindir} \
+       LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{name} \
+       MANDIR=$RPM_BUILD_ROOT%{_mandir}
 
-%if %{!?_without_emacs:1}%{?_without_emacs:0}
+cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
+%{_libdir}/%{name}/stublibs
+%{_libdir}/%{name}
+EOF
+
+%if %{with emacs}
 %{__make} -C emacs DESTDIR=$RPM_BUILD_ROOT install \
        EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
                else echo xemacs; fi`" \
-       EMACSDIR="%{_libdir}/emacs/site-lisp"
+       EMACSDIR="$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp"
 %endif
 
-cp -p {parsing/{location,longident,parsetree},typing/typecore}.{cm,ml}i \
-       $RPM_BUILD_ROOT%{_libdir}/%{name}
-
-for f in ocamlc ocamlopt camlp4o camlp4r; do
+# symlink .opt versions of compilers (if present)
+# warning: don't do that with camlp4 (can't load extensions then)
+for f in ocamlc ocamlopt ocamldoc ocamllex; do
        if test -f $RPM_BUILD_ROOT%{_bindir}/$f.opt; then
                mv -f $RPM_BUILD_ROOT%{_bindir}/$f \
                        $RPM_BUILD_ROOT%{_bindir}/$f.byte
@@ -225,94 +341,139 @@ for f in ocamlc ocamlopt camlp4o camlp4r; do
        fi
 done
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{_name}/*.ml
-ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
+# move includes to the proper place
+mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
+# but leave compatibility symlink
+ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
+
+# compiled sources of compiler, needed by some programs
+for f in {asm,byte}comp parsing typing utils ; do
+       install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
+       cp $f/*.{cmi,cmo,cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
+done
 
-install infoman/*info* $RPM_BUILD_ROOT%{_infodir}
+# this isn't installed by default, but is useful
+install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
+cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
+ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 
-gzip -9nf LICENSE Changes README Upgrading
+# shutup checkfiles
+rm -rf $RPM_BUILD_ROOT%{_mandir}/man3
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%postun
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
+%files runtime
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/ocamlrun
+%dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/stublibs
+%attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
+%exclude %{_libdir}/%{name}/stublibs/dllgraphics.so
+%if %{with tk}
+%exclude %{_libdir}/%{name}/stublibs/dlllabltk.so
+%exclude %{_libdir}/%{name}/stublibs/dlltkanim.so
+%endif
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%attr(755,root,root) %{_bindir}/ocaml
-%attr(755,root,root) %{_bindir}/ocaml[cmdlopry]*
+%doc LICENSE Changes README Upgrading
+%doc docs/html/ocaml
+%attr(755,root,root) %{_bindir}/ocaml*
+%{!?_without_tk:%exclude %{_bindir}/ocamlbrowser}
+%exclude %{_bindir}/ocamlrun
 %attr(755,root,root) %{_bindir}/*labels
+%{_includedir}/caml
 %{_libdir}/%{name}/caml
 %{_libdir}/%{name}/threads
-%{_libdir}/%{name}/[abefhimnopqrstuw]*.*
-%{_libdir}/%{name}/callback.*
-%{_libdir}/%{name}/char.*
-%{_libdir}/%{name}/condition.*
-%{_libdir}/%{name}/dbm.*
-%{_libdir}/%{name}/digest.*
-%attr(755,root,root) %{_libdir}/%{name}/dll[bmnstu]*.so
-%{_libdir}/%{name}/g[ce]*.*
-%{_libdir}/%{name}/l*.cm*
-%{_libdir}/%{name}/l*.mli
-%{_libdir}/%{name}/lib[abc]*.a
-%{_libdir}/%{name}/libmldbm.a
-%{_libdir}/%{name}/lib[nstu]*.a
+%dir %{_libdir}/%{name}/vmthreads
+%dir %{_libdir}/%{name}/vmthreads/*.cm*
+%dir %{_libdir}/%{name}/vmthreads/*.a
+%{_libdir}/%{name}/*.a
+%{_libdir}/%{name}/*.o
+%{_libdir}/%{name}/*.cm*
+%exclude %{_libdir}/%{name}/*graphics*
 %{_libdir}/%{name}/ld.conf
-%attr(755,root,root) %{_libdir}/%{name}/expunge
-%attr(755,root,root) %{_libdir}/%{name}/extract_crc
 %{_libdir}/%{name}/camlheader
 %{_libdir}/%{name}/camlheader_ur
+%dir %{_libdir}/%{name}/ocamldoc
+%{_libdir}/%{name}/ocamldoc/*.hva
+%attr(755,root,root) %{_libdir}/%{name}/expunge
+%attr(755,root,root) %{_libdir}/%{name}/extract_crc
 %attr(755,root,root) %{_libdir}/%{name}/*labels
-%{_mandir}/man*/*ocaml*
-%{_infodir}/*
+%{_mandir}/man1/*ocaml*
+
+%files lib-source
+%defattr(644,root,root,755)
+%{_libdir}/%{name}/*.ml
+%{_libdir}/%{name}/*.mli
+%{_libdir}/%{name}/*/*.mli
+
+%files examples
+%defattr(644,root,root,755)
+%{_examplesdir}/%{name}-%{version}
+
+# they are poor, html is much better
+#%files manpages
+#%%{_mandir}/man3/*
+
+%files compiler-objects
+%defattr(644,root,root,755)
+%{_libdir}/%{name}/compiler
 
 %files camlp4
 %defattr(644,root,root,755)
+%doc docs/html/camlp4*
 %attr(755,root,root) %{_bindir}/*camlp4*
 %attr(755,root,root) %{_bindir}/ocpp
-%attr(755,root,root) %{_bindir}/odyl
+# Not installed since 3.05, is is needed?
+#%attr(755,root,root) %{_bindir}/odyl
 %{_libdir}/%{name}/camlp4
 %{_mandir}/man*/*camlp4*
 %{_mandir}/man*/*ocpp*
 
-%if %{!?_without_tk:1}%{?_without_tk:0}
-%files labltk
+%if %{with tk}
+%files labltk-devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/labltk
 %attr(755,root,root) %{_bindir}/ocamlbrowser
 %dir %{_libdir}/%{name}/labltk
 %{_libdir}/%{name}/labltk/*.cm*
 %{_libdir}/%{name}/labltk/*.a
-%{_libdir}/%{name}/labltk/*.mli
-%attr(755,root,root) %{_libdir}/%{name}/labltk/*.so
-%attr(755,root,root) %{_libdir}/%{name}/labltk/labltktop
 %attr(755,root,root) %{_libdir}/%{name}/labltk/tkcompiler
+%{_examplesdir}/%{name}-labltk-%{version}
+
+%files labltk
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/stublibs/dlllabltk.so
+%attr(755,root,root) %{_libdir}/%{name}/stublibs/dlltkanim.so
 %endif
 
-%if %{!?_without_x11:1}%{?_without_x11:0}
-%files x11graphics
+%if %{with x11}
+%files x11graphics-devel
 %defattr(644,root,root,755)
-%{_libdir}/%{name}/graphics*
+%{_libdir}/%{name}/graphics*.cm*
+%{_libdir}/%{name}/graphics.a
 %{_libdir}/%{name}/libgraphics.a
-%attr(755,root,root) %{_libdir}/%{name}/dllgraphics.so
+
+%files x11graphics
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/stublibs/dllgraphics.so
 %endif
 
-%if %{!?_without_emacs:1}%{?_without_emacs:0}
+%if %{with emacs}
 %files emacs
 %defattr(644,root,root,755)
-%{_libdir}/emacs/site-lisp/*.el
+%{_datadir}/emacs/site-lisp/*.el*
 %endif
 
-%files doc-ps
+%files ocamldoc-devel
 %defattr(644,root,root,755)
-%doc docs/*.ps.gz
+%{_libdir}/%{name}/ocamldoc/*.cm*
+%{_libdir}/%{name}/ocamldoc/*.a
 
-%files doc-html
+%files doc-ps
 %defattr(644,root,root,755)
-%doc docs/html/*
+%doc docs/*.ps.gz
This page took 0.106632 seconds and 4 git commands to generate.