]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- added P: ocaml-devel for clean upgrade from Ra.
[packages/ocaml.git] / ocaml.spec
index a084ff4b052f008bebe3398f100e1122e6a63e89..b84df6b2ba2704551eca8eb9e6ce3ecca46a489a 100644 (file)
@@ -2,30 +2,29 @@
 # Conditional build:
 
 %bcond_without emacs   # emacs subpackage
-%bcond_without x11     # without X11 support 
+%bcond_without x       # without X11 support 
 %bcond_without tk      # tk support
 %bcond_with db3                # use db3 instead of db 4.x
 
 # --without x11 implies --without tk
-%{!?with_x11:%undefine with_tk}
+%{!?with_x:%undefine   with_tk}
 
-%define beta beta2
 %define p4ver 3.06
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl):   Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
 Name:          ocaml
 Version:       3.07
-Release:       0.%{beta}.1
+Release:       7
 License:       distributable
 Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
-Source0:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}.tar.gz
-# Source0-md5: ecc68d67871aeae91bd807f3a3e388cb
-Source1:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}-refman.html.tar.gz
-# Source1-md5: 6f92dcb308c6e6923c39f7aac3749f2d
-Source2:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}-refman.ps.gz
-# Source2-md5: 98b87b91c6ac5fd0ae1be7a732e49094
+Source0:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 2dd038055f5e1350078ad81270411b78
+Source1:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.html.tar.gz
+# Source1-md5: 9ac1f7e9e381b95504f0e7868d9fbf52
+Source2:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.ps.gz
+# Source2-md5: 09a9ac4bc1ec90ca4d16743ffbe76c78
 Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
 # Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
 Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
@@ -42,11 +41,11 @@ Patch0:             %{name}-build.patch
 Patch1:                %{name}-db3.patch
 Patch2:                %{name}-objinfo.patch
 Patch3:                %{name}-mano.patch
+Patch4:                %{name}-unused-var-warning.patch
+Patch5:                %{name}-3.07-patch2.diffs
+#Patch6:               %{name}-emacs_batch_mode.patch
 URL:           http://caml.inria.fr/
-Requires:      ocaml-runtime = %{version}-%{release}
-Obsoletes:     ocaml-ocamldoc
-Provides:      ocaml-ocamldoc
-%{?with_x11:BuildRequires:             XFree86-devel}
+%{?with_x:BuildRequires:               XFree86-devel}
 %{?with_db3:BuildRequires:     db3-devel}
 %{!?with_db3:BuildRequires:    db-devel >= 4.1}
 %{?with_tk:BuildRequires:              tk-devel}
@@ -54,7 +53,11 @@ Provides:    ocaml-ocamldoc
 BuildRequires: xemacs
 BuildRequires: xemacs-common
 BuildRequires: xemacs-fsf-compat-pkg
+
 %endif
+Requires:      ocaml-runtime = %{version}-%{release}
+Provides:      ocaml-ocamldoc
+Obsoletes:     ocaml-ocamldoc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -218,6 +221,7 @@ Summary(pl):        Skompilowane cz
 Group:         Development/Languages
 Requires:      %{name} = %{version}-%{release}
 Obsoletes:     ocaml-devel
+Provides:      ocaml-devel
 
 %description compiler-objects
 This package contains *.cmi and *.cmo files being parts of OCaml
@@ -270,7 +274,7 @@ Pakiet ten zawiera 
 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -n %{name}-%{version}%{beta} -a1 -a3 -a5
+%setup -q -a1 -a3 -a5
 mkdir examples
 tar xjf %{SOURCE7} -C examples
 tar xzf %{SOURCE8} -C examples
@@ -287,8 +291,12 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+#%patch6 -p1
 
 %build
+cp /usr/share/automake/config.sub config/gnu
 ./configure \
         -cc "%{__cc} %{rpmcflags}" \
        -bindir %{_bindir} \
@@ -296,13 +304,15 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
        -mandir %{_mandir}/man1 \
        -host %{_host} \
        %{!?with_tk:-no-tk} \
-       -with-pthread
+       -with-pthread \
+       -x11lib /usr/X11R6/%{_lib}
 
 %{__make} world bootstrap opt.opt
 %{__make} -C tools objinfo
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_includedir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
 
 %{__make} install \
        BINDIR=$RPM_BUILD_ROOT%{_bindir} \
@@ -332,7 +342,6 @@ for f in ocamlc ocamlopt ocamldoc ocamllex; do
 done
 
 # move includes to the proper place
-install -d $RPM_BUILD_ROOT%{_includedir}
 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
 # but leave compatibility symlink
 ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
@@ -345,13 +354,8 @@ done
 
 # this isn't installed by default, but is useful
 install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
 cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
-
 ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 
 # shutup checkfiles
This page took 0.036788 seconds and 4 git commands to generate.