]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- CFLAGS fixes (5 sed invokations replaced with patch)
[packages/ocaml.git] / ocaml.spec
index c1258ddc58f52ee66de1ff1b756a9c59455c456e..9a6e5449e1aeff5fd32108b6ce16aef0ae577fbf 100644 (file)
@@ -1,56 +1,66 @@
 #
 # Conditional build:
-# _without_emacs       - without emacs subpackage
-# _without_tk          - without tk support
-# _without_x11         - without X11 support (implies --without tk)
-# _with_db3            - use db3 instead of db 4.x
+%bcond_without emacs   # without emacs subpackage
+%bcond_without x       # without X11 support 
+%bcond_without tk      # without Tcl/Tk support
+%bcond_with    db3     # use db3 instead of db 4.x
 #
-%{?_without_x11:%define        _without_tk     1}
+# --without x11 implies --without tk
+%{!?with_x:%undefine   with_tk}
+
+%define                p4ver   3.06
+%define                sver    3.08
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl):   Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
 Name:          ocaml
-Version:       3.06
-Release:       3
+Version:       3.08.4
+Release:       2
+Epoch:         1
 License:       distributable
 Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
-Source0:       ftp://ftp.inria.fr/INRIA/caml-light/%{name}-%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 51530ed183b511ce19fed325c8ab1b43
-Source1:       ftp://ftp.inria.fr/INRIA/caml-light/%{name}-%{version}/%{name}-%{version}-refman.html.tar.gz
-# Source1-md5: 2b555271d2630698fcd3a9b9acfd1440
-Source2:       ftp://ftp.inria.fr/INRIA/caml-light/%{name}-%{version}/%{name}-%{version}-refman.ps.gz
-# Source2-md5: 7a23eb2287e04d359500dcaa8a8b504c
-Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-manual.html.tar.gz
+Source0:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.gz
+# Source0-md5: 105d192896bf945b660c4fb1ee486f57
+Source1:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.html.tar.gz
+# Source1-md5: 0daee5643db6960682c1a7d84467885f
+Source2:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
+# Source2-md5: 35a5d4318456c0982e72ee3f33364bf5
+Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
 # Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
-Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-manual.dvi.gz
+Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
 # Source4-md5: 035915d1a530aa7ec9b194d9a7d258eb
-Source5:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.html.tar.gz
+Source5:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.html.tar.gz
 # Source5-md5: 96d8eb4ca5abd58c9a280ba59f73b192
-Source6:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.dvi.gz
+Source6:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.dvi.gz
 # Source6-md5: fcd87c235109364242a0c9ccf176dff8
-Source7:       http://www.oefai.at/~markus/ocaml_sources/pure-fun-1.0.4.tar.bz2
+Source7:       http://www.ocaml.info/ocaml_sources/pure-fun-1.0.4.tar.bz2
 # Source7-md5: 567bc681b4cc1cfcbbfb6fa5f012019b
-Source8:       http://www.oefai.at/~markus/ocaml_sources/ds-contrib.tar.gz
+Source8:       http://www.ocaml.info/ocaml_sources/ds-contrib.tar.gz
 # Source8-md5: 77fa1da7375dea1393cc0b6cd802d7e1
+Source9:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.info.tar.gz
+# Source9-md5: 49b68ec07ccd7ce45eb6bd3f3fdee140
 Patch0:                %{name}-build.patch
-Patch1:                %{name}-manlinks.patch
-Patch2:                %{name}-db3.patch
-Patch3:                %{name}-objinfo.patch
-Patch4:                %{name}-opt-symbols.patch
-Patch5:                %{name}-mano.patch
-Patch6:                %{name}-tk8.4.patch
+Patch1:                %{name}-db3.patch
+Patch2:                %{name}-objinfo.patch
+# needs update for ocaml 3.08
+#Patch3:               %{name}-unused-var-warning.patch
+Patch4:                %{name}-tk85support.patch
+Patch5:                %{name}-CFLAGS.patch
 URL:           http://caml.inria.fr/
-Requires:      ocaml-runtime = %{version}-%{release}
-Obsoletes:     ocaml-ocamldoc
+%{?with_x:BuildRequires:       XFree86-devel}
+%{?with_db3:BuildRequires:     db3-devel}
+%{!?with_db3:BuildRequires:    db-devel >= 4.1}
+%{?with_tk:BuildRequires:      tk-devel}
+%if %{with emacs}
+BuildRequires: sed >= 4.0
+BuildRequires: xemacs
+BuildRequires: xemacs-common
+BuildRequires: xemacs-fsf-compat-pkg
+%endif
+Requires:      %{name}-runtime = %{epoch}:%{version}-%{release}
 Provides:      ocaml-ocamldoc
-%{!?_without_x11:BuildRequires:                XFree86-devel}
-%{?_with_db3:BuildRequires:    db3-devel}
-%{!?_with_db3:BuildRequires:   db-devel >= 4.1}
-%{!?_without_tk:BuildRequires:         tk-devel >= 8.4.3}
-%{!?_without_emacs:BuildRequires:      xemacs}
-%{!?_without_emacs:BuildRequires:      xemacs-common}
-%{!?_without_emacs:BuildRequires:      xemacs-fsf-compat-pkg}
+Obsoletes:     ocaml-ocamldoc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -71,23 +81,44 @@ oraz optymalizuj
 pracy, narzêdzia do tworzenia analizatorów leksykalnych oraz sk³adniowych
 (ocamllex, ocamlyacc), odpluskwiacz (ocamldebug) i biblioteki.
 
+%package doc-html
+Summary:       HTML documentation for OCaml
+Summary(pl):   Dokumentacja dla OCamla w formacie HTML
+Group:         Development/Tools
+
+%description doc-html
+HTML documentation for OCaml.
+
+%description doc-html -l pl
+Dokumentacja dla OCamla w formacie HTML.
+
 %package doc-ps
 Summary:       PostScript documentation for OCaml
 Summary(pl):   Dokumentacja dla OCamla w formacie PostScript
 Group:         Development/Tools
 
 %description doc-ps
-PostScript documentation for OCaml. HTML documentation is in main package.
+PostScript documentation for OCaml.
 
 %description doc-ps -l pl
-Dokumentacja dla OCamla w formacie PostScript. Dokumentacja HTML jest
-w g³ównym pakiecie.
+Dokumentacja dla OCamla w formacie PostScript.
+
+%package doc-info
+Summary:       Info documentation for OCaml
+Summary(pl):   Dokumentacja info dla OCamla
+Group:         Development/Tools
+
+%description doc-info
+Info documentation for OCaml.
+
+%description doc-info -l pl
+Dokumentacja info dla OCamla.
 
 %package emacs
 Summary:       Emacs mode for OCaml
 Summary(pl):   Tryb OCamla dla Emacsa
 Group:         Development/Tools
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description emacs
 Emacs mode files for Objective Caml language.
@@ -107,13 +138,13 @@ ocamlrun bytecode interpreter, and basic dynamic link libraries.
 %description runtime -l pl
 Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
 OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun) oraz
-podstawowe bibliotki linkowane dynamicznie.
+podstawowe biblioteki linkowane dynamicznie.
 
 %package labltk-devel
 Summary:       LablTk library for OCaml
 Summary(pl):   Biblioteka LablTk dla OCamla
 Group:         Development/Libraries
-Requires:      %{name}-labltk = %{version}-%{release}
+Requires:      %{name}-labltk = %{epoch}:%{version}-%{release}
 
 %description labltk-devel
 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
@@ -128,7 +159,7 @@ u
 Summary:       Runtime for LablTk library
 Summary(pl):   ¦rodowisko uruchomieniowe dla biblioteki LablTk
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description labltk
 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
@@ -143,7 +174,7 @@ u
 Summary:       X11 graphic output for OCaml
 Summary(pl):   Dostêp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name}-x11graphics = %{version}-%{release}
+Requires:      %{name}-x11graphics = %{epoch}:%{version}-%{release}
 
 %description x11graphics-devel
 x11graphics module gives OCaml program access to drawing in X11
@@ -159,7 +190,7 @@ niezb
 Summary:       X11 graphic output for OCaml
 Summary(pl):   Dostêp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description x11graphics
 x11graphics module gives OCaml program access to drawing in X11
@@ -175,8 +206,8 @@ potrzebne do uruchamiania program
 Summary:       Objective Caml Preprocessor
 Summary(pl):   Preprocesor OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
-Provides:      camlp4 = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Provides:      camlp4 = %{epoch}:%{version}-%{release}
 Obsoletes:     camlp4
 
 %description camlp4
@@ -208,26 +239,38 @@ Camlp4 umie 
 poprawionej sk³adni OCamla. Potrafi tak¿e t³umaczyæ programy z jednej
 sk³adni na drug±.
 
+%package camlp4-doc-html
+Summary:       Objective Caml Preprocessor - HTML documentation 
+Summary(pl):   Preprocesor OCamla - dokumentacja HTML 
+Group:         Development/Languages
+
+%description camlp4-doc-html
+Objective Caml Preprocessor - HTML documentation.
+
+%description camlp4-doc-html -l pl
+Preprocesor OCamla - dokumentacja HTML.
+
 %package compiler-objects
 Summary:       Compiled parts of OCaml compiler
 Summary(pl):   Skompilowane czê¶ci kompilatora OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Obsoletes:     ocaml-devel
+Provides:      ocaml-devel
 
 %description compiler-objects
 This package contains *.cmi and *.cmo files being parts of OCaml
 compiler. They are needed to compile some programs.
 
 %description compiler-objects -l pl
-Pakiet ten zawiera pliki *.cmi oraz *.cmo bêd±ce cze¶ciami kompilatora
+Pakiet ten zawiera pliki *.cmi oraz *.cmo bêd±ce czê¶ciami kompilatora
 OCamla. S± one wymagane do kompilacji niektórych programów.
 
 %package ocamldoc-devel
 Summary:       Files needed to develop programs using ocamldoc
 Summary(pl):   Pliki potrzebne do tworzenia programów u¿ywaj±cych ocamldoc
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description ocamldoc-devel
 You need this package if you are going to write ocamldoc front end or
@@ -241,7 +284,7 @@ dla ocamldoc lub co
 Summary:       Sources of OCaml standard library
 Summary(pl):   ¬ród³a biblioteki standardowej OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description lib-source
 This sources come helpful during debugging of user programs with ocamldebug.
@@ -255,7 +298,7 @@ z u
 Summary:       Example source code for OCaml
 Summary(pl):   Przyk³adowe kody ¼ród³owe w OCamlu
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description examples
 This packages contains sources for Okasaki's Purely Functional
@@ -266,42 +309,44 @@ Pakiet ten zawiera 
 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -a1 -a3 -a5
+%setup -q -a1 -a3 -a5  
 mkdir examples
 tar xjf %{SOURCE7} -C examples
 tar xzf %{SOURCE8} -C examples
+tar xzf %{SOURCE9}
 # order mess with docs somewhat
-mkdir docs
-mkdir docs/html
+mkdir -p docs/html
 mv htmlman docs/html/ocaml
 cp %{SOURCE2} docs/ocaml.ps.gz
-mv camlp4-%{version}-manual.html docs/html/camlp4
+mv camlp4-%{p4ver}-manual.html docs/html/camlp4
 cp %{SOURCE4} docs/camlp4.ps.gz
-mv camlp4-%{version}-tutorial.html docs/html/camlp4-tutorial
+mv camlp4-%{p4ver}-tutorial.html docs/html/camlp4-tutorial
 cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-#%patch4 -p1
+#%patch3 -p1
+%patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
-%build
+%build 
+cp -f /usr/share/automake/config.sub config/gnu
 ./configure \
-        -cc "%{__cc} %{rpmcflags}" \
+        -cc "%{__cc}" \
        -bindir %{_bindir} \
        -libdir %{_libdir}/%{name} \
        -mandir %{_mandir}/man1 \
        -host %{_host} \
-       %{?_without_tk:-no-tk} \
-       -with-pthread
+       %{!?with_tk:-no-tk} \
+       -with-pthread \
+       -x11lib /usr/X11R6/%{_lib}
 
-%{__make} world bootstrap opt.opt
-%{__make} -C tools objinfo
+%{__make} -j1 world bootstrap opt.opt CFLAGS="%{rpmcflags} -Wall"
+%{__make} -C tools objinfo CFLAGS="%{rpmcflags} -Wall" -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
 
 %{__make} install \
        BINDIR=$RPM_BUILD_ROOT%{_bindir} \
@@ -313,7 +358,7 @@ cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
 %{_libdir}/%{name}
 EOF
 
-%if %{!?_without_emacs:1}%{?_without_emacs:0}
+%if %{with emacs}
 %{__make} -C emacs DESTDIR=$RPM_BUILD_ROOT install \
        EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
                else echo xemacs; fi`" \
@@ -331,7 +376,6 @@ for f in ocamlc ocamlopt ocamldoc ocamllex; do
 done
 
 # move includes to the proper place
-install -d $RPM_BUILD_ROOT%{_includedir}
 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
 # but leave compatibility symlink
 ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
@@ -344,22 +388,26 @@ done
 
 # this isn't installed by default, but is useful
 install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
 cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
-
 ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 
 # shutup checkfiles
 rm -rf $RPM_BUILD_ROOT%{_mandir}/man3
 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
 
+# install info pages
+cp -f infoman/*.gz $RPM_BUILD_ROOT%{_infodir}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post doc-info
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+
+%postun doc-info
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+
 %files runtime
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/ocamlrun
@@ -367,13 +415,14 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/%{name}/stublibs
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
 %exclude %{_libdir}/%{name}/stublibs/dllgraphics.so
-%{!?_without_tk:%exclude %{_libdir}/%{name}/stublibs/dlllabltk.so}
-%{!?_without_tk:%exclude %{_libdir}/%{name}/stublibs/dlltkanim.so}
+%if %{with tk}
+%exclude %{_libdir}/%{name}/stublibs/dlllabltk.so
+%exclude %{_libdir}/%{name}/stublibs/dlltkanim.so
+%endif
 
 %files
 %defattr(644,root,root,755)
 %doc LICENSE Changes README Upgrading
-%doc docs/html/ocaml
 %attr(755,root,root) %{_bindir}/ocaml*
 %{!?_without_tk:%exclude %{_bindir}/ocamlbrowser}
 %exclude %{_bindir}/ocamlrun
@@ -381,6 +430,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/caml
 %{_libdir}/%{name}/caml
 %{_libdir}/%{name}/threads
+%dir %{_libdir}/%{name}/vmthreads
+%dir %{_libdir}/%{name}/vmthreads/*.cm*
+%dir %{_libdir}/%{name}/vmthreads/*.a
 %{_libdir}/%{name}/*.a
 %{_libdir}/%{name}/*.o
 %{_libdir}/%{name}/*.cm*
@@ -389,7 +441,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/camlheader
 %{_libdir}/%{name}/camlheader_ur
 %dir %{_libdir}/%{name}/ocamldoc
-%{_libdir}/%{name}/ocamldoc/*.sty
 %{_libdir}/%{name}/ocamldoc/*.hva
 %attr(755,root,root) %{_libdir}/%{name}/expunge
 %attr(755,root,root) %{_libdir}/%{name}/extract_crc
@@ -400,6 +451,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/*.ml
 %{_libdir}/%{name}/*.mli
+%{_libdir}/%{name}/*/*.mli
 
 %files examples
 %defattr(644,root,root,755)
@@ -415,7 +467,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files camlp4
 %defattr(644,root,root,755)
-%doc docs/html/camlp4*
 %attr(755,root,root) %{_bindir}/*camlp4*
 %attr(755,root,root) %{_bindir}/ocpp
 # Not installed since 3.05, is is needed?
@@ -424,7 +475,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man*/*camlp4*
 %{_mandir}/man*/*ocpp*
 
-%if %{!?_without_tk:1}%{?_without_tk:0}
+%files camlp4-doc-html
+%defattr(644,root,root,755)
+%doc docs/html/camlp4*
+
+%if %{with tk}
 %files labltk-devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/labltk
@@ -441,7 +496,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dlltkanim.so
 %endif
 
-%if %{!?_without_x11:1}%{?_without_x11:0}
+%if %{with x}
 %files x11graphics-devel
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/graphics*.cm*
@@ -453,7 +508,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dllgraphics.so
 %endif
 
-%if %{!?_without_emacs:1}%{?_without_emacs:0}
+%if %{with emacs}
 %files emacs
 %defattr(644,root,root,755)
 %{_datadir}/emacs/site-lisp/*.el*
@@ -464,6 +519,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/ocamldoc/*.cm*
 %{_libdir}/%{name}/ocamldoc/*.a
 
+%files doc-html
+%defattr(644,root,root,755)
+%doc docs/html/ocaml/*
+
 %files doc-ps
 %defattr(644,root,root,755)
 %doc docs/*.ps.gz
+
+%files doc-info
+%defattr(644,root,root,755)
+%{_infodir}/ocaml.info*
This page took 0.043962 seconds and 4 git commands to generate.