]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- CFLAGS fixes (5 sed invokations replaced with patch)
[packages/ocaml.git] / ocaml.spec
index 7ba9c2a386620b68e78a6224091e899655e0781a..9a6e5449e1aeff5fd32108b6ce16aef0ae577fbf 100644 (file)
@@ -1,30 +1,31 @@
 #
 # Conditional build:
-
-%bcond_without emacs   # emacs subpackage
-%bcond_without x       # without X11 support 
-%bcond_without tk      # tk support
-%bcond_with db3                # use db3 instead of db 4.x
-
+%bcond_without emacs   # without emacs subpackage
+%bcond_without x       # without X11 support 
+%bcond_without tk      # without Tcl/Tk support
+%bcond_with    db3     # use db3 instead of db 4.x
+#
 # --without x11 implies --without tk
 %{!?with_x:%undefine   with_tk}
 
-%define p4ver 3.06
+%define                p4ver   3.06
+%define                sver    3.08
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl):   Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
 Name:          ocaml
-Version:       3.07
-Release:       5
+Version:       3.08.4
+Release:       2
+Epoch:         1
 License:       distributable
 Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
-Source0:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 2dd038055f5e1350078ad81270411b78
-Source1:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.html.tar.gz
-# Source1-md5: 9ac1f7e9e381b95504f0e7868d9fbf52
-Source2:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.ps.gz
-# Source2-md5: 09a9ac4bc1ec90ca4d16743ffbe76c78
+Source0:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.gz
+# Source0-md5: 105d192896bf945b660c4fb1ee486f57
+Source1:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.html.tar.gz
+# Source1-md5: 0daee5643db6960682c1a7d84467885f
+Source2:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
+# Source2-md5: 35a5d4318456c0982e72ee3f33364bf5
 Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
 # Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
 Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
@@ -33,29 +34,31 @@ Source5:    ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutori
 # Source5-md5: 96d8eb4ca5abd58c9a280ba59f73b192
 Source6:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.dvi.gz
 # Source6-md5: fcd87c235109364242a0c9ccf176dff8
-Source7:       http://www.oefai.at/~markus/ocaml_sources/pure-fun-1.0.4.tar.bz2
+Source7:       http://www.ocaml.info/ocaml_sources/pure-fun-1.0.4.tar.bz2
 # Source7-md5: 567bc681b4cc1cfcbbfb6fa5f012019b
-Source8:       http://www.oefai.at/~markus/ocaml_sources/ds-contrib.tar.gz
+Source8:       http://www.ocaml.info/ocaml_sources/ds-contrib.tar.gz
 # Source8-md5: 77fa1da7375dea1393cc0b6cd802d7e1
+Source9:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.info.tar.gz
+# Source9-md5: 49b68ec07ccd7ce45eb6bd3f3fdee140
 Patch0:                %{name}-build.patch
 Patch1:                %{name}-db3.patch
 Patch2:                %{name}-objinfo.patch
-Patch3:                %{name}-mano.patch
-Patch4:                %{name}-unused-var-warning.patch
-Patch5:                %{name}-3.07-patch2.diffs
-#Patch6:               %{name}-emacs_batch_mode.patch
+# needs update for ocaml 3.08
+#Patch3:               %{name}-unused-var-warning.patch
+Patch4:                %{name}-tk85support.patch
+Patch5:                %{name}-CFLAGS.patch
 URL:           http://caml.inria.fr/
-%{?with_x:BuildRequires:               XFree86-devel}
+%{?with_x:BuildRequires:       XFree86-devel}
 %{?with_db3:BuildRequires:     db3-devel}
 %{!?with_db3:BuildRequires:    db-devel >= 4.1}
-%{?with_tk:BuildRequires:              tk-devel}
+%{?with_tk:BuildRequires:      tk-devel}
 %if %{with emacs}
+BuildRequires: sed >= 4.0
 BuildRequires: xemacs
 BuildRequires: xemacs-common
 BuildRequires: xemacs-fsf-compat-pkg
-
 %endif
-Requires:      ocaml-runtime = %{version}-%{release}
+Requires:      %{name}-runtime = %{epoch}:%{version}-%{release}
 Provides:      ocaml-ocamldoc
 Obsoletes:     ocaml-ocamldoc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -78,23 +81,44 @@ oraz optymalizuj
 pracy, narzêdzia do tworzenia analizatorów leksykalnych oraz sk³adniowych
 (ocamllex, ocamlyacc), odpluskwiacz (ocamldebug) i biblioteki.
 
+%package doc-html
+Summary:       HTML documentation for OCaml
+Summary(pl):   Dokumentacja dla OCamla w formacie HTML
+Group:         Development/Tools
+
+%description doc-html
+HTML documentation for OCaml.
+
+%description doc-html -l pl
+Dokumentacja dla OCamla w formacie HTML.
+
 %package doc-ps
 Summary:       PostScript documentation for OCaml
 Summary(pl):   Dokumentacja dla OCamla w formacie PostScript
 Group:         Development/Tools
 
 %description doc-ps
-PostScript documentation for OCaml. HTML documentation is in main package.
+PostScript documentation for OCaml.
 
 %description doc-ps -l pl
-Dokumentacja dla OCamla w formacie PostScript. Dokumentacja HTML jest
-w g³ównym pakiecie.
+Dokumentacja dla OCamla w formacie PostScript.
+
+%package doc-info
+Summary:       Info documentation for OCaml
+Summary(pl):   Dokumentacja info dla OCamla
+Group:         Development/Tools
+
+%description doc-info
+Info documentation for OCaml.
+
+%description doc-info -l pl
+Dokumentacja info dla OCamla.
 
 %package emacs
 Summary:       Emacs mode for OCaml
 Summary(pl):   Tryb OCamla dla Emacsa
 Group:         Development/Tools
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description emacs
 Emacs mode files for Objective Caml language.
@@ -114,13 +138,13 @@ ocamlrun bytecode interpreter, and basic dynamic link libraries.
 %description runtime -l pl
 Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
 OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun) oraz
-podstawowe bibliotki linkowane dynamicznie.
+podstawowe biblioteki linkowane dynamicznie.
 
 %package labltk-devel
 Summary:       LablTk library for OCaml
 Summary(pl):   Biblioteka LablTk dla OCamla
 Group:         Development/Libraries
-Requires:      %{name}-labltk = %{version}-%{release}
+Requires:      %{name}-labltk = %{epoch}:%{version}-%{release}
 
 %description labltk-devel
 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
@@ -135,7 +159,7 @@ u
 Summary:       Runtime for LablTk library
 Summary(pl):   ¦rodowisko uruchomieniowe dla biblioteki LablTk
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description labltk
 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
@@ -150,7 +174,7 @@ u
 Summary:       X11 graphic output for OCaml
 Summary(pl):   Dostêp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name}-x11graphics = %{version}-%{release}
+Requires:      %{name}-x11graphics = %{epoch}:%{version}-%{release}
 
 %description x11graphics-devel
 x11graphics module gives OCaml program access to drawing in X11
@@ -166,7 +190,7 @@ niezb
 Summary:       X11 graphic output for OCaml
 Summary(pl):   Dostêp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description x11graphics
 x11graphics module gives OCaml program access to drawing in X11
@@ -182,8 +206,8 @@ potrzebne do uruchamiania program
 Summary:       Objective Caml Preprocessor
 Summary(pl):   Preprocesor OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
-Provides:      camlp4 = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Provides:      camlp4 = %{epoch}:%{version}-%{release}
 Obsoletes:     camlp4
 
 %description camlp4
@@ -215,26 +239,38 @@ Camlp4 umie 
 poprawionej sk³adni OCamla. Potrafi tak¿e t³umaczyæ programy z jednej
 sk³adni na drug±.
 
+%package camlp4-doc-html
+Summary:       Objective Caml Preprocessor - HTML documentation 
+Summary(pl):   Preprocesor OCamla - dokumentacja HTML 
+Group:         Development/Languages
+
+%description camlp4-doc-html
+Objective Caml Preprocessor - HTML documentation.
+
+%description camlp4-doc-html -l pl
+Preprocesor OCamla - dokumentacja HTML.
+
 %package compiler-objects
 Summary:       Compiled parts of OCaml compiler
 Summary(pl):   Skompilowane czê¶ci kompilatora OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Obsoletes:     ocaml-devel
+Provides:      ocaml-devel
 
 %description compiler-objects
 This package contains *.cmi and *.cmo files being parts of OCaml
 compiler. They are needed to compile some programs.
 
 %description compiler-objects -l pl
-Pakiet ten zawiera pliki *.cmi oraz *.cmo bêd±ce cze¶ciami kompilatora
+Pakiet ten zawiera pliki *.cmi oraz *.cmo bêd±ce czê¶ciami kompilatora
 OCamla. S± one wymagane do kompilacji niektórych programów.
 
 %package ocamldoc-devel
 Summary:       Files needed to develop programs using ocamldoc
 Summary(pl):   Pliki potrzebne do tworzenia programów u¿ywaj±cych ocamldoc
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description ocamldoc-devel
 You need this package if you are going to write ocamldoc front end or
@@ -248,7 +284,7 @@ dla ocamldoc lub co
 Summary:       Sources of OCaml standard library
 Summary(pl):   ¬ród³a biblioteki standardowej OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description lib-source
 This sources come helpful during debugging of user programs with ocamldebug.
@@ -262,7 +298,7 @@ z u
 Summary:       Example source code for OCaml
 Summary(pl):   Przyk³adowe kody ¼ród³owe w OCamlu
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description examples
 This packages contains sources for Okasaki's Purely Functional
@@ -273,13 +309,13 @@ Pakiet ten zawiera 
 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -a1 -a3 -a5
+%setup -q -a1 -a3 -a5  
 mkdir examples
 tar xjf %{SOURCE7} -C examples
 tar xzf %{SOURCE8} -C examples
+tar xzf %{SOURCE9}
 # order mess with docs somewhat
-mkdir docs
-mkdir docs/html
+mkdir -p docs/html
 mv htmlman docs/html/ocaml
 cp %{SOURCE2} docs/ocaml.ps.gz
 mv camlp4-%{p4ver}-manual.html docs/html/camlp4
@@ -289,27 +325,28 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+#%patch3 -p1
 %patch4 -p1
 %patch5 -p1
-#%patch6 -p1
 
-%build
+%build 
+cp -f /usr/share/automake/config.sub config/gnu
 ./configure \
-        -cc "%{__cc} %{rpmcflags}" \
+        -cc "%{__cc}" \
        -bindir %{_bindir} \
        -libdir %{_libdir}/%{name} \
        -mandir %{_mandir}/man1 \
        -host %{_host} \
        %{!?with_tk:-no-tk} \
-       -with-pthread
+       -with-pthread \
+       -x11lib /usr/X11R6/%{_lib}
 
-%{__make} world bootstrap opt.opt
-%{__make} -C tools objinfo
+%{__make} -j1 world bootstrap opt.opt CFLAGS="%{rpmcflags} -Wall"
+%{__make} -C tools objinfo CFLAGS="%{rpmcflags} -Wall" -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_includedir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
+install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
 
 %{__make} install \
        BINDIR=$RPM_BUILD_ROOT%{_bindir} \
@@ -359,9 +396,18 @@ ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 rm -rf $RPM_BUILD_ROOT%{_mandir}/man3
 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
 
+# install info pages
+cp -f infoman/*.gz $RPM_BUILD_ROOT%{_infodir}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post doc-info
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+
+%postun doc-info
+[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+
 %files runtime
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/ocamlrun
@@ -377,7 +423,6 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc LICENSE Changes README Upgrading
-%doc docs/html/ocaml
 %attr(755,root,root) %{_bindir}/ocaml*
 %{!?_without_tk:%exclude %{_bindir}/ocamlbrowser}
 %exclude %{_bindir}/ocamlrun
@@ -422,7 +467,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files camlp4
 %defattr(644,root,root,755)
-%doc docs/html/camlp4*
 %attr(755,root,root) %{_bindir}/*camlp4*
 %attr(755,root,root) %{_bindir}/ocpp
 # Not installed since 3.05, is is needed?
@@ -431,6 +475,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man*/*camlp4*
 %{_mandir}/man*/*ocpp*
 
+%files camlp4-doc-html
+%defattr(644,root,root,755)
+%doc docs/html/camlp4*
+
 %if %{with tk}
 %files labltk-devel
 %defattr(644,root,root,755)
@@ -448,7 +496,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dlltkanim.so
 %endif
 
-%if %{with x11}
+%if %{with x}
 %files x11graphics-devel
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/graphics*.cm*
@@ -471,6 +519,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/ocamldoc/*.cm*
 %{_libdir}/%{name}/ocamldoc/*.a
 
+%files doc-html
+%defattr(644,root,root,755)
+%doc docs/html/ocaml/*
+
 %files doc-ps
 %defattr(644,root,root,755)
 %doc docs/*.ps.gz
+
+%files doc-info
+%defattr(644,root,root,755)
+%{_infodir}/ocaml.info*
This page took 0.084438 seconds and 4 git commands to generate.