]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- rel 4 to rebuild with new db
[packages/ocaml.git] / ocaml.spec
index 28b5158df366e5442faf0673e09e78407e3bf1e1..960cc73870554724c641f2cc88d0232e00da4fe4 100644 (file)
@@ -2,30 +2,29 @@
 # Conditional build:
 
 %bcond_without emacs   # emacs subpackage
-%bcond_without x11     # without X11 support 
+%bcond_without x       # without X11 support 
 %bcond_without tk      # tk support
 %bcond_with db3                # use db3 instead of db 4.x
 
 # --without x11 implies --without tk
-%{!?with_x11:%undefine with_tk}
+%{!?with_x:%undefine   with_tk}
 
-%define beta beta2
 %define p4ver 3.06
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl):   Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
 Name:          ocaml
 Version:       3.07
-Release:       0.%{beta}.1
+Release:       4
 License:       distributable
 Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
-Source0:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}.tar.gz
-# Source0-md5: ecc68d67871aeae91bd807f3a3e388cb
-Source1:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}-refman.html.tar.gz
-# Source1-md5: 6f92dcb308c6e6923c39f7aac3749f2d
-Source2:       http://caml.inria.fr/distrib/%{name}-%{version}%{beta}/%{name}-%{version}%{beta}-refman.ps.gz
-# Source2-md5: 98b87b91c6ac5fd0ae1be7a732e49094
+Source0:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 2dd038055f5e1350078ad81270411b78
+Source1:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.html.tar.gz
+# Source1-md5: 9ac1f7e9e381b95504f0e7868d9fbf52
+Source2:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.ps.gz
+# Source2-md5: 09a9ac4bc1ec90ca4d16743ffbe76c78
 Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
 # Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
 Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
@@ -39,25 +38,26 @@ Source7:    http://www.oefai.at/~markus/ocaml_sources/pure-fun-1.0.4.tar.bz2
 Source8:       http://www.oefai.at/~markus/ocaml_sources/ds-contrib.tar.gz
 # Source8-md5: 77fa1da7375dea1393cc0b6cd802d7e1
 Patch0:                %{name}-build.patch
-Patch1:                %{name}-manlinks.patch
-Patch2:                %{name}-db3.patch
-Patch3:                %{name}-objinfo.patch
-Patch4:                %{name}-opt-symbols.patch
-Patch5:                %{name}-mano.patch
-Patch6:                %{name}-tk8.4.patch
+Patch1:                %{name}-db3.patch
+Patch2:                %{name}-objinfo.patch
+Patch3:                %{name}-mano.patch
+Patch4:                %{name}-unused-var-warning.patch
+Patch5:                %{name}-3.07-patch2.diffs
+Patch6:                %{name}-emacs_batch_mode.patch
 URL:           http://caml.inria.fr/
-Requires:      ocaml-runtime = %{version}-%{release}
-Obsoletes:     ocaml-ocamldoc
-Provides:      ocaml-ocamldoc
-%{?with_x11:BuildRequires:             XFree86-devel}
+%{?with_x:BuildRequires:               XFree86-devel}
 %{?with_db3:BuildRequires:     db3-devel}
 %{!?with_db3:BuildRequires:    db-devel >= 4.1}
-%{?with_tk:BuildRequires:              tk-devel >= 8.4.3}
+%{?with_tk:BuildRequires:              tk-devel}
 %if %{with emacs}
 BuildRequires: xemacs
 BuildRequires: xemacs-common
 BuildRequires: xemacs-fsf-compat-pkg
+
 %endif
+Requires:      ocaml-runtime = %{version}-%{release}
+Provides:      ocaml-ocamldoc
+Obsoletes:     ocaml-ocamldoc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -273,7 +273,7 @@ Pakiet ten zawiera 
 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -n %{name}-%{version}%{beta} -a1 -a3 -a5
+%setup -q -a1 -a3 -a5
 mkdir examples
 tar xjf %{SOURCE7} -C examples
 tar xzf %{SOURCE8} -C examples
@@ -287,12 +287,12 @@ cp %{SOURCE4} docs/camlp4.ps.gz
 mv camlp4-%{p4ver}-tutorial.html docs/html/camlp4-tutorial
 cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch0 -p1
-#%patch1 -p1
+%patch1 -p1
 %patch2 -p1
 %patch3 -p1
-#%patch4 -p1
+%patch4 -p1
 %patch5 -p1
-#%patch6 -p1
+%patch6 -p1
 
 %build
 ./configure \
@@ -309,6 +309,7 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_includedir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
 
 %{__make} install \
        BINDIR=$RPM_BUILD_ROOT%{_bindir} \
@@ -338,7 +339,6 @@ for f in ocamlc ocamlopt ocamldoc ocamllex; do
 done
 
 # move includes to the proper place
-install -d $RPM_BUILD_ROOT%{_includedir}
 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
 # but leave compatibility symlink
 ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
@@ -351,13 +351,8 @@ done
 
 # this isn't installed by default, but is useful
 install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
-
-install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
 cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
-
 ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 
 # shutup checkfiles
@@ -390,6 +385,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/caml
 %{_libdir}/%{name}/caml
 %{_libdir}/%{name}/threads
+%dir %{_libdir}/%{name}/vmthreads
+%dir %{_libdir}/%{name}/vmthreads/*.cm*
+%dir %{_libdir}/%{name}/vmthreads/*.a
 %{_libdir}/%{name}/*.a
 %{_libdir}/%{name}/*.o
 %{_libdir}/%{name}/*.cm*
@@ -398,7 +396,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/camlheader
 %{_libdir}/%{name}/camlheader_ur
 %dir %{_libdir}/%{name}/ocamldoc
-%{_libdir}/%{name}/ocamldoc/*.sty
 %{_libdir}/%{name}/ocamldoc/*.hva
 %attr(755,root,root) %{_libdir}/%{name}/expunge
 %attr(755,root,root) %{_libdir}/%{name}/extract_crc
@@ -409,6 +406,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/*.ml
 %{_libdir}/%{name}/*.mli
+%{_libdir}/%{name}/*/*.mli
 
 %files examples
 %defattr(644,root,root,755)
This page took 0.057339 seconds and 4 git commands to generate.