]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- fixed --without tk
[packages/ocaml.git] / ocaml.spec
index d185d67a3537e89a3fcc0981d047a3532088a05b..94f5cea39943b012a5601c5690d94b149c5eb1d3 100644 (file)
@@ -10,7 +10,7 @@ Summary:      The Objective Caml compiler and programming environment
 Summary(pl):   Kompilator Objektowego Camla oraz ¶rodowisko programistyczne
 Name:          ocaml
 Version:       3.06
-Release:       1
+Release:       2
 License:       distributable
 Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
@@ -21,13 +21,14 @@ Source3:    ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-manu
 Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-manual.dvi.gz
 Source5:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.html.tar.gz
 Source6:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.dvi.gz
+Source7:       http://www.oefai.at/~markus/ocaml_sources/pure-fun-1.0.4.tar.bz2
+Source8:       http://www.oefai.at/~markus/ocaml_sources/ds-contrib.tar.gz
 Patch0:                %{name}-build.patch
-Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-manlinks.patch
-Patch3:                %{name}-db3.patch
-Patch4:                %{name}-objinfo.patch
-Patch5:                %{name}-opt-symbols.patch
-Patch6:                %{name}-mano.patch
+Patch1:                %{name}-manlinks.patch
+Patch2:                %{name}-db3.patch
+Patch3:                %{name}-objinfo.patch
+Patch4:                %{name}-opt-symbols.patch
+Patch5:                %{name}-mano.patch
 URL:           http://caml.inria.fr/
 Requires:      ocaml-runtime = %{version}-%{release}
 Obsoletes:     ocaml-ocamldoc
@@ -236,26 +237,43 @@ This sources come helpful during debugging of user programs with ocamldebug.
 ¬ród³a te co¶ przydatne przy odpluskwianiu programów u¿ytkownika
 z u¿yciem ocamldebug.
 
+# maybe we'll want to add some more stuff here?
+%package examples
+Summary:       Example source code for OCaml
+Summary(pl):   Przyk³adowe kody ¼ród³owe w OCamlu
+Group:         Development/Languages
+Requires:      %{name} = %{version}-%{release}
+
+%description examples
+This packages contains sources for Okasaki's Purely Functional 
+Datastructures in OCaml, along with some contributions.
+
+%description examples -l pl
+Pakiet ten zawiera ¼ród³a Czysto-Funkcjonalnych Struktur Danych 
+Okasaki'ego, prze³o¿one na OCamla, wraz z dodatkami.
+
 %prep
 %setup -q -T -b 0
 %setup -q -T -D -a 1
+%setup -q -T -D -c -n %{name}-%{version}/examples -a 7
+%setup -q -T -D -c -n %{name}-%{version}/examples -a 8
+%setup -q -T -D -n %{name}-%{version} -a 3
+%setup -q -T -D -n %{name}-%{version} -a 5
 # order mess with docs somewhat
 mkdir docs
 mkdir docs/html
 mv htmlman docs/html/ocaml
 cp %{SOURCE2} docs/ocaml.ps.gz
-%setup -q -T -D -a 3
-mv camlp4-%{version}-refman.html docs/html/camlp4
+mv camlp4-%{version}-manual.html docs/html/camlp4
 cp %{SOURCE4} docs/camlp4.ps.gz
-%setup -q -T -D -a 5
 mv camlp4-%{version}-tutorial.html docs/html/camlp4-tutorial
 cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-#%patch5 -p1
-%patch6 -p1
+#%patch4 -p1
+%patch5 -p1
 
 %build
 ./configure \
@@ -264,7 +282,7 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
        -libdir %{_libdir}/%{name} \
        -mandir %{_mandir}/man1 \
        -host %{_host} \
-       %{?_without_tk:-notk} \
+       %{?_without_tk:-no-tk} \
        -with-pthread
 
 %{__make} world bootstrap opt.opt
@@ -318,13 +336,16 @@ done
 # this isn't installed by default, but is useful
 install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
 
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
 cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
 
 ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 
 # shutup checkfiles
-#rm -f $RPM_BUILD_ROOT%{_mandir}/man3
+rm -rf $RPM_BUILD_ROOT%{_mandir}/man3
 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
 
 %clean
@@ -370,6 +391,9 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/*.ml
 
+%files examples
+%{_examplesdir}/%{name}-%{version}
+
 # they are poor, html is much better
 #%files manpages
 #%{_mandir}/man3/*
@@ -410,6 +434,7 @@ rm -rf $RPM_BUILD_ROOT
 %files x11graphics-devel
 %defattr(644,root,root,755)
 %{_libdir}/%{name}/graphics*.cm*
+%{_libdir}/%{name}/graphics.a
 %{_libdir}/%{name}/libgraphics.a
 
 %files x11graphics
This page took 0.031222 seconds and 4 git commands to generate.