]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- dropped pre-cvs changelog
[packages/ocaml.git] / ocaml.spec
index 905090f17aebd1d1bfdf27f26645324638fab5f0..80ae6e921b88d1835e658a46985c73827fc84287 100644 (file)
@@ -8,23 +8,22 @@
 %{!?with_x:%undefine   with_tk}
 
 %define                p4ver   3.06
-%define                sver    3.09
+%define                sver    3.11
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl.UTF-8):     Kompilator OCamla (Objective Caml) oraz środowisko programistyczne
 Name:          ocaml
-Version:       3.09.3
+Version:       3.11.0
 Release:       1
 Epoch:         1
 License:       distributable
-Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
 Source0:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.bz2
-# Source0-md5: 8b3744efd0d51b82d55b61d0e2bf0e2b
+# Source0-md5: 6ed1c3ed660a15408362242fa8fa4668
 Source1:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.html.tar.gz
-# Source1-md5: b25eb211bf91bcaa536b12d12731ceec
+# Source1-md5: bfb4ed960974159f4224014a979baf6d
 Source2:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
-# Source2-md5: 598bb8e86329afe1ae374385b2e177e7
+# Source2-md5: d01adeb1ab5ef0905f8656947f928b03
 Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
 # Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
 Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
@@ -38,13 +37,11 @@ Source7:    http://www.ocaml.info/ocaml_sources/pure-fun-1.0.6.tar.bz2
 Source8:       http://www.ocaml.info/ocaml_sources/ds-contrib.tar.gz
 # Source8-md5: 77fa1da7375dea1393cc0b6cd802d7e1
 Source9:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.info.tar.gz
-# Source9-md5: 280160b1fc7c8513074c3fda0446de29
-Patch0:                %{name}-build.patch
-Patch1:                %{name}-db3.patch
-Patch2:                %{name}-objinfo.patch
-Patch3:                %{name}-tk85support.patch
-Patch4:                %{name}-CFLAGS.patch
-Patch5:                %{name}-as_needed.patch
+# Source9-md5: 50fc2a3e3a38db78bd03d169379155de
+Patch0:                %{name}-db3.patch
+Patch1:                %{name}-objinfo.patch
+Patch2:                %{name}-CFLAGS.patch
+Patch3:                %{name}-as_needed.patch
 URL:           http://caml.inria.fr/
 BuildRequires: db-devel >= 4.1
 %{?with_tk:BuildRequires:      tk-devel}
@@ -308,11 +305,10 @@ Pakiet ten zawiera źródła Czysto Funkcyjnych Struktur Danych
 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -a1 -a3 -a5  
+%setup -q -a1 -a3 -a5 -a9
 mkdir examples
 tar xjf %{SOURCE7} -C examples
 tar xzf %{SOURCE8} -C examples
-tar xzf %{SOURCE9}
 # order mess with docs somewhat
 mkdir -p docs/html
 mv htmlman docs/html/ocaml
@@ -325,8 +321,6 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p1
 
 %build 
 cp -f /usr/share/automake/config.sub config/gnu
@@ -343,9 +337,13 @@ cp -f /usr/share/automake/config.sub config/gnu
 %{__make} -j1 world bootstrap opt.opt CFLAGS="%{rpmcflags} -Wall"
 %{__make} -C tools objinfo CFLAGS="%{rpmcflags} -Wall" -j1
 
+# broken build system
+sed -e 's,LIBDIR,%{_libdir},' camlp4/man/camlp4.1.tpl > camlp4/man/camlp4.1
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
+install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/site-lib
 
 %{__make} install \
        BINDIR=$RPM_BUILD_ROOT%{_bindir} \
@@ -398,20 +396,26 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
 # install info pages
 cp -f infoman/*.gz $RPM_BUILD_ROOT%{_infodir}
 
+# broken build system
+install camlp4/man/camlp4.1 $RPM_BUILD_ROOT%{_mandir}/man1
+for f in camlp4o.1 camlp4r.1 mkcamlp4.1 camlp4o.opt.1 camlp4r.opt.1 ; do
+       echo '.so camlp4.1' >$RPM_BUILD_ROOT%{_mandir}/man1/$f
+done
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post doc-info
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post doc-info -p      /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun doc-info
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%postun doc-info       -p      /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files
 %defattr(644,root,root,755)
 %doc LICENSE Changes README Upgrading
 %attr(755,root,root) %{_bindir}/ocaml*
-%{!?_without_tk:%exclude %{_bindir}/ocamlbrowser}
+%{?with_tk:%exclude %{_bindir}/ocamlbrowser}
 %exclude %{_bindir}/ocamlrun
 %attr(755,root,root) %{_bindir}/*labels
 %{_includedir}/caml
@@ -424,9 +428,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/*.o
 %{_libdir}/%{name}/*.cm*
 %exclude %{_libdir}/%{name}/*graphics*
+%{_libdir}/%{name}/Makefile.config
 %{_libdir}/%{name}/ld.conf
 %{_libdir}/%{name}/camlheader
 %{_libdir}/%{name}/camlheader_ur
+%{_libdir}/%{name}/ocamlbuild
 %dir %{_libdir}/%{name}/ocamldoc
 %{_libdir}/%{name}/ocamldoc/*.hva
 %attr(755,root,root) %{_libdir}/%{name}/expunge
@@ -438,9 +444,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/ocamlrun
 %dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/site-lib
 %dir %{_libdir}/%{name}/stublibs
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
 %exclude %{_libdir}/%{name}/stublibs/dllgraphics.so
+%attr(755,root,root) %{_libdir}/%{name}/libcamlrun_shared.so
 %if %{with tk}
 %exclude %{_libdir}/%{name}/stublibs/dlllabltk.so
 %exclude %{_libdir}/%{name}/stublibs/dlltkanim.so
@@ -487,6 +495,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/%{name}/labltk
 %{_libdir}/%{name}/labltk/*.cm*
 %{_libdir}/%{name}/labltk/*.a
+%{_libdir}/%{name}/labltk/*.o
 %attr(755,root,root) %{_libdir}/%{name}/labltk/tkcompiler
 %{_examplesdir}/%{name}-labltk-%{version}
 %endif
@@ -505,13 +514,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files camlp4
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*camlp4*
-%attr(755,root,root) %{_bindir}/ocpp
-# Not installed since 3.05, is it needed?
-#%attr(755,root,root) %{_bindir}/odyl
+%attr(755,root,root) %{_bindir}/camlp4*
+%attr(755,root,root) %{_bindir}/mkcamlp4
 %{_libdir}/%{name}/camlp4
-%{_mandir}/man*/*camlp4*
-%{_mandir}/man*/*ocpp*
+%{_mandir}/man1/camlp4*.1*
+%{_mandir}/man1/mkcamlp4.1*
 
 %files camlp4-doc-html
 %defattr(644,root,root,755)
This page took 0.028746 seconds and 4 git commands to generate.