]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- package Makefile.config
[packages/ocaml.git] / ocaml.spec
index 905090f17aebd1d1bfdf27f26645324638fab5f0..71e4602cf39c547217e47707a81393cf26788718 100644 (file)
@@ -8,23 +8,22 @@
 %{!?with_x:%undefine   with_tk}
 
 %define                p4ver   3.06
-%define                sver    3.09
+%define                sver    3.10
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl.UTF-8):     Kompilator OCamla (Objective Caml) oraz środowisko programistyczne
 Name:          ocaml
-Version:       3.09.3
+Version:       3.10.1
 Release:       1
 Epoch:         1
 License:       distributable
-Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
 Source0:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.bz2
-# Source0-md5: 8b3744efd0d51b82d55b61d0e2bf0e2b
+# Source0-md5: 15a8c603b34d466329881285438349ef
 Source1:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.html.tar.gz
-# Source1-md5: b25eb211bf91bcaa536b12d12731ceec
+# Source1-md5: 663b31c8ea364a531aa325a5b06a2763
 Source2:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
-# Source2-md5: 598bb8e86329afe1ae374385b2e177e7
+# Source2-md5: 69c7acc08ee182c97089fe0736c04e37
 Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
 # Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
 Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
@@ -38,7 +37,7 @@ Source7:      http://www.ocaml.info/ocaml_sources/pure-fun-1.0.6.tar.bz2
 Source8:       http://www.ocaml.info/ocaml_sources/ds-contrib.tar.gz
 # Source8-md5: 77fa1da7375dea1393cc0b6cd802d7e1
 Source9:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.info.tar.gz
-# Source9-md5: 280160b1fc7c8513074c3fda0446de29
+# Source9-md5: f80b52b8bc4b10ed557808fc899acf3a
 Patch0:                %{name}-build.patch
 Patch1:                %{name}-db3.patch
 Patch2:                %{name}-objinfo.patch
@@ -343,9 +342,13 @@ cp -f /usr/share/automake/config.sub config/gnu
 %{__make} -j1 world bootstrap opt.opt CFLAGS="%{rpmcflags} -Wall"
 %{__make} -C tools objinfo CFLAGS="%{rpmcflags} -Wall" -j1
 
+# broken build system
+sed -e 's,LIBDIR,%{_libdir},' camlp4/man/camlp4.1.tpl > camlp4/man/camlp4.1
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
+install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/site-lib
 
 %{__make} install \
        BINDIR=$RPM_BUILD_ROOT%{_bindir} \
@@ -398,6 +401,12 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
 # install info pages
 cp -f infoman/*.gz $RPM_BUILD_ROOT%{_infodir}
 
+# broken build system
+install camlp4/man/camlp4.1 $RPM_BUILD_ROOT%{_mandir}/man1
+for f in camlp4o.1 camlp4r.1 mkcamlp4.1 camlp4o.opt.1 camlp4r.opt.1 ; do
+       echo '.so camlp4.1' >$RPM_BUILD_ROOT%{_mandir}/man1/$f
+done
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -411,7 +420,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc LICENSE Changes README Upgrading
 %attr(755,root,root) %{_bindir}/ocaml*
-%{!?_without_tk:%exclude %{_bindir}/ocamlbrowser}
+%{?with_tk:%exclude %{_bindir}/ocamlbrowser}
 %exclude %{_bindir}/ocamlrun
 %attr(755,root,root) %{_bindir}/*labels
 %{_includedir}/caml
@@ -424,9 +433,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/%{name}/*.o
 %{_libdir}/%{name}/*.cm*
 %exclude %{_libdir}/%{name}/*graphics*
+%{_libdir}/%{name}/Makefile.config
 %{_libdir}/%{name}/ld.conf
 %{_libdir}/%{name}/camlheader
 %{_libdir}/%{name}/camlheader_ur
+%{_libdir}/%{name}/ocamlbuild
 %dir %{_libdir}/%{name}/ocamldoc
 %{_libdir}/%{name}/ocamldoc/*.hva
 %attr(755,root,root) %{_libdir}/%{name}/expunge
@@ -438,6 +449,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/ocamlrun
 %dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/site-lib
 %dir %{_libdir}/%{name}/stublibs
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
 %exclude %{_libdir}/%{name}/stublibs/dllgraphics.so
@@ -505,13 +517,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files camlp4
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*camlp4*
-%attr(755,root,root) %{_bindir}/ocpp
-# Not installed since 3.05, is it needed?
-#%attr(755,root,root) %{_bindir}/odyl
+%attr(755,root,root) %{_bindir}/camlp4*
+%attr(755,root,root) %{_bindir}/mkcamlp4
 %{_libdir}/%{name}/camlp4
-%{_mandir}/man*/*camlp4*
-%{_mandir}/man*/*ocpp*
+%{_mandir}/man1/camlp4*.1*
+%{_mandir}/man1/mkcamlp4.1*
 
 %files camlp4-doc-html
 %defattr(644,root,root,755)
This page took 0.02929 seconds and 4 git commands to generate.