]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- added opt bcond to skip building native compiler (only bytecode)
[packages/ocaml.git] / ocaml.spec
index e265230d322b11ecfc83d4684cf0662755d755cf..5289fc87d78e40b758c12eec7281d04178a239e6 100644 (file)
@@ -1,39 +1,55 @@
+#
+# Conditional build:
+%bcond_without emacs   # without emacs subpackage
+%bcond_without x       # without X11 support 
+%bcond_without opt     # don't build native, optimized compiler
+
+%ifarch x32
+%undefine      with_opt
+%endif
 
-# conditional build:
-# --without emacs
-# --without tk
-# --without x11  (implies --without tk)
-
-%{?_without_x11:%define        _without_tk     1}
+%define                sver    4.02
 
 Summary:       The Objective Caml compiler and programming environment
-Summary(pl):   Kompilator Objektowego Caml oraz ¶rodowisko programistyczne
+Summary(pl.UTF-8):     Kompilator OCamla (Objective Caml) oraz środowisko programistyczne
 Name:          ocaml
-Version:       3.04
-Release:       4
-License:       distributable
-Vendor:                Group of implementors <caml-light@inria.fr>
+Version:       4.02.1
+Release:       2
+Epoch:         1
+License:       QPL v1.0 with linking exception (compiler), LGPL v2 with linking exception (library)
 Group:         Development/Languages
-Source0:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}.tar.gz
-Source1:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}-refman.info.tar.gz
-Source2:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}-refman.html.tar.gz
-Source3:       ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}-refman.ps.gz
-Source4:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-refman.html.tar.gz
-Source5:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-refman.ps.gz
-Source6:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.html.tar.gz
-Source7:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{version}-tutorial.ps.gz
-Patch0:                %{name}-build.patch
-Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-manlinks.patch
-Patch3:                %{name}-db3.patch
+Source0:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.xz
+# Source0-md5: d74ac1b1179af362491e14349dd1958b
+Source1:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman-html.tar.gz
+# Source1-md5: 915a1949f7af7186e16354e9682dc1e5
+Source2:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
+# Source2-md5: e85016fa23b6525d1d10da06010fd90a
+Source3:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.info.tar.gz
+# Source3-md5: 265b7db123e925e8b7b70ca2266b4206
+Source4:       https://github.com/mmottl/pure-fun/archive/v1.0.13/pure-fun-1.0.13.tar.gz
+# Source4-md5: 0a6ff033df78d0880fe4883ace025ebe
+# note: dead URL
+Source5:       http://www.ocaml.info/ocaml_sources/ds-contrib.tar.gz
+# Source5-md5: 77fa1da7375dea1393cc0b6cd802d7e1
+Patch1:                %{name}-CFLAGS.patch
+Patch2:                %{name}-as_needed.patch
+Patch3:                x32.patch
 URL:           http://caml.inria.fr/
-BuildRequires: db3-devel
-%{!?_without_tk:BuildRequires:         tk-devel}
-%{!?_without_x11:BuildRequires:                XFree86-devel}
-%{!?_without_emacs:BuildRequires:      xemacs-common}
-%{!?_without_emacs:BuildRequires:      xemacs-fsf-compat-pkg}
+%{?with_x:BuildRequires:       xorg-lib-libX11-devel}
+%if %{with emacs}
+BuildRequires: sed >= 4.0
+BuildRequires: emacs
+BuildRequires: emacs-common
+%endif
+Requires:      %{name}-runtime = %{epoch}:%{version}-%{release}
+Provides:      ocaml-bytes-devel
+Provides:      ocaml-ocamldoc
+Obsoletes:     ocaml-ocamldoc
+Obsoletes:     ocaml-bytes-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                specflags       -fno-strict-aliasing
+
 %description
 Objective Caml is a high-level, strongly-typed, functional and
 object-oriented programming language from the ML family of languages.
@@ -43,181 +59,221 @@ and an optimizing native-code compiler), an interactive toplevel
 system, Lex&Yacc tools, a replay debugger, and a comprehensive
 library.
 
-%description -l pl
-Objektowy Caml jest funkcjonalnym, obiektowo zorientowanym jêzykiem
-wysokiego poziomu z rodziny jêzyków ML.
+%description -l pl.UTF-8
+OCaml (Objective Caml) jest funkcyjnym, obiektowo zorientowanym
+językiem wysokiego poziomu z silnym typowaniem. Należy do rodziny
+języków ML.
+
+Ten pakiet zawiera dwa kompilatory (szybki kompilator do bajtkodu
+oraz optymalizujący kompilator do kodu natywnego), interaktywne
+środowisko pracy, narzędzia do tworzenia analizatorów leksykalnych
+oraz składniowych (ocamllex, ocamlyacc), odpluskwiacz (ocamldebug) i
+biblioteki.
+
+%package runtime
+Summary:       Runtime system for OCaml
+Summary(pl.UTF-8):     Środowisko uruchomieniowe dla OCamla
+Group:         Libraries
+
+%description runtime
+This package contains binaries needed to run bytecode OCaml programs:
+ocamlrun bytecode interpreter, and basic dynamic link libraries.
+
+%description runtime -l pl.UTF-8
+Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
+OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun)
+oraz podstawowe biblioteki linkowane dynamicznie.
+
+%package lib-source
+Summary:       Sources of OCaml standard library
+Summary(pl.UTF-8):     Źródła biblioteki standardowej OCamla
+Group:         Development/Languages
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
-Ten pakiet zawiera dwa kompilatory (szybki kompilator bytecode oraz
-zoptymalizowany natywny kompilator), interaktywny g³ówny system,
-narzêdzia Lex&Yacc, odpluskwiacz i biblioteki.
+%description lib-source
+This sources come helpful during debugging of user programs with
+ocamldebug.
+
+%description lib-source -l pl.UTF-8
+Źródła te są przydatne przy odpluskwianiu programów użytkownika
+z użyciem ocamldebug.
+
+%package doc-html
+Summary:       HTML documentation for OCaml
+Summary(pl.UTF-8):     Dokumentacja dla OCamla w formacie HTML
+Group:         Development/Tools
+
+%description doc-html
+HTML documentation for OCaml.
+
+%description doc-html -l pl.UTF-8
+Dokumentacja dla OCamla w formacie HTML.
 
 %package doc-ps
 Summary:       PostScript documentation for OCaml
-Summary(pl):   Dokumentacja dla OCaml-a w formacie PostSript
+Summary(pl.UTF-8):     Dokumentacja dla OCamla w formacie PostScript
 Group:         Development/Tools
-Requires:      %{name} = %{version}
 
 %description doc-ps
-PostScript documentation for OCaml
+PostScript documentation for OCaml.
 
-%description doc-ps -l pl
-Dokumentacja dla OCaml-a w formacie PostSript
+%description doc-ps -l pl.UTF-8
+Dokumentacja dla OCamla w formacie PostScript.
 
-%package doc-html
-Summary:       HTML documentation for OCaml
-Summary(pl):   Dokumentacja dla OCaml-a w formacie HTML
+%package doc-info
+Summary:       Info documentation for OCaml
+Summary(pl.UTF-8):     Dokumentacja info dla OCamla
 Group:         Development/Tools
-Requires:      %{name} = %{version}
 
-%description doc-html
-HTML documentation for OCaml
+%description doc-info
+Info documentation for OCaml.
 
-%description doc-html -l pl
-Dokumentacja dla OCaml-a w formacie HTML
+%description doc-info -l pl.UTF-8
+Dokumentacja info dla OCamla.
 
 %package emacs
 Summary:       Emacs mode for OCaml
-Summary(pl):   Tryb Emacsa dla OCaml
+Summary(pl.UTF-8):     Tryb OCamla dla Emacsa
 Group:         Development/Tools
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description emacs
-Emacs mode files for Objective Caml language
+Emacs mode files for Objective Caml language.
 
-%description emacs -l pl
-Pliki trybu Emacsa dla jêzyka Objektowego Caml
+%description emacs -l pl.UTF-8
+Pliki trybu OCamla dla Emacsa.
 
-%package labltk
-Summary:       LabelTk library for OCaml
-Summary(pl):   Biblioteka LablTk dla OCamla
+%package x11graphics
+Summary:       X11 graphic output for OCaml
+Summary(pl.UTF-8):     Dostęp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
-%description labltk
-LablTk gives OCaml program access to Tcl/Tk GUI widgets.
+%description x11graphics
+x11graphics module gives OCaml program access to drawing in X11
+windows. This package contains files needed to run bytecode OCaml
+programs using x11graphics.
 
-%description labltk -l pl
-Biblioteka LablTk daje programom napisanym w OCamlu dostêp do widgetów
-Tcl/Tk.
+%description x11graphics -l pl.UTF-8
+Moduł x11graphics daje programom napisanym w OCamlu możliwość
+korzystania z interfejsu graficznego X11. Pakiet ten zawiera binaria
+potrzebne do uruchamiania programów używających x11graphics.
 
-%package x11graphics
+%package x11graphics-devel
 Summary:       X11 graphic output for OCaml
-Summary(pl):   Iksowe wyj¶cie graficzne dla OCamla
+Summary(pl.UTF-8):     Dostęp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name}-x11graphics = %{epoch}:%{version}-%{release}
 
-%description x11graphics
-This package gives OCaml program access to drawing in X11 windows.
+%description x11graphics-devel
+x11graphics module gives OCaml program access to drawing in X11
+windows. This package contains files needed to develop OCaml programs
+using x11graphics.
+
+%description x11graphics-devel -l pl.UTF-8
+Moduł x11graphics daje programom napisanym w OCamlu możliwość
+korzystania z interfejsu graficznego X11. Pakiet ten zawiera pliki
+niezbędne do tworzenia programów używających x11graphics.
+
+%package compiler-objects
+Summary:       Compiled parts of OCaml compiler
+Summary(pl.UTF-8):     Skompilowane części kompilatora OCamla
+Group:         Development/Languages
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Obsoletes:     ocaml-devel
+Provides:      ocaml-devel
+
+%description compiler-objects
+This package contains *.cmi and *.cmo files being parts of OCaml
+compiler. They are needed to compile some programs.
 
-%description x11graphics -l pl
-Ten pakiet daje programom napisanym w OCamlu dostêp do rysowania po
-oknach X11.
+%description compiler-objects -l pl.UTF-8
+Pakiet ten zawiera pliki *.cmi oraz *.cmo będące częściami kompilatora
+OCamla. Są one wymagane do kompilacji niektórych programów.
 
-%package camlp4
-Summary:       Objective Caml Preprocessor
-Summary(pl):   Preprocesor Ocamla
+%package ocamldoc-devel
+Summary:       Files needed to develop programs using ocamldoc
+Summary(pl.UTF-8):     Pliki potrzebne do tworzenia programów używających ocamldoc
 Group:         Development/Languages
-Requires:      %{name} = %{version}
-Provides:      camlp4 = %{version}
-Obsoletes:     camlp4
-
-%description camlp4
-Camlp4 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
-tools for syntax (grammars) and the ability to modify the concrete
-syntax of the language (quotations, syntax extensions).
-
-Camlp4 can parse normal Ocaml concrete syntax or any other
-user-definable syntax. As an example, an alternative syntax is
-provided, named revised, because it tries to fix some small problems
-of the normal syntax.
-
-Camlp4 can pretty print the normal Ocaml concrete syntax or the
-revised one. It is therefore always possible to have a version of your
-sources compilable by the compiler Objective Caml without
-preprocessing.
-
-%description camlp4 -l pl
-Camlp4 jest preprocesorem dla Ocamla. Oferuje narzêdzia do sk³adni
-(gramatyki) oraz umiejêtno¶æ modyfikowania konkretnej sk³adni jêzyka
-(cytowania, rozszerzenia).
-
-Camlp4 mo¿e sparsowaæ normaln± sk³adniê Ocamla lub inn± dowoln±
-definiowaln± przez u¿ytkownika. Jako przyk³ad jest podana alternatywna
-sk³adnia, nazwana "poprawiona", poniewa¿ próbuje poprawiæ drobne
-problemy ze zwyk³± sk³adni±.
-
-Camlp4 umie ³adnie wypisaæ normaln± sk³adniê Camla lub "poprawion±".
-Dziêki temu jest mo¿liwe posiadanie wersji swoich ¼róde³
-kompilowalnych przez kompilatora Ocamla bez preprocesingu.
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description ocamldoc-devel
+You need this package if you are going to write ocamldoc front end or
+something like that.
+
+%description ocamldoc-devel -l pl.UTF-8
+Będziesz potrzebować tego pakietu, jeśli zamierzasz pisać front end
+dla ocamldoc lub coś podobnego.
+
+# maybe we'll want to add some more stuff here?
+%package examples
+Summary:       Example source code for OCaml
+Summary(pl.UTF-8):     Przykładowe kody źródłowe w OCamlu
+Group:         Development/Languages
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description examples
+This packages contains sources for Okasaki's Purely Functional
+Datastructures in OCaml, along with some contributions.
+
+%description examples -l pl.UTF-8
+Pakiet ten zawiera źródła Czysto Funkcyjnych Struktur Danych
+autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -T -b 0
-%setup -q -T -D -a 1
-%setup -q -T -D -a 2
+%setup -q -a1 -a3
+mkdir examples
+tar xzf %{SOURCE4} -C examples
+tar xzf %{SOURCE5} -C examples
 # order mess with docs somewhat
-mkdir docs
-mkdir docs/html
+mkdir -p docs/html
 mv htmlman docs/html/ocaml
-cp %{SOURCE3} docs/ocaml.ps.gz
-%setup -q -T -D -a 4
-mv camlp4-%{version}-refman.html docs/html/camlp4
-cp %{SOURCE5} docs/camlp4.ps.gz
-%setup -q -T -D -a 6
-mv camlp4-%{version}-tutorial.html docs/html/camlp4-tutorial
-cp %{SOURCE7} docs/camlp4-tutorial.ps.gz
-
-%patch0 -p1
+cp %{SOURCE2} docs/ocaml.ps.gz
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 
-%build
+%build 
+cp -f /usr/share/automake/config.sub config/gnu
 ./configure \
-        -cc "%{__cc} %{rpmcflags}" \
+       -host %{_target_platform} \
+        -cc "%{__cc}" \
        -bindir %{_bindir} \
        -libdir %{_libdir}/%{name} \
        -mandir %{_mandir}/man1 \
-       -host %{_host} \
-       %{?_without_tk:-notk} \
-       -with-pthread
-
-# this is crude hack (works in addition to ocaml-db3.patch)
-cp config/Makefile config/Makefile.tmp
-sed -e 's|-ldb1|-ldb|; s|-I%{_includedir}/db1||' < config/Makefile.tmp > config/Makefile
-
-%{__make} world bootstrap opt ocamlc.opt ocamlopt.opt
-%ifnarch ppc
-%{__make} -C camlp4 optp4
-%endif
+       -with-pthread \
+       -x11lib %{_libdir}
 
-# hack info pages to contain dir entry
-cat <<EOF >infoman/ocaml.info
-INFO-DIR-SECTION Programming Languages:
-START-INFO-DIR-ENTRY
-* Ocaml: (ocaml).                             The Ocaml language
-END-INFO-DIR-ENTRY
-EOF
-zcat infoman/ocaml.info.gz >> infoman/ocaml.info
+%{__make} -j1 world bootstrap %{?with_opt:opt.opt} \
+       CFLAGS="%{rpmcflags} -Wall -DUSE_INTERP_RESULT"
 
-gzip -9nf infoman/ocaml.info
+%{__make} -C tools objinfo \
+       CFLAGS="%{rpmcflags} -Wall -DUSE_INTERP_RESULT" -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_infodir}
+install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-%{version}}
+install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/site-lib
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       BINDIR=$RPM_BUILD_ROOT%{_bindir} \
+       LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{name} \
+       MANDIR=$RPM_BUILD_ROOT%{_mandir}
 
-%if %{!?_without_emacs:1}%{?_without_emacs:0}
-%{__make} -C emacs DESTDIR=$RPM_BUILD_ROOT install \
-       EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
-               else echo xemacs; fi`" \
-       EMACSDIR="%{_libdir}/emacs/site-lisp"
-%endif
+cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
+%{_libdir}/%{name}/stublibs
+%{_libdir}/%{name}
+EOF
 
-cp -p {parsing/{location,longident,parsetree},typing/typecore}.{cm,ml}i \
-       $RPM_BUILD_ROOT%{_libdir}/%{name}
+%if %{with emacs}
+%{__make} -C emacs install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       EMACSDIR="$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp" \
+       EMACS="emacs"
+%endif
 
-for f in ocamlc ocamlopt camlp4o camlp4r; do
+# symlink .opt versions of compilers (if present)
+for f in ocamlc ocamlopt ocamldoc ocamllex; do
        if test -f $RPM_BUILD_ROOT%{_bindir}/$f.opt; then
                mv -f $RPM_BUILD_ROOT%{_bindir}/$f \
                        $RPM_BUILD_ROOT%{_bindir}/$f.byte
@@ -225,94 +281,144 @@ for f in ocamlc ocamlopt camlp4o camlp4r; do
        fi
 done
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{_name}/*.ml
+# move includes to the proper place
+mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
+# but leave compatibility symlink
+ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
+
+# compiled sources of compiler, needed by some programs
+for f in {asm,byte}comp parsing typing utils ; do
+       install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
+       cp $f/*.{cmi,cmo} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
+       %{?with_opt:cp $f/*.{cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f}
+done
+
+# this isn't installed by default, but is useful
+install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
+cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
 
-install infoman/*info* $RPM_BUILD_ROOT%{_infodir}
+# shutup checkfiles
+%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/man3
 
-gzip -9nf LICENSE Changes README Upgrading
+# install info pages
+cp -f infoman/*.gz $RPM_BUILD_ROOT%{_infodir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
-
-%postun
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post  doc-info -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
+%postun        doc-info -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
+%doc Changes LICENSE README
+%attr(755,root,root) %{_bindir}/addlabels
 %attr(755,root,root) %{_bindir}/ocaml
-%attr(755,root,root) %{_bindir}/ocaml[cmdlopry]*
-%attr(755,root,root) %{_bindir}/*labels
+%attr(755,root,root) %{_bindir}/ocamlbuild*
+%attr(755,root,root) %{_bindir}/ocamlc
+%{?with_opt:%attr(755,root,root) %{_bindir}/ocamlc.*}
+%attr(755,root,root) %{_bindir}/ocamlcp
+%attr(755,root,root) %{_bindir}/ocamldebug
+%attr(755,root,root) %{_bindir}/ocamldep*
+%attr(755,root,root) %{_bindir}/ocamldoc*
+%attr(755,root,root) %{_bindir}/ocamllex*
+%attr(755,root,root) %{_bindir}/ocamlmklib
+%attr(755,root,root) %{_bindir}/ocamlmktop
+%attr(755,root,root) %{_bindir}/ocamlobjinfo
+%{?with_opt:%attr(755,root,root) %{_bindir}/ocamlopt}
+%{?with_opt:%attr(755,root,root) %{_bindir}/ocamlopt.*}
+%attr(755,root,root) %{_bindir}/ocamloptp
+%attr(755,root,root) %{_bindir}/ocamlprof
+%attr(755,root,root) %{_bindir}/ocamlyacc
+%attr(755,root,root) %{_bindir}/scrapelabels
+%{_includedir}/caml
 %{_libdir}/%{name}/caml
+%{_libdir}/%{name}/compiler-libs
 %{_libdir}/%{name}/threads
-%{_libdir}/%{name}/[abefhimnopqrstuw]*.*
-%{_libdir}/%{name}/callback.*
-%{_libdir}/%{name}/char.*
-%{_libdir}/%{name}/condition.*
-%{_libdir}/%{name}/dbm.*
-%{_libdir}/%{name}/digest.*
-%attr(755,root,root) %{_libdir}/%{name}/dll[bmnstu]*.so
-%{_libdir}/%{name}/g[ce]*.*
-%{_libdir}/%{name}/l*.cm*
-%{_libdir}/%{name}/l*.mli
-%{_libdir}/%{name}/lib[abc]*.a
-%{_libdir}/%{name}/libmldbm.a
-%{_libdir}/%{name}/lib[nstu]*.a
+%dir %{_libdir}/%{name}/vmthreads
+%dir %{_libdir}/%{name}/vmthreads/*.cm*
+%dir %{_libdir}/%{name}/vmthreads/*.a
+%{_libdir}/%{name}/*.a
+%{?with_opt:%{_libdir}/%{name}/*.o}
+%{_libdir}/%{name}/*.cm*
+%exclude %{_libdir}/%{name}/*graphics*
+%{_libdir}/%{name}/Makefile.config
 %{_libdir}/%{name}/ld.conf
-%attr(755,root,root) %{_libdir}/%{name}/expunge
-%attr(755,root,root) %{_libdir}/%{name}/extract_crc
 %{_libdir}/%{name}/camlheader
 %{_libdir}/%{name}/camlheader_ur
-%attr(755,root,root) %{_libdir}/%{name}/*labels
-%{_mandir}/man*/*ocaml*
-%{_infodir}/*
+%{_libdir}/%{name}/ocamlbuild
+%dir %{_libdir}/%{name}/ocamldoc
+%{_libdir}/%{name}/ocamldoc/*.hva
+%attr(755,root,root) %{_libdir}/%{name}/expunge
+%attr(755,root,root) %{_libdir}/%{name}/extract_crc
+%attr(755,root,root) %{_libdir}/%{name}/objinfo_helper
+%{_mandir}/man1/ocaml*
+%exclude %{_mandir}/man1/ocamlrun.1*
 
-%files camlp4
+%files runtime
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*camlp4*
-%attr(755,root,root) %{_bindir}/ocpp
-%attr(755,root,root) %{_bindir}/odyl
-%{_libdir}/%{name}/camlp4
-%{_mandir}/man*/*camlp4*
-%{_mandir}/man*/*ocpp*
-
-%if %{!?_without_tk:1}%{?_without_tk:0}
-%files labltk
+%attr(755,root,root) %{_bindir}/ocamlrun
+%dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/site-lib
+%dir %{_libdir}/%{name}/stublibs
+%attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
+%exclude %{_libdir}/%{name}/stublibs/dllgraphics.so
+%attr(755,root,root) %{_libdir}/%{name}/libcamlrun_shared.so
+%{_mandir}/man1/ocamlrun.1*
+
+%files lib-source
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/labltk
-%attr(755,root,root) %{_bindir}/ocamlbrowser
-%dir %{_libdir}/%{name}/labltk
-%{_libdir}/%{name}/labltk/*.cm*
-%{_libdir}/%{name}/labltk/*.a
-%{_libdir}/%{name}/labltk/*.mli
-%attr(755,root,root) %{_libdir}/%{name}/labltk/*.so
-%attr(755,root,root) %{_libdir}/%{name}/labltk/labltktop
-%attr(755,root,root) %{_libdir}/%{name}/labltk/tkcompiler
+%{_libdir}/%{name}/*.ml
+%{_libdir}/%{name}/*.mli
+%{_libdir}/%{name}/*/*.mli
+
+%files doc-html
+%defattr(644,root,root,755)
+%doc docs/html/ocaml/*
+
+%files doc-ps
+%defattr(644,root,root,755)
+%doc docs/*.ps.gz
+
+%files doc-info
+%defattr(644,root,root,755)
+%{_infodir}/ocaml.info*
+
+# they are poor, html is much better
+#%files manpages
+#%%{_mandir}/man3/*
+
+%if %{with emacs}
+%files emacs
+%defattr(644,root,root,755)
+%{_datadir}/emacs/site-lisp/*.el*
 %endif
 
-%if %{!?_without_x11:1}%{?_without_x11:0}
+%if %{with x}
 %files x11graphics
 %defattr(644,root,root,755)
-%{_libdir}/%{name}/graphics*
+%attr(755,root,root) %{_libdir}/%{name}/stublibs/dllgraphics.so
+
+%files x11graphics-devel
+%defattr(644,root,root,755)
+%{_libdir}/%{name}/graphics*.cm*
+%{?with_opt:%{_libdir}/%{name}/graphics.a}
 %{_libdir}/%{name}/libgraphics.a
-%attr(755,root,root) %{_libdir}/%{name}/dllgraphics.so
 %endif
 
-%if %{!?_without_emacs:1}%{?_without_emacs:0}
-%files emacs
+%files compiler-objects
 %defattr(644,root,root,755)
-%{_libdir}/emacs/site-lisp/*.el
-%endif
+%{_libdir}/%{name}/compiler
 
-%files doc-ps
+%files ocamldoc-devel
 %defattr(644,root,root,755)
-%doc docs/*.ps.gz
+%{_libdir}/%{name}/ocamldoc/*.cm*
+%{?with_opt:%{_libdir}/%{name}/ocamldoc/*.a}
 
-%files doc-html
+%files examples
 %defattr(644,root,root,755)
-%doc docs/html/*
+%{_examplesdir}/%{name}-%{version}
This page took 0.047194 seconds and 4 git commands to generate.