]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- drop unused site-lib dir
[packages/ocaml.git] / ocaml.spec
index 67b6fea292e02e4c3119e39d4fd366882868a36a..2af1d48dbf50fd65e0e107f545097d0c70a9383f 100644 (file)
@@ -14,7 +14,7 @@ Summary:      The Objective Caml compiler and programming environment
 Summary(pl.UTF-8):     Kompilator OCamla (Objective Caml) oraz środowisko programistyczne
 Name:          ocaml
 Version:       4.12.0
-Release:       0.1
+Release:       4
 Epoch:         1
 License:       QPL v1.0 with linking exception (compiler), LGPL v2 with linking exception (library)
 Group:         Development/Languages
@@ -43,6 +43,10 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags       -fno-strict-aliasing
 
+%if %{without ocaml_opt}
+%define                _noautoreq      Backend_intf Inlining_decision_intf Simplify_boxed_integer_ops_intf
+%endif
+
 %description
 Objective Caml is a high-level, strongly-typed, functional and
 object-oriented programming language from the ML family of languages.
@@ -171,14 +175,19 @@ mv htmlman docs/html/ocaml
 %configure \
        AS=%{__as} \
        ASPP="%{__cc} -c" \
-       --libdir=%{_libdir}/ocaml
-
-%{__make} -j1 world bootstrap %{?with_ocaml_opt:opt.opt}
+       --libdir=%{_libdir}/ocaml \
+       %{!?with_ocaml_opt:--disable-native-compiler}
+
+%{__make} world
+%{__make} bootstrap
+%if %{with ocaml_opt}
+%{__make} opt
+%{__make} opt.opt
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-%{version}}
-install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/site-lib
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -194,7 +203,7 @@ EOF
 ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/ocaml/caml
 
 # compiled sources of compiler, needed by some programs
-for f in {asm,byte}comp parsing typing utils ; do
+for f in %{?with_ocaml_opt:asmcomp} bytecomp parsing typing utils ; do
        install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
        cp $f/*.{cmi,cmo} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
        %{?with_ocaml_opt:cp $f/*.{cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f}
@@ -285,7 +294,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/ocamlrund
 %attr(755,root,root) %{_bindir}/ocamlruni
 %dir %{_libdir}/%{name}
-%dir %{_libdir}/%{name}/site-lib
 %dir %{_libdir}/%{name}/stublibs
 %{_libdir}/%{name}/eventlog_metadata
 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
This page took 0.040703 seconds and 4 git commands to generate.