]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml.spec
- use name macro in internal deps
[packages/ocaml.git] / ocaml.spec
index b6877abb97aa5a6d50d6c9b98682512b7409d858..28afd559aee378e4d2d5afc31d6a281734c88474 100644 (file)
@@ -1,29 +1,30 @@
 #
 # Conditional build:
-
 %bcond_without emacs   # without emacs subpackage
 %bcond_without x       # without X11 support 
 %bcond_without tk      # without Tcl/Tk support
 %bcond_with    db3     # use db3 instead of db 4.x
-
+#
 # --without x11 implies --without tk
 %{!?with_x:%undefine   with_tk}
 
 %define                p4ver   3.06
+%define                sver    3.08
 
 Summary:       The Objective Caml compiler and programming environment
 Summary(pl):   Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
 Name:          ocaml
-Version:       3.08.0
-Release:       1       
+Version:       3.08.1
+Release:       1
+Epoch:         1
 License:       distributable
 Vendor:                Group of implementors <caml-light@inria.fr>
 Group:         Development/Languages
-Source0:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: c6ef478362295c150101cdd2efcd38e0
-Source1:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.html.tar.gz
+Source0:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.gz
+# Source0-md5: 8a32dd665d0d8fc08a027e1b8f68a001
+Source1:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.html.tar.gz
 # Source1-md5: 0daee5643db6960682c1a7d84467885f
-Source2:       http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.ps.gz
+Source2:       http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
 # Source2-md5: 35a5d4318456c0982e72ee3f33364bf5
 Source3:       ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
 # Source3-md5: 21370bae4e7f6435b38aeb21db7ce8bb
@@ -40,10 +41,9 @@ Source8:     http://www.oefai.at/~markus/ocaml_sources/ds-contrib.tar.gz
 Patch0:                %{name}-build.patch
 Patch1:                %{name}-db3.patch
 Patch2:                %{name}-objinfo.patch
-#Patch3:               %{name}-mano.patch
+Patch3:                %{name}-mano.patch
+# needs update for ocaml 3.08
 #Patch4:               %{name}-unused-var-warning.patch
-#Patch5:               %{name}-3.07-patch2.diffs
-#Patch6:               %{name}-emacs_batch_mode.patch
 URL:           http://caml.inria.fr/
 %{?with_x:BuildRequires:       XFree86-devel}
 %{?with_db3:BuildRequires:     db3-devel}
@@ -53,9 +53,8 @@ URL:          http://caml.inria.fr/
 BuildRequires: xemacs
 BuildRequires: xemacs-common
 BuildRequires: xemacs-fsf-compat-pkg
-
 %endif
-Requires:      ocaml-runtime = %{version}-%{release}
+Requires:      %{name}-runtime = %{epoch}:%{version}-%{release}
 Provides:      ocaml-ocamldoc
 Obsoletes:     ocaml-ocamldoc
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -94,7 +93,7 @@ w g
 Summary:       Emacs mode for OCaml
 Summary(pl):   Tryb OCamla dla Emacsa
 Group:         Development/Tools
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description emacs
 Emacs mode files for Objective Caml language.
@@ -120,7 +119,7 @@ podstawowe bibliotki linkowane dynamicznie.
 Summary:       LablTk library for OCaml
 Summary(pl):   Biblioteka LablTk dla OCamla
 Group:         Development/Libraries
-Requires:      %{name}-labltk = %{version}-%{release}
+Requires:      %{name}-labltk = %{epoch}:%{version}-%{release}
 
 %description labltk-devel
 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
@@ -135,7 +134,7 @@ u
 Summary:       Runtime for LablTk library
 Summary(pl):   ¦rodowisko uruchomieniowe dla biblioteki LablTk
 Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description labltk
 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
@@ -150,7 +149,7 @@ u
 Summary:       X11 graphic output for OCaml
 Summary(pl):   Dostêp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name}-x11graphics = %{version}-%{release}
+Requires:      %{name}-x11graphics = %{epoch}:%{version}-%{release}
 
 %description x11graphics-devel
 x11graphics module gives OCaml program access to drawing in X11
@@ -166,7 +165,7 @@ niezb
 Summary:       X11 graphic output for OCaml
 Summary(pl):   Dostêp do X11 dla OCamla
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description x11graphics
 x11graphics module gives OCaml program access to drawing in X11
@@ -182,8 +181,8 @@ potrzebne do uruchamiania program
 Summary:       Objective Caml Preprocessor
 Summary(pl):   Preprocesor OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
-Provides:      camlp4 = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Provides:      camlp4 = %{epoch}:%{version}-%{release}
 Obsoletes:     camlp4
 
 %description camlp4
@@ -219,7 +218,7 @@ sk
 Summary:       Compiled parts of OCaml compiler
 Summary(pl):   Skompilowane czê¶ci kompilatora OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Obsoletes:     ocaml-devel
 Provides:      ocaml-devel
 
@@ -235,7 +234,7 @@ OCamla. S
 Summary:       Files needed to develop programs using ocamldoc
 Summary(pl):   Pliki potrzebne do tworzenia programów u¿ywaj±cych ocamldoc
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description ocamldoc-devel
 You need this package if you are going to write ocamldoc front end or
@@ -249,7 +248,7 @@ dla ocamldoc lub co
 Summary:       Sources of OCaml standard library
 Summary(pl):   ¬ród³a biblioteki standardowej OCamla
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description lib-source
 This sources come helpful during debugging of user programs with ocamldebug.
@@ -263,7 +262,7 @@ z u
 Summary:       Example source code for OCaml
 Summary(pl):   Przyk³adowe kody ¼ród³owe w OCamlu
 Group:         Development/Languages
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description examples
 This packages contains sources for Okasaki's Purely Functional
@@ -274,7 +273,7 @@ Pakiet ten zawiera 
 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
 
 %prep
-%setup -q -a1 -a3 -a5
+%setup -q -a1 -a3 -a5  
 mkdir examples
 tar xjf %{SOURCE7} -C examples
 tar xzf %{SOURCE8} -C examples
@@ -290,13 +289,11 @@ cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-#%patch3 -p1
+%patch3 -p1
 #%patch4 -p1
-#%patch5 -p1
-#%patch6 -p1
 
 %build
-cp /usr/share/automake/config.sub config/gnu
+cp -f /usr/share/automake/config.sub config/gnu
 ./configure \
         -cc "%{__cc} %{rpmcflags}" \
        -bindir %{_bindir} \
This page took 0.062018 seconds and 4 git commands to generate.