]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml-CFLAGS.patch
outdated
[packages/ocaml.git] / ocaml-CFLAGS.patch
index 14a295eeb5caa4188c4e8a3c843c2e9a56be05c5..d787a66186aee0fd064c653a7a50bf1c73040818 100644 (file)
@@ -64,8 +64,8 @@ diff -Nur b.ocaml-3.08.4/otherlibs/bigarray/Makefile n.ocaml-3.08.4/otherlibs/bi
  include ../../config/Makefile
  
  CC=$(BYTECC)
--CFLAGS=-I../../byterun -g -O $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS)
-+override CFLAGS += -I../../byterun -g $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS)
+-CFLAGS=-I../../byterun -O $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS)
++override CFLAGS += -I../../byterun $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS)
  CAMLC=../../ocamlcomp.sh -I ../unix
  CAMLOPT=../../ocamlcompopt.sh -I ../unix
  MKLIB=../../boot/ocamlrun ../../tools/ocamlmklib
@@ -172,10 +172,10 @@ diff -Nur b.ocaml-3.08.4/otherlibs/num/Makefile n.ocaml-3.08.4/otherlibs/num/Mak
  # Compilation options
  CC=$(BYTECC)
 -CFLAGS=-O -I../../byterun $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS) \
-+override CFLAGS += -I../../byterun $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS) \
++override CFLAGS += -O -I../../byterun $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS) \
            -DBNG_ARCH_$(BNG_ARCH) -DBNG_ASM_LEVEL=$(BNG_ASM_LEVEL)
- CAMLC=../../ocamlcomp.sh -w s
- CAMLOPT=../../ocamlcompopt.sh -w s
+ CAMLC=../../boot/ocamlrun ../../ocamlc -I ../../boot -w s
+ CAMLOPT=../../boot/ocamlrun ../../ocamlopt -I ../../stdlib -w s
 diff -Nur b.ocaml-3.08.4/otherlibs/num/Makefile.nt n.ocaml-3.08.4/otherlibs/num/Makefile.nt
 --- b.ocaml-3.08.4/otherlibs/num/Makefile.nt   2004-11-29 09:50:23.000000000 +0100
 +++ n.ocaml-3.08.4/otherlibs/num/Makefile.nt   2005-11-04 21:26:14.779320248 +0100
@@ -183,7 +183,7 @@ diff -Nur b.ocaml-3.08.4/otherlibs/num/Makefile.nt n.ocaml-3.08.4/otherlibs/num/
  
  # Compilation options
  CC=$(BYTECC)
--CFLAGS=-O -I../../byterun \
+-CFLAGS=-I../../byterun \
 +override CFLAGS += -I../../byterun \
            -DBNG_ARCH_$(BNG_ARCH) -DBNG_ASM_LEVEL=$(BNG_ASM_LEVEL)
  CAMLC=../../boot/ocamlrun ../../ocamlc -I ../../boot -w s
@@ -195,8 +195,8 @@ diff -Nur b.ocaml-3.08.4/otherlibs/num/test/Makefile n.ocaml-3.08.4/otherlibs/nu
  CAMLC=../../../boot/ocamlrun ../../../ocamlc -I ../../../stdlib
  CAMLOPT=../../../boot/ocamlrun ../../../ocamlopt -I ../../../stdlib
  CC=$(BYTECC)
--CFLAGS=-I.. $(BYTECCCOMPOPTS)
-+override CFLAGS += -I.. $(BYTECCCOMPOPTS)
+-CFLAGS=-I.. -I../../../byterun $(BYTECCCOMPOPTS)
++override CFLAGS += -I.. -I../../../byterun $(BYTECCCOMPOPTS)
  
  test: test.byt test.opt
        if $(SUPPORTS_SHARED_LIBRARIES); then ../../../byterun/ocamlrun -I .. ./test.byt; else ./test.byt; fi
This page took 0.024456 seconds and 4 git commands to generate.