]> git.pld-linux.org Git - packages/ocaml.git/blobdiff - ocaml-CFLAGS.patch
- updated to 3.09.0
[packages/ocaml.git] / ocaml-CFLAGS.patch
index 14a295eeb5caa4188c4e8a3c843c2e9a56be05c5..f1f6394dfac25dc13a4d248d543da1eb764f3612 100644 (file)
@@ -64,8 +64,8 @@ diff -Nur b.ocaml-3.08.4/otherlibs/bigarray/Makefile n.ocaml-3.08.4/otherlibs/bi
  include ../../config/Makefile
  
  CC=$(BYTECC)
--CFLAGS=-I../../byterun -g -O $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS)
-+override CFLAGS += -I../../byterun -g $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS)
+-CFLAGS=-I../../byterun -O $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS)
++override CFLAGS += -I../../byterun $(BYTECCCOMPOPTS) $(SHAREDCCCOMPOPTS)
  CAMLC=../../ocamlcomp.sh -I ../unix
  CAMLOPT=../../ocamlcompopt.sh -I ../unix
  MKLIB=../../boot/ocamlrun ../../tools/ocamlmklib
@@ -195,8 +195,8 @@ diff -Nur b.ocaml-3.08.4/otherlibs/num/test/Makefile n.ocaml-3.08.4/otherlibs/nu
  CAMLC=../../../boot/ocamlrun ../../../ocamlc -I ../../../stdlib
  CAMLOPT=../../../boot/ocamlrun ../../../ocamlopt -I ../../../stdlib
  CC=$(BYTECC)
--CFLAGS=-I.. $(BYTECCCOMPOPTS)
-+override CFLAGS += -I.. $(BYTECCCOMPOPTS)
+-CFLAGS=-I.. -I../../../byterun $(BYTECCCOMPOPTS)
++override CFLAGS += -I.. -I../../../byterun $(BYTECCCOMPOPTS)
  
  test: test.byt test.opt
        if $(SUPPORTS_SHARED_LIBRARIES); then ../../../byterun/ocamlrun -I .. ./test.byt; else ./test.byt; fi
This page took 0.027815 seconds and 4 git commands to generate.