]> git.pld-linux.org Git - packages/ocaml.git/blob - ocaml.spec
- release 5
[packages/ocaml.git] / ocaml.spec
1 #
2 # Conditional build:
3
4 %bcond_without emacs    # emacs subpackage
5 %bcond_without x        # without X11 support 
6 %bcond_without tk       # tk support
7 %bcond_with db3         # use db3 instead of db 4.x
8
9 # --without x11 implies --without tk
10 %{!?with_x:%undefine    with_tk}
11
12 %define p4ver 3.06
13
14 Summary:        The Objective Caml compiler and programming environment
15 Summary(pl):    Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
16 Name:           ocaml
17 Version:        3.07
18 Release:        5
19 License:        distributable
20 Vendor:         Group of implementors <caml-light@inria.fr>
21 Group:          Development/Languages
22 Source0:        http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  2dd038055f5e1350078ad81270411b78
24 Source1:        http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.html.tar.gz
25 # Source1-md5:  9ac1f7e9e381b95504f0e7868d9fbf52
26 Source2:        http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.ps.gz
27 # Source2-md5:  09a9ac4bc1ec90ca4d16743ffbe76c78
28 Source3:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
29 # Source3-md5:  21370bae4e7f6435b38aeb21db7ce8bb
30 Source4:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
31 # Source4-md5:  035915d1a530aa7ec9b194d9a7d258eb
32 Source5:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.html.tar.gz
33 # Source5-md5:  96d8eb4ca5abd58c9a280ba59f73b192
34 Source6:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.dvi.gz
35 # Source6-md5:  fcd87c235109364242a0c9ccf176dff8
36 Source7:        http://www.oefai.at/~markus/ocaml_sources/pure-fun-1.0.4.tar.bz2
37 # Source7-md5:  567bc681b4cc1cfcbbfb6fa5f012019b
38 Source8:        http://www.oefai.at/~markus/ocaml_sources/ds-contrib.tar.gz
39 # Source8-md5:  77fa1da7375dea1393cc0b6cd802d7e1
40 Patch0:         %{name}-build.patch
41 Patch1:         %{name}-db3.patch
42 Patch2:         %{name}-objinfo.patch
43 Patch3:         %{name}-mano.patch
44 Patch4:         %{name}-unused-var-warning.patch
45 Patch5:         %{name}-3.07-patch2.diffs
46 #Patch6:                %{name}-emacs_batch_mode.patch
47 URL:            http://caml.inria.fr/
48 %{?with_x:BuildRequires:                XFree86-devel}
49 %{?with_db3:BuildRequires:      db3-devel}
50 %{!?with_db3:BuildRequires:     db-devel >= 4.1}
51 %{?with_tk:BuildRequires:               tk-devel}
52 %if %{with emacs}
53 BuildRequires:  xemacs
54 BuildRequires:  xemacs-common
55 BuildRequires:  xemacs-fsf-compat-pkg
56
57 %endif
58 Requires:       ocaml-runtime = %{version}-%{release}
59 Provides:       ocaml-ocamldoc
60 Obsoletes:      ocaml-ocamldoc
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 Objective Caml is a high-level, strongly-typed, functional and
65 object-oriented programming language from the ML family of languages.
66
67 This package comprises two batch compilers (a fast bytecode compiler
68 and an optimizing native-code compiler), an interactive toplevel
69 system, Lex&Yacc tools, a replay debugger, and a comprehensive
70 library.
71
72 %description -l pl
73 OCaml (Objective Caml) jest funkcyjnym, obiektowo zorientowanym jêzykiem
74 wysokiego poziomu z silnym typowaniem. Nale¿y do rodziny jêzyków ML.
75
76 Ten pakiet zawiera dwa kompilatory (szybki kompilator do bajtkodu
77 oraz optymalizuj±cy kompilator do kodu natywnego), interaktywne ¶rodowisko
78 pracy, narzêdzia do tworzenia analizatorów leksykalnych oraz sk³adniowych
79 (ocamllex, ocamlyacc), odpluskwiacz (ocamldebug) i biblioteki.
80
81 %package doc-ps
82 Summary:        PostScript documentation for OCaml
83 Summary(pl):    Dokumentacja dla OCamla w formacie PostScript
84 Group:          Development/Tools
85
86 %description doc-ps
87 PostScript documentation for OCaml. HTML documentation is in main package.
88
89 %description doc-ps -l pl
90 Dokumentacja dla OCamla w formacie PostScript. Dokumentacja HTML jest
91 w g³ównym pakiecie.
92
93 %package emacs
94 Summary:        Emacs mode for OCaml
95 Summary(pl):    Tryb OCamla dla Emacsa
96 Group:          Development/Tools
97 Requires:       %{name} = %{version}
98
99 %description emacs
100 Emacs mode files for Objective Caml language.
101
102 %description emacs -l pl
103 Pliki trybu OCamla dla Emacsa.
104
105 %package runtime
106 Summary:        Runtime system for OCaml
107 Summary(pl):    ¦rodowisko uruchomieniowe dla OCamla
108 Group:          Libraries
109
110 %description runtime
111 This package contains binaries needed to run bytecode OCaml programs:
112 ocamlrun bytecode interpreter, and basic dynamic link libraries.
113
114 %description runtime -l pl
115 Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
116 OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun) oraz
117 podstawowe bibliotki linkowane dynamicznie.
118
119 %package labltk-devel
120 Summary:        LablTk library for OCaml
121 Summary(pl):    Biblioteka LablTk dla OCamla
122 Group:          Development/Libraries
123 Requires:       %{name}-labltk = %{version}-%{release}
124
125 %description labltk-devel
126 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
127 contains files needed to develop OCaml programs using LablTk.
128
129 %description labltk-devel -l pl
130 Biblioteka LablTk daje programom napisanym w OCamlu dostêp do widgetów
131 Tcl/Tk. Pakiet ten zawiera pliki niezbêdne do tworzenia programów
132 u¿ywaj±cych LablTk.
133
134 %package labltk
135 Summary:        Runtime for LablTk library
136 Summary(pl):    ¦rodowisko uruchomieniowe dla biblioteki LablTk
137 Group:          Libraries
138 Requires:       %{name} = %{version}-%{release}
139
140 %description labltk
141 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
142 contains files needed to run bytecode OCaml programs using LablTk.
143
144 %description labltk -l pl
145 Biblioteka LablTk daje programom napisanym w OCamlu dostêp do widgetów
146 Tcl/Tk. Pakiet ten zawiera binaria potrzebne do uruchamiania programów
147 u¿ywaj±cych LablTk.
148
149 %package x11graphics-devel
150 Summary:        X11 graphic output for OCaml
151 Summary(pl):    Dostêp do X11 dla OCamla
152 Group:          Development/Libraries
153 Requires:       %{name}-x11graphics = %{version}-%{release}
154
155 %description x11graphics-devel
156 x11graphics module gives OCaml program access to drawing in X11
157 windows. This package contains files needed to develop OCaml programs
158 using x11graphics.
159
160 %description x11graphics-devel -l pl
161 Modu³ x11graphics daje programom napisanym w OCamlu mo¿liwo¶æ
162 korzystania z interfejsu graficznego X11. Pakiet ten zawiera pliki
163 niezbêdne do tworzenia programów u¿ywaj±cych x11graphics.
164
165 %package x11graphics
166 Summary:        X11 graphic output for OCaml
167 Summary(pl):    Dostêp do X11 dla OCamla
168 Group:          Development/Libraries
169 Requires:       %{name} = %{version}-%{release}
170
171 %description x11graphics
172 x11graphics module gives OCaml program access to drawing in X11
173 windows. This package contains files needed to run bytecode OCaml
174 programs using x11graphics.
175
176 %description x11graphics -l pl
177 Modu³ x11graphics daje programom napisanym w OCamlu mo¿liwo¶æ
178 korzystania z interfejsu graficznego X11. Pakiet ten zawiera binaria
179 potrzebne do uruchamiania programów u¿ywaj±cych x11graphics.
180
181 %package camlp4
182 Summary:        Objective Caml Preprocessor
183 Summary(pl):    Preprocesor OCamla
184 Group:          Development/Languages
185 Requires:       %{name} = %{version}-%{release}
186 Provides:       camlp4 = %{version}-%{release}
187 Obsoletes:      camlp4
188
189 %description camlp4
190 Camlp4 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
191 tools for syntax (grammars) and the ability to modify the concrete
192 syntax of the language (quotations, syntax extensions).
193
194 Camlp4 can parse normal Ocaml concrete syntax or any other
195 user-definable syntax. As an example, an alternative syntax is
196 provided, named revised, because it tries to fix some small problems
197 of the normal syntax.
198
199 Camlp4 can pretty print the normal Ocaml concrete syntax or the
200 revised one. It is therefore always possible to have a version of your
201 sources compilable by the Objective Caml compiler without
202 preprocessing.
203
204 %description camlp4 -l pl
205 Camlp4 jest preprocesorem OCamla. Oferuje narzêdzia do manipulowania
206 sk³adni± (gramatyki) oraz mo¿liwo¶æ modyfikowania oryginalnej sk³adni
207 jêzyka (cytowania, rozszerzenia).
208
209 Camlp4 mo¿e sparsowaæ oryginaln± sk³adniê Ocamla lub dowoln± inn±
210 definiowaln± przez u¿ytkownika. Jako przyk³ad podana jest alternatywna
211 sk³adnia (revised syntax), która próbuje poprawiæ drobne problemy
212 wystêpuj±ce w sk³adni oryginalnej.
213
214 Camlp4 umie ³adnie formatowaæ ¼ród³a zarówno w oryginalnej jak i
215 poprawionej sk³adni OCamla. Potrafi tak¿e t³umaczyæ programy z jednej
216 sk³adni na drug±.
217
218 %package compiler-objects
219 Summary:        Compiled parts of OCaml compiler
220 Summary(pl):    Skompilowane czê¶ci kompilatora OCamla
221 Group:          Development/Languages
222 Requires:       %{name} = %{version}-%{release}
223 Obsoletes:      ocaml-devel
224
225 %description compiler-objects
226 This package contains *.cmi and *.cmo files being parts of OCaml
227 compiler. They are needed to compile some programs.
228
229 %description compiler-objects -l pl
230 Pakiet ten zawiera pliki *.cmi oraz *.cmo bêd±ce cze¶ciami kompilatora
231 OCamla. S± one wymagane do kompilacji niektórych programów.
232
233 %package ocamldoc-devel
234 Summary:        Files needed to develop programs using ocamldoc
235 Summary(pl):    Pliki potrzebne do tworzenia programów u¿ywaj±cych ocamldoc
236 Group:          Development/Languages
237 Requires:       %{name} = %{version}-%{release}
238
239 %description ocamldoc-devel
240 You need this package if you are going to write ocamldoc front end or
241 something like that.
242
243 %description ocamldoc-devel -l pl
244 Bêdziesz potrzebowaæ tego pakietu, je¶li zamierzasz pisaæ front end
245 dla ocamldoc lub co¶ podobnego.
246
247 %package lib-source
248 Summary:        Sources of OCaml standard library
249 Summary(pl):    ¬ród³a biblioteki standardowej OCamla
250 Group:          Development/Languages
251 Requires:       %{name} = %{version}-%{release}
252
253 %description lib-source
254 This sources come helpful during debugging of user programs with ocamldebug.
255
256 %description lib-source -l pl
257 ¬ród³a te s± przydatne przy odpluskwianiu programów u¿ytkownika
258 z u¿yciem ocamldebug.
259
260 # maybe we'll want to add some more stuff here?
261 %package examples
262 Summary:        Example source code for OCaml
263 Summary(pl):    Przyk³adowe kody ¼ród³owe w OCamlu
264 Group:          Development/Languages
265 Requires:       %{name} = %{version}-%{release}
266
267 %description examples
268 This packages contains sources for Okasaki's Purely Functional
269 Datastructures in OCaml, along with some contributions.
270
271 %description examples -l pl
272 Pakiet ten zawiera ¼ród³a Czysto Funkcyjnych Struktur Danych
273 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
274
275 %prep
276 %setup -q -a1 -a3 -a5
277 mkdir examples
278 tar xjf %{SOURCE7} -C examples
279 tar xzf %{SOURCE8} -C examples
280 # order mess with docs somewhat
281 mkdir docs
282 mkdir docs/html
283 mv htmlman docs/html/ocaml
284 cp %{SOURCE2} docs/ocaml.ps.gz
285 mv camlp4-%{p4ver}-manual.html docs/html/camlp4
286 cp %{SOURCE4} docs/camlp4.ps.gz
287 mv camlp4-%{p4ver}-tutorial.html docs/html/camlp4-tutorial
288 cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
289 %patch0 -p1
290 %patch1 -p1
291 %patch2 -p1
292 %patch3 -p1
293 %patch4 -p1
294 %patch5 -p1
295 #%patch6 -p1
296
297 %build
298 ./configure \
299         -cc "%{__cc} %{rpmcflags}" \
300         -bindir %{_bindir} \
301         -libdir %{_libdir}/%{name} \
302         -mandir %{_mandir}/man1 \
303         -host %{_host} \
304         %{!?with_tk:-no-tk} \
305         -with-pthread
306
307 %{__make} world bootstrap opt.opt
308 %{__make} -C tools objinfo
309
310 %install
311 rm -rf $RPM_BUILD_ROOT
312 install -d $RPM_BUILD_ROOT{%{_includedir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
313
314 %{__make} install \
315         BINDIR=$RPM_BUILD_ROOT%{_bindir} \
316         LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{name} \
317         MANDIR=$RPM_BUILD_ROOT%{_mandir}
318
319 cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
320 %{_libdir}/%{name}/stublibs
321 %{_libdir}/%{name}
322 EOF
323
324 %if %{with emacs}
325 %{__make} -C emacs DESTDIR=$RPM_BUILD_ROOT install \
326         EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
327                 else echo xemacs; fi`" \
328         EMACSDIR="$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp"
329 %endif
330
331 # symlink .opt versions of compilers (if present)
332 # warning: don't do that with camlp4 (can't load extensions then)
333 for f in ocamlc ocamlopt ocamldoc ocamllex; do
334         if test -f $RPM_BUILD_ROOT%{_bindir}/$f.opt; then
335                 mv -f $RPM_BUILD_ROOT%{_bindir}/$f \
336                         $RPM_BUILD_ROOT%{_bindir}/$f.byte
337                 ln -sf %{_bindir}/$f.opt $RPM_BUILD_ROOT%{_bindir}/$f
338         fi
339 done
340
341 # move includes to the proper place
342 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
343 # but leave compatibility symlink
344 ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
345
346 # compiled sources of compiler, needed by some programs
347 for f in {asm,byte}comp parsing typing utils ; do
348         install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
349         cp $f/*.{cmi,cmo,cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
350 done
351
352 # this isn't installed by default, but is useful
353 install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
354 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
355 cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
356 ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
357
358 # shutup checkfiles
359 rm -rf $RPM_BUILD_ROOT%{_mandir}/man3
360 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
361
362 %clean
363 rm -rf $RPM_BUILD_ROOT
364
365 %files runtime
366 %defattr(644,root,root,755)
367 %attr(755,root,root) %{_bindir}/ocamlrun
368 %dir %{_libdir}/%{name}
369 %dir %{_libdir}/%{name}/stublibs
370 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
371 %exclude %{_libdir}/%{name}/stublibs/dllgraphics.so
372 %if %{with tk}
373 %exclude %{_libdir}/%{name}/stublibs/dlllabltk.so
374 %exclude %{_libdir}/%{name}/stublibs/dlltkanim.so
375 %endif
376
377 %files
378 %defattr(644,root,root,755)
379 %doc LICENSE Changes README Upgrading
380 %doc docs/html/ocaml
381 %attr(755,root,root) %{_bindir}/ocaml*
382 %{!?_without_tk:%exclude %{_bindir}/ocamlbrowser}
383 %exclude %{_bindir}/ocamlrun
384 %attr(755,root,root) %{_bindir}/*labels
385 %{_includedir}/caml
386 %{_libdir}/%{name}/caml
387 %{_libdir}/%{name}/threads
388 %dir %{_libdir}/%{name}/vmthreads
389 %dir %{_libdir}/%{name}/vmthreads/*.cm*
390 %dir %{_libdir}/%{name}/vmthreads/*.a
391 %{_libdir}/%{name}/*.a
392 %{_libdir}/%{name}/*.o
393 %{_libdir}/%{name}/*.cm*
394 %exclude %{_libdir}/%{name}/*graphics*
395 %{_libdir}/%{name}/ld.conf
396 %{_libdir}/%{name}/camlheader
397 %{_libdir}/%{name}/camlheader_ur
398 %dir %{_libdir}/%{name}/ocamldoc
399 %{_libdir}/%{name}/ocamldoc/*.hva
400 %attr(755,root,root) %{_libdir}/%{name}/expunge
401 %attr(755,root,root) %{_libdir}/%{name}/extract_crc
402 %attr(755,root,root) %{_libdir}/%{name}/*labels
403 %{_mandir}/man1/*ocaml*
404
405 %files lib-source
406 %defattr(644,root,root,755)
407 %{_libdir}/%{name}/*.ml
408 %{_libdir}/%{name}/*.mli
409 %{_libdir}/%{name}/*/*.mli
410
411 %files examples
412 %defattr(644,root,root,755)
413 %{_examplesdir}/%{name}-%{version}
414
415 # they are poor, html is much better
416 #%files manpages
417 #%%{_mandir}/man3/*
418
419 %files compiler-objects
420 %defattr(644,root,root,755)
421 %{_libdir}/%{name}/compiler
422
423 %files camlp4
424 %defattr(644,root,root,755)
425 %doc docs/html/camlp4*
426 %attr(755,root,root) %{_bindir}/*camlp4*
427 %attr(755,root,root) %{_bindir}/ocpp
428 # Not installed since 3.05, is is needed?
429 #%attr(755,root,root) %{_bindir}/odyl
430 %{_libdir}/%{name}/camlp4
431 %{_mandir}/man*/*camlp4*
432 %{_mandir}/man*/*ocpp*
433
434 %if %{with tk}
435 %files labltk-devel
436 %defattr(644,root,root,755)
437 %attr(755,root,root) %{_bindir}/labltk
438 %attr(755,root,root) %{_bindir}/ocamlbrowser
439 %dir %{_libdir}/%{name}/labltk
440 %{_libdir}/%{name}/labltk/*.cm*
441 %{_libdir}/%{name}/labltk/*.a
442 %attr(755,root,root) %{_libdir}/%{name}/labltk/tkcompiler
443 %{_examplesdir}/%{name}-labltk-%{version}
444
445 %files labltk
446 %defattr(644,root,root,755)
447 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dlllabltk.so
448 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dlltkanim.so
449 %endif
450
451 %if %{with x11}
452 %files x11graphics-devel
453 %defattr(644,root,root,755)
454 %{_libdir}/%{name}/graphics*.cm*
455 %{_libdir}/%{name}/graphics.a
456 %{_libdir}/%{name}/libgraphics.a
457
458 %files x11graphics
459 %defattr(644,root,root,755)
460 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dllgraphics.so
461 %endif
462
463 %if %{with emacs}
464 %files emacs
465 %defattr(644,root,root,755)
466 %{_datadir}/emacs/site-lisp/*.el*
467 %endif
468
469 %files ocamldoc-devel
470 %defattr(644,root,root,755)
471 %{_libdir}/%{name}/ocamldoc/*.cm*
472 %{_libdir}/%{name}/ocamldoc/*.a
473
474 %files doc-ps
475 %defattr(644,root,root,755)
476 %doc docs/*.ps.gz
This page took 0.285491 seconds and 4 git commands to generate.