]> git.pld-linux.org Git - packages/ocaml.git/blob - ocaml.spec
- adapterized and made spec %%debug ready or added using %%rpm*flags macros
[packages/ocaml.git] / ocaml.spec
1 Summary:        The Objective Caml compiler and programming environment
2 Summary(pl):    Kompilator Objektowego Caml oraz ¶rodowisko programistyczne
3 Name:           ocaml
4 Version:        2.04
5 Release:        1
6 URL:            http://pauillac.inria.fr/caml/
7 Vendor:         Group of implementors <caml-light@inria.fr>
8 Source0:        ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}.tar.gz
9 Source1:        ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}-refman.html.tar.gz
10 Patch0:         %{name}-ext_prof.patch
11 Patch1:         %{name}-opt.patch
12 Copyright:      Distributable
13 Group:          Development/Languages
14 Group(de):      Entwicklung/Sprachen
15 Group(pl):      Programowanie/Jêzyki
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Objective Caml is a high-level, strongly-typed, functional and
20 object-oriented programming language from the ML family of languages.
21
22 This package comprises two batch compilers (a fast bytecode compiler
23 and an optimizing native-code compiler), an interactive toplevel
24 system, Lex&Yacc tools, a replay debugger, and a comprehensive
25 library.
26
27 %description -l pl
28 Objektowy Caml jest funkcjonalnym, obiektowo zorientowanym jêzykiem
29 wysokiego poziomu rodziny jêzyków ML.
30
31 Ten pakiet zawiera dwa kompilatory (szybki kompilator bytecode oraz
32 zoptymalizowany natywny kompilator), interaktywny g³ówny system,
33 narzêdzia Lex&Yacc, odpluskwiacz i biblioteki.
34
35 %package emacs
36 Summary:        Emacs mode for OCaml
37 Summary(pl):    Tryb Emacsa dla OCaml
38 Group:          Development/Tools
39 Group(de):      Entwicklung/Werkzeuge
40 Group(fr):      Development/Outils
41 Group(pl):      Programowanie/Narzêdzia
42 Requires:       %{name} = %{version}
43 # xemacs doesn't have Provide emacs ?
44 #BuildRequires: emacs
45
46 %description emacs
47 Emacs mode files for Objective Caml language
48
49 %description -l pl emacs
50 Pliki trybu Emacsa dla jêzyka Objektowego Caml
51
52 %prep
53 %setup -q -T -b 0
54 %setup -q -T -D -a 1
55 %patch0 -p0
56 %patch1 -p1
57
58 %build
59 ./configure \
60         -cc "%{__cc} %{rpmcflags}" \
61         -bindir %{_bindir} \
62         -libdir %{_libdir}/%{name} \
63         -mandir %{_mandir}/man1 \
64         -host %{_host_alias} \
65         -with-pthread
66
67 %{__make} world bootstrap opt ocamlc.opt ocamlopt.opt
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 umask 022
72 echo    BINDIR=$RPM_BUILD_ROOT%{_bindir} >> config/Makefile
73 echo    LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{name} >> config/Makefile
74 echo    MANDIR=$RPM_BUILD_ROOT%{_mandir}/man1 >> config/Makefile
75 make    install 
76 %{__make} -C emacs install \
77         EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
78                 else echo xemacs; fi`" \
79         EMACSDIR="$RPM_BUILD_ROOT%{_libdir}/emacs/site-lisp"
80 cp -p {parsing/{location,longident,parsetree},typing/typecore}.{cm,ml}i \
81         $RPM_BUILD_ROOT%{_libdir}/%{name}
82                         
83 gzip -9nf LICENSE Changes README
84
85 cd $RPM_BUILD_ROOT%{_bindir}
86 mv -f ocamlc            $RPM_BUILD_ROOT%{_bindir}/ocamlc.byte
87 mv -f ocamlc.opt        $RPM_BUILD_ROOT%{_bindir}/ocamlc
88 mv -f ocamlopt          $RPM_BUILD_ROOT%{_bindir}/ocamlopt.byte
89 mv -f ocamlopt.opt      $RPM_BUILD_ROOT%{_bindir}/ocamlopt
90 rm -f                   $RPM_BUILD_ROOT%{_libdir}/%{_name}/*.ml
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc htmlman *.gz
98 %attr(755, root, root) %{_bindir}/*
99 %{_libdir}/%{name}
100 %{_mandir}/man*/*
101
102 %files emacs
103 %defattr(644,root,root,755)
104 %{_libdir}/emacs/site-lisp/*.el
This page took 0.071736 seconds and 4 git commands to generate.