]> git.pld-linux.org Git - packages/ocaml.git/blob - ocaml.spec
- changed all BuildRoot definitons
[packages/ocaml.git] / ocaml.spec
1 Summary:        The Objective Caml compiler and programming environment
2 Summary(pl):    Kompilator Objektowego Caml oraz ¶rodowisko programistyczne
3 Name:           ocaml
4 Version:        2.02
5 Release:        1
6 URL:            http://pauillac.inria.fr/caml/
7 Vendor:         Group of implementors <caml-light@inria.fr>
8 Source0:        ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}.tar.gz
9 Source1:        ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}-refman.html.tar.gz
10 Patch0:         ocaml-ext_prof.patch
11 Patch1:         ocaml-opt.patch
12 Copyright:      Distributable
13 Group:          Development/Languages
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Objective Caml is a high-level, strongly-typed, functional and
18 object-oriented programming language from the ML family of languages.
19
20 This package comprises two batch compilers (a fast bytecode compiler
21 and an optimizing native-code compiler), an interactive toplevel system,
22 Lex&Yacc tools, a replay debugger, and a comprehensive library.
23
24 %description -l pl
25 Objektowy Caml jest funkcjonalnym, objektowo zorientowanym jêzykiem
26 wysokiego poziomuz rodziny jêzyków ML.
27
28 Ten pakiet zawiera dwa kompilatory (szybki kompilator bytecode
29 oraz zoptymalizowany natywny kompilator), interaktywny g³ówny system,
30 narzêdzia Lex&Yacc, odpluskwiacz i biblioteki.
31
32 %package emacs
33 Group:          Development/Tools
34 Summary:        Emacs mode for OCaml
35 Summary(pl):    Tryb Emacsa dla OCaml
36 Requires:       %{name} = %{version}
37 # xemacs doesn't have Provide emacs ?
38 #BuildRequires: emacs
39
40 %description emacs
41 Emacs mode files for Objective Caml language
42
43 %description -l pl emacs
44 Pliki trybu Emacsa dla jêzyka Objektowego Caml
45
46 %prep
47 %setup -q -T -b 0
48 %setup -q -T -D -a 1
49 %patch0 -p0
50 %patch1 -p1
51
52 %build
53 ./configure \
54         -cc "cc $RPM_OPT_FLAGS" \
55         -bindir %{_bindir} \
56         -libdir %{_libdir}/%{name} \
57         -mandir %{_mandir}/man1 \
58         -host %{_host_alias} \
59         -with-pthread
60
61 make world bootstrap opt ocamlc.opt ocamlopt.opt
62
63 %install
64 umask 022
65 rm -rf $RPM_BUILD_ROOT
66 echo    BINDIR=$RPM_BUILD_ROOT%{_bindir} >> config/Makefile
67 echo    LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{name} >> config/Makefile
68 echo    MANDIR=$RPM_BUILD_ROOT%{_mandir}/man1 >> config/Makefile
69 make    install 
70 make -C emacs install \
71         EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
72                 else echo xemacs; fi`" \
73         EMACSDIR="$RPM_BUILD_ROOT%{_libdir}/emacs/site-lisp"
74 cp -p {parsing/{location,longident,parsetree},typing/typecore}.{cm,ml}i \
75         $RPM_BUILD_ROOT%{_libdir}/%{name}
76                         
77 gzip -9nf LICENSE Changes README $RPM_BUILD_ROOT%{_mandir}/man*/*
78
79 cd $RPM_BUILD_ROOT%{_bindir}
80 mv -f ocamlc            $RPM_BUILD_ROOT%{_bindir}/ocamlc.byte
81 mv -f ocamlc.opt        $RPM_BUILD_ROOT%{_bindir}/ocamlc
82 mv -f ocamlopt          $RPM_BUILD_ROOT%{_bindir}/ocamlopt.byte
83 mv -f ocamlopt.opt      $RPM_BUILD_ROOT%{_bindir}/ocamlopt
84 rm -f                   $RPM_BUILD_ROOT%{_libdir}/%{_name}/*.ml
85
86 strip                   $RPM_BUILD_ROOT%{_bindir}/* || :
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc htmlman *.gz
93 %attr(755, root, root) %{_bindir}/*
94 %{_libdir}/%{name}
95 %{_mandir}/man*/*
96
97 %files emacs
98 %defattr(644,root,root,755)
99 %{_libdir}/emacs/site-lisp/*.el
This page took 0.031869 seconds and 4 git commands to generate.