]> git.pld-linux.org Git - packages/ocaml.git/blame_incremental - ocaml.spec
- drop unused site-lib dir
[packages/ocaml.git] / ocaml.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without ocaml_opt # native, optimized compiler
4
5# ppc64, sparc64 and x32 variants not supported currently
6# alpha, hppa, ia64, mips removed since 4.00
7%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
8%undefine with_ocaml_opt
9%endif
10
11%define sver 4.12
12
13Summary: The Objective Caml compiler and programming environment
14Summary(pl.UTF-8): Kompilator OCamla (Objective Caml) oraz środowisko programistyczne
15Name: ocaml
16Version: 4.12.0
17Release: 4
18Epoch: 1
19License: QPL v1.0 with linking exception (compiler), LGPL v2 with linking exception (library)
20Group: Development/Languages
21Source0: http://caml.inria.fr/distrib/ocaml-%{sver}/%{name}-%{version}.tar.xz
22# Source0-md5: 7343cd398d477001db2c3f2ac92e12ea
23Source1: http://caml.inria.fr/distrib/ocaml-%{sver}/%{name}-%{sver}-refman-html.tar.gz
24# Source1-md5: 1bda3d0a46328a985c817d551423e2c6
25Source3: http://caml.inria.fr/distrib/ocaml-%{sver}/%{name}-%{sver}-refman.info.tar.gz
26# Source3-md5: c808dbbe35a6cc5d14da6c3b2f175d2c
27Source4: https://github.com/mmottl/pure-fun/archive/v1.0.13/pure-fun-1.0.13.tar.gz
28# Source4-md5: 0a6ff033df78d0880fe4883ace025ebe
29# note: dead URL
30Source5: http://www.ocaml.info/ocaml_sources/ds-contrib.tar.gz
31# Source5-md5: 77fa1da7375dea1393cc0b6cd802d7e1
32URL: https://www.ocaml.org/
33Requires: %{name}-runtime = %{epoch}:%{version}-%{release}
34Provides: ocaml-bytes-devel
35Provides: ocaml-ocamldoc
36Obsoletes: ocaml-bytes-devel
37Obsoletes: ocaml-doc-ps < 4.12
38Obsoletes: ocaml-emacs < 4.12
39Obsoletes: ocaml-ocamldoc
40Obsoletes: ocaml-x11graphics < 4.12
41Obsoletes: ocaml-x11graphics-devel < 4.12
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%define specflags -fno-strict-aliasing
45
46%if %{without ocaml_opt}
47%define _noautoreq Backend_intf Inlining_decision_intf Simplify_boxed_integer_ops_intf
48%endif
49
50%description
51Objective Caml is a high-level, strongly-typed, functional and
52object-oriented programming language from the ML family of languages.
53
54This package comprises two batch compilers (a fast bytecode compiler
55and an optimizing native-code compiler), an interactive toplevel
56system, Lex&Yacc tools, a replay debugger, and a comprehensive
57library.
58
59%description -l pl.UTF-8
60OCaml (Objective Caml) jest funkcyjnym, obiektowo zorientowanym
61językiem wysokiego poziomu z silnym typowaniem. Należy do rodziny
62języków ML.
63
64Ten pakiet zawiera dwa kompilatory (szybki kompilator do bajtkodu oraz
65optymalizujący kompilator do kodu natywnego), interaktywne środowisko
66pracy, narzędzia do tworzenia analizatorów leksykalnych oraz
67składniowych (ocamllex, ocamlyacc), odpluskwiacz (ocamldebug) i
68biblioteki.
69
70%package runtime
71Summary: Runtime system for OCaml
72Summary(pl.UTF-8): Środowisko uruchomieniowe dla OCamla
73Group: Libraries
74
75%description runtime
76This package contains binaries needed to run bytecode OCaml programs:
77ocamlrun bytecode interpreter, and basic dynamic link libraries.
78
79%description runtime -l pl.UTF-8
80Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
81OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun)
82oraz podstawowe biblioteki linkowane dynamicznie.
83
84%package lib-source
85Summary: Sources of OCaml standard library
86Summary(pl.UTF-8): Źródła biblioteki standardowej OCamla
87Group: Development/Languages
88Requires: %{name} = %{epoch}:%{version}-%{release}
89
90%description lib-source
91This sources come helpful during debugging of user programs with
92ocamldebug.
93
94%description lib-source -l pl.UTF-8
95Źródła te są przydatne przy odpluskwianiu programów użytkownika z
96użyciem ocamldebug.
97
98%package doc-html
99Summary: HTML documentation for OCaml
100Summary(pl.UTF-8): Dokumentacja dla OCamla w formacie HTML
101Group: Development/Tools
102
103%description doc-html
104HTML documentation for OCaml.
105
106%description doc-html -l pl.UTF-8
107Dokumentacja dla OCamla w formacie HTML.
108
109%package doc-info
110Summary: Info documentation for OCaml
111Summary(pl.UTF-8): Dokumentacja info dla OCamla
112Group: Development/Tools
113
114%description doc-info
115Info documentation for OCaml.
116
117%description doc-info -l pl.UTF-8
118Dokumentacja info dla OCamla.
119
120%package compiler-objects
121Summary: Compiled parts of OCaml compiler
122Summary(pl.UTF-8): Skompilowane części kompilatora OCamla
123Group: Development/Languages
124Requires: %{name} = %{epoch}:%{version}-%{release}
125Provides: ocaml-devel
126Obsoletes: ocaml-devel
127
128%description compiler-objects
129This package contains *.cmi and *.cmo files being parts of OCaml
130compiler. They are needed to compile some programs.
131
132%description compiler-objects -l pl.UTF-8
133Pakiet ten zawiera pliki *.cmi oraz *.cmo będące częściami kompilatora
134OCamla. Są one wymagane do kompilacji niektórych programów.
135
136%package ocamldoc-devel
137Summary: Files needed to develop programs using ocamldoc
138Summary(pl.UTF-8): Pliki potrzebne do tworzenia programów używających ocamldoc
139Group: Development/Languages
140Requires: %{name} = %{epoch}:%{version}-%{release}
141
142%description ocamldoc-devel
143You need this package if you are going to write ocamldoc front end or
144something like that.
145
146%description ocamldoc-devel -l pl.UTF-8
147Będziesz potrzebować tego pakietu, jeśli zamierzasz pisać front end
148dla ocamldoc lub coś podobnego.
149
150# maybe we'll want to add some more stuff here?
151%package examples
152Summary: Example source code for OCaml
153Summary(pl.UTF-8): Przykładowe kody źródłowe w OCamlu
154Group: Development/Languages
155Requires: %{name} = %{epoch}:%{version}-%{release}
156
157%description examples
158This packages contains sources for Okasaki's Purely Functional
159Datastructures in OCaml, along with some contributions.
160
161%description examples -l pl.UTF-8
162Pakiet ten zawiera źródła Czysto Funkcyjnych Struktur Danych autorstwa
163Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
164
165%prep
166%setup -q -a1 -a3
167mkdir examples
168tar xzf %{SOURCE4} -C examples
169tar xzf %{SOURCE5} -C examples
170# order mess with docs somewhat
171mkdir -p docs/html
172mv htmlman docs/html/ocaml
173
174%build
175%configure \
176 AS=%{__as} \
177 ASPP="%{__cc} -c" \
178 --libdir=%{_libdir}/ocaml \
179 %{!?with_ocaml_opt:--disable-native-compiler}
180
181%{__make} world
182%{__make} bootstrap
183%if %{with ocaml_opt}
184%{__make} opt
185%{__make} opt.opt
186%endif
187
188%install
189rm -rf $RPM_BUILD_ROOT
190install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-%{version}}
191
192%{__make} install \
193 DESTDIR=$RPM_BUILD_ROOT
194
195cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
196%{_libdir}/%{name}/stublibs
197%{_libdir}/%{name}
198EOF
199
200# move includes to the proper place
201%{__mv} $RPM_BUILD_ROOT%{_libdir}/ocaml/caml $RPM_BUILD_ROOT%{_includedir}/caml
202# but leave compatibility symlink
203ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/ocaml/caml
204
205# compiled sources of compiler, needed by some programs
206for f in %{?with_ocaml_opt:asmcomp} bytecomp parsing typing utils ; do
207 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
208 cp $f/*.{cmi,cmo} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
209 %{?with_ocaml_opt:cp $f/*.{cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f}
210done
211
212cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
213ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
214
215# shutup checkfiles
216%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/man3
217
218# install info pages
219cp -f infoman/*.gz $RPM_BUILD_ROOT%{_infodir}
220
221%clean
222rm -rf $RPM_BUILD_ROOT
223
224%post doc-info -p /sbin/postshell
225-/usr/sbin/fix-info-dir -c %{_infodir}
226
227%postun doc-info -p /sbin/postshell
228-/usr/sbin/fix-info-dir -c %{_infodir}
229
230%files
231%defattr(644,root,root,755)
232%doc Changes LICENSE README.adoc
233%attr(755,root,root) %{_bindir}/addlabels
234%attr(755,root,root) %{_bindir}/ocaml
235%attr(755,root,root) %{_bindir}/ocamlc
236%attr(755,root,root) %{_bindir}/ocamlc.byte
237%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlc.opt}
238%attr(755,root,root) %{_bindir}/ocamlcmt
239%attr(755,root,root) %{_bindir}/ocamlcp
240%attr(755,root,root) %{_bindir}/ocamlcp.byte
241%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlcp.opt}
242%attr(755,root,root) %{_bindir}/ocamldebug
243%attr(755,root,root) %{_bindir}/ocamldep
244%attr(755,root,root) %{_bindir}/ocamldep.byte
245%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamldep.opt}
246%attr(755,root,root) %{_bindir}/ocamldoc
247%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamldoc.opt}
248%attr(755,root,root) %{_bindir}/ocamllex
249%attr(755,root,root) %{_bindir}/ocamllex.byte
250%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamllex.opt}
251%attr(755,root,root) %{_bindir}/ocamlmklib
252%attr(755,root,root) %{_bindir}/ocamlmklib.byte
253%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlmklib.opt}
254%attr(755,root,root) %{_bindir}/ocamlmktop
255%attr(755,root,root) %{_bindir}/ocamlmktop.byte
256%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlmktop.opt}
257%attr(755,root,root) %{_bindir}/ocamlobjinfo
258%attr(755,root,root) %{_bindir}/ocamlobjinfo.byte
259%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlobjinfo.opt}
260%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlopt}
261%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlopt.byte}
262%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlopt.opt}
263%attr(755,root,root) %{_bindir}/ocamloptp
264%attr(755,root,root) %{_bindir}/ocamloptp.byte
265%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamloptp.opt}
266%attr(755,root,root) %{_bindir}/ocamlprof
267%attr(755,root,root) %{_bindir}/ocamlprof.byte
268%{?with_ocaml_opt:%attr(755,root,root) %{_bindir}/ocamlprof.opt}
269%attr(755,root,root) %{_bindir}/ocamlyacc
270%attr(755,root,root) %{_bindir}/scrapelabels
271%{_includedir}/caml
272%{_libdir}/%{name}/caml
273%{_libdir}/%{name}/compiler-libs
274%{_libdir}/%{name}/threads
275%{_libdir}/%{name}/*.a
276%{?with_ocaml_opt:%{_libdir}/%{name}/*.o}
277%{_libdir}/%{name}/*.cm*
278%{_libdir}/%{name}/Makefile.config
279%{_libdir}/%{name}/ld.conf
280%{_libdir}/%{name}/camlheader
281%{_libdir}/%{name}/camlheaderd
282%{_libdir}/%{name}/camlheaderi
283%{_libdir}/%{name}/camlheader_ur
284%dir %{_libdir}/%{name}/ocamldoc
285%{_libdir}/%{name}/ocamldoc/*.hva
286%attr(755,root,root) %{_libdir}/%{name}/expunge
287%attr(755,root,root) %{_libdir}/%{name}/extract_crc
288%{_mandir}/man1/ocaml*
289%exclude %{_mandir}/man1/ocamlrun.1*
290
291%files runtime
292%defattr(644,root,root,755)
293%attr(755,root,root) %{_bindir}/ocamlrun
294%attr(755,root,root) %{_bindir}/ocamlrund
295%attr(755,root,root) %{_bindir}/ocamlruni
296%dir %{_libdir}/%{name}
297%dir %{_libdir}/%{name}/stublibs
298%{_libdir}/%{name}/eventlog_metadata
299%attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
300%{?with_ocaml_opt:%attr(755,root,root) %{_libdir}/%{name}/libasmrun_shared.so}
301%attr(755,root,root) %{_libdir}/%{name}/libcamlrun_shared.so
302%{_mandir}/man1/ocamlrun.1*
303
304%files lib-source
305%defattr(644,root,root,755)
306%{_libdir}/%{name}/*.ml
307%{_libdir}/%{name}/*.mli
308%{_libdir}/%{name}/*/*.mli
309
310%files doc-html
311%defattr(644,root,root,755)
312%doc docs/html/ocaml/*
313
314%files doc-info
315%defattr(644,root,root,755)
316%{_infodir}/ocaml.info*
317
318%files compiler-objects
319%defattr(644,root,root,755)
320%{_libdir}/%{name}/compiler
321
322%files ocamldoc-devel
323%defattr(644,root,root,755)
324%{_libdir}/%{name}/ocamldoc/*.cm*
325%{?with_ocaml_opt:%{_libdir}/%{name}/ocamldoc/*.a}
326
327%files examples
328%defattr(644,root,root,755)
329%{_examplesdir}/%{name}-%{version}
This page took 0.061774 seconds and 4 git commands to generate.