]> git.pld-linux.org Git - packages/ocaml.git/blame - ocaml.spec
- release 13 (by relup.sh)
[packages/ocaml.git] / ocaml.spec
CommitLineData
3105856a
JB
1#
2# Conditional build:
b552f088
JB
3%bcond_without emacs # without emacs subpackage
4%bcond_without x # without X11 support
5%bcond_without tk # without Tcl/Tk support
ed19172f 6#
f4710e3c 7# --without x11 implies --without tk
1b2eae14 8%{!?with_x:%undefine with_tk}
4797676b 9
6e71517f 10%define p4ver 3.06
9de25172 11%define sver 3.12
db184753 12
65fbc6c7 13Summary: The Objective Caml compiler and programming environment
6e95eae7 14Summary(pl.UTF-8): Kompilator OCamla (Objective Caml) oraz środowisko programistyczne
65fbc6c7 15Name: ocaml
356fa1c2 16Version: 3.12.1
6c693d64 17Release: 13
4694cc06 18Epoch: 1
a13fc47d 19License: distributable
65fbc6c7 20Group: Development/Languages
7845a5c9 21Source0: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{version}.tar.bz2
356fa1c2 22# Source0-md5: 227a3daaedb150bf5037a3db01f5bf42
307e1de8 23Source1: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.html.tar.gz
9de25172 24# Source1-md5: 93cd91f525441eb7e94cc49b9b64bab0
307e1de8 25Source2: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.ps.gz
9de25172
JB
26# Source2-md5: a9c17db6ffd400c5ea00c6d51cbf56bf
27Source3: http://caml.inria.fr/distrib/%{name}-%{sver}/%{name}-%{sver}-refman.info.tar.gz
28# Source3-md5: 8cf24c4f69c6f9c9f9cc1edb9b18f6cb
29Source4: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
30# Source4-md5: 21370bae4e7f6435b38aeb21db7ce8bb
31Source5: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
32# Source5-md5: 035915d1a530aa7ec9b194d9a7d258eb
33Source6: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.html.tar.gz
34# Source6-md5: 96d8eb4ca5abd58c9a280ba59f73b192
35Source7: ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.dvi.gz
36# Source7-md5: fcd87c235109364242a0c9ccf176dff8
37Source8: http://www.ocaml.info/ocaml_sources/pure-fun-1.0.6.tar.bz2
38# Source8-md5: 94eac3fa1ac51b8ada344b04839cb43c
39Source9: http://www.ocaml.info/ocaml_sources/ds-contrib.tar.gz
40# Source9-md5: 77fa1da7375dea1393cc0b6cd802d7e1
42946d4f 41Patch0: %{name}-db3.patch
9de25172
JB
42Patch1: %{name}-CFLAGS.patch
43Patch2: %{name}-as_needed.patch
44Patch3: %{name}-gas.patch
8b0de54e 45URL: http://caml.inria.fr/
3a1adca1 46BuildRequires: db-devel >= 4.1
6e71517f 47%{?with_tk:BuildRequires: tk-devel}
3232e3f5 48%{?with_x:BuildRequires: xorg-lib-libX11-devel}
f4710e3c 49%if %{with emacs}
69735a4b 50BuildRequires: sed >= 4.0
3889f6d2
JR
51BuildRequires: emacs
52BuildRequires: emacs-common
f4710e3c 53%endif
4e386054 54Requires: %{name}-runtime = %{epoch}:%{version}-%{release}
5a1e52bf
PG
55Provides: ocaml-ocamldoc
56Obsoletes: ocaml-ocamldoc
151fbae6 57BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65fbc6c7 58
0053154a
PS
59%define specflags -fno-strict-aliasing
60
65fbc6c7
AM
61%description
62Objective Caml is a high-level, strongly-typed, functional and
63object-oriented programming language from the ML family of languages.
64
65This package comprises two batch compilers (a fast bytecode compiler
5ca6b9fb
MP
66and an optimizing native-code compiler), an interactive toplevel
67system, Lex&Yacc tools, a replay debugger, and a comprehensive
68library.
65fbc6c7 69
3f556f71
JR
70%description -l pl.UTF-8
71OCaml (Objective Caml) jest funkcyjnym, obiektowo zorientowanym językiem
72wysokiego poziomu z silnym typowaniem. Należy do rodziny języków ML.
65fbc6c7 73
8151bf1e 74Ten pakiet zawiera dwa kompilatory (szybki kompilator do bajtkodu
3f556f71
JR
75oraz optymalizujący kompilator do kodu natywnego), interaktywne środowisko
76pracy, narzędzia do tworzenia analizatorów leksykalnych oraz składniowych
8151bf1e 77(ocamllex, ocamlyacc), odpluskwiacz (ocamldebug) i biblioteki.
65fbc6c7 78
79502218
JB
79%package runtime
80Summary: Runtime system for OCaml
6e95eae7 81Summary(pl.UTF-8): Środowisko uruchomieniowe dla OCamla
79502218
JB
82Group: Libraries
83
84%description runtime
85This package contains binaries needed to run bytecode OCaml programs:
86ocamlrun bytecode interpreter, and basic dynamic link libraries.
87
3f556f71
JR
88%description runtime -l pl.UTF-8
89Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
79502218
JB
90OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun) oraz
91podstawowe biblioteki linkowane dynamicznie.
92
93%package lib-source
94Summary: Sources of OCaml standard library
6e95eae7 95Summary(pl.UTF-8): Źródła biblioteki standardowej OCamla
79502218
JB
96Group: Development/Languages
97Requires: %{name} = %{epoch}:%{version}-%{release}
98
99%description lib-source
100This sources come helpful during debugging of user programs with ocamldebug.
101
3f556f71
JR
102%description lib-source -l pl.UTF-8
103Źródła te są przydatne przy odpluskwianiu programów użytkownika
104z użyciem ocamldebug.
79502218 105
69735a4b 106%package doc-html
107Summary: HTML documentation for OCaml
6e95eae7 108Summary(pl.UTF-8): Dokumentacja dla OCamla w formacie HTML
69735a4b 109Group: Development/Tools
110
111%description doc-html
112HTML documentation for OCaml.
113
3f556f71 114%description doc-html -l pl.UTF-8
69735a4b 115Dokumentacja dla OCamla w formacie HTML.
116
13b509d1 117%package doc-ps
4797676b 118Summary: PostScript documentation for OCaml
6e95eae7 119Summary(pl.UTF-8): Dokumentacja dla OCamla w formacie PostScript
4797676b 120Group: Development/Tools
4797676b 121
13b509d1 122%description doc-ps
69735a4b 123PostScript documentation for OCaml.
4797676b 124
3f556f71 125%description doc-ps -l pl.UTF-8
69735a4b 126Dokumentacja dla OCamla w formacie PostScript.
127
128%package doc-info
129Summary: Info documentation for OCaml
6e95eae7 130Summary(pl.UTF-8): Dokumentacja info dla OCamla
69735a4b 131Group: Development/Tools
132
133%description doc-info
134Info documentation for OCaml.
135
3f556f71 136%description doc-info -l pl.UTF-8
69735a4b 137Dokumentacja info dla OCamla.
4797676b 138
65fbc6c7 139%package emacs
c4a5fbda 140Summary: Emacs mode for OCaml
6e95eae7 141Summary(pl.UTF-8): Tryb OCamla dla Emacsa
65fbc6c7 142Group: Development/Tools
4694cc06 143Requires: %{name} = %{epoch}:%{version}-%{release}
65fbc6c7
AM
144
145%description emacs
981ff793 146Emacs mode files for Objective Caml language.
65fbc6c7 147
3f556f71 148%description emacs -l pl.UTF-8
8151bf1e 149Pliki trybu OCamla dla Emacsa.
56260732 150
79502218
JB
151%package labltk
152Summary: Runtime for LablTk library
6e95eae7 153Summary(pl.UTF-8): Środowisko uruchomieniowe dla biblioteki LablTk
981ff793 154Group: Libraries
79502218 155Requires: %{name} = %{epoch}:%{version}-%{release}
981ff793 156
79502218
JB
157%description labltk
158LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
159contains files needed to run bytecode OCaml programs using LablTk.
981ff793 160
3f556f71
JR
161%description labltk -l pl.UTF-8
162Biblioteka LablTk daje programom napisanym w OCamlu dostęp do widgetów
163Tcl/Tk. Pakiet ten zawiera binaria potrzebne do uruchamiania programów
164używających LablTk.
981ff793
MM
165
166%package labltk-devel
8151bf1e 167Summary: LablTk library for OCaml
6e95eae7 168Summary(pl.UTF-8): Biblioteka LablTk dla OCamla
56260732 169Group: Development/Libraries
4694cc06 170Requires: %{name}-labltk = %{epoch}:%{version}-%{release}
981ff793
MM
171
172%description labltk-devel
173LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
174contains files needed to develop OCaml programs using LablTk.
175
3f556f71
JR
176%description labltk-devel -l pl.UTF-8
177Biblioteka LablTk daje programom napisanym w OCamlu dostęp do widgetów
178Tcl/Tk. Pakiet ten zawiera pliki niezbędne do tworzenia programów
179używających LablTk.
981ff793 180
79502218
JB
181%package x11graphics
182Summary: X11 graphic output for OCaml
6e95eae7 183Summary(pl.UTF-8): Dostęp do X11 dla OCamla
79502218 184Group: Development/Libraries
4694cc06 185Requires: %{name} = %{epoch}:%{version}-%{release}
56260732 186
79502218
JB
187%description x11graphics
188x11graphics module gives OCaml program access to drawing in X11
189windows. This package contains files needed to run bytecode OCaml
190programs using x11graphics.
56260732 191
3f556f71
JR
192%description x11graphics -l pl.UTF-8
193Moduł x11graphics daje programom napisanym w OCamlu możliwość
79502218 194korzystania z interfejsu graficznego X11. Pakiet ten zawiera binaria
3f556f71 195potrzebne do uruchamiania programów używających x11graphics.
981ff793
MM
196
197%package x11graphics-devel
198Summary: X11 graphic output for OCaml
6e95eae7 199Summary(pl.UTF-8): Dostęp do X11 dla OCamla
981ff793 200Group: Development/Libraries
4694cc06 201Requires: %{name}-x11graphics = %{epoch}:%{version}-%{release}
981ff793
MM
202
203%description x11graphics-devel
204x11graphics module gives OCaml program access to drawing in X11
205windows. This package contains files needed to develop OCaml programs
206using x11graphics.
207
3f556f71
JR
208%description x11graphics-devel -l pl.UTF-8
209Moduł x11graphics daje programom napisanym w OCamlu możliwość
8151bf1e 210korzystania z interfejsu graficznego X11. Pakiet ten zawiera pliki
3f556f71 211niezbędne do tworzenia programów używających x11graphics.
56260732 212
56260732
MM
213%package camlp4
214Summary: Objective Caml Preprocessor
6e95eae7 215Summary(pl.UTF-8): Preprocesor OCamla
56260732 216Group: Development/Languages
4694cc06 217Requires: %{name} = %{epoch}:%{version}-%{release}
218Provides: camlp4 = %{epoch}:%{version}-%{release}
56260732
MM
219Obsoletes: camlp4
220
221%description camlp4
222Camlp4 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
223tools for syntax (grammars) and the ability to modify the concrete
224syntax of the language (quotations, syntax extensions).
225
226Camlp4 can parse normal Ocaml concrete syntax or any other
227user-definable syntax. As an example, an alternative syntax is
228provided, named revised, because it tries to fix some small problems
229of the normal syntax.
230
231Camlp4 can pretty print the normal Ocaml concrete syntax or the
232revised one. It is therefore always possible to have a version of your
8151bf1e 233sources compilable by the Objective Caml compiler without
56260732
MM
234preprocessing.
235
3f556f71
JR
236%description camlp4 -l pl.UTF-8
237Camlp4 jest preprocesorem OCamla. Oferuje narzędzia do manipulowania
238składnią (gramatyki) oraz możliwość modyfikowania oryginalnej składni
239języka (cytowania, rozszerzenia).
56260732 240
3f556f71
JR
241Camlp4 może sparsować oryginalną składnię Ocamla lub dowolną inną
242definiowalną przez użytkownika. Jako przykład podana jest alternatywna
243składnia (revised syntax), która próbuje poprawić drobne problemy
244występujące w składni oryginalnej.
56260732 245
3f556f71
JR
246Camlp4 umie ładnie formatować źródła zarówno w oryginalnej jak i
247poprawionej składni OCamla. Potrafi także tłumaczyć programy z jednej
248składni na drugą.
65fbc6c7 249
69735a4b 250%package camlp4-doc-html
251Summary: Objective Caml Preprocessor - HTML documentation
6e95eae7 252Summary(pl.UTF-8): Preprocesor OCamla - dokumentacja HTML
69735a4b 253Group: Development/Languages
254
255%description camlp4-doc-html
256Objective Caml Preprocessor - HTML documentation.
257
3f556f71 258%description camlp4-doc-html -l pl.UTF-8
69735a4b 259Preprocesor OCamla - dokumentacja HTML.
260
6dfc0e1a 261%package compiler-objects
981ff793 262Summary: Compiled parts of OCaml compiler
6e95eae7 263Summary(pl.UTF-8): Skompilowane części kompilatora OCamla
981ff793 264Group: Development/Languages
4694cc06 265Requires: %{name} = %{epoch}:%{version}-%{release}
68076664 266Obsoletes: ocaml-devel
6adc6dd7 267Provides: ocaml-devel
981ff793 268
6dfc0e1a 269%description compiler-objects
981ff793
MM
270This package contains *.cmi and *.cmo files being parts of OCaml
271compiler. They are needed to compile some programs.
272
3f556f71
JR
273%description compiler-objects -l pl.UTF-8
274Pakiet ten zawiera pliki *.cmi oraz *.cmo będące częściami kompilatora
275OCamla. Są one wymagane do kompilacji niektórych programów.
981ff793 276
13b509d1
MM
277%package ocamldoc-devel
278Summary: Files needed to develop programs using ocamldoc
6e95eae7 279Summary(pl.UTF-8): Pliki potrzebne do tworzenia programów używających ocamldoc
13b509d1 280Group: Development/Languages
4694cc06 281Requires: %{name} = %{epoch}:%{version}-%{release}
13b509d1
MM
282
283%description ocamldoc-devel
284You need this package if you are going to write ocamldoc front end or
285something like that.
286
3f556f71
JR
287%description ocamldoc-devel -l pl.UTF-8
288Będziesz potrzebować tego pakietu, jeśli zamierzasz pisać front end
289dla ocamldoc lub coś podobnego.
13b509d1 290
53fbd845
MM
291# maybe we'll want to add some more stuff here?
292%package examples
293Summary: Example source code for OCaml
6e95eae7 294Summary(pl.UTF-8): Przykładowe kody źródłowe w OCamlu
53fbd845 295Group: Development/Languages
4694cc06 296Requires: %{name} = %{epoch}:%{version}-%{release}
53fbd845
MM
297
298%description examples
63004413 299This packages contains sources for Okasaki's Purely Functional
53fbd845
MM
300Datastructures in OCaml, along with some contributions.
301
3f556f71
JR
302%description examples -l pl.UTF-8
303Pakiet ten zawiera źródła Czysto Funkcyjnych Struktur Danych
8151bf1e 304autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
53fbd845 305
65fbc6c7 306%prep
9de25172 307%setup -q -a1 -a3 -a4 -a6
19e77905 308mkdir examples
9de25172
JB
309tar xjf %{SOURCE8} -C examples
310tar xzf %{SOURCE9} -C examples
56260732 311# order mess with docs somewhat
69735a4b 312mkdir -p docs/html
56260732 313mv htmlman docs/html/ocaml
fa4b2219 314cp %{SOURCE2} docs/ocaml.ps.gz
db184753 315mv camlp4-%{p4ver}-manual.html docs/html/camlp4
9de25172 316cp %{SOURCE5} docs/camlp4.ps.gz
db184753 317mv camlp4-%{p4ver}-tutorial.html docs/html/camlp4-tutorial
9de25172 318cp %{SOURCE7} docs/camlp4-tutorial.ps.gz
56260732 319%patch0 -p1
4c1e0f62 320%patch1 -p1
56260732 321%patch2 -p1
3a1adca1 322%patch3 -p1
69735a4b 323
324%build
ed19172f 325cp -f /usr/share/automake/config.sub config/gnu
65fbc6c7 326./configure \
69735a4b 327 -cc "%{__cc}" \
65fbc6c7
AM
328 -bindir %{_bindir} \
329 -libdir %{_libdir}/%{name} \
330 -mandir %{_mandir}/man1 \
530dec71 331 -host %{_host} \
f4710e3c 332 %{!?with_tk:-no-tk} \
2e6ceb74 333 -with-pthread \
0053154a 334 -x11lib %{_libdir}
65fbc6c7 335
bf9b6da9 336%{__make} -j1 world bootstrap opt.opt CFLAGS="%{rpmcflags} -Wall"
7ae05805 337%{__make} -C tools objinfo CFLAGS="%{rpmcflags} -Wall" -j1
65fbc6c7 338
e1542d3b
JB
339# broken build system
340sed -e 's,LIBDIR,%{_libdir},' camlp4/man/camlp4.1.tpl > camlp4/man/camlp4.1
341
65fbc6c7 342%install
5ca6b9fb 343rm -rf $RPM_BUILD_ROOT
69735a4b 344install -d $RPM_BUILD_ROOT{%{_includedir},%{_infodir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
7ff0f82f 345install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/site-lib
e42e1457 346
7ae05805 347%{__make} install \
13b509d1
MM
348 BINDIR=$RPM_BUILD_ROOT%{_bindir} \
349 LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{name} \
350 MANDIR=$RPM_BUILD_ROOT%{_mandir}
351
352cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
353%{_libdir}/%{name}/stublibs
354%{_libdir}/%{name}
355EOF
4797676b 356
f4710e3c 357%if %{with emacs}
3889f6d2
JR
358%{__make} -C emacs install \
359 DESTDIR=$RPM_BUILD_ROOT \
360 EMACSDIR="$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp" \
361 EMACS="emacs"
56260732
MM
362%endif
363
981ff793 364# symlink .opt versions of compilers (if present)
13b509d1
MM
365# warning: don't do that with camlp4 (can't load extensions then)
366for f in ocamlc ocamlopt ocamldoc ocamllex; do
067af37d
MM
367 if test -f $RPM_BUILD_ROOT%{_bindir}/$f.opt; then
368 mv -f $RPM_BUILD_ROOT%{_bindir}/$f \
369 $RPM_BUILD_ROOT%{_bindir}/$f.byte
370 ln -sf %{_bindir}/$f.opt $RPM_BUILD_ROOT%{_bindir}/$f
371 fi
1511bcd5 372done
65fbc6c7 373
981ff793 374# move includes to the proper place
ba35c88b 375mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
981ff793 376# but leave compatibility symlink
379cf672 377ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
981ff793 378
360c386d
MM
379# compiled sources of compiler, needed by some programs
380for f in {asm,byte}comp parsing typing utils ; do
381 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
382 cp $f/*.{cmi,cmo,cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
383done
981ff793
MM
384
385# this isn't installed by default, but is useful
386install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
53fbd845 387cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
13b509d1 388cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
56260732
MM
389ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
390
13b509d1 391# shutup checkfiles
9de25172
JB
392%{__rm} -r $RPM_BUILD_ROOT%{_mandir}/man3
393%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
13b509d1 394
69735a4b 395# install info pages
396cp -f infoman/*.gz $RPM_BUILD_ROOT%{_infodir}
397
e1542d3b
JB
398# broken build system
399install camlp4/man/camlp4.1 $RPM_BUILD_ROOT%{_mandir}/man1
400for f in camlp4o.1 camlp4r.1 mkcamlp4.1 camlp4o.opt.1 camlp4r.opt.1 ; do
401 echo '.so camlp4.1' >$RPM_BUILD_ROOT%{_mandir}/man1/$f
402done
403
65fbc6c7
AM
404%clean
405rm -rf $RPM_BUILD_ROOT
406
9de25172 407%post doc-info -p /sbin/postshell
4a452533 408-/usr/sbin/fix-info-dir -c %{_infodir}
69735a4b 409
9de25172 410%postun doc-info -p /sbin/postshell
4a452533 411-/usr/sbin/fix-info-dir -c %{_infodir}
69735a4b 412
65fbc6c7
AM
413%files
414%defattr(644,root,root,755)
f1920819 415%doc LICENSE Changes README Upgrading
9de25172 416%attr(755,root,root) %{_bindir}/addlabels
13b509d1 417%attr(755,root,root) %{_bindir}/ocaml*
9de25172 418%attr(755,root,root) %{_bindir}/scrapelabels
dd90c8d9 419%{?with_tk:%exclude %{_bindir}/ocamlbrowser}
13b509d1 420%exclude %{_bindir}/ocamlrun
ba35c88b 421%{_includedir}/caml
530dec71 422%{_libdir}/%{name}/caml
530dec71 423%{_libdir}/%{name}/threads
4c1e0f62
MM
424%dir %{_libdir}/%{name}/vmthreads
425%dir %{_libdir}/%{name}/vmthreads/*.cm*
426%dir %{_libdir}/%{name}/vmthreads/*.a
13b509d1
MM
427%{_libdir}/%{name}/*.a
428%{_libdir}/%{name}/*.o
429%{_libdir}/%{name}/*.cm*
430%exclude %{_libdir}/%{name}/*graphics*
dd90c8d9 431%{_libdir}/%{name}/Makefile.config
4251bfb1 432%{_libdir}/%{name}/ld.conf
56260732
MM
433%{_libdir}/%{name}/camlheader
434%{_libdir}/%{name}/camlheader_ur
7ff0f82f 435%{_libdir}/%{name}/ocamlbuild
13b509d1 436%dir %{_libdir}/%{name}/ocamldoc
13b509d1
MM
437%{_libdir}/%{name}/ocamldoc/*.hva
438%attr(755,root,root) %{_libdir}/%{name}/expunge
439%attr(755,root,root) %{_libdir}/%{name}/extract_crc
9de25172
JB
440%attr(755,root,root) %{_libdir}/%{name}/objinfo_helper
441%{_mandir}/man1/ocaml*
442%exclude %{_mandir}/man1/ocamlrun.1*
13b509d1 443
79502218
JB
444%files runtime
445%defattr(644,root,root,755)
446%attr(755,root,root) %{_bindir}/ocamlrun
447%dir %{_libdir}/%{name}
7ff0f82f 448%dir %{_libdir}/%{name}/site-lib
79502218
JB
449%dir %{_libdir}/%{name}/stublibs
450%attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
451%exclude %{_libdir}/%{name}/stublibs/dllgraphics.so
42946d4f 452%attr(755,root,root) %{_libdir}/%{name}/libcamlrun_shared.so
79502218
JB
453%if %{with tk}
454%exclude %{_libdir}/%{name}/stublibs/dlllabltk.so
79502218 455%endif
9de25172 456%{_mandir}/man1/ocamlrun.1*
79502218 457
13b509d1
MM
458%files lib-source
459%defattr(644,root,root,755)
460%{_libdir}/%{name}/*.ml
8151bf1e 461%{_libdir}/%{name}/*.mli
4c1e0f62 462%{_libdir}/%{name}/*/*.mli
13b509d1 463
79502218 464%files doc-html
763b9075 465%defattr(644,root,root,755)
79502218
JB
466%doc docs/html/ocaml/*
467
468%files doc-ps
469%defattr(644,root,root,755)
470%doc docs/*.ps.gz
471
472%files doc-info
473%defattr(644,root,root,755)
474%{_infodir}/ocaml.info*
53fbd845 475
13b509d1
MM
476# they are poor, html is much better
477#%files manpages
e68873d9 478#%%{_mandir}/man3/*
65fbc6c7 479
79502218
JB
480%if %{with emacs}
481%files emacs
56260732 482%defattr(644,root,root,755)
79502218
JB
483%{_datadir}/emacs/site-lisp/*.el*
484%endif
56260732 485
79502218
JB
486%if %{with tk}
487%files labltk
69735a4b 488%defattr(644,root,root,755)
79502218 489%attr(755,root,root) %{_libdir}/%{name}/stublibs/dlllabltk.so
69735a4b 490
981ff793 491%files labltk-devel
56260732 492%defattr(644,root,root,755)
73a93122 493%attr(755,root,root) %{_bindir}/labltk
494%attr(755,root,root) %{_bindir}/ocamlbrowser
56260732
MM
495%dir %{_libdir}/%{name}/labltk
496%{_libdir}/%{name}/labltk/*.cm*
497%{_libdir}/%{name}/labltk/*.a
42946d4f 498%{_libdir}/%{name}/labltk/*.o
73a93122 499%attr(755,root,root) %{_libdir}/%{name}/labltk/tkcompiler
ba35c88b 500%{_examplesdir}/%{name}-labltk-%{version}
56260732
MM
501%endif
502
b552f088 503%if %{with x}
79502218
JB
504%files x11graphics
505%defattr(644,root,root,755)
506%attr(755,root,root) %{_libdir}/%{name}/stublibs/dllgraphics.so
507
981ff793 508%files x11graphics-devel
56260732 509%defattr(644,root,root,755)
13b509d1 510%{_libdir}/%{name}/graphics*.cm*
f442d039 511%{_libdir}/%{name}/graphics.a
56260732 512%{_libdir}/%{name}/libgraphics.a
56260732
MM
513%endif
514
79502218 515%files camlp4
65fbc6c7 516%defattr(644,root,root,755)
e1542d3b
JB
517%attr(755,root,root) %{_bindir}/camlp4*
518%attr(755,root,root) %{_bindir}/mkcamlp4
79502218 519%{_libdir}/%{name}/camlp4
e1542d3b
JB
520%{_mandir}/man1/camlp4*.1*
521%{_mandir}/man1/mkcamlp4.1*
4797676b 522
79502218 523%files camlp4-doc-html
13b509d1 524%defattr(644,root,root,755)
79502218 525%doc docs/html/camlp4*
13b509d1 526
79502218 527%files compiler-objects
69735a4b 528%defattr(644,root,root,755)
79502218 529%{_libdir}/%{name}/compiler
69735a4b 530
79502218 531%files ocamldoc-devel
73a93122 532%defattr(644,root,root,755)
79502218
JB
533%{_libdir}/%{name}/ocamldoc/*.cm*
534%{_libdir}/%{name}/ocamldoc/*.a
69735a4b 535
79502218 536%files examples
69735a4b 537%defattr(644,root,root,755)
79502218 538%{_examplesdir}/%{name}-%{version}
This page took 0.140566 seconds and 4 git commands to generate.